[Ubuntu-x-swat] [Bug 931122] Re: 3D performance is very bad

2012-03-22 Thread Oded Arbel
Same problem with the lice CD, same problem with Kubuntu. The performance is very bad with Unity 3D and Kwin with desktop effects, to the point where using the desktop is not possible. Using Unity 2D or KWin without effects makes the desktop usable, just slow. If you want me to run any sort of

[Ubuntu-x-swat] [Bug 36812]

2012-08-29 Thread Oded Arbel
(In reply to comment #103) This patch breaks the keyboard layout switcher from KDE3 and Trinity. It works correctly with the layout switcher in KDE4. Have other people tested this patch with other layout switchers? What are the results? This works fine with all switchers shipped on Ubuntu

[Ubuntu-x-swat] [Bug 36812]

2011-12-26 Thread Oded Arbel
(In reply to comment #75) Things to test would include 3. Is there any problem when using IBus? Check the shortcuts that activate/deactivate/switch layout in IBus. Input methods may be a problem as i dont think anyone who is interested in this is using IM. I dont know why - maybe IM users

[Ubuntu-x-swat] [Bug 36812]

2011-12-26 Thread Oded Arbel
The following comments were made by Peter Hutterer (an X.org input developer) on the corresponding bug in RedHat bugzilla ( https://bugzilla.redhat.com/show_bug.cgi?id=660254 ): (In reply to comment #6) implementing this behaviour requires guesswork that I'm not sure is safe in a number of

[Ubuntu-x-swat] [Bug 36812]

2011-12-26 Thread Oded Arbel
(In reply to comment #86) Already proven to break the XKB specification, yes. Hi Daniel. I've seen this comment about breaking the XKB specification in several places and - I'm really not trying to be contrary - I looked at the protocol specs here

[Ubuntu-x-swat] [Bug 931122] [NEW] 3D performance is very bad

2012-02-12 Thread Oded Arbel
Public bug reported: I'm using a couple of computers based on Intel DQ35JO board, which has a GMA graphics chip: $ lspci | grep VGA 00:02.0 VGA compatible controller: Intel Corporation 82Q35 Express Integrated Graphics Controller (rev 02) Running any sort of 3D graphics is incredibly slow, for

[Ubuntu-x-swat] [Bug 931122] Re: 3D performance is very bad

2012-02-12 Thread Oded Arbel
-- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xserver-xorg-video-intel in Ubuntu. https://bugs.launchpad.net/bugs/931122 Title: 3D performance is very bad To manage notifications about this bug go to:

[Ubuntu-x-swat] [Bug 36812] Re: Keyboard layout change on hotkeys press instead of release and do not work well with shortcuts

2011-02-02 Thread Oded Arbel
@Bryce Harrington: This feature was apparently dropped from the latest Natty release ( 2:1.9.99.901+git20110131.be3be758-0ubuntu1 - http://changelogs.ubuntu.com/changelogs/pool/main/x/xorg-server/xorg- server_1.9.99.901+git20110131.be3be758-0ubuntu1/changelog ) by Christopher James Halse Rogers

[Ubuntu-x-swat] [Bug 36812] Re: Keyboard layout change on hotkeys press instead of release and do not work well with shortcuts

2011-02-02 Thread Oded Arbel
Oops - apparently I can't reopen this bug. Someone with permissions - please reopen this ticket and/or resubmit the patch. Thanks in advance. -- You received this bug notification because you are a member of Ubuntu-X, which is a direct subscriber. https://bugs.launchpad.net/bugs/36812 Title:

[Ubuntu-x-swat] [Bug 716251] Re: Xorg assert failure: *** glibc detected *** /usr/bin/X: corrupted double-linked list: 0x08da5930 ***

2011-02-15 Thread Oded Arbel
I'm not sure if its the same problem, but while I can't reproduce my original problem (X unresponsive after resume), I now get the crash reported in bug #719310 every time I log out. -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg-server in

[Ubuntu-x-swat] [Bug 719310] Re: Xorg assert failure: *** glibc detected *** /usr/bin/X: double free or corruption (!prev): 0x00000000036ef480 ***

2011-02-15 Thread Oded Arbel
** Visibility changed to: Public -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg-server in ubuntu. https://bugs.launchpad.net/bugs/719310 Title: Xorg assert failure: *** glibc detected *** /usr/bin/X: double free or corruption (!prev):

[Ubuntu-x-swat] [Bug 359392] Re: [i965] X freezes starting on April 3rd

2009-05-17 Thread Oded Arbel
I see similar issues with GM915, but only on KDE - it doesn't happen for me with GNOME. I see similar artifacts all the time in KDE4, so I think this is related to KWin and not specifically the driver. -- [i965] X freezes starting on April 3rd https://bugs.launchpad.net/bugs/359392 You received

[Ubuntu-x-swat] [Bug 359392] Re: [i965] X freezes starting on April 3rd

2009-05-22 Thread Oded Arbel
I just had another crash, when I started playing a video. After I restarted the same video would play fine, so I can't actually reproduce this (it was probably related to the better then week up time I had up until now). My setup is: - Thinkpad T61 with i965 - ubuntu-x-swat X server with Intel

Re: [Ubuntu-x-swat] [Bug 359392] Re: [i965] X freezes starting on April 3rd

2009-05-26 Thread Oded Arbel
On Tue, 2009-05-26 at 16:09 +, Dave Conniff wrote: however I experienced a lockup on launching a video using mplayer's xv Intel(R) Video Overlay option, which had been fixing the horrible screen tearing I have been getting on every driver and kernel I have tested (which is all of them I

[Ubuntu-x-swat] [Bug 359392] Re: [i965] X freezes starting on April 3rd

2009-05-26 Thread Oded Arbel
** Bug watch added: Red Hat Bugzilla #499245 https://bugzilla.redhat.com/show_bug.cgi?id=499245 -- [i965] X freezes starting on April 3rd https://bugs.launchpad.net/bugs/359392 You received this bug notification because you are a member of Ubuntu-X, which is the registrant for

Re: [Ubuntu-x-swat] [Bug 359392] Re: [i965] X freezes starting on April 3rd --- please test new package

2009-06-07 Thread Oded Arbel
On Sat, 2009-06-06 at 12:15 +, Martin Pitt wrote: many thanks to Albert Damen for his comprehensive analysis. The cited kernel patches are only for UXA and don't backport well, so we won't backport them to Jaunty (at least not now). However, his aperture patch already got good feedback and

[Ubuntu-x-swat] [Bug 359392] Re: [i965] X freezes starting on April 3rd

2009-06-20 Thread Oded Arbel
I have a regression in Karmic: after living with the green drivers for a couple of week and everything was fine, I upgraded to Karmic on Thursday and ever since I had multiple freezes. I don't know if this is related to this bug, but I'll assume that it is unless someone tell me otherwise: I got

[Ubuntu-x-swat] [Bug 359392] Re: [i965] X freezes starting on April 3rd

2009-06-21 Thread Oded Arbel
I got the same freeze again (with laptop screen closed) but without the syslog messages, so its probably not related. My problem is not an immediate lockup like it seems that Jithin Emmanuel reported (though I haven't looked at the Xorg log yet) - if I just close the lid and leave it for a few

[Ubuntu-x-swat] [Bug 390633] [NEW] Computer freezes and does not respond when returning from blank screen

2009-06-22 Thread Oded Arbel
Public bug reported: Binary package hint: xserver-xorg-video-intel After upgrade to Karmic, when the laptop is powered (connected to AC) and set to blank screen when laptop lid is closed, if laptop lid is closed for a long time (a couple of hours or more) then when I open the screen again the

[Ubuntu-x-swat] [Bug 359392] Re: [i965] X freezes starting on April 3rd

2009-06-22 Thread Oded Arbel
I opened bug #390633 for intel freeze in Karmic when doing blank screen. Thanks for all the help, I think this issue is resolved for Jaunty and I hope it doesn't come back for Karmic. -- [i965] X freezes starting on April 3rd https://bugs.launchpad.net/bugs/359392 You received this bug

[Ubuntu-x-swat] [Bug 390633] Re: Computer freezes and does not respond when returning from blank screen

2009-06-22 Thread Oded Arbel
I don't think it is - I don't have any problem with the screensaver (which I enabled to test and got back after several hours and everything came back). -- Computer freezes and does not respond when returning from blank screen https://bugs.launchpad.net/bugs/390633 You received this bug

[Ubuntu-x-swat] [Bug 390633] Re: Computer freezes and does not respond when returning from blank screen

2009-06-28 Thread Oded Arbel
Attached the lspci output. I don't think I am experiencing the infinite loop bug, as I could not find the report error message in the Xserver log files. I did not see any error messages in the log files, for that matter. I will try the x-updates drivers later. I do want to also note that

[Ubuntu-x-swat] [Bug 451518] Re: [i945G] karmic: INFO: task i915/* blocked for more than 120 seconds.

2009-12-21 Thread Oded Arbel
This also just happened to me. The display is blank (the power led is blinking to signify that DPMS is off), the mouse and keyboard do not respond (the num lock led is stuck). Syslog has: Dec 21 15:31:32 dov kernel: [81840.640063] INFO: task i915/0:360 blocked for more than 120 seconds. Dec 21

[Ubuntu-x-swat] [Bug 500079] [NEW] KUbuntu 10.04: KWin effects cannot be enabled on Intel 82Q35 Express

2009-12-24 Thread Oded Arbel
Public bug reported: Binary package hint: xserver-xorg-video-intel I can't enabled KWin desktop effects through the Configure Window Behavior dialog. I get an error Desktop Effects could not be enabled using the current configuration options, while running compiz (using --replace) works well

[Ubuntu-x-swat] [Bug 500079] Re: KUbuntu 10.04: KWin effects cannot be enabled on Intel 82Q35 Express

2009-12-24 Thread Oded Arbel
** Attachment added: Xorg configuration http://launchpadlibrarian.net/37153970/xorg.conf ** Attachment added: BootDmesg.txt http://launchpadlibrarian.net/37153971/BootDmesg.txt ** Attachment added: CurrentDmesg.txt http://launchpadlibrarian.net/37153972/CurrentDmesg.txt ** Attachment

[Ubuntu-x-swat] [Bug 451518] Re: [i945G] karmic: INFO: task i915/* blocked for more than 120 seconds.

2010-01-02 Thread Oded Arbel
My i915 laptop is out of commission, but I do get freezes with an 82Q35 Express IGC, and annoying blanking with GM965 IGC. Are any of these relevant to this? -- [i945G] karmic: INFO: task i915/* blocked for more than 120 seconds. https://bugs.launchpad.net/bugs/451518 You received this bug

[Ubuntu-x-swat] [Bug 390917] Re: LVDS display not returning from dpms off state on intel after a set time period.

2009-07-06 Thread Oded Arbel
the package for xserver-xorg-video-intel version 2:2.7.99.901+git20090702.74227141-0ubuntu1 from the x-swat ppa above fixed the hanging problem for me, but introduced a serious screen corruption issue - should I report it here or open a new ticket for it? -- LVDS display not returning from dpms

[Ubuntu-x-swat] [Bug 390633] Re: Computer freezes and does not respond when returning from blank screen

2009-07-06 Thread Oded Arbel
*** This bug is a duplicate of bug 390917 *** https://bugs.launchpad.net/bugs/390917 Unfortunately, the last driver also introduces other much more serious problems for me. This is just a warning for people that might read this ticket and think the x-swat driver will solve their problems. I

[Ubuntu-x-swat] [Bug 390633] Re: Computer freezes and does not respond when returning from blank screen

2009-07-06 Thread Oded Arbel
That driver fixed the problem to me also -- Computer freezes and does not respond when returning from blank screen https://bugs.launchpad.net/bugs/390633 You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xserver-xorg-video-intel in ubuntu.

[Ubuntu-x-swat] [Bug 396171] [NEW] after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted

2009-07-06 Thread Oded Arbel
Public bug reported: Binary package hint: xserver-xorg-video-intel After installing latest intel driver (xserver-xorg-video-intel version 2:2.7.99.901+git20090702.74227141-0ubuntu1) from the x-swat ppa (here: https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-updates), I get a serious screen

[Ubuntu-x-swat] [Bug 396171] apport-collect data

2009-07-07 Thread Oded Arbel
Architecture: amd64 DistroRelease: Ubuntu 9.10 MachineType: LENOVO 88986DG Package: xserver-xorg-video-intel 2:2.7.99.901+git20090702.74227141-0ubuntu1 PackageArchitecture: amd64 ProcCmdLine: root=UUID=414f00b9-7a73-447d-b354-7c8e9373e54e ro quiet splash ProcEnviron: SHELL=/bin/bash

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: BootDmesg.txt http://launchpadlibrarian.net/28761798/BootDmesg.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of Ubuntu-X,

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: CurrentDmesg.txt http://launchpadlibrarian.net/28761799/CurrentDmesg.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: Dependencies.txt http://launchpadlibrarian.net/28761800/Dependencies.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: Lspci.txt http://launchpadlibrarian.net/28761801/Lspci.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of Ubuntu-X, which is

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: Lsusb.txt http://launchpadlibrarian.net/28761811/Lsusb.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of Ubuntu-X, which is

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: PciDisplay.txt http://launchpadlibrarian.net/28761812/PciDisplay.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of Ubuntu-X,

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: UdevDb.txt http://launchpadlibrarian.net/28761829/UdevDb.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of Ubuntu-X, which is

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: ProcCpuinfo.txt http://launchpadlibrarian.net/28761813/ProcCpuinfo.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: ProcInterrupts.txt http://launchpadlibrarian.net/28761814/ProcInterrupts.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: UdevLog.txt http://launchpadlibrarian.net/28761834/UdevLog.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of Ubuntu-X, which

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: XorgLog.txt http://launchpadlibrarian.net/28761836/XorgLog.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of Ubuntu-X, which

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: XorgLogOld.txt http://launchpadlibrarian.net/28761837/XorgLogOld.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of Ubuntu-X,

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: glxinfo.txt http://launchpadlibrarian.net/28761841/glxinfo.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of Ubuntu-X, which

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: Xrandr.txt http://launchpadlibrarian.net/28761838/Xrandr.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of Ubuntu-X, which is

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: xdpyinfo.txt http://launchpadlibrarian.net/28761844/xdpyinfo.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of Ubuntu-X,

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: setxkbmap.txt http://launchpadlibrarian.net/28761843/setxkbmap.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of Ubuntu-X,

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: monitors.xml.txt http://launchpadlibrarian.net/28761842/monitors.xml.txt -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of

[Ubuntu-x-swat] [Bug 396171]

2009-07-07 Thread Oded Arbel
** Attachment added: xkbcomp.txt http://launchpadlibrarian.net/28761845/xkbcomp.txt ** Changed in: xserver-xorg-video-intel (Ubuntu) Status: Incomplete = New -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted

[Ubuntu-x-swat] [Bug 396171] Re: after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted

2009-07-07 Thread Oded Arbel
Re: comment #3 - yes, I have compiz enabled. -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xserver-xorg-video-intel

[Ubuntu-x-swat] [Bug 396171] Re: after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted

2009-07-07 Thread Oded Arbel
Sorry, also happens with compiz disabled. -- after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted https://bugs.launchpad.net/bugs/396171 You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xserver-xorg-video-intel in

[Ubuntu-x-swat] [Bug 396171] Re: after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted

2009-07-10 Thread Oded Arbel
I've noticed that the graphics adapter resets itself to 85Hz refresh rate - which causes the screen corruption - rather spuriously: when connecting external monitors or coming back from sleep. When the screen comes back from sleep, and the refresh rate is reset to 85Hz, I get this in Xorg.0.log:

[Ubuntu-x-swat] [Bug 396171] Re: after installing latest x-swat intel driver for Karmic, screen is sometimes corrupted

2009-07-11 Thread Oded Arbel
Just running xrandr doesn't do anything. the output is: $ xrandr Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192 VGA1 disconnected (normal left inverted right x axis y axis) LVDS1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 287mm x 215mm 1024x768

[Ubuntu-x-swat] [Bug 398026] Re: [GM45] Default 60Hz display mode drives LVDS incorrectly

2009-07-15 Thread Oded Arbel
I also am not seeing corruption issues with the kernel update (I checked before and after and the kernel update indeed seems to be the reason). The screen still changes refresh rate when going into and out of docking, but now all modes look fine. -- [GM45] Default 60Hz display mode drives LVDS

[Ubuntu-x-swat] [Bug 398026] Re: [GM45] Default 60Hz display mode drives LVDS incorrectly

2009-07-15 Thread Oded Arbel
Sure, no probs - just let me know how can I help. -- [GM45] Default 60Hz display mode drives LVDS incorrectly https://bugs.launchpad.net/bugs/398026 You received this bug notification because you are a member of Ubuntu-X, which is the registrant for xf86-video-intel.

[Ubuntu-x-swat] [Bug 398026] Re: [GM45] Default 60Hz display mode drives LVDS incorrectly

2009-07-18 Thread Oded Arbel
I've added the patch to 2.6.31-3-generic and there is no change in behavior (although I think its crashing a bit - but I can't reproduce reliably). I'll patch 2.6.31-2 and get back to you with more info (compiling takes a long time ;-) ). -- [GM45] Default 60Hz display mode drives LVDS

[Ubuntu-x-swat] [Bug 398026] Re: [GM45] Default 60Hz display mode drives LVDS incorrectly

2009-07-20 Thread Oded Arbel
I can't find the source package for 2.6.31-2 - packages.ubuntu.com only has 2.6.31-3 and 2.6.30 or older. Can you please direct me to where I can find ubuntu sources for 2.6.31-2 that I can patch and install? -- [GM45] Default 60Hz display mode drives LVDS incorrectly

[Ubuntu-x-swat] [Bug 398026] Re: [GM45] Default 60Hz display mode drives LVDS incorrectly

2009-07-22 Thread Oded Arbel
I applied the patch to the above mentioned kernel and run it. Curiously it does not feature the screen corruption that was the issue of this bug, but it does still changes to 85Hz when docked and back to 60Hz when undocked: Docked: $ xrandr Screen 0: minimum 320 x 200, current 1024 x 768,

[Ubuntu-x-swat] [Bug 398026] Re: [GM45] Default 60Hz display mode drives LVDS incorrectly

2009-07-28 Thread Oded Arbel
With the patch applied to 2.6.31.2 , I could not reproduce the screen corruption problem that is the original complaint of this ticket. I could not reproduce it ever since I did an upgrade that installed kernel 2.6.31.3, so on the face of it it looks like another update, and not the kernel

[Ubuntu-x-swat] [Bug 398026] Re: [GM45] Default 60Hz display mode drives LVDS incorrectly

2009-07-28 Thread Oded Arbel
$ cat /sys/class/drm/card0-LVDS*/modes 1024x768 1024x768 -- [GM45] Default 60Hz display mode drives LVDS incorrectly https://bugs.launchpad.net/bugs/398026 You received this bug notification because you are a member of Ubuntu-X, which is the registrant for xf86-video-intel.

[Ubuntu-x-swat] [Bug 398026] Re: [GM45] Default 60Hz display mode drives LVDS incorrectly

2009-08-03 Thread Oded Arbel
Sorry about the late reply - I'm moving to a new apartment and haven't got much time. It took me a while to figure out what is KMS, and then to try to disable it. When I add i915.modeset=0 to the kernel command line, it complains that its an unknown boot option and modinfo shows no such parameter

[Ubuntu-x-swat] [Bug 398026] Re: [GM45] Default 60Hz display mode drives LVDS incorrectly

2009-08-04 Thread Oded Arbel
With KMS disabled, the screen also no longer changes refresh rates when docking and undocking. I'll enable KMS and check if I can reproduce the refresh rate change again. -- [GM45] Default 60Hz display mode drives LVDS incorrectly https://bugs.launchpad.net/bugs/398026 You received this bug

[Ubuntu-x-swat] [Bug 398026] Re: [GM45] Default 60Hz display mode drives LVDS incorrectly

2009-08-04 Thread Oded Arbel
Ok, I used the kernel command line param and indeed the display names are as you specified. When KMS is disabled, there is no /sys/class/drm/card0-LVDS*/modes file. Here's the output of xrandr: $ xrandr --verbose Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096 VGA

[Ubuntu-x-swat] [Bug 397839] Re: Screen randomly goes off in karmic

2009-08-07 Thread Oded Arbel
I have the same issue with a Thinkpad T61 with intel 945 card. -- Screen randomly goes off in karmic https://bugs.launchpad.net/bugs/397839 You received this bug notification because you are a member of Ubuntu-X, which is the registrant for xserver-xorg-driver-ati.

[Ubuntu-x-swat] [Bug 397839] Re: Screen randomly goes off in karmic

2009-09-10 Thread Oded Arbel
Actually I have not seen this problem in a while. I'm using GNOME though. -- Screen randomly goes off in karmic https://bugs.launchpad.net/bugs/397839 You received this bug notification because you are a member of Ubuntu-X, which is the registrant for xserver-xorg-driver-ati.

[Ubuntu-x-swat] [Bug 36812] Re: Keyboard layout change on hotkeys press instead of release and do not work well with shortcuts

2010-09-27 Thread Oded Arbel
I have seen this behavior as well in the patched X-Server, and I may have also seen this with the original Maverick X-Server - though I'm not sure about it. I get this bug triggered only by using Synergy, but with almost 100% consistency: I use Ubuntu 10.04 as a Synergy server, and 10.10 is the

[Ubuntu-x-swat] [Bug 458230] [NEW] Xorg freezes computer

2009-10-22 Thread Oded Arbel
Public bug reported: X randomly freezes, and the computer has to be restarted. When that happens the keyboard does not response (NUM lock does not change the NUM lock led even), but I can still log in remotely to the server over SSH. LSPCI: ---8--- $ lspci 00:00.0 Host bridge: Intel Corporation

[Ubuntu-x-swat] [Bug 458230] Re: Xorg freezes computer

2009-10-22 Thread Oded Arbel
** Attachment added: Xorg.0.log http://launchpadlibrarian.net/34147917/Xorg.0.log ** Attachment added: BootDmesg.txt http://launchpadlibrarian.net/34147918/BootDmesg.txt ** Attachment added: CurrentDmesg.txt http://launchpadlibrarian.net/34147919/CurrentDmesg.txt ** Attachment added:

[Ubuntu-x-swat] [Bug 458230] Re: Xorg freezes computer

2009-10-22 Thread Oded Arbel
Xorg.1.log attached. ** Attachment added: Xorg.1.log http://launchpadlibrarian.net/34147967/Xorg.1.log -- Xorg freezes computer https://bugs.launchpad.net/bugs/458230 You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg-server in ubuntu.

[Ubuntu-x-swat] [Bug 36812]

2012-10-04 Thread Oded Arbel
(In reply to comment #108) I don't know what they have done in Ubuntu but 12.04 understands both press and release. Layout switching happens on release. Ubuntu have simply applied Ilya's patch (one of the revisions attached here) to fix the layout switching problem. If you press Alt you see

[Ubuntu-x-swat] [Bug 1109806] [NEW] [xorg-edgers] Failed to run applications under optirun after upgrading nvidia driver

2013-01-29 Thread Oded Arbel
Public bug reported: I'm using a Thinkpad T420 with Nvidia 4200M (Optimus). I've been successfully using Ubuntu 12.04 and now 12.10 with Bumblebee and the Ubuntu provided Nvidia drivers for a while. Today - wanting to get the latest release of the Nvidia 310 series driver, I installed

[Ubuntu-x-swat] [Bug 1109806] Re: [xorg-edgers] Failed to run applications under optirun after upgrading nvidia driver

2013-03-05 Thread Oded Arbel
I have Bumblebee 3.1 installed, and it still doesn't work. Here is what syslog has to say when I run 'optirun glxgears': Mar 5 23:30:19 shehy kernel: [ 9173.423024] bbswitch: enabling discrete graphics Mar 5 23:30:20 shehy kernel: [ 9173.663711] thinkpad_acpi: EC reports that Thermal Table

[Ubuntu-x-swat] [Bug 36812] Re: Keyboard layout change on hotkeys press instead of release and do not work well with shortcuts

2013-11-30 Thread Oded Arbel
This issue is still solved for me - test if the fix still works by holding slowly ALT then SHIFT then some letter key, then release all one by one - if the keyboard layout has not changed, then the issue is still resolved. -- You received this bug notification because you are a member of

[Ubuntu-x-swat] [Bug 1306470] [NEW] Under KDE, X consumes 100% CPU after returning from VT switch

2014-04-11 Thread Oded Arbel
Public bug reported: Running on current trusty (though is has been going on for a while), when I'm using KDE and I switch to another VT, when I get back into KDE the X server is eating up all the CPU (of one core). After a few minutes it settles down. Also, while the CPU is loaded, sometimes

[Ubuntu-x-swat] [Bug 1306470] Re: Under KDE, X consumes 100% CPU after returning from VT switch

2014-04-11 Thread Oded Arbel
I forgot to mention my system settings - I'm using Thinkpad T420 with Nvidia Optimus. I am *not* using nvidia-prime, as that setup didn't work for me, instead I'm using the bumblebee setup where X is configured only for the Intel graphics, and bumblebee is using a second X server to render 3D

[Ubuntu-x-swat] [Bug 36812]

2014-09-06 Thread Oded Arbel
(In reply to comment #129) As far as I can tell, it is already clear that XKB specifications needs to be extended for this to be cleanly solved. While Ilya's hack works for many people, and as much as I would like to see this fixed, I understand why it is unacceptable to the developers. ...

[Ubuntu-x-swat] [Bug 1306470] Re: Under KDE, X consumes 100% CPU after returning from VT switch

2015-02-17 Thread Oded Arbel
Unfortunately, I no longer have this device - it was stolen. I may be able to get my hands on such a device to try it, but that is a long shot. If reproducing on an updated T420 is required to continue working on this bug, then I suggest to close it for now and if I manage to reproduce I'll

[Ubuntu-x-swat] [Bug 36812]

2015-07-25 Thread Oded Arbel
Currently, Alon Bar-Lev's patch (xorg-server-1.12.2-xkb-switch-on- release.patch) applies cleanly against Xorg 1.17.2 from Fedora 22, but apparently has no effect - with `setxkbmap -print` output like this: xkb_keymap { xkb_keycodes { include evdev+aliases(qwerty) }; xkb_types

[Ubuntu-x-swat] [Bug 36812]

2015-07-25 Thread Oded Arbel
(In reply to Oded Arbel from comment #135) Currently, Alon Bar-Lev's patch (xorg-server-1.12.2-xkb-switch-on-release.patch) applies cleanly against Xorg 1.17.2 from Fedora 22, but apparently has no effect Ö¼sorry, my bad - I was mistaken. Apparently the problem has something to do with GNOME's

[Ubuntu-x-swat] [Bug 1491860] [NEW] Xorg crashes spontaneously

2015-09-03 Thread Oded Arbel
Public bug reported: Since upgrading to the Kubuntu Wily beta, Xorg crashes a few times a day. See attached log ProblemType: Bug DistroRelease: Ubuntu 15.10 Package: xorg 1:7.7+7ubuntu4 ProcVersionSignature: Ubuntu 4.1.0-3.3-generic 4.1.3 Uname: Linux 4.1.0-3-generic x86_64 ApportVersion:

[Ubuntu-x-swat] [Bug 1491860] Re: Xorg crashes spontaneously

2015-09-03 Thread Oded Arbel
** Attachment added: "Xorg log from crashed session" https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1491860/+attachment/4456867/+files/Xorg.0.log.old -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg in Ubuntu.

[Ubuntu-x-swat] [Bug 36812] Re: Keyboard layout change on hotkeys press instead of release and do not work well with shortcuts

2016-03-29 Thread Oded Arbel
@orange-buffalo: the problem you describe is not this bug - its a problem with GNOME itself. This report is about the Xserver bug that was fixed by Ubuntu (though not in Xorg itself, so it is still evident in non-Ubuntu operating system). For the GNOME shell bug, check this bug report:

[Ubuntu-x-swat] [Bug 1716741] [NEW] [artful] After killing Google Chrome, X.org crashes

2017-09-12 Thread Oded Arbel
Public bug reported: Sometimes (quite often recently) Google Chrome gets stuck on my computer - its not responding at all and when resizing the window there is no repaint. If I then kill the process (it seems to happen both for TERM and KILL), the Google Chrome windows close and everything seems

[Ubuntu-x-swat] [Bug 36812]

2018-06-08 Thread Oded Arbel
The issue of fixing the spec was raised before, and the answer thn was: (Vasily Khoruzhick from comment #37) > Daniel is now working on XKB2, so fixing/changing XKB1 has no sense :) As far as I know, XKB2 was never released, not even as a draft. Are you saying that the situation has changed and

[Ubuntu-x-swat] [Bug 1777395] Re: [bionic] Dell precision touchpad RMB no longer works

2018-06-18 Thread Oded Arbel
Confirmed this is a libinput regression - I've built and installed libinput 1.8.4 from Artful and that returned the RMB click functionality (though of course many other things that rely on libinput >= 1.9 broke). ** Package changed: xinput (Ubuntu) => libinput (Ubuntu) -- You received this bug

[Ubuntu-x-swat] [Bug 1777395] Re: [bionic] Dell precision touchpad RMB no longer works

2018-06-18 Thread Oded Arbel
*** This bug is a duplicate of bug 1759300 *** https://bugs.launchpad.net/bugs/1759300 After several upgrades/downgrades of libinput and reboots, including setting up xinput quirks according to http://www.dell.com/support/article/ca/en/cabsdt1/sln308258/precision-

[Ubuntu-x-swat] [Bug 1777395] Re: [bionic] Dell precision touchpad RMB no longer works

2018-06-18 Thread Oded Arbel
Reading into it a bit, it could be an issue with libinput, which Bionic ships version 1.10 (over Artful's 1.8). -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xinput in Ubuntu. https://bugs.launchpad.net/bugs/1777395 Title: [bionic] Dell

[Ubuntu-x-swat] [Bug 1777395] [NEW] [bionic] Dell precision touchpad RMB no longer works

2018-06-18 Thread Oded Arbel
Public bug reported: Using the clickable touchpad on the Dell Precision 5520, the "right mouse button" (an area marked on the bottom right of the touchpad) no longer produces an RMB event when clicked. This used to work in Artful. More details: The Dell Precision touchpad is "clickable" - i.e.

[Ubuntu-x-swat] [Bug 1716741] CurrentDmesg.txt

2018-02-09 Thread Oded Arbel
apport information ** Attachment added: "CurrentDmesg.txt" https://bugs.launchpad.net/bugs/1716741/+attachment/5052276/+files/CurrentDmesg.txt -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg in Ubuntu.

[Ubuntu-x-swat] [Bug 1716741] ProcModules.txt

2018-02-09 Thread Oded Arbel
apport information ** Attachment added: "ProcModules.txt" https://bugs.launchpad.net/bugs/1716741/+attachment/5052274/+files/ProcModules.txt -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg in Ubuntu.

[Ubuntu-x-swat] [Bug 1716741] Lspci.txt

2018-02-09 Thread Oded Arbel
apport information ** Attachment added: "Lspci.txt" https://bugs.launchpad.net/bugs/1716741/+attachment/5052281/+files/Lspci.txt -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg in Ubuntu. https://bugs.launchpad.net/bugs/1716741 Title:

[Ubuntu-x-swat] [Bug 1716741] JournalErrors.txt

2018-02-09 Thread Oded Arbel
apport information ** Attachment added: "JournalErrors.txt" https://bugs.launchpad.net/bugs/1716741/+attachment/5052280/+files/JournalErrors.txt -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg in Ubuntu.

[Ubuntu-x-swat] [Bug 1716741] ProcEnviron.txt

2018-02-09 Thread Oded Arbel
apport information ** Attachment added: "ProcEnviron.txt" https://bugs.launchpad.net/bugs/1716741/+attachment/5052272/+files/ProcEnviron.txt -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg in Ubuntu.

[Ubuntu-x-swat] [Bug 1716741] UdevDb.txt

2018-02-09 Thread Oded Arbel
apport information ** Attachment added: "UdevDb.txt" https://bugs.launchpad.net/bugs/1716741/+attachment/5052275/+files/UdevDb.txt ** Description changed: Sometimes (quite often recently) Google Chrome gets stuck on my computer - its not responding at all and when resizing the window

[Ubuntu-x-swat] [Bug 1716741] ProcInterrupts.txt

2018-02-09 Thread Oded Arbel
apport information ** Attachment added: "ProcInterrupts.txt" https://bugs.launchpad.net/bugs/1716741/+attachment/5052273/+files/ProcInterrupts.txt -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg in Ubuntu.

[Ubuntu-x-swat] [Bug 1716741] DpkgLog.txt

2018-02-09 Thread Oded Arbel
apport information ** Attachment added: "DpkgLog.txt" https://bugs.launchpad.net/bugs/1716741/+attachment/5052266/+files/DpkgLog.txt -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg in Ubuntu. https://bugs.launchpad.net/bugs/1716741

[Ubuntu-x-swat] [Bug 1716741] DpkgLog.txt

2018-02-09 Thread Oded Arbel
apport information ** Attachment added: "DpkgLog.txt" https://bugs.launchpad.net/bugs/1716741/+attachment/5052278/+files/DpkgLog.txt -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg in Ubuntu. https://bugs.launchpad.net/bugs/1716741

[Ubuntu-x-swat] [Bug 1716741] ProcCpuinfoMinimal.txt

2018-02-09 Thread Oded Arbel
apport information ** Attachment added: "ProcCpuinfoMinimal.txt" https://bugs.launchpad.net/bugs/1716741/+attachment/5052283/+files/ProcCpuinfoMinimal.txt -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg in Ubuntu.

[Ubuntu-x-swat] [Bug 1716741] ProcEnviron.txt

2018-02-09 Thread Oded Arbel
apport information ** Attachment added: "ProcEnviron.txt" https://bugs.launchpad.net/bugs/1716741/+attachment/5052284/+files/ProcEnviron.txt -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg in Ubuntu.

[Ubuntu-x-swat] [Bug 1716741] ProcModules.txt

2018-02-09 Thread Oded Arbel
apport information ** Attachment added: "ProcModules.txt" https://bugs.launchpad.net/bugs/1716741/+attachment/5052286/+files/ProcModules.txt -- You received this bug notification because you are a member of Ubuntu-X, which is subscribed to xorg in Ubuntu.

  1   2   >