Re: Difference between "html" and "htmlText" in clipboardData?

2017-02-01 Thread Stephen Barncard via use-livecode
On Wed, Feb 1, 2017 at 7:33 PM, Richard Gaskin via use-livecode < use-livecode@lists.runrev.com> wrote: > Thanks. Interestingly, it shows a key for "html" but not "htmlText". > > Do you know what the difference between those keys is? > no. The key list is derived from the clipboard array. >

Re: Difference between "html" and "htmlText" in clipboardData?

2017-02-01 Thread J. Landman Gay via use-livecode
On 2/1/17 9:33 PM, Richard Gaskin via use-livecode wrote: Interestingly, it shows a key for "html" but not "htmlText". Do you know what the difference between those keys is? Is this just a bug in the Dictionary and there is no "htmlText", with the "html" key using LC's htmlText? They appear

Re: Difference between "html" and "htmlText" in clipboardData?

2017-02-01 Thread Richard Gaskin via use-livecode
Stephen Barncard wrote: > On Wed, Feb 1, 2017 at 4:46 PM, Richard Gaskin wrote: > >> The Dictionary entry for clipboardData lists these among the array >> keys: >> >> - htmlText: LiveCode HTML text >> - html: styled text in LiveCode HTML format >> >> What is the difference between "LiveCode HTML

Re: Dirty HTTP Launch

2017-02-01 Thread Tom Glod via use-livecode
scratch that...bob's solution works and isn't likley to do anything ever except take out the last space. great jobthere should be no spaces in URLs anyways..thanks Bob On Wed, Feb 1, 2017 at 9:05 PM, Tom Glod wrote: > Bob, I can't really use yours since it doesn't

Re: Dirty HTTP Launch

2017-02-01 Thread Tom Glod via use-livecode
Bob, I can't really use yours since it doesn't always happen and Mike's suggestion did not work.. there is no magnifying glass in the variable watcher, so it is just the last character. replace space with empty also didn't work. head scratching continues. On Mon, Jan 30, 2017 at 5:54

Re: Auto scrolling a locked field when mouse comes to edge

2017-02-01 Thread David Epstein via use-livecode
To clarify: For a locked field with autohilite and traversalOn both true, the “built in” auto scrolling works the same as with an unlocked field. I’m looking for a way to script this kind of auto scrolling with autohilite and traversalOn both false. David Epstein

Re: Using a variable for an array name

2017-02-01 Thread Peter Bogdanoff via use-livecode
OK, I’ll test the two methods when I get the general procedure working. > On Feb 1, 2017, at 7:52 PM, Richard Gaskin via use-livecode > wrote: > > Peter Bogdanoff wrote: > > > Richard, I’ve heard that “do” is slow because it must be compiled > > every time. I

Re: Using a variable for an array name

2017-02-01 Thread Richard Gaskin via use-livecode
Peter Bogdanoff wrote: > Richard, I’ve heard that “do” is slow because it must be compiled > every time. I am reiterating this possibly hundreds of times, so > it is probably much better to combine the arrays into a Big Array? It'll be a little faster, and to my eye much more readable. "Do" is

Re: Difference between "html" and "htmlText" in clipboardData?

2017-02-01 Thread Stephen Barncard via use-livecode
if you need it. http://media.barncard.com/downloads/clipboardTest.livecode On Wed, Feb 1, 2017 at 4:46 PM, Richard Gaskin via use-livecode < use-livecode@lists.runrev.com> wrote: > The Dictionary entry for clipboardData lists these among the array keys: > > - htmlText: LiveCode HTML text > -

Difference between "html" and "htmlText" in clipboardData?

2017-02-01 Thread Richard Gaskin via use-livecode
The Dictionary entry for clipboardData lists these among the array keys: - htmlText: LiveCode HTML text - html: styled text in LiveCode HTML format What is the difference between "LiveCode HTML text" and "LiveCode HTML format"? If there is no difference and they're both LC's htmlText, why

Re: Auto scrolling a locked field when mouse comes to edge

2017-02-01 Thread Peter Bogdanoff via use-livecode
Is this an issue with “Focus with Keyboard” not checked or traversalOn not true? > On Feb 1, 2017, at 6:33 PM, David Epstein via use-livecode > wrote: > > When the mouse drags across text in an unlocked (horizontally and vertically) > scrolling field, the

Re: Using a variable for an array name

2017-02-01 Thread Peter Bogdanoff via use-livecode
Yes, “do” does it. Thank you Ralph and Bob. Richard, I’ve heard that “do” is slow because it must be compiled every time. I am reiterating this possibly hundreds of times, so it is probably much better to combine the arrays into a Big Array? Peter > On Feb 1, 2017, at 7:16 PM, Bob Sneidar via

Re: Auto scrolling a locked field when mouse comes to edge

2017-02-01 Thread dunbarx via use-livecode
Hi. Not sure, I guess, what you are asking. I make an ordinary field, fill it with lots of dross, and lock the text. If I click on any visible line and then drag the mouse around, the text below the cursor, whether above or below the original clickLine, are all hilited. Craig NEwman -- View

Re: Using a variable for an array name

2017-02-01 Thread Bob Sneidar via use-livecode
Even better! Bob S On Feb 1, 2017, at 16:08 , Richard Gaskin via use-livecode > wrote: Whenever you have a collection of variables whose names may be variable, an array is a natural fit. LiveCode supports n-dimensional

Re: Using a variable for an array name

2017-02-01 Thread Richard Gaskin via use-livecode
Peter Bogdanoff wrote: > I have arrays: > tArray1 > tArray2 > tArray3 > tArray4 > > I want to get data from one of them: > > put “tArray” & “1” into tVar > put tVar [“Text”] into tText1 > > tText1 is empty. > > Is there a way to get the data from the arrays without doing this > kind of thing for

Re: Auto scrolling a locked field when mouse comes to edge

2017-02-01 Thread Dr. Hawkins via use-livecode
On Wed, Feb 1, 2017 at 3:33 PM, David Epstein via use-livecode < use-livecode@lists.runrev.com> wrote: > When the mouse drags across text in an unlocked (horizontally and > vertically) scrolling field, the field automatically scrolls at a legible > rate to display the (previously hidden) text

Re: Using a variable for an array name

2017-02-01 Thread Bob Sneidar via use-livecode
This is called macro substitution in other languages. You would use the form array in Foxpro for instance. LC has no macro Substitution. Instead: put "put tArray" & tVar & "[temp] into tText" & tVar into tCommand replace "temp" with quote & "text" & quote in tCommand do tCommand (untested) bob

RE: Using a variable for an array name

2017-02-01 Thread Ralph DiMola via use-livecode
"Do" will do the trick. Repeat with tVarNum = 1 to 4 do "put"&&"["("Text")&"] into tText" do "put"&&"["("SomeOtherArrayValue")&"] into tSomeOtherArrayValue" end repeat function WrapQ pString return quote end WrapQ Ralph DiMola IT Director Evergreen Information Services

Auto scrolling a locked field when mouse comes to edge

2017-02-01 Thread David Epstein via use-livecode
When the mouse drags across text in an unlocked (horizontally and vertically) scrolling field, the field automatically scrolls at a legible rate to display the (previously hidden) text that the mouse was dragging toward. Has anyone scripted a way to reproduce this effect for a locked field? Many

Using a variable for an array name

2017-02-01 Thread Peter Bogdanoff via use-livecode
I have arrays: tArray1 tArray2 tArray3 tArray4 I want to get data from one of them: put “tArray” & “1” into tVar put tVar [“Text”] into tText1 tText1 is empty. Is there a way to get the data from the arrays without doing this kind of thing for each array: put tArray1 [“Text”] into tText1

Re: Yertle the Turtle

2017-02-01 Thread Alejandro Tejada via use-livecode
Hi All, Remember that Jim Hurley wrote a book: http://jamesphurley.com/RunRev/TurtlePhysicsText.doc and many stacks about Turtle Graphics: http://jamesphurley.com/Revolution.html Al ___ use-livecode mailing list use-livecode@lists.runrev.com Please

Re: Mobile library for barcodes?

2017-02-01 Thread Mike Kerner via use-livecode
Roger, golf clap. With one hand. Jonathan, that's by design. We've had enough spyware on PC's that cause the camera to take video and stills. In fact, there was a case of a local rent-to-own company near me commissioning such software and then they had installed on every PC they rented. When

Re: 'the printerSettings' LC Indy 7.0 to 8.1.3 rc1

2017-02-01 Thread panagiotis merakos via use-livecode
You can add your email in the cc list of this bug report http://quality.livecode.com/show_bug.cgi?id=19200 if you want to be notified when the fix is available. On Wed, Feb 1, 2017 at 3:21 PM, panagiotis merakos < panos.mera...@livecode.com> wrote: > Hi Rob, > > I can replicate this, and this is

Re: 'the printerSettings' LC Indy 7.0 to 8.1.3 rc1

2017-02-01 Thread panagiotis merakos via use-livecode
Hi Rob, I can replicate this, and this is a bug introduced in LC 7. I will submit a PR with the fix soon. Best, Panos -- On Tue, Jan 31, 2017 at 7:16 PM, Robert Eppich via use-livecode < use-livecode@lists.runrev.com> wrote: > The following pasted into the message box returns the result:

Re: LC-Magick Collection

2017-02-01 Thread Roger Eller via use-livecode
*FOUND IT:* TracingBN_0_3.livecode.zip and sample files: images with transparency.zip At the bottom of this thread:

Re: Mobile library for barcodes?

2017-02-01 Thread Jonathan Lynch via use-livecode
Yah, that is an issue. The getUserMedia() method does not work in any form on iPhone. Wow, that's annoying. Good to know - thanks Mike. Sent from my iPhone > On Feb 1, 2017, at 6:47 AM, Roger Eller via use-livecode > wrote: > > No worries, Mike. Someday

Re: Mobile library for barcodes?

2017-02-01 Thread Roger Eller via use-livecode
No worries, Mike. Someday perhaps a widget for every platform will eMERGE. /see what I did there. :) On Jan 31, 2017 10:03 PM, "Mike Kerner via use-livecode" < use-livecode@lists.runrev.com> wrote: > Roger, I agree. I was not aware, until you mentioned it, this evening, > that zx ran on

Re: LC-Magick Collection

2017-02-01 Thread Roger Eller via use-livecode
There is a dedicated tracing stack somewhere on the LC forum. I think it was made about a year ago, maybe longer. ~Roger On Feb 1, 2017 2:37 AM, "hh via use-livecode" wrote: > Tracing all opaque parts of a picture with transparency, not only the > outline, is