Re: Is there an issue with beep on iOS?

2021-08-07 Thread David Squance via use-livecode
If you develop an app to measure the water volume for a drip system, I’d be 
interested. Mine are all on timers, so I don’t need to know that, but the 
amount of water going through would be good to know.

Dave

> On Aug 7, 2021, at 3:01 PM, William Prothero via use-livecode 
>  wrote:
> 
> Stephen:
> Thanks. I tried adding the number and it didn’t make a sound. This is not a 
> major problem for me. I’m making a timer. It beeps each second and when I 
> press “Done”, it stops and goes to a number entry screen. I’m timing the flow 
> of water on my drip system. The beep would be nice, but the vibration works 
> every second. 
> 
> Best,
> Bill
> 
> 
>> On Aug 5, 2021, at 5:38 PM, Stephen Barncard  wrote:
>> 
>> Try adding the parameter 1 for a single beep
>> 
>> Beep 1
>> Beep 2
>> 
>> It appears that beep by itself does not work, or perhaps on a phone it would 
>> work the vibrator.
>> 
>> On Thu, Aug 5, 2021 at 17:11 William Prothero via use-livecode 
>> mailto:use-livecode@lists.runrev.com>> wrote:
>> Folks:
>> This is a small thing, but I wonder if there is an issue with the beep 
>> command on iOS. I am on LC 9.6.3 and iOS 14.7.1, I get sound for other apps 
>> but my LC app only gives me the vibration.
>> 
>> Best,
>> Bill Prothero
>> 
>> 
>> 
>> William Prothero
>> waproth...@gmail.com 
>> 
>> 
>> 
>> 
>> ___
>> use-livecode mailing list
>> use-livecode@lists.runrev.com 
>> Please visit this url to subscribe, unsubscribe and manage your subscription 
>> preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode 
>> 
>> -- 
>> --
>> Stephen Barncard - Sebastopol Ca. USA - 
>> mixstream.org 
> William Prothero
> waproth...@gmail.com
> 
> 
> 
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription 
> preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Is there an issue with beep on iOS?

2021-08-07 Thread Rick Harrison via use-livecode
Hi Bill,

You can always make your own beep sound, but you will have
to call it like you would any other sound.  Don’t use beep.

Example from the dictionary:

put specialFolderPath("engine") & "/applause.mp3" into tSoundFile
play tSoundFile

Good luck!

Rick

> On Aug 5, 2021, at 8:09 PM, William Prothero via use-livecode 
>  wrote:
> 
> Folks:
> This is a small thing, but I wonder if there is an issue with the beep 
> command on iOS. I am on LC 9.6.3 and iOS 14.7.1, I get sound for other apps 
> but my LC app only gives me the vibration.
> 
> Best,
> Bill Prothero
> 
> 
> 
> William Prothero
> waproth...@gmail.com
> 
> 
> 
> 
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription 
> preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Is there an issue with beep on iOS?

2021-08-07 Thread William Prothero via use-livecode
Stephen:
Thanks. I tried adding the number and it didn’t make a sound. This is not a 
major problem for me. I’m making a timer. It beeps each second and when I press 
“Done”, it stops and goes to a number entry screen. I’m timing the flow of 
water on my drip system. The beep would be nice, but the vibration works every 
second. 

Best,
Bill


> On Aug 5, 2021, at 5:38 PM, Stephen Barncard  wrote:
> 
> Try adding the parameter 1 for a single beep
> 
> Beep 1
> Beep 2
> 
> It appears that beep by itself does not work, or perhaps on a phone it would 
> work the vibrator.
> 
> On Thu, Aug 5, 2021 at 17:11 William Prothero via use-livecode 
> mailto:use-livecode@lists.runrev.com>> wrote:
> Folks:
> This is a small thing, but I wonder if there is an issue with the beep 
> command on iOS. I am on LC 9.6.3 and iOS 14.7.1, I get sound for other apps 
> but my LC app only gives me the vibration.
> 
> Best,
> Bill Prothero
> 
> 
> 
> William Prothero
> waproth...@gmail.com 
> 
> 
> 
> 
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com 
> Please visit this url to subscribe, unsubscribe and manage your subscription 
> preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode 
> 
> -- 
> --
> Stephen Barncard - Sebastopol Ca. USA - 
> mixstream.org 
William Prothero
waproth...@gmail.com



___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode