Re: Problem with converting time

2017-03-16 Thread Richard Gaskin via use-livecode
Michael Doub wrote: > I am getting different answers based on environment when trying to > convert EPOC seconds to dateitems or internet date. On my mac I get > the expected result but on a HostM server I get something totally > different. How different? > Does any one have a conversion

Problem with converting time

2017-03-16 Thread Michael Doub via use-livecode
I am getting different answers based on environment when trying to convert EPOC seconds to dateitems or internet date. On my mac I get the expected result but on a HostM server I get something totally different. Does any one have a conversion function that does not use the livecode's

Solved: Re: Help test please? GoLiveNet in v9

2017-03-16 Thread Richard Gaskin via use-livecode
Many thanks to all of you who helped test LiveNet. Much appreciated. The problem appears to be specific to LC on Linux, and thanks to Charles Warwick's excellent support of tsNet he was able to deliver a possible fix, which I've confirmed works:

AW: AW: tsneterr: (6) could not resolve host - can anyone else test this?

2017-03-16 Thread Tiemo Hollmann TB via use-livecode
Panos from LC solved the mystery. In my URL the password has a special character, which can't be handled in 8.1.2 and 8.1.3 on Windows. When doing urlencode(myPW), it also works in 8.1.3 The why is not known Tiemo -Ursprüngliche Nachricht- Von: use-livecode

RE: AW: tsneterr: (6) could not resolve host - can anyone else test this?

2017-03-16 Thread Paul Richards via use-livecode
LC 8.1.3 - Windows 10 64Bit - Works for me -Original Message- From: use-livecode [mailto:use-livecode-boun...@lists.runrev.com] On Behalf Of Charles Warwick via use-livecode Sent: 16 March 2017 10:11 To: use-livecode@lists.runrev.com Cc: Charles Warwick

Re: the screenpixelscale on Microsoft SurfaceBook?

2017-03-16 Thread Trevor DeVore via use-livecode
On Mon, Mar 6, 2017 at 1:11 PM, Andre Garzia wrote: > Hey Trevor, > > This is a Surface Pro 4 with Intel HD 520 running latest Windows 10 at > 2736x1284 with 200% display scaling. The screenPixelScale reported is 2 on > LC 8.1.2 > > I can't have my machine go to 3000x2000,

AW: AW: tsneterr: (6) could not resolve host - can anyone else test this?

2017-03-16 Thread Tiemo Hollmann TB via use-livecode
Hi Charles, this test URL works for me also in 8.1.3 my URL still doesn't works in 8.1.3 (but in 9.0 and older versions) - what happened to tsnet in 8.1.3? your workaround with tsNetGetSync also works with my URL in 8.1.3 - whats the difference under the hood to put URL? interesting results!

Re: SFTP with .PPK file

2017-03-16 Thread Stephen MacLean via use-livecode
Hi Charles, One other thing… in looking at the .ppk file, it contains both “public lines” and "private lines”. All I see in the ssh key file is private. Not sure that make any difference, but thought I’d mention it. Best, Steve > On Mar 16, 2017, at 7:53 AM, Stephen MacLean via

Re: SFTP with .PPK file

2017-03-16 Thread Stephen MacLean via use-livecode
Hi Charles, Thank you so much for reply! I converted the key file as you described, however, I’m still getting the error 67 (authentication error) when running the script. Any further help would be greatly appreciated. Best, Steve MacLean > On Mar 16, 2017, at 3:08 AM, Charles Warwick via

Re: tsneterr: (6) could not resolve host - can anyone else test this?

2017-03-16 Thread Matthias Rebbe via use-livecode
Tried it here with LC 8.1.3, Win 7 Pro, 64bit -> works LC 8.1.3, Win 10 Pro, 32bit -> works Matthias Rebbe Bramkampsieke 13 32312 Lübbecke Tel +49 5741 31 +49 160 5504462 Fax: +49 5741 310002 eMail: matth...@m-r-d.de BR5 Konverter - BR5 ->

Re: AW: tsneterr: (6) could not resolve host - can anyone else test this?

2017-03-16 Thread Charles Warwick via use-livecode
I have not been able to replicate this issue here, but I am using an older version of Windows. Is there anyone that can try this on various versions of Windows to see if this problem is specific to Win 10? Try typing the following into the message box: put URL

Re: Help test please? GoLiveNet in v9

2017-03-16 Thread Dave Kilroy via use-livecode
Works very nicely with LC8.1.3 and 9.0.0(dp6) on mac 10.12.3 Dave ___ use-livecode mailing list use-livecode@lists.runrev.com Please visit this url to subscribe, unsubscribe and manage your subscription preferences:

Re: AW: tsneterr: (6) could not resolve host

2017-03-16 Thread Charles Warwick via use-livecode
Hi Tiemo, I have not heard of this issue before but will see if I can reproduce it and get back to you. A workaround would be to use the tsNetGetSync function directly so that you can specify the user/pass separately like this: -- local tHeaders, tOutHeaders, tResultCode, tBytes, tSettings

Re: Translating escape sequences

2017-03-16 Thread Richmond via use-livecode
Should do. Richmond. On 15/03/17 23:03, Mike Bonner via use-livecode wrote: does this mean one could replace /u with 0x and then replace uls with empty and end up with the correct end result? On Wed, Mar 15, 2017 at 2:16 PM, Richmond Mathewson via use-livecode < use-livecode@lists.runrev.com>

Re: Translating escape sequences

2017-03-16 Thread Richmond via use-livecode
Ouch. My excuse is that I was working with the example you supplied. Richmond. On 15/03/17 22:36, J. Landman Gay via use-livecode wrote: What if the user name has seven characters after the escape sequence? On 3/15/17 3:16 PM, Richmond Mathewson via use-livecode wrote: Just knock off the

Re: SFTP with .PPK file

2017-03-16 Thread Charles Warwick via use-livecode
Hi Steve, It looks like you are using a SSH private key in PuTTY format (.ppk). tsNet requires it to be in OpenSSH format. That is easy to fix though, you can convert the .ppk with PuttyGen. To do this, open PuttyGen and load the .ppk file. Then select "Conversions" -> "Export OpenSSH