Re: any secrets printing only a section from a card?

2017-04-11 Thread Robert Brenstein via use-livecode
This might be an older issue. I have been struggling with that myself, 
in context of producing PDFs, in version 7. Only printing the full card 
works reliably. Any other option produces a different output but not the 
desired one, at least not reliably.


On 10 Apr 2017, at 12:06, Tiemo Hollmann TB via use-livecode wrote:


Hello,

LC 8.1.4, Win 10. (Same with LC 6-9) When printing a whole card with 
just
"print card" everything of the card is being printed fine, only 
stretched to

the papersize.

But when trying to print only a part of the  card by "print card from
myLeftTop to myRightBottom into page Rect" I never get the wanted 
rectangle
being printed into the pageRect. It is always clipped somewhere and 
only a
small part of the wanted rectangle is being printed. I have also tried 
to
set the printpapersize and printmargins and fiddled around with 
different

rectangle sizes, but didn't got the wanted section.

Are there any secret conversion factors, when printing "from to"?

Thanks for any hint

Tiemo


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: ListMagic still available?

2017-06-24 Thread Robert Brenstein via use-livecode
I managed to get in touch with Eric’s son at the time and offered to 
support and develop it further, but nothing came out of it, so consider 
ListMagic a history.


On 24 Jun 2017, at 1:50, Bob Sneidar via use-livecode wrote:

Thanks Matthias. I was hoping someone picked it up. It really is a 
nice piece of work. I will research to see if Jim is still able to be 
contacted.


Bob S


On Jun 23, 2017, at 16:26 , Matthias Rebbe via use-livecode 
 wrote:


Eric Chatonet, the author of ListMagic, passed away in January 2009. 
Jim Bufalini, a business partner of Eric, if i remember right, sold 
and supported the product for some time to support Eric´s family.


But i am afraid it is not sold anymore. The last post of Jim Bufalini 
to this list was 2010.


Matthias


Matthias Rebbe
+49 5741 31
‌matthiasrebbe.eu ‌


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your 
subscription preferences:

http://lists.runrev.com/mailman/listinfo/use-livecode

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode

Re: Regex help...

2017-06-07 Thread Robert Brenstein via use-livecode
If the number of comma-delimited and tab-delimited elements is always 
the same, I would replace all commas with tabs and then filter to have 
item x having value of y.


Robert

On 5 Jun 2017, at 15:23, Paul Dupuis via use-livecode wrote:


Thank you Thierry and everyone else.

I should have realized that I couldn't do this entirely with regex due
to the need to compare the number values. It was a long day yesterday
and my brain just wasn't in full gear.

-- Paul

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: livecode changes image colors without being asked to do it

2017-09-06 Thread Robert Brenstein via use-livecode
Thanks Sean. I finally had time to check your file and indeed it 
displays correctly in 8.1.6.


It still displays wrong in 7.1.3, but it displays differently than the 
file without profile, so this must be the profile issue that was fixed 
in 8.1.3.


In other words, my problem is with the way jpeg file were generated. It 
would be nice if LC handled such files like Preview does or at least 
returned a warning that profile is missing.


Robert

On 1 Sep 2017, at 2:34, Sean Cole (Pi) via use-livecode wrote:


Hi Robert

I have looked at this and it is reacting this way because a correct
CMYK colorspace profile has not been embedded into the jpeg file.
LiveCode, therefore, has no idea how to interpret the colors and
handles them in an almost raw state oversaturating them. Adding the
closest profile to its natural state helps, in this instance, US Web
Coated (SWOP) v2.

I've attached another source jpg to test with which has this embedded 
profile.


http://quality.livecode.com/show_bug.cgi?id=20316


Sean Cole
*Pi Digital Productions Ltd*

'Don't try to think outside the box. Just remember the truth: There is 
no

box!'
'For then you realise it is not the box you are trying to look outside 
of,

but it is yourself!'

eMail Ts & Cs <http://pidigital.co.uk/emailTCs.rtf>   Pi Digital
Productions Ltd is a UK registered limited company, no. 5255609

On 1 September 2017 at 00:11, Robert Brenstein via use-livecode <
use-livecode@lists.runrev.com> wrote:


I just tested this in LC 8.1.6 and it shows the same problem as 
7.1.3. I
filed a bug report for the team to check into this, including the 
files.

Bug 20316.

Robert


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Autocomplete toggle?

2017-09-27 Thread Robert Brenstein via use-livecode

On 27 Sep 2017, at 7:16, J. Landman Gay via use-livecode wrote:

What this sounds like (at least I think it sounds like) is an 
autocomplete placeholder got messed up somehow causing typing in one 
place to also add the text elsewhere. If that’s the case then 
turning autocomplete off once it’s messed up won’t really help. 
There’s been a bit of movement in this code since DP 2 so it may be 
that your issue is fixed already. If you see it again do you think 
you could take some screen recording of it and send to me?



I'd need to find some screen recording software. Preferably free, if 
you know of anything.


Quicktime Player can do it. Nothing fancy but is free. I’ve been using 
it regularly to record screen activity for troubleshooting. Make sure to 
check recording the mouse clicks, otherwise it is often hard to see what 
you ate doing.


Robert
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode

Re: livecode changes image colors without being asked to do it

2017-08-31 Thread Robert Brenstein via use-livecode
I just tested this in LC 8.1.6 and it shows the same problem as 7.1.3. I 
filed a bug report for the team to check into this, including the files. 
Bug 20316.


Robert

On 31 Aug 2017, at 18:25, Mark Waddingham via use-livecode wrote:


On 2017-08-31 18:22, Robert Brenstein via use-livecode wrote:

As Panos wrote: CMYK images should display correctly if you are using
LC >=8.1.3:
I am using 7.1.3. This is what I meant that this was a known problem.
I just fetched 8.1.6 to check but I won’t habe time to do it until 
next week.


Oops - I missed that email of Panos's - I thought something like this 
sounded familiar.


Anyway, keep us posted on how you get on - hopefully that fix will 
solve the problem for you.


Warmest Regards,

Mark.

--
Mark Waddingham ~ m...@livecode.com ~ http://www.livecode.com/
LiveCode: Everyone can create apps

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your 
subscription preferences:

http://lists.runrev.com/mailman/listinfo/use-livecode

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode

Re: livecode changes image colors without being asked to do it

2017-08-30 Thread Robert Brenstein via use-livecode

resizequality is set to best…

On 30 Aug 2017, at 15:03, Mike Bonner via use-livecode wrote:


Not sure if it will make a difference, but you might want to-- set the
resizequality of the img "imagename"  to "best"

On Wed, Aug 30, 2017 at 6:54 AM, Robert Brenstein via use-livecode <
use-livecode@lists.runrev.com> wrote:

I have a stack that dynamically sets the image that is displayed on a 
card

using

set the filename of img vImageName of stack vStackName to 
vFilePath


I just encountered a problem with a new batch of jpeg files. Their 
colors
change when they are displayed in the stack. I mean that when I open 
them
in Preview, the color saturation and hue are different than when 
viewing

the same pic in a stack.

Anything I can do to avoid that or anything I can tell the graphics 
person

to do differently when producing those files in AI?

RObert
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your
subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your 
subscription preferences:

http://lists.runrev.com/mailman/listinfo/use-livecode

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode

livecode changes image colors without being asked to do it

2017-08-30 Thread Robert Brenstein via use-livecode
I have a stack that dynamically sets the image that is displayed on a 
card using


set the filename of img vImageName of stack vStackName to vFilePath

I just encountered a problem with a new batch of jpeg files. Their 
colors change when they are displayed in the stack. I mean that when I 
open them in Preview, the color saturation and hue are different than 
when viewing the same pic in a stack.


Anything I can do to avoid that or anything I can tell the graphics 
person to do differently when producing those files in AI?


RObert
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: livecode changes image colors without being asked to do it

2017-08-30 Thread Robert Brenstein via use-livecode
Thanks for pointing me in the right direction. The images are indeed 
CMYK. The stack is used to produce a PDF file and the printing shop 
requested CMYK. I just checked that last year we had indeed used sRGB 
not CMYK.


RObert

On 30 Aug 2017, at 16:03, Sean Cole (Pi) via use-livecode wrote:


Hi Robert,

This is likely down to the colour space the images are embedded with.
Preview will respect the colour space whereas LC will not in some 
cases.
Make sure the jpg is saved with the sRGB (IEC61966-2.1) profile to 
maintain

the correct colour. And make sure it's not CMYK.

Sean Cole
*Pi Digital Productions Ltd*
www.pidigital.co.uk
+44(1634)402193
+44(7702)116447
'Don't try to think outside the box. Just remember the truth: There is 
no

box!'
'For then you realise it is not the box you are trying to look outside 
of,

but it is yourself!'

eMail Ts & Cs <http://pidigital.co.uk/emailTCs.rtf>   Pi Digital
Productions Ltd is a UK registered limited company, no. 5255609

On 30 August 2017 at 14:03, Mike Bonner via use-livecode <
use-livecode@lists.runrev.com> wrote:

Not sure if it will make a difference, but you might want to-- set 
the

resizequality of the img "imagename"  to "best"

On Wed, Aug 30, 2017 at 6:54 AM, Robert Brenstein via use-livecode <
use-livecode@lists.runrev.com> wrote:

I have a stack that dynamically sets the image that is displayed on 
a

card

using

set the filename of img vImageName of stack vStackName to

vFilePath


I just encountered a problem with a new batch of jpeg files. Their 
colors
change when they are displayed in the stack. I mean that when I open 
them
in Preview, the color saturation and hue are different than when 
viewing

the same pic in a stack.

Anything I can do to avoid that or anything I can tell the graphics

person

to do differently when producing those files in AI?

RObert
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your
subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your
subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your 
subscription preferences:

http://lists.runrev.com/mailman/listinfo/use-livecode

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: livecode changes image colors without being asked to do it

2017-08-30 Thread Robert Brenstein via use-livecode

LC 7.1.3

It sounds like I must venture into LC8-land or see whether I manage to 
get by with sRGB yet…


RObert

On 30 Aug 2017, at 16:07, panagiotis merakos via use-livecode wrote:


@Robert which LiveCode version are you using?

CMYK images should display correctly if you are using LC >=8.1.3:

https://github.com/livecode/livecode/pull/4950

Best,
Panos
--

On Wed, Aug 30, 2017 at 3:03 PM, Sean Cole (Pi) via use-livecode <
use-livecode@lists.runrev.com> wrote:


Hi Robert,

This is likely down to the colour space the images are embedded with.
Preview will respect the colour space whereas LC will not in some 
cases.
Make sure the jpg is saved with the sRGB (IEC61966-2.1) profile to 
maintain

the correct colour. And make sure it's not CMYK.

Sean Cole
*Pi Digital Productions Ltd*
www.pidigital.co.uk
+44(1634)402193
+44(7702)116447
'Don't try to think outside the box. Just remember the truth: There 
is no

box!'
'For then you realise it is not the box you are trying to look 
outside of,

but it is yourself!'

eMail Ts & Cs <http://pidigital.co.uk/emailTCs.rtf>   Pi Digital
Productions Ltd is a UK registered limited company, no. 5255609

On 30 August 2017 at 14:03, Mike Bonner via use-livecode <
use-livecode@lists.runrev.com> wrote:

Not sure if it will make a difference, but you might want to-- set 
the

resizequality of the img "imagename"  to "best"

On Wed, Aug 30, 2017 at 6:54 AM, Robert Brenstein via use-livecode <
use-livecode@lists.runrev.com> wrote:

I have a stack that dynamically sets the image that is displayed on 
a

card

using

set the filename of img vImageName of stack vStackName to

vFilePath


I just encountered a problem with a new batch of jpeg files. Their

colors
change when they are displayed in the stack. I mean that when I 
open

them

in Preview, the color saturation and hue are different than when

viewing

the same pic in a stack.

Anything I can do to avoid that or anything I can tell the graphics

person

to do differently when producing those files in AI?

RObert
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your
subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your
subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your
subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your 
subscription preferences:

http://lists.runrev.com/mailman/listinfo/use-livecode

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode

Re: livecode changes image colors without being asked to do it

2017-08-31 Thread Robert Brenstein via use-livecode
As Panos wrote: CMYK images should display correctly if you are using LC 
>=8.1.3:

I am using 7.1.3. This is what I meant that this was a known problem.
I just fetched 8.1.6 to check but I won’t habe time to do it until 
next week.


Robert

On 31 Aug 2017, at 17:55, Mark Waddingham via use-livecode wrote:

That's why I was intrigued - I inferred that your fix was to use an 
sRGB profile in the JPEGs rather than CMYK.


However, there still sounds like an issue somewhere - the engine 
should cope with CMYK, so assuming there is a profile in the JPEG for 
CMYK it should display similar to Preview. I know CMYK JPEGs are a bit 
gnarly so having an example which doesn't work quite right might help 
them work a little better and more consistent generally.


Of course, I could have misunderstood entirely!

Warmest Regards,

Mark.

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode

Re: livecode changes image colors without being asked to do it

2017-08-31 Thread Robert Brenstein via use-livecode
Mark, if you follow the thread, you will find that I hit a known problem 
and it was remedied in a newer version of LC8. The comment/tip from 
Keith is quite useful since the files I produce are printed by different 
print shops in different countries. The shop I use locally accepts files 
with sRGB but warns that color might be slightly off due to conversion 
to CMYK.


RObert

On 31 Aug 2017, at 17:07, Mark Waddingham via use-livecode wrote:


Hi Robert,

Are you able to file a bug with the offending image?

The engine does handle colour profiles in many cases so there may be 
an issue with that kind of profile (if the image has one).


Of course, if the image does not have a profile then it might the 
engine isn't using an appropriate default.


Warmest Regards,

Mark.

Sent from my iPhone

On 30 Aug 2017, at 13:54, Robert Brenstein via use-livecode 
<use-livecode@lists.runrev.com> wrote:


I have a stack that dynamically sets the image that is displayed on a 
card using


   set the filename of img vImageName of stack vStackName to 
vFilePath


I just encountered a problem with a new batch of jpeg files. Their 
colors change when they are displayed in the stack. I mean that when 
I open them in Preview, the color saturation and hue are different 
than when viewing the same pic in a stack.


Anything I can do to avoid that or anything I can tell the graphics 
person to do differently when producing those files in AI?


RObert
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your 
subscription preferences:

http://lists.runrev.com/mailman/listinfo/use-livecode



___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your 
subscription preferences:

http://lists.runrev.com/mailman/listinfo/use-livecode

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Livecode Content Management System

2017-12-01 Thread Robert Brenstein via use-livecode
I have been using LC to generate complete websites but I use LC only as 
a generator of HTML pages from data files and database content, using 
CSS for theming and HTML hierarchical template files that call LC 
functions through merge. I believe that Richard Gaskin is still selling 
a commercial product that does this in a more generic way.


I have been thinking for a while to convert my setup into a more proper 
CMS but gave up at the planning stage once I realized how much effort 
that is. I also started playing with revIgniter and am really impressed 
with what it offers, but I came to a similar conclusion like you.


I actually had a real CMS developed in MetaCard years ago. It was 
developed as a special-purpose product for a client and not a generic 
CMS. It broke because at the time I did not use proper modularizing and 
abstraction layers and keeping it compatible with the database engine 
became impossible at some point.


BTW, wasn’t there a commercial CMS produced in LC (or whatever it was 
called at the time)? I think its name was Hemingway or sth like that.


Robert

On 1 Dec 2017, at 2:56, Alex Tweedly via use-livecode wrote:


Hi folks,

I'm looking for (initial) interest, previous experience, comments, 
etc.


Every few [ = 4 to 8] months for the last few [= 2 to 3] years, I've 
been either building a new website for someone, or making significant 
changes/enhancements to an existing one. Almost every time, unless the 
changes are very small, I've decided that I really *should* convert it 
to use a 'proper' CMS - e.g. Wordpress.


And I've tried - but every time I've foundered on not being able to 
get the site to be what I want, or realizing (believing?) that to do 
what I want requires real development skills within WP - and therefore 
too much of a learning curve and/or too much PHP.  Or, I've decided 
that to make it a bearable experience I need to use multiple add-ons 
(plugins, themes, etc.) and then found that the plugins I spent hours 
investigating and choosing were incompatible. Or were just not well 
enough documented.


[ I won't tell you how often I've found a (video) tutorial, wasted an 
entire hour or more watching it - then realized that it was for an 
out-of-date version of the plugin, or an old version of Wordpress, and 
that all the helpful screenshots showed me how to modify settings / 
actions that didn't exist, or had no obvious equivalent, in the 
current versions. ]


Twice, having run into brick walls with Wordpress, I've tried other 
CMSs (Concrete5 and ??Dolphin??) with similar results - poor / 
out-of-date docs have left me stranded - 80% of the way towards doing 
what I wanted and unable to get any further.


So in every case until now, I've given up, made tweaks / extensions to 
my own "home-grown" web site tool(s), and - so far - completed my 
enhancements in less time than I had wasted trying the "real" CMS.


I put that down to:
 - the power of Livecode
 - the power of revIgniter  (thank you ! again, Ralf)
 - my impatience in trying to learn new tools

But now I have a new, bigger opportunity / challenge - I've been asked 
to build a web site (actually two unrelated web sites) which are 
bigger and more complex, and for which I absolutely do not want to 
become the de facto on-going (content) maintainer.


So, I've decided to build LCMS - a Livecode Content Management System.

It will be (very loosely) based on what I think are the useful ideas 
in Wordpress (but without any tendency towards blogs). It will be 
relatively simple.


It won't be:
 - smooth, slick and all-powerful like WP
 - able to support (initially, and for some time) real independent 
development of themes, plugins, auto-loading and updating, etc. etc. 
(yada, yada, yada ...) - that might be done in a few [= 2 to 20 years]


It will be :
 - based on Livecode (and extensible in LC)
 - (I hope) simple and easy (for a LC developer) to understand, use 
and extend

 - complete with at least one complete theme (based on Botstrap)
 - (at some point) open source, on github, etc. under MIT liceense
 - documented in some old-fashioned way (i.e. written, searchable, 
skimmable tutorials - few or no Youtube videos to waste your time)


OK - enough of the advertising pitch :-)

Here are the requests for input 

1.  has anyone tried this before ? and did you succeed ?  or why did 
you stop ? any foreseeable problems to contend with ?


2. am I just tilting at windmills and I should just go back to 
studying WP and its plugins ?


3. the current prototype is based on (or rather 'is written over' 
revIgniter).


I have very conflicting opinions of revIgniter
    + it's wonderful, it has a huge quantity of things it "just 
does" (in a well documented, well tested, etc. way)  so that I don't 
need to think or learn about them, etc. - I love it.
    - (a) it is intimately tied to LC server, with heavy dependency 
on 'include' so it's impossible to (as I would want to do) test 99% of 
my code in the IDE, 

Re: Anyone have an open source or else a gratis stop watch app

2018-04-16 Thread Robert Brenstein via use-livecode
You probably can just modify the analog clock project that was 
produced/discussed on this list a while ago…


On 14 Apr 2018, at 4:37, Mark Rauterkus via use-livecode wrote:


Hi,

A swim coach friend was talking about a stopwatch app. Anyone have one 
in

LIVECODE already done?

Wondering.

Mark Rauterkus

--

--
Ta.


Mark Rauterkus   m...@rauterkus.com
Executive Director of SKWIM USA, a 501(c)(3)
PPS Summer Dreamers' Swim & Water Polo Camp Executive Coach
Middle School Swim Coach at The Ellis School
Former Varsity Boys Swim Coach, Pittsburgh Obama Academy
Recent Head Water Polo Coach, Carnegie Mellon University Women's Club 
Team

Pittsburgh Combined Water Polo Team

http://CLOH.org 

412 298 3432 = cell
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your 
subscription preferences:

http://lists.runrev.com/mailman/listinfo/use-livecode

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode

Re: ANN: Script Editor Refactoring Support

2019-03-21 Thread Robert Brenstein via use-livecode

Wow! Which versions of LiveCode is this baby compatible with?

On 20 Mar 2019, at 18:45, Mark Wieder via use-livecode wrote:


Announcing (60 days until the San Jose conference):

Script Editor Refactor Plugin
Brings refactoring support to the LiveCode Script Editor.
Place the plugin into your user Plugins folder.
After launching the script editor there will be a new Refactoring 
menuItem in the Edit menu.
The Refactoring menuItem will also appear in the contextual menu 
of the Script Editor.
The Refactoring menu is inspired by the JetBrains refactoring 
support in RubyMine, etc.



___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: launch & quit

2019-10-13 Thread Robert Brenstein via use-livecode
I’d guess that quit command triggers some closeXxxx handlers to run 
and one causes the delay. The duration of delay sounds a bit like 
network timeout. Have you tried to switch off messages before quit?


On Oct 12, 2019, at 13:28, Paul Dupuis via use-livecode 
 wrote:


I have a stand alone with a card with a button with a mouseUp handler

on mouseUp

  -- some stuff

  -- tApplication variable contains a path to another standalone for 
OSX or Window depending upon what platform() this standalon is running 
on


  launch tApplication
  put the result into tError
  if tError is not empty then
answer error tErrormEssage
  end if
  quit
end mouseUp

On Windows, the designated application launches promptly and my app 
quits immediately.


On OSX, the designated application launches promptly and my app waits 
way too long (a minute or two) before quitting.


Standalone built for OSX and Windows on Windows under LC905

Anyone have any experience like this? Any ideas on what to do to get 
the OSX version to quit when told to quit?

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode