Slightly OT - Liquid volume measurement (was Is there an issue with beep on IOS)

2021-08-08 Thread Robert Earp via use-livecode
David/Bill/et al, my challenge was accurately filling bottles of wine (draining 
them never has been a problem !!).  For a long time I tried to get LC to 
communicate with external hardware and finally gave up when I found the joy of 
the Arduino, and more recently the Raspberry Pie Pico.  For liquid volume 
measurement take a look at this, 
https://www.electroschematics.com/working-with-water-flow-sensors-arduino/

….and it’s only an intro on what wonders you can use these devices for.  They 
are very inexpensive and the Arduino IDE is very simple.  If you go the Pico 
route you can also use Python.

best, Bob...


> Message: 3
> Date: Sat, 7 Aug 2021 19:17:49 -0700
> From: David Squance mailto:dsqua...@telus.net>>
> To: How to use LiveCode  <mailto:use-livecode@lists.runrev.com>>
> Subject: Re: Is there an issue with beep on iOS?
> Message-ID: <94ee2d7a-845c-401a-8e6a-b05bb2e18...@telus.net 
> <mailto:94ee2d7a-845c-401a-8e6a-b05bb2e18...@telus.net>>
> Content-Type: text/plain; charset=utf-8
> 
> If you develop an app to measure the water volume for a drip system, I?d be 
> interested. Mine are all on timers, so I don?t need to know that, but the 
> amount of water going through would be good to know.
> 
> Dave



Robert (Bob) Earp
White Rock
British Columbia
Canada






___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Is there an issue with beep on iOS?

2021-08-08 Thread hakan--- via use-livecode
Maybe a stupid suggestion, but has happened to me several times :-0 Have you 
checked that your phone Is not in silent mode in any way? If you have the phone 
in silent mode the normal behaviour is to just vibrate.

> On 6 Aug 2021, at 02:09, William Prothero via use-livecode 
>  wrote:
> 
> Folks:
> This is a small thing, but I wonder if there is an issue with the beep 
> command on iOS. I am on LC 9.6.3 and iOS 14.7.1, I get sound for other apps 
> but my LC app only gives me the vibration.
> 
> Best,
> Bill Prothero
> 
> 
> 
> William Prothero
> waproth...@gmail.com
> 
> 
> 
> 
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription 
> preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Is there an issue with beep on iOS?

2021-08-07 Thread David Squance via use-livecode
If you develop an app to measure the water volume for a drip system, I’d be 
interested. Mine are all on timers, so I don’t need to know that, but the 
amount of water going through would be good to know.

Dave

> On Aug 7, 2021, at 3:01 PM, William Prothero via use-livecode 
>  wrote:
> 
> Stephen:
> Thanks. I tried adding the number and it didn’t make a sound. This is not a 
> major problem for me. I’m making a timer. It beeps each second and when I 
> press “Done”, it stops and goes to a number entry screen. I’m timing the flow 
> of water on my drip system. The beep would be nice, but the vibration works 
> every second. 
> 
> Best,
> Bill
> 
> 
>> On Aug 5, 2021, at 5:38 PM, Stephen Barncard  wrote:
>> 
>> Try adding the parameter 1 for a single beep
>> 
>> Beep 1
>> Beep 2
>> 
>> It appears that beep by itself does not work, or perhaps on a phone it would 
>> work the vibrator.
>> 
>> On Thu, Aug 5, 2021 at 17:11 William Prothero via use-livecode 
>> mailto:use-livecode@lists.runrev.com>> wrote:
>> Folks:
>> This is a small thing, but I wonder if there is an issue with the beep 
>> command on iOS. I am on LC 9.6.3 and iOS 14.7.1, I get sound for other apps 
>> but my LC app only gives me the vibration.
>> 
>> Best,
>> Bill Prothero
>> 
>> 
>> 
>> William Prothero
>> waproth...@gmail.com 
>> 
>> 
>> 
>> 
>> ___
>> use-livecode mailing list
>> use-livecode@lists.runrev.com 
>> Please visit this url to subscribe, unsubscribe and manage your subscription 
>> preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode 
>> 
>> -- 
>> --
>> Stephen Barncard - Sebastopol Ca. USA - 
>> mixstream.org 
> William Prothero
> waproth...@gmail.com
> 
> 
> 
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription 
> preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Is there an issue with beep on iOS?

2021-08-07 Thread Rick Harrison via use-livecode
Hi Bill,

You can always make your own beep sound, but you will have
to call it like you would any other sound.  Don’t use beep.

Example from the dictionary:

put specialFolderPath("engine") & "/applause.mp3" into tSoundFile
play tSoundFile

Good luck!

Rick

> On Aug 5, 2021, at 8:09 PM, William Prothero via use-livecode 
>  wrote:
> 
> Folks:
> This is a small thing, but I wonder if there is an issue with the beep 
> command on iOS. I am on LC 9.6.3 and iOS 14.7.1, I get sound for other apps 
> but my LC app only gives me the vibration.
> 
> Best,
> Bill Prothero
> 
> 
> 
> William Prothero
> waproth...@gmail.com
> 
> 
> 
> 
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription 
> preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Is there an issue with beep on iOS?

2021-08-07 Thread William Prothero via use-livecode
Stephen:
Thanks. I tried adding the number and it didn’t make a sound. This is not a 
major problem for me. I’m making a timer. It beeps each second and when I press 
“Done”, it stops and goes to a number entry screen. I’m timing the flow of 
water on my drip system. The beep would be nice, but the vibration works every 
second. 

Best,
Bill


> On Aug 5, 2021, at 5:38 PM, Stephen Barncard  wrote:
> 
> Try adding the parameter 1 for a single beep
> 
> Beep 1
> Beep 2
> 
> It appears that beep by itself does not work, or perhaps on a phone it would 
> work the vibrator.
> 
> On Thu, Aug 5, 2021 at 17:11 William Prothero via use-livecode 
> mailto:use-livecode@lists.runrev.com>> wrote:
> Folks:
> This is a small thing, but I wonder if there is an issue with the beep 
> command on iOS. I am on LC 9.6.3 and iOS 14.7.1, I get sound for other apps 
> but my LC app only gives me the vibration.
> 
> Best,
> Bill Prothero
> 
> 
> 
> William Prothero
> waproth...@gmail.com 
> 
> 
> 
> 
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com 
> Please visit this url to subscribe, unsubscribe and manage your subscription 
> preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode 
> 
> -- 
> --
> Stephen Barncard - Sebastopol Ca. USA - 
> mixstream.org 
William Prothero
waproth...@gmail.com



___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Is there an issue with beep on iOS?

2021-08-05 Thread Stephen Barncard via use-livecode
Try adding the parameter 1 for a single beep

Beep 1
Beep 2

It appears that beep by itself does not work, or perhaps on a phone it
would work the vibrator.

On Thu, Aug 5, 2021 at 17:11 William Prothero via use-livecode <
use-livecode@lists.runrev.com> wrote:

> Folks:
> This is a small thing, but I wonder if there is an issue with the beep
> command on iOS. I am on LC 9.6.3 and iOS 14.7.1, I get sound for other apps
> but my LC app only gives me the vibration.
>
> Best,
> Bill Prothero
>
>
>
> William Prothero
> waproth...@gmail.com
>
>
>
>
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
-- 
--
Stephen Barncard - Sebastopol Ca. USA -
mixstream.org
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Is there an issue with beep on iOS?

2021-08-05 Thread William Prothero via use-livecode
Folks:
This is a small thing, but I wonder if there is an issue with the beep command 
on iOS. I am on LC 9.6.3 and iOS 14.7.1, I get sound for other apps but my LC 
app only gives me the vibration.

Best,
Bill Prothero



William Prothero
waproth...@gmail.com




___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Issue with 'beep' on iOS

2020-11-07 Thread Graham Samuel via use-livecode
In my iOS app, I create a special beep sound, as explained in the LC Dictionary 
entry for ‘beep’. It works fine on the Simulator, but on a real phone, there’s 
no sound. Vibration works OK. I have not turned off sound on the phone, and I 
have checked to see if any other controls on the phone might be wrongly set but 
I can’t find any. Ring tones, system sounds, music and sounds from external 
sources work. I seem to remember it worked before I upgraded to iOS 14. Can 
anyone suggest what’s happening?
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode