Re: Fat widgets

2017-07-09 Thread Matthias Rebbe via use-livecode
Thanks Kevin. That´s working. To be honest, i did not know this command until your post. Regards, Matthias Matthias Rebbe +49 5741 31 ‌matthiasrebbe.eu ‌ > Am 08.07.2017 um 19:37 schrieb Kevin Miller via use-livecode >

Re: Fat widgets

2017-07-08 Thread Kevin Miller via use-livecode
I haven't encountered this because our widgets are a library. But - I'm guessing - you could try the revert command? Sent from my iPhone > On 8 Jul 2017, at 15:49, Matthias Rebbe via use-livecode > wrote: > > Thank you very much. :) > > This makes it so much

Re: Fat widgets

2017-07-08 Thread hh via use-livecode
Thank you very much for that. This solves the situation where the LC-8 version and the LC-9 version are the same (have the same lcb file). Thus you can only have widgets that use LCB-syntax/features that are present in both LC-8 and LC-9, especially no new/different LCB features from LC-9. >

Re: Fat widgets

2017-07-08 Thread Matthias Rebbe via use-livecode
Thank you very much. :) This makes it so much easier to test stacks between 8 and 9. I had to make some adjustments, because the source of my extensions is stored somewhere else and the updateMessage is also not present. I get the widget recompiled when i load the stack, but the widget in the

Re: Fat widgets

2017-07-08 Thread Kevin Miller via use-livecode
I don¹t see why not: on openStack -- Build widgets and libraries if the environment is "development" then _checkExtension _rootFolder() & "/extensions/com.library.folder.here" -- insert any others here end if end openStack -- -- Remove all the files with the extension pExtension in

Re: Fat widgets

2017-07-08 Thread Matthias Rebbe via use-livecode
LC version than LC 8.1.5, >> [*] A stack that contains a widget that is compiled with LC 9.0.0 >> can not be used with any other LC version than LC 9.0.0 >> >> Mark Waddingham did recently already post thoughts to that here (see >> below). >> >> Opt

Re: Fat widgets

2017-07-08 Thread Kevin Miller via use-livecode
stack that contains a widget that is compiled with LC 9.0.0 >can not be used with any other LC version than LC 9.0.0 > >Mark Waddingham did recently already post thoughts to that here (see >below). > >Option (1) below is the build of "fat widgets" that contain several >b

Fat widgets

2017-07-08 Thread hh via use-livecode
recently already post thoughts to that here (see below). Option (1) below is the build of "fat widgets" that contain several binaries, one for each currently valid widget format. Would be great, thus one could be "downward compatible" in LC 8/9. Is there any chance to enab