Re: UTF8 on LC server

2018-06-01 Thread Tim Selander via use-livecode
Mark, Success! Greatly appreciate your walking me through this. Have a great weekend. Tim Selander Tokyo, Japan On Fri, Jun 1, 2018 at 7:15 AM, Mark Waddingham via use-livecode < use-livecode@lists.runrev.com> wrote: On 2018-06-01 12:53, Tim Selander via use-livecode wrote: Hi Mark,

Re: UTF8 on LC server

2018-06-01 Thread Tom Glod via use-livecode
also just fyi ...if u are encoding arrays and u need the character handling, you need the extra parameter arrayencode(myarray,"7.0") On Fri, Jun 1, 2018 at 7:15 AM, Mark Waddingham via use-livecode < use-livecode@lists.runrev.com> wrote: > On 2018-06-01 12:53, Tim Selander via

Re: UTF8 on LC server

2018-06-01 Thread Mark Waddingham via use-livecode
On 2018-06-01 12:53, Tim Selander via use-livecode wrote: Hi Mark, Here is the script. The files I'm using are bamboobabies.com/getjapanesetext.lc, and the text it is getting is bamboobabies.com/news.txt. In the script, there are two lines reading the text file that I've taken turns commenting

Re: UTF8 on LC server

2018-06-01 Thread Tim Selander via use-livecode
Hi Mark, Here is the script. The files I'm using are bamboobabies.com/getjapanesetext.lc, and the text it is getting is bamboobabies.com/news.txt. In the script, there are two lines reading the text file that I've taken turns commenting out If you can give me any hints, it would be

Re: UTF8 on LC server

2018-06-01 Thread Mark Waddingham via use-livecode
On 2018-06-01 02:14, Tim Selander via use-livecode wrote: Hi Kee and Alex, The original documents I'm working with are UTF8, so that's that I've been using. So converting them to UTF16 is recommended? I'll try that. Alex, desktop is version 8 something, and the server is the one installed on

Re: UTF8 on LC server

2018-05-31 Thread Mike Bonner via use-livecode
oops, dyslexic typo on my part, sorry about that. On Thu, May 31, 2018 at 6:33 PM, Alex Tweedly via use-livecode < use-livecode@lists.runrev.com> wrote: > > > On 01/06/2018 01:17, Mike Bonner via use-livecode wrote: > >> on-rev host is 7.0.1 you can get it with version() >> > Hmmm - I get 7.1.0

Re: UTF8 on LC server

2018-05-31 Thread Alex Tweedly via use-livecode
On 01/06/2018 01:17, Mike Bonner via use-livecode wrote: on-rev host is 7.0.1 you can get it with version() Hmmm - I get 7.1.0 (on sage). And that might just be the problem with Unicode handling I think it improved in LC v 8 upwards,  but that's an area I know nothing about. You

Re: UTF8 on LC server

2018-05-31 Thread Mike Bonner via use-livecode
on-rev host is 7.0.1 you can get it with version() On Thu, May 31, 2018 at 6:14 PM, Tim Selander via use-livecode < use-livecode@lists.runrev.com> wrote: > Hi Kee and Alex, > > The original documents I'm working with are UTF8, so that's that I've been > using. So converting them to UTF16 is

Re: UTF8 on LC server

2018-05-31 Thread Tim Selander via use-livecode
Hi Kee and Alex, The original documents I'm working with are UTF8, so that's that I've been using. So converting them to UTF16 is recommended? I'll try that. Alex, desktop is version 8 something, and the server is the one installed on the on-rev host; can't remember what the key in $_Server

Re: UTF8 on LC server

2018-05-31 Thread Alex Tweedly via use-livecode
Hi Tim, which version of LC engine are you using on the LC Server ? ( and which version on the desktop? ) Alex. On 01/06/2018 00:33, Tim Selander via use-livecode wrote: Thanks, Warren. Yes, I've got that header set up, and UTF8 is working fine, pages look great. But LC server is not

Re: UTF8 on LC server

2018-05-31 Thread kee nethery via use-livecode
I’m assuming you are using “unicode” (aka UTF-16) and not UTF8 to do all your transforming of the data? Kee > On May 31, 2018, at 4:46 PM, Tim Selander via use-livecode > wrote: > > Thanks, Kee. > > Actually, I had found the reference to codepoint in the dictionary and tried > it. But it

Re: UTF8 on LC server

2018-05-31 Thread Tim Selander via use-livecode
Thanks, Kee. Actually, I had found the reference to codepoint in the dictionary and tried it. But it seems to work the same as character -- breaking kanji. My test code is "put codepoint 500 to 550 of variable1" and the webpage shows: �。こうして夕があり、朝があった。� The beginning and ending kanji got

Re: UTF8 on LC server

2018-05-31 Thread kee nethery via use-livecode
> On May 31, 2018, at 4:33 PM, Tim Selander via use-livecode > wrote: > > Thanks, Warren. > > Yes, I've got that header set up, and UTF8 is working fine, pages look great. > But LC server is not handling character chunking in variables the same way as > LC desktop. In desktop, I can say

Re: UTF8 on LC server

2018-05-31 Thread Tim Selander via use-livecode
Thanks, Warren. Yes, I've got that header set up, and UTF8 is working fine, pages look great. But LC server is not handling character chunking in variables the same way as LC desktop. In desktop, I can say "put char 1 of variable1" and I get a Japanese kanji. In LC Server, I only get half a

Re: UTF8 on LC server

2018-05-31 Thread Warren Samples via use-livecode
On 05/31/2018 06:43 AM, Tim Selander via use-livecode wrote: Is there any way to get LC Server to handle double-byte characters the same way LC desktop does? Tim Selander Tokyo, Japan LC Server serves pages with a default "Content-Type" header of: Content-Type: text/html;

UTF8 on LC server

2018-05-31 Thread Tim Selander via use-livecode
Hi, In LC, if I have a field or variable in Japanese (double-byte) and get, say, the 5th character, it returns the correct double-byte character. But on LC server (on-rev hosting) "character" commands get single bytes, breaking the Japanese character turning it into gibberish. Is there any