Re: iOS multi-line input field

2018-07-30 Thread J. Landman Gay via use-livecode
Moving the "close" command elsewhere did the trick. This is a stack 
created almost 5 years ago and it used to work, so something changed.


Thanks Mike.

On 7/30/18 10:06 AM, Mike Kerner via use-livecode wrote:

Second one:  I've had a similar problem.  I think there's a QR for it
First one:  Try moving your handler to inputEndEditing, just for giggles

On Sun, Jul 29, 2018 at 6:30 PM J. Landman Gay via use-livecode <
use-livecode@lists.runrev.com> wrote:


I'm looking at a stack with a multi-line input field in the iOS
simulator. A handler shows a group and creates a multi-line input in the
correct location, but as soon as I tap into the field to type the group
is hidden.

There is only one command anywhere in the stack that hides the group and
it is in a keyboardDeactivated handler. But the keyboard never activates
in the first place, so that handler never triggers.

Is this a simulator issue? Here are the settings for the multi-line input:

show grp "noteEntry"
put calcInputControlPadding(8) into tInputRect -- calcs a display rect
mobileControlCreate "multiline","usernote"
mobileControlSet "usernote","rect",tInputRect
mobileControlSet "usernote","opaque",false
mobileControlSet "usernote","visible","true"
mobileControlSet "usernote","editable","true"
if the platform = "iPhone" then
  mobileControlSet "usernote","backgroundcolor","255,255,255,0" --
transparent
  mobileControlSet "usernote","delayTouches","true"
end if


LC 9.0.1 (rc 1), Mac 10.13.4, XCode 9.4.1, simulator iPhone 7 (11.4).

Another issue:
If I make script changes, set breakpoints, save the stack, and test, the
remote debugger triggers but the script that is shown is older and
doesn't include the new changes. I have to quit and re-launch LC to
debug the changes. Is there a way to force the remote debugger to
recognize the altered script?

--
Jacqueline Landman Gay | jac...@hyperactivesw.com
HyperActive Software   | http://www.hyperactivesw.com

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your
subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode







--
Jacqueline Landman Gay | jac...@hyperactivesw.com
HyperActive Software   | http://www.hyperactivesw.com

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: iOS multi-line input field

2018-07-30 Thread Mike Kerner via use-livecode
Second one:  I've had a similar problem.  I think there's a QR for it
First one:  Try moving your handler to inputEndEditing, just for giggles

On Sun, Jul 29, 2018 at 6:30 PM J. Landman Gay via use-livecode <
use-livecode@lists.runrev.com> wrote:

> I'm looking at a stack with a multi-line input field in the iOS
> simulator. A handler shows a group and creates a multi-line input in the
> correct location, but as soon as I tap into the field to type the group
> is hidden.
>
> There is only one command anywhere in the stack that hides the group and
> it is in a keyboardDeactivated handler. But the keyboard never activates
> in the first place, so that handler never triggers.
>
> Is this a simulator issue? Here are the settings for the multi-line input:
>
>show grp "noteEntry"
>put calcInputControlPadding(8) into tInputRect -- calcs a display rect
>mobileControlCreate "multiline","usernote"
>mobileControlSet "usernote","rect",tInputRect
>mobileControlSet "usernote","opaque",false
>mobileControlSet "usernote","visible","true"
>mobileControlSet "usernote","editable","true"
>if the platform = "iPhone" then
>  mobileControlSet "usernote","backgroundcolor","255,255,255,0" --
> transparent
>  mobileControlSet "usernote","delayTouches","true"
>end if
>
>
> LC 9.0.1 (rc 1), Mac 10.13.4, XCode 9.4.1, simulator iPhone 7 (11.4).
>
> Another issue:
> If I make script changes, set breakpoints, save the stack, and test, the
> remote debugger triggers but the script that is shown is older and
> doesn't include the new changes. I have to quit and re-launch LC to
> debug the changes. Is there a way to force the remote debugger to
> recognize the altered script?
>
> --
> Jacqueline Landman Gay | jac...@hyperactivesw.com
> HyperActive Software   | http://www.hyperactivesw.com
>
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>


-- 
On the first day, God created the heavens and the Earth
On the second day, God created the oceans.
On the third day, God put the animals on hold for a few hours,
   and did a little diving.
And God said, "This is good."
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


iOS multi-line input field

2018-07-29 Thread J. Landman Gay via use-livecode
I'm looking at a stack with a multi-line input field in the iOS 
simulator. A handler shows a group and creates a multi-line input in the 
correct location, but as soon as I tap into the field to type the group 
is hidden.


There is only one command anywhere in the stack that hides the group and 
it is in a keyboardDeactivated handler. But the keyboard never activates 
in the first place, so that handler never triggers.


Is this a simulator issue? Here are the settings for the multi-line input:

  show grp "noteEntry"
  put calcInputControlPadding(8) into tInputRect -- calcs a display rect
  mobileControlCreate "multiline","usernote"
  mobileControlSet "usernote","rect",tInputRect
  mobileControlSet "usernote","opaque",false
  mobileControlSet "usernote","visible","true"
  mobileControlSet "usernote","editable","true"
  if the platform = "iPhone" then
mobileControlSet "usernote","backgroundcolor","255,255,255,0" -- 
transparent

mobileControlSet "usernote","delayTouches","true"
  end if


LC 9.0.1 (rc 1), Mac 10.13.4, XCode 9.4.1, simulator iPhone 7 (11.4).

Another issue:
If I make script changes, set breakpoints, save the stack, and test, the 
remote debugger triggers but the script that is shown is older and 
doesn't include the new changes. I have to quit and re-launch LC to 
debug the changes. Is there a way to force the remote debugger to 
recognize the altered script?


--
Jacqueline Landman Gay | jac...@hyperactivesw.com
HyperActive Software   | http://www.hyperactivesw.com

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode