Re: launch & quit

2019-10-14 Thread Curry Kenworthy via use-livecode



Robert:

> Have you tried to switch off messages before quit?

Yes - get angry and then quit with prejudice. Lock messages, unload 
libraries, close stacks, etc, and really QUIT! :)


Also, consider an alternate approach to launching the second app, so 
that shell doesn't keep your first app hanging


Best wishes,

Curry Kenworthy

Custom Software Development
"Better Methods, Better Results"
LiveCode Training and Consulting
http://livecodeconsulting.com/

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: launch & quit

2019-10-13 Thread Robert Brenstein via use-livecode
I’d guess that quit command triggers some closeXxxx handlers to run 
and one causes the delay. The duration of delay sounds a bit like 
network timeout. Have you tried to switch off messages before quit?


On Oct 12, 2019, at 13:28, Paul Dupuis via use-livecode 
 wrote:


I have a stand alone with a card with a button with a mouseUp handler

on mouseUp

  -- some stuff

  -- tApplication variable contains a path to another standalone for 
OSX or Window depending upon what platform() this standalon is running 
on


  launch tApplication
  put the result into tError
  if tError is not empty then
answer error tErrormEssage
  end if
  quit
end mouseUp

On Windows, the designated application launches promptly and my app 
quits immediately.


On OSX, the designated application launches promptly and my app waits 
way too long (a minute or two) before quitting.


Standalone built for OSX and Windows on Windows under LC905

Anyone have any experience like this? Any ideas on what to do to get 
the OSX version to quit when told to quit?

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: launch & quit

2019-10-13 Thread Paul Hibbert via use-livecode
I’ve used quit before on Mac with no problems, so I tried a few tests and it 
still seems to work fine for me (even with your mismatch variable 
tError/tErrormEssage).

I tried both with and without generating a deliberate error and it quit 
straight away, so I’d guess there may be something else causing the delay.

One thing I did notice was that when testing in the IDE the app being launched 
is brought to the front, but in a standalone the app being launched stayed in 
the background until I changed the quit command to:

   send “quit" to me in 10 ticks

This seems to give the app time to launch and come to the front, but the time 
seems to be be dependant on the size of the app, I tested with another 
standalone, and Apple Preview.

Tested in LC9.0.5 & LC9.5.0 - same results.

Hope you track down the issue.

Paul

> On Oct 12, 2019, at 13:28, Paul Dupuis via use-livecode 
>  wrote:
> 
> I have a stand alone with a card with a button with a mouseUp handler
> 
> on mouseUp
> 
>   -- some stuff
> 
>   -- tApplication variable contains a path to another standalone for OSX or 
> Window depending upon what platform() this standalon is running on
> 
>   launch tApplication
>   put the result into tError
>   if tError is not empty then
> answer error tErrormEssage
>   end if
>   quit
> end mouseUp
> 
> On Windows, the designated application launches promptly and my app quits 
> immediately.
> 
> On OSX, the designated application launches promptly and my app waits way too 
> long (a minute or two) before quitting.
> 
> Standalone built for OSX and Windows on Windows under LC905
> 
> Anyone have any experience like this? Any ideas on what to do to get the OSX 
> version to quit when told to quit?
> 
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription 
> preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


launch & quit

2019-10-12 Thread Paul Dupuis via use-livecode

I have a stand alone with a card with a button with a mouseUp handler

on mouseUp

  -- some stuff

  -- tApplication variable contains a path to another standalone for 
OSX or Window depending upon what platform() this standalon is running on


  launch tApplication
  put the result into tError
  if tError is not empty then
    answer error tErrormEssage
  end if
  quit
end mouseUp

On Windows, the designated application launches promptly and my app 
quits immediately.


On OSX, the designated application launches promptly and my app waits 
way too long (a minute or two) before quitting.


Standalone built for OSX and Windows on Windows under LC905

Anyone have any experience like this? Any ideas on what to do to get the 
OSX version to quit when told to quit?


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode