Logging for mobile simulator on iOS?

2019-05-06 Thread Alan Stenhouse via use-livecode
Asked this on the forums with no response, so trying here...: Opening the "System Log" from the Debug menu in the mobile simulator opens the system log but it doesn't seem like any of our usual log messages appear there now. I think this changed some time ago but don't remember what (if any)

Re: Question for LCB FFI workshop attendees at upcoming conference

2019-05-08 Thread Alan Stenhouse via use-livecode
openCV (open source Computer Vision) perhaps? https://github.com/opencv/ Sadly not attending this year though! cheers Alan On 7 May 2019, at08:35:21,Trevor DeVore mailto:li...@mangomultimedia.com>> wrote: This is for anyone who plans on attending my workshop on using FFI in LCB at the

Re: load app to ios device for testing??

2019-08-10 Thread Alan Stenhouse via use-livecode
he correct platform in ?Standalone Application Settings?? Is "Mobile Support? configured correctly in LC Preferences? ? Scott Morrow On Aug 9, 2019, at 12:42 AM, Alan Stenhouse via use-livecode mailto:use-livecode@lists.runrev.com>> wrote: Just wondering how we can download an ios b

Re: load app to ios device for testing??

2019-08-11 Thread Alan Stenhouse via use-livecode
Hi Panos Thanks for clarifying this. Now I'm wondering when exactly this changed as it definitely used to work in the Indy edition. On the brights side, thanks to you (+ Scott), I won't have to try Scott's 4th suggestion as to which color chicken to sacrifice...! :-) cheers Alan On 11 Aug

Re: mobilePickPhoto and Galaxy Note 8

2019-08-23 Thread Alan Stenhouse via use-livecode
Hi Dan This is a confirmed bug, see (+ subscribe to) it at: https://quality.livecode.com/show_bug.cgi?id=22054 cheers Alan On 24 Aug 2019, at 8:52 am,Dan Friedman mailto:d...@clearvisiontech.com>> wrote: Greetings! I am using mobilePickPhoto to take a photo. On all Apple devices it's

load app to ios device for testing??

2019-08-09 Thread Alan Stenhouse via use-livecode
Just wondering how we can download an ios build to our own local device for testing these days? It used to be easy with iTunes to just attach your phone and download the app to the connected device inside iTunes, but that no longer seems possible (though possibly I'm missing something?). I

Re: put img into img after import snapshot

2019-12-01 Thread Alan Stenhouse via use-livecode
Hi Dan Try putting a wait 50 millisecs (more or less?) after the import - pretty sure that's what I ended up with on mobile for the same issue. Not sure if it'd be device-dependent though - probably would be...? HTH cheers Alan > On 2 Dec 2019, at 3:30 am,Dan Friedman wrote: > This works

Re: iOS scrollers

2019-12-01 Thread Alan Stenhouse via use-livecode
Hi Jacque, Does putting a CR at the end of the field contents help? Before making the mobile scroller etc. I think that was a workaround I came up with ages ago for the same (/similar?) problem. But could be that I'm misunderstanding your issue... cheers Alan On 2 Dec 2019, at 3:30 am, J.

Re: Problem simulating a location

2020-04-13 Thread Alan Stenhouse via use-livecode
Hi Graham IIRC, mobileSensorReading() returns an array so you need to check the keys of the array. Perhaps: if tSensorData["latitude"] is empty then HTH cheers Alan > On Mon, 13 Apr 2020 14:38:56,Graham Samuel > wrote: > > > I?m trying to use the 10.2 XCode

Re: Detecting full Mobile Sensor activation

2020-04-25 Thread Alan Stenhouse via use-livecode
Hi Graham Some ideas, from experience: 1. Start your sensor on openStack or as soon as possible. 2. Ignore locationChanged messages with empty location or if "horizontal accuracy" is outside a threshold of x metres. 3. Just set a flag or other mechanism when you want to start and stop

Re: Detecting full Mobile Sensor activation

2020-04-26 Thread Alan Stenhouse via use-livecode
Hi Graham So, how do you define a "meaningful" GPS signal? The GPS data you'll receive from locationChanged messages may have nothing for 1-n messages at the start, followed by an increasingly accurate number of messages (as measured by the "horizontal accuracy" and/or "vertical accuracy"

Re: use-livecode Digest, Vol 200, Issue 5

2020-05-04 Thread Alan Stenhouse via use-livecode
Hi Graham Have you tried it walking around outside in varying locations? Have you tried different devices and/or OS versions? You could try sharing it with a friend using Diawi or similar and see what they get. Also try restarting your phone to see if that helps. As you move around the

LC9.6 Android EXIF image data issue

2020-05-12 Thread Alan Stenhouse via use-livecode
There seems to be an issue with getting EXIF data from images using mobilePickPhoto on Android (well, at least new Samsung mobile phones). I *think* this is a new bug with LC 9.6, but as I don't have a relevant phone to test with, it's sorta difficult to check further. Particularly as we

Re: LC9.6 Android EXIF image data issue

2020-05-13 Thread Alan Stenhouse via use-livecode
idth and height parameters > but if those parameters aren?t used it might be there (depending on what the > camera app does). > > Cheers > > Monte > >> On 13 May 2020, at 11:39 am, Alan Stenhouse via use-livecode >> mailto:use-livecode@lists.runrev.com>>

Re: LC9.6 Android EXIF image data issue

2020-05-14 Thread Alan Stenhouse via use-livecode
Thanks Mark and Monte for the info. Had already stopped using the width/height specs and for photos from the library we had been getting EXIF info and still do in many cases (I think - more testing needed!), but as we can't do anything about what the OS gives us, I'll just slightly change the

get URL results in tsneterr(6) on Android, previously worked ok

2020-06-28 Thread Alan Stenhouse via use-livecode
Hi all Am re-building an app that's been running fine for over 2 years now and when attempting to get a URL I always get the error "tsneterr: (6)" contained in it with "could not resolve host" as the result. When I try the same code in the IDE it works as expected. I didn't previously include

Re: Ideas on iOS GPS tracking needed

2020-11-03 Thread Alan Stenhouse via use-livecode
Hi Graham Are you checking the horizontal accuracy of each reading? (It's part of the array of data with your lat-longs, as well as speed, etc - though not on every phone). If not, try that and see if the anomalous readings are hugely out. From my experience, that's normally the case. If so,

Re: A question/survey of sorts for users of Navigator

2022-01-04 Thread Alan Stenhouse via use-livecode
Sounds interesting Geoff. The ability to customise your own actions on objects would be great - I think we all get annoyed with some of the clunkiness of repeated actions (and no doubt we don't use all the existing capabilities of LC..), so your addition to Navigator sounds very worthwhile!

Re: use-livecode Digest, Vol 222, Issue 27

2022-03-18 Thread Alan Stenhouse via use-livecode
Yes, you should textencode() to UTF when storing and textdecode() when reading - at least doing that on mobile worked for me. cheers Alan > On 19 Mar 2022, at 8:01 am, Paul Dupuis via > use-livecode-requ...@lists.runrev.com wrote: > > On 3/18/2022 12:18 PM, Dan Friedman via use-livecode

Re: Audio Control on Mobile?

2022-05-15 Thread Alan Stenhouse via use-livecode
Hi Dan, Check out mobilePlaySoundOnChannel in the dictionary and the related commands linked to it. Don't think there's a player command for mobile, though I may have missed it...! HTH cheers, Alan > On 15 May 2022, at 1:30 am, use-livecode-requ...@lists.runrev.com wrote: > > Date: Fri,