Re: Big Sur bugs

2020-11-18 Thread Paul Dupuis via use-livecode

Jacque,

Thank you! My blood pressure is already going down to more normal 
levels. I will work on the assumtion it is a VM issue for now and set up 
a partitioned Big Sur install.




On 11/18/2020 3:07 PM, J. Landman Gay via use-livecode wrote:

On 11/18/20 12:06 PM, Paul Dupuis via use-livecode wrote:
Has any experienced any problems playing back media (.mp3 audio files 
or .mp4 video) under macOS Big Sur?


I just ran into an issue where none of my media is playing (at all) 
in a LC9.6.1 built stand-alone under Big Sur.


I haven't built an app in Big Sur yet, but an app built in Mojave 
plays audio when run in Big Sur.





___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-11-18 Thread panagiotis merakos via use-livecode
@Paul
I tested on a VM too, but on Parallels, not on VirtualBox.

If Quicktime cannot open the video either, then it sounds like a VM issue.
It would be great if anyone running Big Sur natively could give some input.

Regards,
Panos

On Wed, Nov 18, 2020, 22:08 J. Landman Gay via use-livecode <
use-livecode@lists.runrev.com> wrote:

> On 11/18/20 12:06 PM, Paul Dupuis via use-livecode wrote:
> > Has any experienced any problems playing back media (.mp3 audio files or
> .mp4 video) under
> > macOS Big Sur?
> >
> > I just ran into an issue where none of my media is playing (at all) in a
> LC9.6.1 built
> > stand-alone under Big Sur.
>
> I haven't built an app in Big Sur yet, but an app built in Mojave plays
> audio when run in Big Sur.
>
> --
> Jacqueline Landman Gay | jac...@hyperactivesw.com
> HyperActive Software   | http://www.hyperactivesw.com
>
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-11-18 Thread J. Landman Gay via use-livecode

On 11/18/20 12:06 PM, Paul Dupuis via use-livecode wrote:
Has any experienced any problems playing back media (.mp3 audio files or .mp4 video) under 
macOS Big Sur?


I just ran into an issue where none of my media is playing (at all) in a LC9.6.1 built 
stand-alone under Big Sur.


I haven't built an app in Big Sur yet, but an app built in Mojave plays audio 
when run in Big Sur.

--
Jacqueline Landman Gay | jac...@hyperactivesw.com
HyperActive Software   | http://www.hyperactivesw.com

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-11-18 Thread Paul Dupuis via use-livecode
No, however, I am running Big Sur in a Virtual Box VM under macOS 
Mojave. All other Big Sur features and functions appear to work fine in 
the VM (we just can not afford Apple hardware for every version of their 
OS from Mavericks to Big Sur. VM's are a lot more versatile as they can 
be clones, snapshotted, and restored when things get messed up)


If I try to just double click on the video under Big Sure, it opens the 
Quicktime Player (?) and I get a "unknown error occurred (-101).


I am glad to hear it is working for you Panos - very glad. Both our 
commercial apps depend on the player object and I was in a panic! I'd 
ask anyone following this thread to please take time to test media under 
Big Sur.


I would be ecstatic to learn in is a VM issue. We'll then move to our 
backup of installing on a partition for a dual (actually more than dual 
as we have about 5 version of macOS each on its own partition) boot system.


-- Paul

On 11/18/2020 2:21 PM, panagiotis merakos wrote:

@Paul Dupuis 

Hmm that is strange, the player works for me. I used the video you 
attached in the bug report. Are you by any chance using a new Silicon 
(ARM) Mac?


I am curious to see if other folks can reproduce this bug.

Kind regards,
Panos
--

On Wed, 18 Nov 2020 at 20:58, Paul Dupuis via use-livecode 
mailto:use-livecode@lists.runrev.com>> 
wrote:


I just filed bug
https://quality.livecode.com/show_bug.cgi?id=22986


Media is dead under Big Sur


On 11/18/2020 1:06 PM, Paul Dupuis via use-livecode wrote:
> Has any experienced any problems playing back media (.mp3 audio
files
> or .mp4 video) under macOS Big Sur?
>
> I just ran into an issue where none of my media is playing (at
all) in
> a LC9.6.1 built stand-alone under Big Sur.
>
>
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com 
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode



___
use-livecode mailing list
use-livecode@lists.runrev.com 
Please visit this url to subscribe, unsubscribe and manage your
subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode





___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-11-18 Thread panagiotis merakos via use-livecode
@Paul Dupuis 

Hmm that is strange, the player works for me. I used the video you attached
in the bug report. Are you by any chance using a new Silicon (ARM) Mac?

I am curious to see if other folks can reproduce this bug.

Kind regards,
Panos
--

On Wed, 18 Nov 2020 at 20:58, Paul Dupuis via use-livecode <
use-livecode@lists.runrev.com> wrote:

> I just filed bug https://quality.livecode.com/show_bug.cgi?id=22986
>
> Media is dead under Big Sur
>
>
> On 11/18/2020 1:06 PM, Paul Dupuis via use-livecode wrote:
> > Has any experienced any problems playing back media (.mp3 audio files
> > or .mp4 video) under macOS Big Sur?
> >
> > I just ran into an issue where none of my media is playing (at all) in
> > a LC9.6.1 built stand-alone under Big Sur.
> >
> >
> > ___
> > use-livecode mailing list
> > use-livecode@lists.runrev.com
> > Please visit this url to subscribe, unsubscribe and manage your
> > subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-11-18 Thread Paul Dupuis via use-livecode

I just filed bug https://quality.livecode.com/show_bug.cgi?id=22986

Media is dead under Big Sur


On 11/18/2020 1:06 PM, Paul Dupuis via use-livecode wrote:
Has any experienced any problems playing back media (.mp3 audio files 
or .mp4 video) under macOS Big Sur?


I just ran into an issue where none of my media is playing (at all) in 
a LC9.6.1 built stand-alone under Big Sur.



___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your 
subscription preferences:

http://lists.runrev.com/mailman/listinfo/use-livecode



___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-11-18 Thread Paul Dupuis via use-livecode
Has any experienced any problems playing back media (.mp3 audio files or 
.mp4 video) under macOS Big Sur?


I just ran into an issue where none of my media is playing (at all) in a 
LC9.6.1 built stand-alone under Big Sur.



___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-11-15 Thread Kee Nethery via use-livecode
Just to prevent bugs with earlier versions of macOS, please change:

  if item 1 of tVersion>10 or item 2 of tVersion>15 then

to:

  if (item 1 of tVersion=10 and item 2 of tVersion>15) or (item 1 of 
tVersion>10) then

Kee Nethery

> On Nov 15, 2020, at 9:51 AM, Marty Knapp via use-livecode 
>  wrote:
> 
>   if item 1 of tVersion>10 or item 2 of tVersion>15 then


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-11-15 Thread Marty Knapp via use-livecode
Here’s a work-around for the tabbed button issue (the text of the hilited tab 
is white on a white background, thus unreadable)

on preOpenCard
   if the platform is "MacOS" and BigSur() is true then
  repeat with x=1 to the number of btns of this stack
 if the menuMode of btn x of this stack is "tabbed" then
set the backgroundColor of btn x of this stack to black
 end if
  end repeat
  
   else
  repeat with x=1 to the number of btns of this stack
 if the menuMode of btn x of this stack is "tabbed" then
set the backgroundColor of btn x of this stack to empty
 end if
  end repeat
   end if
   pass preOpenCard
end preOpenCard

function BigSur
   --LC 9.6.1 reports "Big Sur" as version as 10.16, though Apple is calling it 
11 - this covers both
   set the itemDelimiter to "."
   put the systemVersion into tVersion
   if item 1 of tVersion>10 or item 2 of tVersion>15 then
  return true
   else return false
end BigSur

Just put this in your main stack and Bob’s your uncle. Speaking of Bob, he has 
a customer control that circumvents the issue too. I’ll let him chime in to let 
you know where you can find that,

—Marty

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-11-15 Thread Paul Dupuis via use-livecode

On 11/15/2020 11:27 AM, Klaus major-k via use-livecode wrote:

But just enter -> Big Sur
in the search field on the page and hit RETURN!:-)


Thank you!


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-11-15 Thread Colin Holgate via use-livecode
I haven’t tested much, but LiveCode seems to work normally in Big Sur on Intel, 
and on the M1 chip machines there is a – in front of each menu item, but 
otherwise it’s working.


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-11-15 Thread Klaus major-k via use-livecode
Hi Paul,

> Am 15.11.2020 um 17:24 schrieb Paul Dupuis via use-livecode 
> :
> 
> Panos,
> 
> Thank you for the rapid-response update!
> 
> The link you provide presents me with the error "There is no with the id 
> '97748'. "
> Just knowing a compatible LC release is on its way in 9.6.1 is a help, but 
> I'd love to see the list
> of bugs if there is an alternate URL to view them.

yes, the links give an error.

But just enter -> Big Sur 
in the search field on the page and hit RETURN! :-)


Best

Klaus

--
Klaus Major
https://www.major-k.de
kl...@major-k.de


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-11-15 Thread Paul Dupuis via use-livecode

Panos,

Thank you for the rapid-response update!

The link you provide presents me with the error "There is no with the id 
'97748'. " Just knowing a compatible LC release is on its way in 9.6.1 
is a help, but I'd love to see the list of bugs if there is an alternate 
URL to view them.




On 11/15/2020 10:31 AM, panagiotis merakos via use-livecode wrote:

Hello Paul,

Here are the bugs that have been discovered so far, either by LC users or
by us (LiveCode Ltd):

https://quality.livecode.com/buglist.cgi?regetlastlist=97748

The 2 serious ones have been addressed and are to be tested in our
pre-release build. There are another 2 cosmetic bugs, and one that seems to
affect only the new ARM Macs.

These bugfixes are expected to appear in the upcoming release of LC 9.6.2
RC-1.

Kind regards,
Panos
--

On Sun, 15 Nov 2020 at 17:05, Paul Dupuis via use-livecode <
use-livecode@lists.runrev.com> wrote:


So Big Sur was released on the 12th. It is not our in user's hands.

Does anyone (or LiveCode corporate) have any update about Big Sur
compatibility? We have customer's inquiring. We can not afford the time
to jump through Apple's hoops for any of their beta versions. Now that
the release is out, we can start testing our apps with it IF we can get
it installed over one of our Catalina VMs but it would be nice to know
what testing LC Ltd has done or others have done?


On 10/8/2020 8:31 PM, Marty Knapp via use-livecode wrote:

In my testing of LC apps running under Big Sur I have run into the

following bugs running LC 9.6.1:

1) Tabbed buttons: The background of the highlighted tab is now white by

default. Since LC renders the text for the highlighted button as white, it
is not readable until you switch to another tab. Work-around - set the
backgroundColor of the button to black. Bug report 22879

2) Window Shape: Setting the windowShape of a stack to an imported image

no longer works. It will show the rectangle of the stack. Bug report 22880

3) SystemVersion: Big Sur is designated by Apple as version 11 but LC

will report it as 10.16. Easy enough to code around until it’s fixed. Bug
report 22887

4) Printing: LC hangs as I mentioned in a previous post. Bug report 22930
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your

subscription preferences:

http://lists.runrev.com/mailman/listinfo/use-livecode


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your
subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode



___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-11-15 Thread panagiotis merakos via use-livecode
Hello Paul,

Here are the bugs that have been discovered so far, either by LC users or
by us (LiveCode Ltd):

https://quality.livecode.com/buglist.cgi?regetlastlist=97748

The 2 serious ones have been addressed and are to be tested in our
pre-release build. There are another 2 cosmetic bugs, and one that seems to
affect only the new ARM Macs.

These bugfixes are expected to appear in the upcoming release of LC 9.6.2
RC-1.

Kind regards,
Panos
--

On Sun, 15 Nov 2020 at 17:05, Paul Dupuis via use-livecode <
use-livecode@lists.runrev.com> wrote:

> So Big Sur was released on the 12th. It is not our in user's hands.
>
> Does anyone (or LiveCode corporate) have any update about Big Sur
> compatibility? We have customer's inquiring. We can not afford the time
> to jump through Apple's hoops for any of their beta versions. Now that
> the release is out, we can start testing our apps with it IF we can get
> it installed over one of our Catalina VMs but it would be nice to know
> what testing LC Ltd has done or others have done?
>
>
> On 10/8/2020 8:31 PM, Marty Knapp via use-livecode wrote:
> > In my testing of LC apps running under Big Sur I have run into the
> following bugs running LC 9.6.1:
> >
> > 1) Tabbed buttons: The background of the highlighted tab is now white by
> default. Since LC renders the text for the highlighted button as white, it
> is not readable until you switch to another tab. Work-around - set the
> backgroundColor of the button to black. Bug report 22879
> >
> > 2) Window Shape: Setting the windowShape of a stack to an imported image
> no longer works. It will show the rectangle of the stack. Bug report 22880
> >
> > 3) SystemVersion: Big Sur is designated by Apple as version 11 but LC
> will report it as 10.16. Easy enough to code around until it’s fixed. Bug
> report 22887
> >
> > 4) Printing: LC hangs as I mentioned in a previous post. Bug report 22930
> > ___
> > use-livecode mailing list
> > use-livecode@lists.runrev.com
> > Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-11-15 Thread Paul Dupuis via use-livecode

So Big Sur was released on the 12th. It is not our in user's hands.

Does anyone (or LiveCode corporate) have any update about Big Sur 
compatibility? We have customer's inquiring. We can not afford the time 
to jump through Apple's hoops for any of their beta versions. Now that 
the release is out, we can start testing our apps with it IF we can get 
it installed over one of our Catalina VMs but it would be nice to know 
what testing LC Ltd has done or others have done?



On 10/8/2020 8:31 PM, Marty Knapp via use-livecode wrote:

In my testing of LC apps running under Big Sur I have run into the following 
bugs running LC 9.6.1:

1) Tabbed buttons: The background of the highlighted tab is now white by 
default. Since LC renders the text for the highlighted button as white, it is 
not readable until you switch to another tab. Work-around - set the 
backgroundColor of the button to black. Bug report 22879

2) Window Shape: Setting the windowShape of a stack to an imported image no 
longer works. It will show the rectangle of the stack. Bug report 22880

3) SystemVersion: Big Sur is designated by Apple as version 11 but LC will 
report it as 10.16. Easy enough to code around until it’s fixed. Bug report 
22887

4) Printing: LC hangs as I mentioned in a previous post. Bug report 22930
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode



___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-10-10 Thread Tekne via use-livecode
1,2 and 4 are definitely show stoppers for Mac devs. 
Is  LC ready with a new version?

Riccardo



> Il giorno 9 ott 2020, alle ore 02:32, Marty Knapp via use-livecode 
>  ha scritto:
> 
> In my testing of LC apps running under Big Sur I have run into the following 
> bugs running LC 9.6.1:
> 
> 1) Tabbed buttons: The background of the highlighted tab is now white by 
> default. Since LC renders the text for the highlighted button as white, it is 
> not readable until you switch to another tab. Work-around - set the 
> backgroundColor of the button to black. Bug report 22879
> 
> 2) Window Shape: Setting the windowShape of a stack to an imported image no 
> longer works. It will show the rectangle of the stack. Bug report 22880
> 
> 3) SystemVersion: Big Sur is designated by Apple as version 11 but LC will 
> report it as 10.16. Easy enough to code around until it’s fixed. Bug report 
> 22887
> 
> 4) Printing: LC hangs as I mentioned in a previous post. Bug report 22930
> ___
> use-livecode mailing list
> use-livecode@lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription 
> preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


Re: Big Sur bugs

2020-10-09 Thread Bob Sneidar via use-livecode
So my custom tabbed object would come in handy then. :-)

Bob S


On Oct 8, 2020, at 5:31 PM, Marty Knapp via use-livecode 
mailto:use-livecode@lists.runrev.com>> wrote:

In my testing of LC apps running under Big Sur I have run into the following 
bugs running LC 9.6.1:

1) Tabbed buttons: The background of the highlighted tab is now white by 
default. Since LC renders the text for the highlighted button as white, it is 
not readable until you switch to another tab. Work-around - set the 
backgroundColor of the button to black. Bug report 22879

___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode