Re: mesos-slave Failed to initialize: Failed to bind on 0.0.0.0:0: Address already in use: Address already in use [98]

2018-05-03 Thread Benjamin Mahler
>From the man page for bind: *EADDRINUSE* (Internet domain sockets) The port number was specified as zero in the socket address structure, but, upon attempting to bind to an ephemeral port, it was determined that all port numbers in the

Re: mesos-slave Failed to initialize: Failed to bind on 0.0.0.0:0: Address already in use: Address already in use [98]

2018-05-03 Thread Srikanth Viswanathan
fwiw, I've seen this type of error in the past when the system runs out of ephemeral ports. Not saying this definitely the same issue, but I suggest checking to see if you have ephemeral ports available. On Thu, May 3, 2018 at 8:57 AM, Zhitao Li wrote: > Can you paste the

Re: mesos-slave Failed to initialize: Failed to bind on 0.0.0.0:0: Address already in use: Address already in use [98]

2018-05-03 Thread Zhitao Li
Can you paste the command line of how you started the Mesos agent process? On Wed, May 2, 2018 at 9:21 PM, Luke Adolph wrote: > Hi all: > When mesos slave run task, the stderr file shows > I0503 04:01:20.488590 9110 logging.cpp:188] INFO level logging started! > I0503

mesos-slave Failed to initialize: Failed to bind on 0.0.0.0:0: Address already in use: Address already in use [98]

2018-05-02 Thread Luke Adolph
Hi all: When mesos slave run task, the stderr file shows I0503 04:01:20.488590 9110 logging.cpp:188] INFO level logging started! I0503 04:01:20.489073 9110 fetcher.cpp:424] Fetcher Info: