Re: Cache Entries get lost after multiple nodes started ?

2017-02-23 Thread Neeraj Vaidya
I was able to resolve this after I changed the Key from AffinityUuid to a simple Integer which is auto-incremented. How does one explain the behaviour ? Regards, Neeraj On Fri, 24/2/17, Neeraj Vaidya <neeraj.vai...@yahoo.co.in> wrote: S

Re: Cache Entries get lost after multiple nodes started ?

2017-02-23 Thread Neeraj Vaidya
Another thing I noticed is that if I stop the node which initially populated the entries, some entries are suddenly lost from the cache. This is really strange to me. Regards, Neeraj On Fri, 24/2/17, Neeraj Vaidya <neeraj.vai...@yahoo.co.in>

Cache Entries get lost after multiple nodes started ?

2017-02-23 Thread Neeraj Vaidya
Hi, I have populated a cache containing a K,V pair of . It gets populated fine when I start a single node which is responsible for populating the cache. I am able to retrieve all rows using Zeppelin ignite interpreter or even using web-console.

Re: Real-time computing

2017-02-23 Thread Neeraj Vaidya
sed by any other listener because listener1 has already started processing it ? Regards, Neeraj On Fri, 24/2/17, Andrey Mashenkov <andrey.mashen...@gmail.com> wrote: Subject: Re: Real-time computing To: user@ignite.apache.org, "Neera

[RESOLVED] Cache Entries get lost after multiple nodes started ?

2017-02-24 Thread Neeraj Vaidya
and then redistributing that data to live nodes ? Is maintaining a backup copy the only option to not lose data in case of node failure ? Regards, Neeraj On Fri, 24/2/17, Neeraj Vaidya <neeraj.vai...@yahoo.co.in> wrote: Subject: Re: Cache Entri

Real-time computing

2017-02-22 Thread Neeraj Vaidya
Hi, I have a use case where I need to perform computation on records in files (specifically files containing telecom CDRs). To this, I have a few questions : 1) Should I have just one client node which reads these records and creates Callable compute jobs for each record ? With just 1 client

Disabling Ignite console logs

2017-03-02 Thread Neeraj Vaidya
Hi, I am using logback with slf4j in my Ignite application. When I start my node using my custom code, it has started printing a lot of output to the console which it does not when I just start the node using default Ignite.sh/bat. I don't mind the Ignite startup banner. How can I disable the

Re: Akka vs Ignite

2017-03-26 Thread Neeraj Vaidya
to develop Ignite... Ignite is much more > higher level platform: SQL/NoSQL, ACID, compute/data grids, etc. > > -- > Nikita Ivanov > > >> On Sun, Mar 26, 2017 at 11:59 AM, Neeraj Vaidya <neeraj.vai...@yahoo.co.in> >> wrote: >> Thanks Denis, by "latter&quo

Re: Akka vs Ignite

2017-03-26 Thread Neeraj Vaidya
’s current goals and > its future evolvement, that latter might be more attractive since a lot of > functionality is provided out-of-the-box in a single platform. > > — > Denis > >> On Mar 26, 2017, at 6:07 AM, Neeraj Vaidya <neeraj.vai...@yahoo.co.in> wrote: >&

Akka vs Ignite

2017-03-26 Thread Neeraj Vaidya
Dear Experts, While doing development on my application related to telecom projects, I was wondering if Akka would have any specific advantages/disadvantages in comparison to Ignite. My application is a realtime telecom transactional application. I can think of the following major pluses for

Re: Disabling Ignite console logs

2017-03-02 Thread Neeraj Vaidya
Thanks Andrey. Regards, Neeraj Sent from my iPhone > On 3 Mar 2017, at 09:32, Andrey Mashenkov wrote: > > Hi Neeraj, > > I see IGNITE-4248 is fixed in 1.9 version that has to be released soon. > >> On Fri, Mar 3, 2017 at 1:02 AM, vkulichenko

Re: Ignite with dBeaver

2018-03-06 Thread Neeraj Vaidya
Dbeaver works just fine. Or, you can even build Ignite-web-console. Regards, Neeraj > On 7 Mar 2018, at 05:53, Wilhelm Thomas wrote: > > Hello, > > I’m evaluating ignite and I need a free tool to see the tables and cache > content. > What is the best free tool

TcpDiscoverSpi error connection refused

2018-04-05 Thread Neeraj Vaidya
Hi, I have 2 virtualbox guest OS'es (CentOS7 64-bit) , each having firewalld stopped and disabled. The nodes are axlrate-node-1 and axlrate-node-2. I have updated default-config.xml in both servers My default-config.xml looks like below :

Re: Failing to deploy service

2018-04-04 Thread Neeraj Vaidya
ani...@gmail.com> wrote: Subject: Re: Failing to deploy service To: "Neeraj Vaidya" <neeraj.vai...@yahoo.co.in> Cc: user@ignite.apache.org Date: Wednesday, 4 April, 2018, 9:19 AM Neeraj, Thanks for sharing the details!I'll try to reproduce this issue. If you put

Re: Failing to deploy service

2018-04-04 Thread Neeraj Vaidya
In addition to marking LOG as @transient, I also made it lazy val so that it does not result in initialization order issues. Regards, Neeraj On Wed, 4/4/18, Neeraj Vaidya <neeraj.vai...@yahoo.co.in> wrote: Subject: Re: Failing to deploy s

Re: TcpDiscoverSpi error connection refused

2018-04-08 Thread Neeraj Vaidya
successfully: >> Topology snapshot [ver=1, servers=1, ...] >> >> You can disable debug logging not to see these exceptions. >> >> The second exception is also doesn't mean anything bad. >> It only means, that some object was transferred to this node, and conne

Re: TcpDiscoverSpi error connection refused

2018-04-09 Thread Neeraj Vaidya
uot; + e.getMessage(), e); > > So, these exceptions are shown only when debug logging is enabled, and they > are logged as errors. > > Neeraj, you probably just didn't enable debug log on the second node, so you > don't see these exceptions on it. > > Denis > > пн,

Failing to deploy service

2018-04-03 Thread Neeraj Vaidya
Hi, I am trying to deploy a service during ignite node startup. But I noticed 2 peculiar behaviours. I am loading the class using Note that I am using a single-node cluster. Thus, the service class is present on the classpath of the node where I am trying to deploy this service.

Re: Failing to deploy service

2018-04-04 Thread Neeraj Vaidya
15:06, Neeraj Vaidya <neeraj.vai...@yahoo.co.in> wrote: > > Hi, > > I am trying to deploy a service during ignite node startup. But I noticed 2 > peculiar behaviours. I am loading the class using > Note that I am using a single-node cluster. Thus, the service class is

Re: Failing to deploy service

2018-04-04 Thread Neeraj Vaidya
, 7:43 AM Neeraj, There is no such restriction, as far as I know.What do you mean by "using"? Could you provide this class?  Denis ср, 4 апр. 2018 г. в 10:32, Neeraj Vaidya <neeraj.vai...@yahoo.co.in>: On analysing further it seems the field id indicated as “marker” b

Service Grid launching Compute Tasks

2018-03-21 Thread Neeraj Vaidya
Hi, Is it advisable to launch compute tasks from the execute method of a Service implementation task ? Are there any shortcomings ? The service execute methods are long running back ground method waiting for data arrival in queues/pipes, tcp connections, file system folders, etc. Regards,