Re: [OMPI users] Open MPI installation problem

2019-01-23 Thread Serdar Hiçdurmaz
Thanks Ralph. It worked.

Serdar

Ralph H Castain , 23 Oca 2019 Çar, 15:48 tarihinde şunu
yazdı:

> Your PATH and LD_LIBRARY_PATH setting is incorrect. You installed OMPI
> into $HOME/openmpi, so you should have done:
>
> PATH=$HOME/openmpi/bin:$PATH
> LD_LIBRARY_PATH=$HOME/openmpi/lib:$LD_LIBRARY_PATH
>
> Ralph
>
>
> On Jan 23, 2019, at 6:36 AM, Serdar Hiçdurmaz 
> wrote:
>
> Hi All,
>
> I try to install Open MPI, which is prerequiste for liggghts (DEM
> software). Some info about my current linux version :
>
> NAME="SLED"
> VERSION="12-SP3"
> VERSION_ID="12.3"
> PRETTY_NAME="SUSE Linux Enterprise Desktop 12 SP3"
> ID="sled"
>
> I installed Open MPI 1.6 by typing
>
> ./configure --prefix=$HOME/openmpi
> make all
> make install
>
> Here, it is discussed that openmpi 1.6 is compatible with OpenSuse 12.3
> https://public.kitware.com/pipermail/paraview/2014-February/030487.html
> https://build.opensuse.org/package/show/openSUSE:12.3/openmpi
>
> To add OpenMPI to my path and LD_LIBRARY_PATH, I execute the following
> comands on terminal:
>
> export PATH=$PATH:/usr/lib64/mpi/gcc/openmpi/bin
> export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib64/mpi/gcc/openmpi/lib64
>
> Then, in /liggghts/src directory, I execute make auto, this appears :
>
> Creating list of contact models completed.
> make[1]: Entering directory
> '/home/serdarhd/liggghts/LIGGGHTS-PUBLIC/src/Obj_auto'
> Makefile:456: *** 'Could not compile a simple MPI example. Test was done
> with MPI_INC="" and MPICXX="mpicxx"'. Stop.
> make[1]: Leaving directory
> '/home/serdarhd/liggghts/LIGGGHTS-PUBLIC/src/Obj_auto'
> Makefile:106: recipe for target 'auto' failed
> make: *** [auto] Error 2
>
> Do you have any idea what the problem is here ? I went through the
> "makefile" but it looks like quite complicated as linux beginner like me.
>
> Thanks in advance. Regards,
>
> Serdar
>
> ___
> users mailing list
> users@lists.open-mpi.org
> https://lists.open-mpi.org/mailman/listinfo/users
>
>
> ___
> users mailing list
> users@lists.open-mpi.org
> https://lists.open-mpi.org/mailman/listinfo/users
___
users mailing list
users@lists.open-mpi.org
https://lists.open-mpi.org/mailman/listinfo/users

[OMPI users] Open MPI installation problem

2019-01-23 Thread Serdar Hiçdurmaz
Hi All,

I try to install Open MPI, which is prerequiste for liggghts (DEM
software). Some info about my current linux version :

NAME="SLED"
VERSION="12-SP3"
VERSION_ID="12.3"
PRETTY_NAME="SUSE Linux Enterprise Desktop 12 SP3"
ID="sled"

I installed Open MPI 1.6 by typing

./configure --prefix=$HOME/openmpi
make all
make install

Here, it is discussed that openmpi 1.6 is compatible with OpenSuse 12.3
https://public.kitware.com/pipermail/paraview/2014-February/030487.html
https://build.opensuse.org/package/show/openSUSE:12.3/openmpi

To add OpenMPI to my path and LD_LIBRARY_PATH, I execute the following
comands on terminal:

export PATH=$PATH:/usr/lib64/mpi/gcc/openmpi/bin
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib64/mpi/gcc/openmpi/lib64

Then, in /liggghts/src directory, I execute make auto, this appears :

Creating list of contact models completed.
make[1]: Entering directory
'/home/serdarhd/liggghts/LIGGGHTS-PUBLIC/src/Obj_auto'
Makefile:456: *** 'Could not compile a simple MPI example. Test was done
with MPI_INC="" and MPICXX="mpicxx"'. Stop.
make[1]: Leaving directory
'/home/serdarhd/liggghts/LIGGGHTS-PUBLIC/src/Obj_auto'
Makefile:106: recipe for target 'auto' failed
make: *** [auto] Error 2

Do you have any idea what the problem is here ? I went through the
"makefile" but it looks like quite complicated as linux beginner like me.

Thanks in advance. Regards,

Serdar
___
users mailing list
users@lists.open-mpi.org
https://lists.open-mpi.org/mailman/listinfo/users

Re: [OMPI users] Open MPI installation problem

2019-01-25 Thread Serdar Hiçdurmaz
Hi folks,

After installing OpenMPI, I executed these lines

echo 'PATH=$HOME/openmpi/bin:$PATH' >> ~/.bashrc
echo 'LD_LIBRARY_PATH=$HOME/openmpi/' >> ~/.bashrc
source. bashrc

and run  a simple file by using

mpirun np 1 helloworld

The error message is

helloworld: error while loading shared libraries: libmpi_cxx.so.1: cannot
open shared object file: No such file or directory
--
mpirun noticed that the job aborted, but has no info as to the process
that caused that situation.
--
 It is about inaccurate linking the libraries but I could not fix it. When
i run ldd helloworld, this appears

linux-vdso.so.1 (0x7fff8f2d2000)
libmpi_cxx.so.1 => not found
libmpi.so.1 => not found
libm.so.6 => /lib64/libm.so.6 (0x7fbc21e55000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x7fbc21acb000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x7fbc218b3000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x7fbc21696000)
libc.so.6 => /lib64/libc.so.6 (0x7fbc212f1000)
/lib64/ld-linux-x86-64.so.2 (0x7fbc22152000)

Do you have any idea to fix it ?

Best,
Serdar


Serdar Hiçdurmaz , 23 Oca 2019 Çar, 16:26
tarihinde şunu yazdı:

> Thanks Ralph. It worked.
>
> Serdar
>
> Ralph H Castain , 23 Oca 2019 Çar, 15:48 tarihinde şunu
> yazdı:
>
>> Your PATH and LD_LIBRARY_PATH setting is incorrect. You installed OMPI
>> into $HOME/openmpi, so you should have done:
>>
>> PATH=$HOME/openmpi/bin:$PATH
>> LD_LIBRARY_PATH=$HOME/openmpi/lib:$LD_LIBRARY_PATH
>>
>> Ralph
>>
>>
>> On Jan 23, 2019, at 6:36 AM, Serdar Hiçdurmaz 
>> wrote:
>>
>> Hi All,
>>
>> I try to install Open MPI, which is prerequiste for liggghts (DEM
>> software). Some info about my current linux version :
>>
>> NAME="SLED"
>> VERSION="12-SP3"
>> VERSION_ID="12.3"
>> PRETTY_NAME="SUSE Linux Enterprise Desktop 12 SP3"
>> ID="sled"
>>
>> I installed Open MPI 1.6 by typing
>>
>> ./configure --prefix=$HOME/openmpi
>> make all
>> make install
>>
>> Here, it is discussed that openmpi 1.6 is compatible with OpenSuse 12.3
>> https://public.kitware.com/pipermail/paraview/2014-February/030487.html
>> https://build.opensuse.org/package/show/openSUSE:12.3/openmpi
>>
>> To add OpenMPI to my path and LD_LIBRARY_PATH, I execute the following
>> comands on terminal:
>>
>> export PATH=$PATH:/usr/lib64/mpi/gcc/openmpi/bin
>> export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib64/mpi/gcc/openmpi/lib64
>>
>> Then, in /liggghts/src directory, I execute make auto, this appears :
>>
>> Creating list of contact models completed.
>> make[1]: Entering directory
>> '/home/serdarhd/liggghts/LIGGGHTS-PUBLIC/src/Obj_auto'
>> Makefile:456: *** 'Could not compile a simple MPI example. Test was done
>> with MPI_INC="" and MPICXX="mpicxx"'. Stop.
>> make[1]: Leaving directory
>> '/home/serdarhd/liggghts/LIGGGHTS-PUBLIC/src/Obj_auto'
>> Makefile:106: recipe for target 'auto' failed
>> make: *** [auto] Error 2
>>
>> Do you have any idea what the problem is here ? I went through the
>> "makefile" but it looks like quite complicated as linux beginner like me.
>>
>> Thanks in advance. Regards,
>>
>> Serdar
>>
>> ___
>> users mailing list
>> users@lists.open-mpi.org
>> https://lists.open-mpi.org/mailman/listinfo/users
>>
>>
>> ___
>> users mailing list
>> users@lists.open-mpi.org
>> https://lists.open-mpi.org/mailman/listinfo/users
>
>
___
users mailing list
users@lists.open-mpi.org
https://lists.open-mpi.org/mailman/listinfo/users