Re: [OMPI users] How to keep multiple installations at same time

2014-08-05 Thread Gus Correa
Thanks for not saying this turn that Environment Modules is "outdated and not maintained". That might mislead the OMPI list audience, which has a big intersection with Environment Modules users. On May 16, 2014, at 4:07 PM, Maxime Boissonneault wrote: >

Re: [OMPI users] How to keep multiple installations at same time

2014-08-05 Thread Maxime Boissonneault
The Environment Modules package user base is not negligible, including many universities, research centers, national labs, ans private companies, in the US and around the world. How does the user base of LMod compare? The user base certainly is much larger for Environment Modules than LMod.

Re: [OMPI users] How to keep multiple installations at same time

2014-08-05 Thread Ralph Castain
Nobody was trying to make a statement here, Gus - I was only quoting something based on the last known repo of which I was aware. If the modules folks moved to Github, then they might want to make that a little more obvious. :-/ Lmod vs modules - I couldn't care less. My understanding is that

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-05 Thread Dan Shell
Jeff Thanks I am reinstalling now with a newer version of openmpi dated August 1 2014 Check my gfortran version is 4.4.3 as you said should be ok. Thank you for your help Dan Shell -Original Message- From: users [mailto:users-boun...@open-mpi.org] On Behalf Of Jeff Squyres (jsquyres)

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-05 Thread Jeff Squyres (jsquyres)
On Aug 5, 2014, at 1:13 PM, Dan Shell wrote: > Need to use mpif.h for my application > I will get the newest versions of gcc and gfortran You should be fine without the newest versions of gcc/gfortran. The older gcc/gfortran will support mpif.h and a limited form of

Re: [OMPI users] How to keep multiple installations at same time

2014-08-05 Thread Gus Correa
Hi Ralph and list I am no developer, but my impression is that, paraphrasing Mark Twain, the reports about the death of the Environment Modules (http://modules.sourceforge.net/) package have been exaggerated. That presumed death/obsolescence has been repeated a few times on the OMPI list, which

Re: [OMPI users] How to keep multiple installations at same time

2014-08-05 Thread David Turner
I checked with my colleague, who is one of the module developers. His response: > That's a surprise to me?! > I will admit that I'm a little slow on releases, > but it's still quite active. On 8/5/14 11:39 AM, Fabricio Cannini wrote: On 05-08-2014 13:54, Ralph Castain wrote: Check the repo -

Re: [OMPI users] How to keep multiple installations at same time

2014-08-05 Thread Bennet Fauber
There is also the Lmod project, based at TACC, and run by Robert McLay. https://www.tacc.utexas.edu/tacc-projects/lmod That's under current, active development, and if you'd be creating a brand new modules infrastructure, bears a close look. -- bennet On Tue, Aug 5, 2014 at 2:39 PM, Fabricio

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-05 Thread Dan Shell
Jeff Need to use mpif.h for my application I will get the newest versions of gcc and gfortran Dan Shell -Original Message- From: users [mailto:users-boun...@open-mpi.org] On Behalf Of Jeff Squyres (jsquyres) Sent: Tuesday, August 05, 2014 11:13 AM To: Open MPI User's List Subject: Re:

Re: [OMPI users] How to keep multiple installations at same time

2014-08-05 Thread Ralph Castain
Check the repo - hasn't been touched in a very long time On Aug 5, 2014, at 9:42 AM, Fabricio Cannini wrote: > On 05-08-2014 13:10, Ralph Castain wrote: >> Since modules isn't a supported s/w package any more, you might consider >> using LMOD instead: >> >>

Re: [OMPI users] How to keep multiple installations at same time

2014-08-05 Thread Fabricio Cannini
On 05-08-2014 13:10, Ralph Castain wrote: Since modules isn't a supported s/w package any more, you might consider using LMOD instead: https://www.tacc.utexas.edu/tacc-projects/lmod Modules isn't supported anymore? :O Could you please send a link about it ?

Re: [OMPI users] How to keep multiple installations at same time

2014-08-05 Thread Ralph Castain
Since modules isn't a supported s/w package any more, you might consider using LMOD instead: https://www.tacc.utexas.edu/tacc-projects/lmod On Aug 5, 2014, at 9:04 AM, Gus Correa wrote: > Hi Ahsan > > Besides Andrew's excellent suggestion for the runtime environment.

Re: [OMPI users] How to keep multiple installations at same time

2014-08-05 Thread Gus Correa
Hi Ahsan Besides Andrew's excellent suggestion for the runtime environment. For the installation, Open MPI configuration scripts and Makefiles support VPATH. Hence, you can create two separate directories to *build* it with Gnu and Intel compilers. Then you launch configure, make, make install

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-05 Thread Jeff Squyres (jsquyres)
On Aug 5, 2014, at 10:57 AM, Dan Shell wrote: > Should I look for a newer version of gfortran? > I saw from the config fortran compile section that mpi_f08 was not compiled It depends on what your MPI application needs. MPI (i.e., the spec, not Open MPI) defines

Re: [OMPI users] problem with rankfile in openmpi-1.8.2rc3

2014-08-05 Thread Ralph Castain
I can't replicate - this worked fine for me. I'm at a loss as to how you got that error as it would require some strange error in the report-bindngs option. If you remove that option from your cmd line, does the problem go away? On Aug 5, 2014, at 12:56 AM, Siegmar Gross

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-05 Thread Dan Shell
Jeff Ok Should I look for a newer version of gfortran? I saw from the config fortran compile section that mpi_f08 was not compiled Thank you for the help Dan Shell -Original Message- From: users [mailto:users-boun...@open-mpi.org] On Behalf Of Jeff Squyres (jsquyres) Sent: Tuesday,

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-05 Thread Jeff Squyres (jsquyres)
Dan -- The version of gfortran that you have does not support the mpi_f08 bindings. Note that: - newer versions of gfortran will support the mpi_f08 bindings - all versions of gfortran support the mpi module and the mpif.h Fortran bindings See the README: -- The following notes apply

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-05 Thread Dan Shell
Gus Ok I will give that a try Thank you for the help Dan Shell -Original Message- From: users [mailto:users-boun...@open-mpi.org] On Behalf Of Gus Correa Sent: Monday, August 04, 2014 4:39 PM To: Open MPI Users Subject: Re: [OMPI users] openmpi 1.8.1 gfortran not working >> I have the

Re: [OMPI users] bus error with openmpi-1.8.2rc2 on Solaris 10 Sparc

2014-08-05 Thread Ralph Castain
Did you configure this --enable-debug? If so, you should get a line number in the backtrace On Aug 5, 2014, at 2:59 AM, Siegmar Gross wrote: > Hi, > > I'm sorry to answer so late, but last week I didn't have Internet > access. In the meantime I've

Re: [OMPI users] bus error with openmpi-1.8.2rc2 on Solaris 10 Sparc

2014-08-05 Thread Siegmar Gross
Hi, I'm sorry to answer so late, but last week I didn't have Internet access. In the meantime I've installed openmpi-1.8.2rc3 and I get the same error. > This looks like the typical type of alignment error that we used > to see when testing regularly on SPARC. :-\ > > It looks like the error

Re: [OMPI users] SIGSEGV for Java program in openmpi-1.8.2rc2 onSolaris 10

2014-08-05 Thread Siegmar Gross
Hi, I'm sorry to answer so late, but last week I didn't have Internet access. In the meantime I've installed openmpi-1.8.2rc3 and I get the same error. > That's quite odd that it only happens for Java programs -- it > should happen for *all* programs, based on the stack trace you've shown. > >

[OMPI users] problem with rankfile in openmpi-1.8.2rc3

2014-08-05 Thread Siegmar Gross
Hi, yesterday I installed openmpi-1.8.2rc3 on my machines (Solaris 10 Sparc, Solaris 10 x86_64, and openSUSE Linux 12.1 x86_64) with Sun C 5.12. I get an error, if I use a rankfile for all three architectures. The error message depends on the local machine, which I use to run "mpiexec". I get a

Re: [OMPI users] How to keep multiple installations at same time

2014-08-05 Thread Andrew Caird
Hi Ahsan, We, and I think many people, use the Environment Modules software, http://modules.sourceforge.net , to do this. I hope that helps. --andy > On Aug 4, 2014, at 11:47 PM, Syed Ahsan Ali wrote: > > > I want to compile openmpi with both intel and gnu

[OMPI users] How to keep multiple installations at same time

2014-08-05 Thread Syed Ahsan Ali
I want to compile openmpi with both intel and gnu compilers. How can I install both at the same time and then specify which one to use during job submission. Regards Ahsan