Re: [OMPI users] Newbie query - mpirun will not run if it's previously been killed with Control-C

2014-08-07 Thread Ralph Castain
On Aug 7, 2014, at 9:17 AM, Gus Correa wrote: > On 08/07/2014 11:49 AM, Ralph Castain wrote: >> >> On Aug 7, 2014, at 8:47 AM, Reuti > > wrote: >> >>> Am 07.08.2014 um 17:28 schrieb Gus Correa: >>> I

Re: [OMPI users] Newbie query - mpirun will not run if it's previously been killed with Control-C

2014-08-07 Thread Gus Correa
On 08/07/2014 11:49 AM, Ralph Castain wrote: On Aug 7, 2014, at 8:47 AM, Reuti > wrote: Am 07.08.2014 um 17:28 schrieb Gus Correa: I guess Control-C will kill only the mpirun process. You may need to kill the (two) jules.exe

Re: [OMPI users] problem with rankfile in openmpi-1.8.2rc3

2014-08-07 Thread Siegmar Gross
Hello Ralph, > Try replacing --report-bindings with -mca hwloc_base_report_bindings 1 > and see if that works I get even more warnings with the new option. It seems that I always get the bindings only for the local machine. I used Solaris Sparc (tyr), Solaris x86_64 (sunpc1), and Linux x86_64

Re: [OMPI users] Newbie query - mpirun will not run if it's previously been killed with Control-C

2014-08-07 Thread Gus Correa
On 08/07/2014 11:28 AM, Gus Correa wrote: I guess Control-C will kill only the mpirun process. You may need to kill the (two) jules.exe processes separately, say, with kill -9. ps -u "yourname" will show what you have running. Something may have been left behind by Control-C, although as

Re: [OMPI users] Newbie query - mpirun will not run if it's previously been killed with Control-C

2014-08-07 Thread Jeff Squyres (jsquyres)
Can you try upgrading? 1.6.x is super old. 1.8.1 is the current stable release. On Aug 7, 2014, at 11:16 AM, Jane Lewis wrote: > Hi all, > > This is a really simple problem (I hope) where I’ve introduced MPI to a > complex numerical model which I have to kill

Re: [OMPI users] Newbie query - mpirun will not run if it's previously been killed with Control-C

2014-08-07 Thread Ralph Castain
On Aug 7, 2014, at 8:47 AM, Reuti wrote: > Am 07.08.2014 um 17:28 schrieb Gus Correa: > >> I guess Control-C will kill only the mpirun process. >> You may need to kill the (two) jules.exe processes separately, >> say, with kill -9. >> ps -u "yourname" >> will show

Re: [OMPI users] Newbie query - mpirun will not run if it's previously been killed with Control-C

2014-08-07 Thread Reuti
Am 07.08.2014 um 17:28 schrieb Gus Correa: > I guess Control-C will kill only the mpirun process. > You may need to kill the (two) jules.exe processes separately, > say, with kill -9. > ps -u "yourname" > will show what you have running. Shouldn't Open MPI clean this up in a proper way when

Re: [OMPI users] Newbie query - mpirun will not run if it's previously been killed with Control-C

2014-08-07 Thread Gus Correa
I guess Control-C will kill only the mpirun process. You may need to kill the (two) jules.exe processes separately, say, with kill -9. ps -u "yourname" will show what you have running. On 08/07/2014 11:16 AM, Jane Lewis wrote: Hi all, This is a really simple problem (I hope) where I’ve

[OMPI users] Newbie query - mpirun will not run if it's previously been killed with Control-C

2014-08-07 Thread Jane Lewis
Hi all, This is a really simple problem (I hope) where I've introduced MPI to a complex numerical model which I have to kill occasionally with Control-C as I don't want it running forever. I have only used mpi_init(), mpi_comm_size(), mpi_comm_rank() and mpi_finalize()- there are no

[MTT users] MTT on PPC64

2014-08-07 Thread Adrian Reber
I was trying to run MTT on ppc64 and it complained that I need to write a patch. Since the name 'Fedora Core' does not exist anymore (since Fedora 7) I have following patch for MTT: diff --git a/client/whatami/whatami b/client/whatami/whatami index b4c50f5..aa275f0 100755 ---

Re: [OMPI users] problem with rankfile in openmpi-1.8.2rc3

2014-08-07 Thread Ralph Castain
Try replacing --report-bindings with -mca hwloc_base_report_bindings 1 and see if that works On Aug 7, 2014, at 4:04 AM, Siegmar Gross wrote: > Hi, > >> I can't replicate - this worked fine for me. I'm at a loss as >> to how you got that error as it

Re: [OMPI users] problem with rankfile in openmpi-1.8.2rc3

2014-08-07 Thread Siegmar Gross
Hi, > I can't replicate - this worked fine for me. I'm at a loss as > to how you got that error as it would require some strange > error in the report-bindngs option. If you remove that option > from your cmd line, does the problem go away? Yes. tyr openmpi_1.7.x_or_newer 468 mpiexec -np 4 -rf

Re: [OMPI users] bus error with openmpi-1.8.2rc2 on Solaris 10 Sparc

2014-08-07 Thread Siegmar Gross
Hi, I'm sorry once more to answer late, but the last two days our mail server was down (hardware error). > Did you configure this --enable-debug? Yes, I used the following command. ../openmpi-1.8.2rc3/configure --prefix=/usr/local/openmpi-1.8.2_64_gcc \