Re: [OMPI users] MPI the correct solution?

2017-05-18 Thread doark
On Tue, 9 May 2017 00:30:38 +0200 Reuti wrote: > Hi, > > Am 08.05.2017 um 23:25 schrieb David Niklas: > > > Hello, > > I originally ported this question at LQ, but the answer I got back > > shows rather poor insight on the subject of MPI, so I'm taking the > >

Re: [OMPI users] IBM Spectrum MPI problem

2017-05-18 Thread Gabriele Fatigati
Hi Gilles, attached the requested info 2017-05-18 15:04 GMT+02:00 Gilles Gouaillardet < gilles.gouaillar...@gmail.com>: > Gabriele, > > can you > ompi_info --all | grep pml > > also, make sure there is nothing in your environment pointing to an other > Open MPI install > for example > ldd a.out

Re: [OMPI users] IBM Spectrum MPI problem

2017-05-18 Thread Chuck Schneider
Another thing Gabriele might want to check is whether the Spectrum MPI launcher is being used. In Spectrum MPI, "mpirun" is a script that, among other things, sets up the environment for Spectrum-specific libraries to be found. In my experience, trying to "short circuit" the use of that

Re: [OMPI users] IBM Spectrum MPI problem

2017-05-18 Thread Gilles Gouaillardet
Gabriele, can you ompi_info --all | grep pml also, make sure there is nothing in your environment pointing to an other Open MPI install for example ldd a.out should only point to IBM libraries Cheers, Gilles On Thursday, May 18, 2017, Gabriele Fatigati wrote: > Dear

Re: [OMPI users] IBM Spectrum MPI problem

2017-05-18 Thread John Hearns via users
One very stupid question...what does 'ibv_devinfo' say when you run it on the compute nodes? ps. I know nothing about IBM MPI or pami but I think this is as you say some simple library being missing etc. On 18 May 2017 at 14:20, Gabriele Fatigati wrote: > Hi John,

Re: [OMPI users] IBM Spectrum MPI problem

2017-05-18 Thread Gabriele Fatigati
Hi John, about btl this is the output of ompi_info: MCA btl: self (MCA v2.1.0, API v3.0.0, Component v10.1.0) MCA btl: sm (MCA v2.1.0, API v3.0.0, Component v10.1.0) MCA btl: tcp (MCA v2.1.0, API v3.0.0, Component v10.1.0) MCA btl: vader (MCA v2.1.0, API v3.0.0, Component v10.1.0) MCA fbtl: posix

Re: [OMPI users] IBM Spectrum MPI problem

2017-05-18 Thread Gabriele Fatigati
Hi Reuti, I think is it freely available. I posted also on IBM Spectrum forum, I'm waiting some reply. 2017-05-18 14:10 GMT+02:00 Reuti : > Hi, > > > Am 18.05.2017 um 14:02 schrieb Gabriele Fatigati : > > > > Dear OpenMPI users and developers,

Re: [OMPI users] IBM Spectrum MPI problem

2017-05-18 Thread John Hearns via users
Gabriele, as this is based on OpenMPI can you run ompi_info then look for the btl which are available and the mtl which are available? On 18 May 2017 at 14:10, Reuti wrote: > Hi, > > > Am 18.05.2017 um 14:02 schrieb Gabriele Fatigati : > > >

Re: [OMPI users] IBM Spectrum MPI problem

2017-05-18 Thread Reuti
Hi, > Am 18.05.2017 um 14:02 schrieb Gabriele Fatigati : > > Dear OpenMPI users and developers, I'm using IBM Spectrum MPI 10.1.0 I noticed this on IBM's website too. Is this freely available? Up to now I was always bounced back to their former Platform MPI when trying to

[OMPI users] IBM Spectrum MPI problem

2017-05-18 Thread Gabriele Fatigati
Dear OpenMPI users and developers, I'm using IBM Spectrum MPI 10.1.0 based on OpenMPI, so I hope there are some MPI expert can help me to solve the problem. When I run a simple Hello World MPI program, I get the follow error message: A requested component was not found, or was unable to be