Re: [OMPI users] openmpi/slurm/pmix

2018-04-25 Thread r...@open-mpi.org
> On Apr 25, 2018, at 8:16 AM, Michael Di Domenico > wrote: > > On Mon, Apr 23, 2018 at 6:07 PM, r...@open-mpi.org wrote: >> Looks like the problem is that you didn’t wind up with the external PMIx. >> The component listed in your error is the

Re: [OMPI users] openmpi/slurm/pmix

2018-04-25 Thread Michael Di Domenico
On Mon, Apr 23, 2018 at 6:07 PM, r...@open-mpi.org wrote: > Looks like the problem is that you didn’t wind up with the external PMIx. The > component listed in your error is the internal PMIx one which shouldn’t have > built given that configure line. > > Check your

Re: [OMPI users] Fwd: Fwd: problem in cluster

2018-04-25 Thread John Hearns via users
That fine. But in your job script ppn=2 Also check ldd cgles on the compute servers themselves. Are all the libraries available in your path? On 25 April 2018 at 11:43, Ankita m wrote: > i have 16 cores per one node. I usually use 4 node each node has 16 cores > so

Re: [OMPI users] Fwd: Fwd: problem in cluster

2018-04-25 Thread John Hearns via users
Ankita, please read here:https://www.open-mpi.org/faq/?category=mpi-apps On 25 April 2018 at 11:44, Ankita m wrote: > Can you please tell me whether to use mpicc compiler ar any other compiler > for openmpi programs > > On Wed, Apr 25, 2018 at 3:13 PM, Ankita m

Re: [OMPI users] Fwd: Fwd: problem in cluster

2018-04-25 Thread Ankita m
Can you please tell me whether to use mpicc compiler ar any other compiler for openmpi programs On Wed, Apr 25, 2018 at 3:13 PM, Ankita m wrote: > i have 16 cores per one node. I usually use 4 node each node has 16 cores > so total 64 processes. > > On Wed, Apr 25, 2018

Re: [OMPI users] Fwd: Fwd: problem in cluster

2018-04-25 Thread Ankita m
i have 16 cores per one node. I usually use 4 node each node has 16 cores so total 64 processes. On Wed, Apr 25, 2018 at 2:57 PM, John Hearns via users < users@lists.open-mpi.org> wrote: > I do not see much wrong with that. > However nodes=4 ppn=2 makes 8 processes in all. > You are using

Re: [OMPI users] Fwd: Fwd: problem in cluster

2018-04-25 Thread John Hearns via users
I do not see much wrong with that. However nodes=4 ppn=2 makes 8 processes in all. You are using mpirun -np 64 Actually it is better practice to use the PBS supplied environment variables during the job, rather than hard-wiring 64 I dont have access to a PBS cluster from my desk at the

[OMPI users] Fwd: Fwd: problem in cluster

2018-04-25 Thread Ankita m
> > > while using openmpi- 1.4.5 the program ended by showing this error file > (in the attachment) > I am Using PBS file . Below u can find the script that i am using to run my program cgles.err Description: Binary data run.pbs Description: Binary data

Re: [OMPI users] Fwd: problem in cluster

2018-04-25 Thread John Hearns via users
Ankita, this is problem with your batch queuing system. Do you know which batch system you are using on this cluster? Can you share with us what command you use to submit a job? Also please do not share your teamviewer password with us. I doubt this is of much use to anyone, but... On 25 April

[OMPI users] Fwd: problem in cluster

2018-04-25 Thread Ankita m
While using the open mpi got this error. Can you please tell why so -- Forwarded message - From: Ankita m Date: Tue, 24 Apr 2018, 12:55 pm Subject: Re: problem in cluster To: sagar mcp , Krishna Singh while using