Re: [OMPI users] --mca btl params

2018-10-09 Thread Noam Bernstein
> On Oct 9, 2018, at 7:02 PM, Noam Bernstein > wrote: > >> On Oct 9, 2018, at 6:01 PM, Jeffrey A Cummings > > wrote: >> >> What are the allowable values for the –mca btl parameter on the mpirun >> command line? > > That's basically what the output of >

Re: [OMPI users] --mca btl params

2018-10-09 Thread Noam Bernstein
> On Oct 9, 2018, at 6:01 PM, Jeffrey A Cummings > wrote: > > What are the allowable values for the –mca btl parameter on the mpirun > command line? That's basically what the output of ompi_info -a says. So it appears, for the moment at least, like things are magically better. In the

[OMPI users] --mca btl params

2018-10-09 Thread Jeffrey A Cummings
What are the allowable values for the –mca btl parameter on the mpirun command line? – Jeff Jeffrey A. Cummings Engineering Specialist Mission Analysis and Operations Department Systems Analysis and Simulation Subdivision Systems Engineering Division Engineering and Technology Group The

Re: [OMPI users] no openmpi over IB on new CentOS 7 system

2018-10-09 Thread Andy Riebs
Noam, Start with the FAQ, etc., under "Getting Help/Support" in the left-column menu at https://www.open-mpi.org/ Andy *From:* Noam Bernstein *Sent:* Tuesday, October 09, 2018 2:26PM *To:* Open Mpi Users *Cc:*

[OMPI users] no openmpi over IB on new CentOS 7 system

2018-10-09 Thread Noam Bernstein
Hi - I’m trying to get OpenMPI working on a newly configured CentOS 7 system, and I’m not even sure what information would be useful to provide. I’m using the CentOS built in libibverbs and/or libfabric, and I configure openmpi with just —with-verbs —with-ofi —prefix=$DEST also tried

Re: [OMPI users] Cannot run MPI code on multiple cores with PBS

2018-10-09 Thread John Hearns via users
Michele, as other have said libibverbs.so.1 is not in your library path. Can you ask the person who manages yoru cluster where libibverbs is located on the compute nodes? Also try to runibv_devinfo On Tue, 9 Oct 2018 at 16:03, Castellana Michele wrote: > > Dear John, > Thank you for your

Re: [OMPI users] Cannot run MPI code on multiple cores with PBS

2018-10-09 Thread Castellana Michele
Dear John, Thank you for your reply. Here is the output of ldd $ ldd ./code.io linux-vdso.so.1 => (0x7ffcc759f000) liblapack.so.3 => /usr/lib64/liblapack.so.3 (0x7fbc1c613000) libgsl.so.0 => /usr/lib64/libgsl.so.0 (0x7fbc1c1ea000) libgslcblas.so.0 =>

Re: [OMPI users] ompio on Lustre

2018-10-09 Thread Gabriel, Edgar
Ok, thanks. I usually run these test with 4 or 8, but the major item is that atomicity is one of the areas that are not well supported in ompio (along with data representations), so a failure in those tests is not entirely surprising . Most of the work to support atomicity properly is actually

Re: [OMPI users] ompio on Lustre

2018-10-09 Thread Dave Love
"Gabriel, Edgar" writes: > Hm, thanks for the report, I will look into this. I did not run the > romio tests, but the hdf5 tests are run regularly and with 3.1.2 you > should not have any problems on a regular unix fs. How many processes > did you use, and which tests did you run specifically?

Re: [OMPI users] error building Java api for openmpi-v4.0.x-201810090241-2124192 and openmpi-master-201810090329-e9e4d2a

2018-10-09 Thread Kawashima, Takahiro
I confirmed the patch resolved the issue with OpenJDK 11. I've created a PR for the master branch. I'll also create PRs for release branches. Thanks to your bug report! https://github.com/open-mpi/ompi/pull/5870 Takahiro Kawashima, Fujitsu > Siegmar, > > I think you are using Java 11 and it

Re: [OMPI users] error building Java api for openmpi-v4.0.x-201810090241-2124192 and openmpi-master-201810090329-e9e4d2a

2018-10-09 Thread Kawashima, Takahiro
Siegmar, I think you are using Java 11 and it changed the default output HTML version. I'll take a look. But downloading OpenJDK 11 takes time... Probably the following patch will resolve the issue. diff --git

Re: [OMPI users] error building Java api for openmpi-v4.0.x-201810090241-2124192 and openmpi-master-201810090329-e9e4d2a

2018-10-09 Thread Kawashima, Takahiro
What version of Java are you using? Could you type "java -version" and show the output? Takahiro Kawashima, Fujitsu > today I've tried to build openmpi-v4.0.x-201810090241-2124192 and > openmpi-master-201810090329-e9e4d2a on my "SUSE Linux Enterprise Server > 12.3 (x86_64)" with Sun C 5.15, gcc

[OMPI users] error building Java api for openmpi-v4.0.x-201810090241-2124192 and openmpi-master-201810090329-e9e4d2a

2018-10-09 Thread Siegmar Gross
Hi, today I've tried to build openmpi-v4.0.x-201810090241-2124192 and openmpi-master-201810090329-e9e4d2a on my "SUSE Linux Enterprise Server 12.3 (x86_64)" with Sun C 5.15, gcc 6.4.0, Intel icc 18.0.3, and Portland Group pgcc 18.4-0. Unfortunately, I get the following error for all seven