Re: [OMPI users] Fwd: MCA version error

2017-10-13 Thread abhisek Mondal
Hi, I'm bit confused now. When I supply ompi_info, it gives: *[user@localhost openmpi-x86_64]$ ompi_info * *[localhost.localdomain:11068] Error: Unable to get the current working directory* * Package: Open MPI root@3fecdf07461e Distribution* *Open MPI: 2.1.1* *

Re: [OMPI users] Fwd: MCA version error

2017-10-13 Thread Jeff Squyres (jsquyres)
>From the output you supplied, it looks like you are running Open MPI v2.1.x. Did you install Open MPI v2.1.x from source, and install it into the same directory that you had previously installed Open MPI v2.0.x? If so, the warnings you are seeing (not errors) are likely the fact that there

Re: [OMPI users] Fwd: MCA version error

2017-10-13 Thread Gilles Gouaillardet
one more thing, can you run rpm -qf /usr/lib64/openmpi/lib/openmpi/mca_shmem_mmap.so and make sure this comes from the openmpi rpm ? if not, you can remove the openmpi rpm, rm -rf /usr/lib64/openmpi/lib/openmpi and then re-install the rpm Cheers, Gilles On Fri, Oct 13, 2017 at 10:49 PM, Gilles

Re: [OMPI users] Fwd: MCA version error

2017-10-13 Thread John Hearns via users
Abhisek ... Gilles asked which program you re trying to run, and how it was linked with OpenMPI Also please realise that you do not HAVE to use the openmpi packages provided by your linux distribution. It is perfectly OK to download, compile and install another version. On 13 October 2017 at

Re: [OMPI users] Fwd: MCA version error

2017-10-13 Thread Gilles Gouaillardet
can you run ldd on your binary ? i suspect it might not use the right Open MPI library Cheers, Gilles On Fri, Oct 13, 2017 at 10:41 PM, abhisek Mondal wrote: > Hello, > > I'm getting this following error: > [localhost.localdomain:00307]

Re: [OMPI users] Fwd: MCA version error

2017-10-13 Thread abhisek Mondal
Hello, I'm getting this following error: * [localhost.localdomain:00307] mca_base_component_repository_open: shmem "/usr/lib64/openmpi/lib/openmpi/mca_shmem_mmap" uses an MCA interface that is not recognized (component MCA v2.0.0 != supported MCA v2.1.0) -- ignored* *

Re: [OMPI users] Fwd: MCA version error

2017-10-13 Thread Gilles Gouaillardet
Hi, let's take one or two steps back. which version of Open MPI did you use in order to build your program ? what does "not working under MCA2.1" mean ? link error ? unresolved symbols ? runtime crash ? please detail your environment and post all relevant error messages Cheers, Gilles On

[OMPI users] Fwd: MCA version error

2017-10-13 Thread abhisek Mondal
Hi, I have installed an openmpi using following command: *yum install openmpi-1.10.0-10.el7* When I put *ompi_info* command it shows me that it is using MCAv.2.1. Is there any way I can use MCA2.0 ? My program is not working under MCA2.1. Please help me out here. Thank you. -- Abhisek