Re: [OMPI users] Trying to use openmpi with MOM getting a compile error

2014-07-25 Thread Gus Correa
On 07/25/2014 03:02 PM, Jeff Squyres (jsquyres) wrote: On Jul 25, 2014, at 1:14 PM, Gus Correa wrote: Change the mkmf.template file and replace the Fortran compiler name (gfortran) by the Open MPI (OMPI) Fortran compiler wrapper: mpifortran (or mpif90 if it still

Re: [OMPI users] Trying to use openmpi with MOM getting a compile error

2014-07-25 Thread Dan Shell
Gus Thank you I give that a try. Dan Shell -Original Message- From: users [mailto:users-boun...@open-mpi.org] On Behalf Of Gus Correa Sent: Friday, July 25, 2014 1:15 PM To: Open MPI Users Subject: Re: [OMPI users] Trying to use openmpi with MOM getting a compile error Hi Dan This is

Re: [OMPI users] Trying to use openmpi with MOM getting a compile error

2014-07-25 Thread Gus Correa
Hi Dan This is not an Open MPI problem. This is most likely a problem with the MOM Makefile, which seems to be missing your Open MPI include directory. Change the mkmf.template file and replace the Fortran compiler name (gfortran) by the Open MPI (OMPI) Fortran compiler wrapper: mpifortran (or

[OMPI users] Trying to use openmpi with MOM getting a compile error

2014-07-25 Thread Dan Shell
OpenMOM-mpi I am trying to compile MOM and have installed openmpi 1.8.1 getting an installation error below Looking for some help in openmpi to make sure the mpif.h is loaded correctly Should I use an older version of openmpi? Thank You Dan Shell gfortran -Duse_netCDF -Duse_netCDF3 -Duse_libMPI