Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-05 Thread Dan Shell
) Sent: Tuesday, August 05, 2014 3:18 PM To: Open MPI User's List Subject: Re: [OMPI users] openmpi 1.8.1 gfortran not working On Aug 5, 2014, at 1:13 PM, Dan Shell <dshellwirel...@gmail.com> wrote: > Need to use mpif.h for my application > I will get the newest versions of gcc and g

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-05 Thread Jeff Squyres (jsquyres)
On Aug 5, 2014, at 1:13 PM, Dan Shell wrote: > Need to use mpif.h for my application > I will get the newest versions of gcc and gfortran You should be fine without the newest versions of gcc/gfortran. The older gcc/gfortran will support mpif.h and a limited form of

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-05 Thread Dan Shell
: [OMPI users] openmpi 1.8.1 gfortran not working On Aug 5, 2014, at 10:57 AM, Dan Shell <dshellwirel...@gmail.com> wrote: > Should I look for a newer version of gfortran? > I saw from the config fortran compile section that mpi_f08 was not > compiled It depends on what your MPI ap

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-05 Thread Jeff Squyres (jsquyres)
On Aug 5, 2014, at 10:57 AM, Dan Shell wrote: > Should I look for a newer version of gfortran? > I saw from the config fortran compile section that mpi_f08 was not compiled It depends on what your MPI application needs. MPI (i.e., the spec, not Open MPI) defines

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-05 Thread Dan Shell
, August 05, 2014 10:36 AM To: Open MPI User's List Subject: Re: [OMPI users] openmpi 1.8.1 gfortran not working Dan -- The version of gfortran that you have does not support the mpi_f08 bindings. Note that: - newer versions of gfortran will support the mpi_f08 bindings - all versions of gfortran

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-05 Thread Jeff Squyres (jsquyres)
users-boun...@open-mpi.org] On Behalf Of Gus Correa > Sent: Monday, August 04, 2014 4:39 PM > To: Open MPI Users > Subject: Re: [OMPI users] openmpi 1.8.1 gfortran not working > >>> I have the following env variables set export OMPI_CC=gcc echo >> > $OMPI_CC exp

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-05 Thread Dan Shell
Gus Ok I will give that a try Thank you for the help Dan Shell -Original Message- From: users [mailto:users-boun...@open-mpi.org] On Behalf Of Gus Correa Sent: Monday, August 04, 2014 4:39 PM To: Open MPI Users Subject: Re: [OMPI users] openmpi 1.8.1 gfortran not working >>

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-04 Thread Gus Correa
nday, August 04, 2014 3:11 PM To: Open MPI Users Subject: Re: [OMPI users] openmpi 1.8.1 gfortran not working I know there were some lingering issues in 1.8.1 - you might want to try the latest nightly 1.8 tarball as I believe things have been fixed now. On Aug 4, 2014, at 11:09 AM, Dan

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-04 Thread Dan Shell
Ralph Ok I will give that a try Thanks Dan Shell -Original Message- From: users [mailto:users-boun...@open-mpi.org] On Behalf Of Ralph Castain Sent: Monday, August 04, 2014 3:11 PM To: Open MPI Users Subject: Re: [OMPI users] openmpi 1.8.1 gfortran not working I know there were some

Re: [OMPI users] openmpi 1.8.1 gfortran not working

2014-08-04 Thread Ralph Castain
I know there were some lingering issues in 1.8.1 - you might want to try the latest nightly 1.8 tarball as I believe things have been fixed now. On Aug 4, 2014, at 11:09 AM, Dan Shell wrote: > openmpi > > I have the following env variables set > export OMPI_CC=gcc

[OMPI users] openmpi 1.8.1 gfortran not working

2014-08-04 Thread Dan Shell
openmpi I have the following env variables set export OMPI_CC=gcc echo $OMPI_CC export OMPI_CXX=g++ echo $OMPI_CXX export OMPI_F77=gfortran echo $OMPI_F77 export OMPI_FC=gfortran echo $OMPI_FC I run the configure script See fortran section below Looks like mpifort should be configure >From what