Re: [ovirt-users] Hiding events

2016-03-13 Thread Ravi Nori


Currently there is no way to hide an event type from showing up in the 
events list.


The UI only provides a way to hide a specific event after it occurs, 
future occurrences can not be hidden.


Thanks

Ravi

On 03/10/2016 02:32 PM, nico...@devels.es wrote:

Hi,

Is there currently a way to hide specific events from the event list? 
I mean not showing them up when they occur.


Thanks.
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] VM get stuck randomly

2016-03-13 Thread Yaniv Kaul
On Sun, Mar 13, 2016 at 1:14 PM, Christophe TREFOIS <
christophe.tref...@uni.lu> wrote:

> Hi Yaniv,
>
>
>
> See my answers / questions below under [CT].
>
>
>
> *From:* Yaniv Kaul [mailto:yk...@redhat.com]
> *Sent:* dimanche 13 mars 2016 12:08
> *To:* Christophe TREFOIS 
> *Cc:* users 
> *Subject:* Re: [ovirt-users] VM get stuck randomly
>
>
>
>
>
>
>
> On Sun, Mar 13, 2016 at 9:46 AM, Christophe TREFOIS <
> christophe.tref...@uni.lu> wrote:
>
> Dear all,
>
> I have a problem since couple of weeks, where randomly 1 VM (not always
> the same) becomes completely unresponsive.
> We find this out because our Icinga server complains that host is down.
>
> Upon inspection, we find we can’t open a console to the VM, nor can we
> login.
>
>
>
> I assume 3.6's console feature, or is it Spice/VNC?
>
> *[CT] *
>
>
>
> This is 3.5, VNC/Spice yes. Sometimes we can connect, but there’s no way
> to do anything, eg type or so on.
>
>
>
>
> In oVirt engine, the VM looks like “up”. The only weird thing is that RAM
> usage shows 0% and CPU usage shows 100% or 75% depending on number of cores.
>
>
>
> Any chance there's really something bad going on within the VM? Anything
> in its journal or /var/log/messages or ... depending on the OS?
>
> Y.
>
> *[CT] *
>
> *It is possible. It seems to be mostly VMs with Ubuntu 14.04 and latest
> kernels. I read somewhere, I couldn’t find now, that there’s perhaps a bug
> in 3.x kernel with regards to libvirt / vdsm. But my knowledge is too
> limited to even know where to begin the investigation **J*
>
>
>
> *On the VM logs, we just see normal VM stuff, then nothing, and then when
> the VM was rebooted, there’s a couple of lines of ^@^@^@ characters
> repeating. But nothing else really.*
>
> *Initially we thought it’s a bug with aufs on Docker, but the machines
> getting stuck now don’t run either.*
>
>
>
> *From your answer, I deduce that if vdsm or libvirt or spm would see a
> problem with storage / memory / cpu, it would suspend the VM and provide
> that info to ovirt-engine? *
>
> *Since this is not happening, you think it could be related to the inside
> of the VM rather than the oVirt environment, correct?*
>

Either that, or to libvirt/QEMU.
I suggest, if possible, to upgrade the components first to newer versions
(as Nir suggested).
Y.


>
> *Thank you for your help (especially on a Sunday) **J*
>
>
>
>
>
> The only way to recover is to force shutdown the VM via 2-times shutdown
> from the engine.
>
> Could you please help me to start debugging this?
> I can provide any logs, but I’m not sure which ones, because I couldn’t
> see anything with ERROR in the vdsm logs on the host.
>
> The host is running
>
> OS Version: RHEL - 7 - 1.1503.el7.centos.2.8
> Kernel Version: 3.10.0 - 229.14.1.el7.x86_64
> KVM Version:2.1.2 - 23.el7_1.8.1
> LIBVIRT Version:libvirt-1.2.8-16.el7_1.4
> VDSM Version:   vdsm-4.16.26-0.el7.centos
> SPICE Version:  0.12.4 - 9.el7_1.3
> GlusterFS Version:  glusterfs-3.7.5-1.el7
>
> We use a locally exported gluster as storage domain (eg, storage is on the
> same machine exposed via gluster). No replica.
> We run around 50 VMs on that host.
>
> Thank you for your help in this,
>
> —
> Christophe
>
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Know the console client IP from guest

2016-03-13 Thread Gianluca Cecchi
Il 13/Mar/2016 15:29, "Yaniv Dary"  ha scritto:
>
> The IP of the VM should be reported to the management via the guest
agent. Is this what you are looking for?
>

>
> On Wed, Mar 2, 2016 at 6:18 AM, Simon Lévesuqe  wrote:

[Snip]

>> The problem is that many other clients boot to the oVirt user portal and
users log to Windows 7 vm using Virt-Viewer and Spice. In bginfo, the only
thing i can get is the IP of the Windows guest. It's ok, for most cases we
can take control of the guest ant it do the trick but sometimes it's useful
to vnc the thin itself.

No, he needs the ip from which the spice client session (using virt-viewer
program) has been launched
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Know the console client IP from guest

2016-03-13 Thread Yaniv Dary
The IP of the VM should be reported to the management via the guest agent.
Is this what you are looking for?

Yaniv Dary
Technical Product Manager
Red Hat Israel Ltd.
34 Jerusalem Road
Building A, 4th floor
Ra'anana, Israel 4350109

Tel : +972 (9) 7692306
8272306
Email: yd...@redhat.com
IRC : ydary


On Wed, Mar 2, 2016 at 6:18 AM, Simon Lévesuqe  wrote:

> From a windows guest (can be useful for linux guest as well), is it
> possible to get the IP of the spice client connected to console?
>
> I setup oVirt for a VDI. The users use thin clients that PXE boot using
> LTSP. I need the client IP to offer remote support via VNC. Now, I use
> epoptes as remote support tool, its an excellent peace of software but I
> need technicians from other branch of the company to be able to offer
> remote support to my users and they are all Windows guy ans don't want to
> connect to the LTSP server to start epoptes... They already use VNC to
> support Wyse type clients so I installed x11vnc on my clients chroot and
> setup it to start at boot. I know this is a security issue but this is the
> boss decision.
>
> Some client log to terminal servers using xfreerdp (LTSP clients boot
> directly to xfreerdp). In that case, everything is ok, we setup bginfo to
> print the client name and ip as they are windows environment variables.
>
> The problem is that many other clients boot to the oVirt user portal and
> users log to Windows 7 vm using Virt-Viewer and Spice. In bginfo, the only
> thing i can get is the IP of the Windows guest. It's ok, for most cases we
> can take control of the guest ant it do the trick but sometimes it's useful
> to vnc the thin itself.
>
> Thanks!
>
> Simon L
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] spacewalk integration

2016-03-13 Thread Yaniv Dary
It is not possible to use spacewalk with oVirt. Patches to add this to
oVirt are welcomed.

Yaniv Dary
Technical Product Manager
Red Hat Israel Ltd.
34 Jerusalem Road
Building A, 4th floor
Ra'anana, Israel 4350109

Tel : +972 (9) 7692306
8272306
Email: yd...@redhat.com
IRC : ydary


On Sat, Feb 20, 2016 at 11:00 PM, Charles Kozler 
wrote:

> Hi Guys -
>
> Can you use spacewalk as an external provider in oVirt? I see it allows
> Satelilte/Foreman but I know the new Satellite product is much different
> than Spacewalk as I believe Spacewalk is still technically Satellite 5
> whereas Satellite 6 is an entire rewrite
>
> If Spacewalk can be used, what are some pre-reqs needed to get it working?
> Also, what are the benefits of using this? I was looking at it for the
> eratta information
>
> Thanks!
>
> --
>
> *Charles Kozler*
> *Vice President, IT Operations*
>
> FIX Flyer, LLC
> 225 Broadway | Suite 1600 | New York, NY 10007
> 1-888-349-3593
> http://www.fixflyer.com 
>
> NOTICE TO RECIPIENT: THIS E-MAIL IS MEANT ONLY FOR THE INTENDED
> RECIPIENT(S) OF THE TRANSMISSION, AND CONTAINS CONFIDENTIAL INFORMATION
> WHICH IS PROPRIETARY TO FIX FLYER LLC.  ANY UNAUTHORIZED USE, COPYING,
> DISTRIBUTION, OR DISSEMINATION IS STRICTLY PROHIBITED.  ALL RIGHTS TO THIS
> INFORMATION IS RESERVED BY FIX FLYER LLC.  IF YOU ARE NOT THE INTENDED
> RECIPIENT, PLEASE CONTACT THE SENDER BY REPLY E-MAIL AND PLEASE DELETE THIS
> E-MAIL FROM YOUR SYSTEM AND DESTROY ANY COPIES.
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] el6 and el7 clusters and SPM

2016-03-13 Thread Yaniv Dary
Should work the same on el6 and el7.

Yaniv Dary
Technical Product Manager
Red Hat Israel Ltd.
34 Jerusalem Road
Building A, 4th floor
Ra'anana, Israel 4350109

Tel : +972 (9) 7692306
8272306
Email: yd...@redhat.com
IRC : ydary


On Thu, Feb 18, 2016 at 10:05 PM, Sigbjorn Lie  wrote:

> Hi
>
> I am looking to migrate several el6 rhev-h nodes to el7 rhev-h nodes.
> There are multiple clusters
> in the datacenter and it will take a while (several months) to have all
> the clusters in the data
> center migrated to el7.
>
> Is there be any potential issues to look out for with regards to having
> the SPM for this
> datacenter running on a el6 or a el7 node in this datacenter? Any cross
> compatability issues to
> look out for?
>
> RHEV-M is currently at version 3.5.6. We are using FC storage.
>
>
>
> Regards,
> Siggi
>
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] vlan range?

2016-03-13 Thread Dan Kenigsberg
On Thu, Mar 10, 2016 at 03:44:50PM +0100, gflwqs gflwqs wrote:
> Hi list!
> How do i expose a vlan range to a vm in ovirt?

You should attach your VM to a network with no vlan tag.

Most commonly, you should also enable mac spoofing on that vnic, as
reported on
http://lists.ovirt.org/pipermail/users/2016-March/038403.html

This latter step is going to become much simpler when
https://www.ovirt.org/feature/networkfilter/ is included in oVirt's next
release.
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] VM get stuck randomly

2016-03-13 Thread Christophe TREFOIS
Hi Yaniv,

See my answers / questions below under [CT].

From: Yaniv Kaul [mailto:yk...@redhat.com]
Sent: dimanche 13 mars 2016 12:08
To: Christophe TREFOIS 
Cc: users 
Subject: Re: [ovirt-users] VM get stuck randomly



On Sun, Mar 13, 2016 at 9:46 AM, Christophe TREFOIS 
> wrote:
Dear all,

I have a problem since couple of weeks, where randomly 1 VM (not always the 
same) becomes completely unresponsive.
We find this out because our Icinga server complains that host is down.

Upon inspection, we find we can’t open a console to the VM, nor can we login.

I assume 3.6's console feature, or is it Spice/VNC?
[CT]

This is 3.5, VNC/Spice yes. Sometimes we can connect, but there’s no way to do 
anything, eg type or so on.


In oVirt engine, the VM looks like “up”. The only weird thing is that RAM usage 
shows 0% and CPU usage shows 100% or 75% depending on number of cores.

Any chance there's really something bad going on within the VM? Anything in its 
journal or /var/log/messages or ... depending on the OS?
Y.
[CT]
It is possible. It seems to be mostly VMs with Ubuntu 14.04 and latest kernels. 
I read somewhere, I couldn’t find now, that there’s perhaps a bug in 3.x kernel 
with regards to libvirt / vdsm. But my knowledge is too limited to even know 
where to begin the investigation ☺

On the VM logs, we just see normal VM stuff, then nothing, and then when the VM 
was rebooted, there’s a couple of lines of ^@^@^@ characters repeating. But 
nothing else really.
Initially we thought it’s a bug with aufs on Docker, but the machines getting 
stuck now don’t run either.

From your answer, I deduce that if vdsm or libvirt or spm would see a problem 
with storage / memory / cpu, it would suspend the VM and provide that info to 
ovirt-engine?
Since this is not happening, you think it could be related to the inside of the 
VM rather than the oVirt environment, correct?

Thank you for your help (especially on a Sunday) ☺


The only way to recover is to force shutdown the VM via 2-times shutdown from 
the engine.

Could you please help me to start debugging this?
I can provide any logs, but I’m not sure which ones, because I couldn’t see 
anything with ERROR in the vdsm logs on the host.

The host is running

OS Version: RHEL - 7 - 1.1503.el7.centos.2.8
Kernel Version: 3.10.0 - 229.14.1.el7.x86_64
KVM Version:2.1.2 - 23.el7_1.8.1
LIBVIRT Version:libvirt-1.2.8-16.el7_1.4
VDSM Version:   vdsm-4.16.26-0.el7.centos
SPICE Version:  0.12.4 - 9.el7_1.3
GlusterFS Version:  glusterfs-3.7.5-1.el7

We use a locally exported gluster as storage domain (eg, storage is on the same 
machine exposed via gluster). No replica.
We run around 50 VMs on that host.

Thank you for your help in this,

—
Christophe


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] VM get stuck randomly

2016-03-13 Thread Nir Soffer
On Sun, Mar 13, 2016 at 9:46 AM, Christophe TREFOIS
 wrote:
> Dear all,
>
> I have a problem since couple of weeks, where randomly 1 VM (not always the 
> same) becomes completely unresponsive.
> We find this out because our Icinga server complains that host is down.
>
> Upon inspection, we find we can’t open a console to the VM, nor can we login.
>
> In oVirt engine, the VM looks like “up”. The only weird thing is that RAM 
> usage shows 0% and CPU usage shows 100% or 75% depending on number of cores.
> The only way to recover is to force shutdown the VM via 2-times shutdown from 
> the engine.
>
> Could you please help me to start debugging this?
> I can provide any logs, but I’m not sure which ones, because I couldn’t see 
> anything with ERROR in the vdsm logs on the host.

I would inspect this vm on the host when it happens.

What is vdsm cpu usage? what is the qemu process (for this vm) cpu usage?

strace output of this qemu process (all threads) or a core dump can help qemu
developers to understand this issue.

>
> The host is running
>
> OS Version: RHEL - 7 - 1.1503.el7.centos.2.8
> Kernel Version: 3.10.0 - 229.14.1.el7.x86_64
> KVM Version:2.1.2 - 23.el7_1.8.1
> LIBVIRT Version:libvirt-1.2.8-16.el7_1.4
> VDSM Version:   vdsm-4.16.26-0.el7.centos
> SPICE Version:  0.12.4 - 9.el7_1.3
> GlusterFS Version:  glusterfs-3.7.5-1.el7

You are running old versions, missing lot of fixes. Nothing specific
to your problem
but this lower the chance to get a working system.

It would be nice if you can upgrade to ovirt-3.6 and report if it made
any change.
Or at lest latest ovirt-3.5.

> We use a locally exported gluster as storage domain (eg, storage is on the 
> same machine exposed via gluster). No replica.
> We run around 50 VMs on that host.

Why use gluster for this? Do you plan to add more gluster servers in the future?

Nir
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] VM get stuck randomly

2016-03-13 Thread Yaniv Kaul
On Sun, Mar 13, 2016 at 9:46 AM, Christophe TREFOIS <
christophe.tref...@uni.lu> wrote:

> Dear all,
>
> I have a problem since couple of weeks, where randomly 1 VM (not always
> the same) becomes completely unresponsive.
> We find this out because our Icinga server complains that host is down.
>
> Upon inspection, we find we can’t open a console to the VM, nor can we
> login.
>

I assume 3.6's console feature, or is it Spice/VNC?


>
> In oVirt engine, the VM looks like “up”. The only weird thing is that RAM
> usage shows 0% and CPU usage shows 100% or 75% depending on number of cores.
>

Any chance there's really something bad going on within the VM? Anything in
its journal or /var/log/messages or ... depending on the OS?
Y.



> The only way to recover is to force shutdown the VM via 2-times shutdown
> from the engine.
>
> Could you please help me to start debugging this?
> I can provide any logs, but I’m not sure which ones, because I couldn’t
> see anything with ERROR in the vdsm logs on the host.
>
> The host is running
>
> OS Version: RHEL - 7 - 1.1503.el7.centos.2.8
> Kernel Version: 3.10.0 - 229.14.1.el7.x86_64
> KVM Version:2.1.2 - 23.el7_1.8.1
> LIBVIRT Version:libvirt-1.2.8-16.el7_1.4
> VDSM Version:   vdsm-4.16.26-0.el7.centos
> SPICE Version:  0.12.4 - 9.el7_1.3
> GlusterFS Version:  glusterfs-3.7.5-1.el7
>
> We use a locally exported gluster as storage domain (eg, storage is on the
> same machine exposed via gluster). No replica.
> We run around 50 VMs on that host.
>
> Thank you for your help in this,
>
> —
> Christophe
>
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] QEMU GlusterFS support in oVirt

2016-03-13 Thread Nir Soffer
On Sat, Mar 12, 2016 at 11:17 PM, Samuli Heinonen  wrote:
>
>> On 12 Mar 2016, at 17:04, Nir Soffer  wrote:
>>
>> On Sat, Mar 12, 2016 at 1:55 PM, Samuli Heinonen  
>> wrote:
>>> Hello all,
>>>
>>> It seems that oVirt 3.6 is still using FUSE to access GlusterFS storage 
>>> domains instead of using QEMU driver (libgfapi). As far as I know libgfapi 
>>> support should be available in Libvirt and QEMU packages provided in CentOS 
>>> 7.
>>
>> We started to work this during 3.6 development, but the work was
>> suspended because
>> libvirt and qemu do not support multiple gluster servers [1]. This
>> means that if your single
>> server is down, you will not be able to connect to glister.
>
> Since this is only used to fetch volume information when connecting to 
> Gluster volume I don’t think it should be treated as blocking issue. If we 
> lose one storage server that’s a problem we have to fix as soon as possible 
> anyway. Even then hypervisors are already connected to other storage servers 
> and there is no need to fetch volume information again. Also there are other 
> ways to work around this like having a separate hostname that is used to 
> fetch volume information and which can then be pointed to server that’s up.

Multiple servers are used to connect to gluster. If you are using only
one server address
and this server is not reachable, your connection will fail, and you
will not able to start
a vm.

The solution is either manage server addresses in engine (like iscsi
targets), and pass this
to vdsm, or use special DNS name that point to all servers.

The first option is not possible yet since libvirt can accept only one
host in the disk
description.

>
> It would be great if libgfapi could be available even as selectable option so 
> it could be tested in real world situation.
>
>> Recently Niels suggested that we use DNS for this purpose - if the DNS
>> return multiple
>> servers, libgafpi should be able to failover to one of these servers,
>> so connecting with
>> single server address should good as multiple server support in libvirt or 
>> qemu.
>>
>> The changes needed to support this are not big as you can see in [2],
>> [3]. However the work
>> was not completed and I don't know if it will completed for 4.0.
>
> Thank you for these links. I’ll see if this is something we can try out in 
> our test environment

The patches not complete, so I don't think they will be useful in the
current state.
They can be used as a starting point for someone who want to complete this work.

Nir
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] MAC spoofing for specific VMs

2016-03-13 Thread Dan Kenigsberg
On Thu, Mar 10, 2016 at 04:57:01PM -0500, Christopher Young wrote:
> Does anyone see a reason why simply installing the EL7 latest rpm for
> this on an ovirt node/RHEV-H system would not work or would be a bad
> solution to getting this working with ovirt-node/RHEV-H?  I don't want
> to do something that is either lost on reboot or would cause issues in
> the future.
> 
> Thoughts?

I do not see a problem in that, but please note that we plan a
fully-fledged integration of this feature in our next release.
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users