Re: [ovirt-users] IP Address Stealing

2016-08-03 Thread Subhendu Ghosh
Not built into ovirt AFAIK,  but an ebtables rule can allow you to filter out mac+ip combinations  Look at the anti-spoofing rules on ebtables.netfilter.org It doesn't prevent the user adding it in the vm, but the infrastructure blocks it's usage. From: Bill

[ovirt-users] IP Address Stealing

2016-08-03 Thread Bill Bill
Hello, It is possible to prevent a VM from adding an IP? For example, if we provision a VM with one IP, if the user has root access they can simply add random IP’s from within the same range as sub interfaces: eth0:0 eth0:1 eth0:2 so on and so forth. Subnetting is not ideal in this situation

Re: [ovirt-users] ovirt4.0.1 and new node, migration fails

2016-08-03 Thread Bill James
opened bug 1363900. It also includes recent logs from all 3 servers. Also tried updating vdsm to 4.18.10-1 and restarted ovirt-engine. No change in results. I can migrate VMs to new node but not initially assign VMs to that node. On 07/29/2016 09:31 AM, Bill James wrote: ok, I will raise a

Re: [ovirt-users] Unable to login to the WEB UI

2016-08-03 Thread Martin Perina
On Wed, Aug 3, 2016 at 5:25 PM, Fabrice Bacchella < fabrice.bacche...@icloud.com> wrote: > Next step : > > The UI says, even with a restarted navigator: > > org.codehaus.jackson.JsonParseException: Unexpected character ('<' (code > 60)): expected a valid value (number, String, array, object,

[ovirt-users] Migrate machines in unknown state?

2016-08-03 Thread Nicolás
Hi, We're running oVirt 4.0.1 and today I found out that one of our hosts has all its VMs in an unknown state. I actually don't know how (and when) did this happen, but I'd like to restore service possibly without turning off these machines. The host is up, the VMs are up, 'qemu' process

Re: [ovirt-users] Unable to login to the WEB UI

2016-08-03 Thread Fabrice Bacchella
Next step : The UI says, even with a restarted navigator: org.codehaus.jackson.JsonParseException: Unexpected character ('<' (code 60)): expected a valid value (number, String, array, object, 'true', 'false' or 'null') at [Source: java.io.StringReader@74749f78; line: 3, column: 2]

Re: [ovirt-users] Unable to login to the WEB UI

2016-08-03 Thread Martin Perina
Hi, please follow steps as described in BZ: 1. Create /etc/ovirt-engine/engine.conf.d/99-custom-truststore.conf (you may choose different filename but it has to end with '.conf' suffix) with following content: ENGINE_HTTPS_PKI_TRUST_STORE="" ENGINE_HTTPS_PKI_TRUST_STORE_PASSWORD="" 2.

Re: [ovirt-users] Unable to login to the WEB UI

2016-08-03 Thread Fabrice Bacchella
Indeed, the certificate for the web interface is not coming from ovirt's internal PKI, but from our own internal one. I have a custom trust store not located in /etc/pki/java/cacerts, I did try to add ENGINE_PROPERTIES="${ENGINE_PROPERTIES} javax.net.ssl.trustStore=.../allmyca.jks

Re: [ovirt-users] Upgrade from 3.6 to 4.0

2016-08-03 Thread nicola.gentile.to
Il 03/08/2016 14:04, Yedidyah Bar David ha scritto: On Wed, Aug 3, 2016 at 2:51 PM, nicola.gentile.to > wrote: Il 03/08/2016 13:42, Yedidyah Bar David ha scritto: On Wed, Aug 3, 2016 at 2:30

Re: [ovirt-users] Upgrade from 3.6 to 4.0

2016-08-03 Thread Yedidyah Bar David
On Wed, Aug 3, 2016 at 2:51 PM, nicola.gentile.to < nicola.gentile...@gmail.com> wrote: > Il 03/08/2016 13:42, Yedidyah Bar David ha scritto: > > On Wed, Aug 3, 2016 at 2:30 PM, > nicola.gentile.to > wrote: > > Il 05/07/2016 10:30,

[ovirt-users] [ANN] oVirt 4.0.2 Third Release Candidate is now available

2016-08-03 Thread Sandro Bonazzola
The oVirt Project is pleased to announce the availability of the Third Release Candidate of oVirt 4.0.2 for testing, as of August 3rd, 2016. This release is available now for: * Fedora 23 (tech preview) * Red Hat Enterprise Linux 7.2 or later * CentOS Linux (or similar) 7.2 or later This release

Re: [ovirt-users] Upgrade from 3.6 to 4.0

2016-08-03 Thread nicola.gentile.to
Il 03/08/2016 13:42, Yedidyah Bar David ha scritto: On Wed, Aug 3, 2016 at 2:30 PM, nicola.gentile.to wrote: Il 05/07/2016 10:30, Gianluca Cecchi ha scritto: Two final steps I've done that are only necessary in my environment, where the host itslef is providing

Re: [ovirt-users] Upgrade from 3.6 to 4.0

2016-08-03 Thread Yedidyah Bar David
On Wed, Aug 3, 2016 at 2:30 PM, nicola.gentile.to wrote: > Il 05/07/2016 10:30, Gianluca Cecchi ha scritto: > > Two final steps I've done that are only necessary in my environment, where > the host itslef is providing the NFS service for storage domains: > > After

Re: [ovirt-users] Upgrade from 3.6 to 4.0

2016-08-03 Thread nicola.gentile.to
Il 05/07/2016 10:30, Gianluca Cecchi ha scritto: Two final steps I've done that are only necessary in my environment, where the host itslef is providing the NFS service for storage domains: After install you have to make a dependency so that VDSM Broker starts after NFS Server In

Re: [ovirt-users] Unable to login to the WEB UI

2016-08-03 Thread Martin Perina
Hi, are you using HTTPS certificate signed by external CA? If so please follow steps described in Doc Text of https://bugzilla.redhat.com/show_bug.cgi?id=1336838 Thanks Martin Perina On Wed, Aug 3, 2016 at 1:18 PM, Fabrice Bacchella < fabrice.bacche...@icloud.com> wrote: > After the upgrad,

[ovirt-users] Unable to login to the WEB UI

2016-08-03 Thread Fabrice Bacchella
After the upgrad, I'm unable to log in, I'm getting the following error: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target Where should I look to

[ovirt-users] Unusable log in engine.log

2016-08-03 Thread Fabrice Bacchella
In the engine.log, there are many line like that : grep '2016-08-03 13:00:46,371 INFO .org.ovirt.engine.core.vdsbroker.HostDevListByCapsVDSCommand. .org.ovirt.thread.pool-8-thread-16. .28054a0c. ' /var/log/ovirt-engine/engine.log | wc 18574 179635 1 line 8574 words 179635

Re: [ovirt-users] Upgrade to 4.0.1 failed with NPE on org.postgresql.jdbc.TypeInfoCache.getSQLType

2016-08-03 Thread Martin Perina
Hi, we support only postgresql packages included in centos: postgresql-9.2.15-1.el7_2.x86_64 postgresql-libs-9.2.15-1.el7_2.x86_64 postgresql-jdbc-9.2.1002-5.el7.noarch postgresql-server-9.2.15-1.el7_2.x86_64 This is the postgresql version which we test. In your special case downgrading

Re: [ovirt-users] Upgrade to 4.0.1 failed with NPE on org.postgresql.jdbc.TypeInfoCache.getSQLType

2016-08-03 Thread Fabrice Bacchella
Just a little investigation show : # lsof -p | grep postgresql-jdbc.jar java2138 ovirt mem REG8,2486139 18729421 /usr/share/java/postgresql-jdbc.jar rpm -qf /usr/share/java/postgresql-jdbc.jar postgresql-jdbc-9.4.1208-1.rhel7.noarch rpm -qi

Re: [ovirt-users] Upgrade to 4.0.1 failed with NPE on org.postgresql.jdbc.TypeInfoCache.getSQLType

2016-08-03 Thread Martin Perina
Hi, what is the version of postgresql-jdbc package are you using? I saw this error only with latest postgresql-jdbc drivers 9.4-1209, but those are not packaged in RPMs AFAIK. Thanks Martin Perina On Wed, Aug 3, 2016 at 12:31 PM, Fabrice Bacchella < fabrice.bacche...@icloud.com> wrote: > I'm

[ovirt-users] Upgrade to 4.0.1 failed with NPE on org.postgresql.jdbc.TypeInfoCache.getSQLType

2016-08-03 Thread Fabrice Bacchella
I'm running on Centos 7, just upgraded to ovirt 4.01 using the procedure given in the release notes. But now I'm getting that in /var/log/ovirt-engine/engine.log: 2016-08-03 12:04:39,751 ERROR [org.ovirt.engine.core.bll.Backend] (ServerService Thread Pool -- 54) [] Error during initialization:

[ovirt-users] upgrade to ovirt 4 failed

2016-08-03 Thread Fabrice Bacchella
I'm running on Centos 7, just upgraded to ovirt 4.01 using the procedure given in the release notes. But now I'm getting that in /var/log/ovirt-engine/engine.log: 2016-08-03 12:04:39,751 ERROR [org.ovirt.engine.core.bll.Backend] (ServerService Thread Pool -- 54) [] Error during initialization:

Re: [ovirt-users] storage domain operation python api sample codes needed

2016-08-03 Thread Ondra Machacek
On 08/02/2016 10:53 PM, Huan He (huhe) wrote: Hi, I can’t figure out how to do the following, a sample code will be helpful. Put a storage domain in maintenance mode Detach the storage domain Remove the storage domain Are you looking for v4 or v3 examples? Those are completelly different