[Users] How to approve the host to custom cluster instead the default cluster

2012-12-11 Thread Mohua Li
Hi all,

In admin portal, when try to approve a host, need to select the cluster first, 
but with rest api,

/*code*/

try:
   api = API(url=HOST,
 username=USER,
 password=PASS,
 ca_file=ca.crt)
   h = api.hosts.get(name=Atlantic)
   if(h.approve()):
print Host '%s' approved (Status: %s). % (h.get_name(),
 h.get_status().get_state())
   else:
print Approval of '%s' failed. % h.get_name()
   api.disconnect()
except Exception as ex:
   print Unexpected error: %s % ex

above code will register to the default cluster, could you give me an example 
how to register to the custom 
cluster instead the default?  or i misunderstand some workflow,  light me pls, 
thanks



Regards,
Mohua Li




signature.asc
Description: Digital signature
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] complete shutdown

2012-12-11 Thread Vered Volansky
Jonathan,

Shutdown should work.
Please send us your logs so we can understand what went wrong, hopefully fix 
it, and avoid this happening again.

Regards,
Vered



- Original Message -
 From: Jonathan Horne jho...@skopos.us
 To: users@ovirt.org
 Sent: Monday, December 10, 2012 10:31:57 PM
 Subject: [Users] complete shutdown
 
 
 
 
 
 Ugh… i just did a complete shutdown of my node and manager servers,
 now that they are back up i cannot bring the storage domain back
 online.
 
 
 A) i can't figure out what I'm doing wrong to bring it back online
 
 
 And B) should i just never shutdown the whole thing once i get it
 fixed? Or, is there a proper shutdown/restore method i should be
 following?



 
 
 Thanks,
 jonathan
 
 
 
 This is a PRIVATE message. If you are not the intended recipient,
 please delete without copying and kindly advise us by e-mail of the
 mistake in delivery. NOTE: Regardless of content, this e-mail shall
 not operate to bind SKOPOS to any order or other contract unless
 pursuant to explicit written agreement or government initiative
 expressly permitting the use of e-mail for such purpose.
 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] mislabelled template source

2012-12-11 Thread Eli Mesika


- Original Message -
 From: Jim Kinney jim.kin...@gmail.com
 To: users@ovirt.org
 Sent: Sunday, December 9, 2012 7:22:32 PM
 Subject: [Users] mislabelled template source
 
 
 Greetings,
 
 I've built several new templates from the blank template and a ISO
 install of various OS's. However, when I built a new VM using the
 new template(s), the new VM still says it's based from the blank
 template. I expected it to say it was from the template-foo U
 specified. The VM is correctly built from the template so I think
 it's a generation/database issue.

Hi Jim
Did you created the VM from the Web Admin UI or from the API ?

 
 --
 --
 James P. Kinney III
 
 Every time you stop a school, you will have to build a jail. What you
 gain at one end you lose at the other. It's like feeding a dog on
 his own tail. It won't fatten the dog.
 - Speech 11/23/1900 Mark Twain
 
 http://electjimkinney.org
 http://heretothereideas.blogspot.com/
 
 
 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] How to approve the host to custom cluster instead the default cluster

2012-12-11 Thread Eli Mesika


- Original Message -
 From: Mohua Li m...@redhat.com
 To: users@ovirt.org
 Sent: Tuesday, December 11, 2012 9:22:43 AM
 Subject: [Users] How to approve the host to custom cluster instead the
 default cluster
 
 Hi all,
 
 In admin portal, when try to approve a host, need to select the
 cluster first, but with rest api,
 
 /*code*/
 
 try:
api = API(url=HOST,
  username=USER,
  password=PASS,
  ca_file=ca.crt)
h = api.hosts.get(name=Atlantic)
if(h.approve()):
 print Host '%s' approved (Status: %s). % (h.get_name(),
  h.get_status().get_state())
else:
 print Approval of '%s' failed. % h.get_name()
api.disconnect()
 except Exception as ex:
print Unexpected error: %s % ex
 
 above code will register to the default cluster, could you give me an
 example how to register to the custom
 cluster instead the default?  or i misunderstand some workflow,
  light me pls, thanks

CC Michael P

 
 
 
 Regards,
 Mohua Li
 
 
 
 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Fwd: How to approve the host to custom cluster instead the default cluster

2012-12-11 Thread Michael Pasternak
Hi Mohua,

 
  Original Message 
 Subject: [Users] How to approve the host to custom cluster instead the 
 default cluster
 Date: Tue, 11 Dec 2012 15:22:43 +0800
 From: Mohua Li m...@redhat.com
 To: users@ovirt.org
 
 Hi all,
 
 In admin portal, when try to approve a host, need to select the cluster 
 first, but with rest api,
 
 /*code*/
 
 try:
api = API(url=HOST,
  username=USER,
  password=PASS,
  ca_file=ca.crt)
h = api.hosts.get(name=Atlantic)
if(h.approve()):
 print Host '%s' approved (Status: %s). % (h.get_name(),
  h.get_status().get_state())
else:
 print Approval of '%s' failed. % h.get_name()
api.disconnect()
 except Exception as ex:
print Unexpected error: %s % ex
 
 above code will register to the default cluster, could you give me an example 
 how to register to the custom
 cluster instead the default?  or i misunderstand some workflow,  light me 
 pls, thanks

If you'll look at host.approve().__doc__, you will see:

'''
@type Action:

[@param action.cluster.id|name: string]
[@param action.async: boolean]
[@param action.grace_period.expiry: long]
[@param correlation_id: any string]

@return Response:
'''

i.e you have to specify action.cluster.id|name in .approve() method.

 
 
 
 Regards,
 Mohua Li
 
 
 
 
 


-- 

Michael Pasternak
RedHat, ENG-Virtualization RD
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] How to approve the host to custom cluster instead the default cluster

2012-12-11 Thread Alex Jia
Hi Mohua,
The following link should be helpful for you(see add() of the class 
HostManager):

https://github.com/chuanchang/autotest/commit/1a59defaf1987d197d90b3e21bc518c78bfb4823

-- 
Regards, 
Alex


- Original Message -
From: Mohua Li m...@redhat.com
To: users@ovirt.org
Sent: Tuesday, December 11, 2012 3:22:43 PM
Subject: [Users] How to approve the host to custom cluster instead the  default 
cluster

Hi all,

In admin portal, when try to approve a host, need to select the cluster first, 
but with rest api,

/*code*/

try:
   api = API(url=HOST,
 username=USER,
 password=PASS,
 ca_file=ca.crt)
   h = api.hosts.get(name=Atlantic)
   if(h.approve()):
print Host '%s' approved (Status: %s). % (h.get_name(),
 h.get_status().get_state())
   else:
print Approval of '%s' failed. % h.get_name()
   api.disconnect()
except Exception as ex:
   print Unexpected error: %s % ex

above code will register to the default cluster, could you give me an example 
how to register to the custom 
cluster instead the default?  or i misunderstand some workflow,  light me pls, 
thanks



Regards,
Mohua Li



___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[Users] Managing Gluster from oVirt

2012-12-11 Thread Shireesh Anjal

Hi all,

Here is the link to the video of the talk I gave at FOSS.IN 2012 
Bangalore on the topic Managing Gluster from oVirt


http://youtu.be/NBu3wAXxq-Q

Regards,
Shireesh
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] .ova image file

2012-12-11 Thread Adrian Gibanel
So... No import from Virtualbox OVA? Or a Virtualbox OVA is technically an 
vmware one perhaps? 

Thank you. 

- Mensaje original -

 De: Matthew Booth mbo...@redhat.com

 We can only output to oVirt's OVF, and we can only import from
 VMware's
 OVA. The command line looks something like:

 Matt

-- 

Adrián Gibanel 
I.T. Manager 

+34 675 683 301 
www.btactic.com 

Ens podeu seguir a/Nos podeis seguir en: 

i 

Abans d´imprimir aquest missatge, pensa en el medi ambient. El medi ambient és 
cosa de tothom. / Antes de imprimir el mensaje piensa en el medio ambiente. El 
medio ambiente es cosa de todos. 

AVIS: 
El contingut d'aquest missatge i els seus annexos és confidencial. Si no en sou 
el destinatari, us fem saber que està prohibit utilitzar-lo, divulgar-lo i/o 
copiar-lo sense tenir l'autorització corresponent. Si heu rebut aquest missatge 
per error, us agrairem que ho feu saber immediatament al remitent i que 
procediu a destruir el missatge . 

AVISO: 
El contenido de este mensaje y de sus anexos es confidencial. Si no es el 
destinatario, les hacemos saber que está prohibido utilizarlo, divulgarlo y/o 
copiarlo sin tener la autorización correspondiente. Si han recibido este 
mensaje por error, les agradeceríamos que lo hagan saber inmediatamente al 
remitente y que procedan a destruir el mensaje . 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[Users] what happen to uploaded images at wiki?

2012-12-11 Thread Michael Pasternak
Looks like all images are gone/links are broken [1] and
page is added to Categories: * Pages with broken file links,
adding new files doesn't solve this issue.

Error creating thumbnail: convert: unable to open image 
`/var/lib/openshift/847edb45aea84198838f915be6faa066/app-root/runtime/repo/php/images/8/80/0jsdk.jpg':
 No such file
or directory @ blob.c/OpenBlob/2480.
convert: missing an image filename `/tmp/transform_12aa7b-1.jpg' @ 
convert.c/ConvertImageCommand/2800.

[1] http://www.ovirt.org/Java-sdk
-- 

Michael Pasternak
RedHat, ENG-Virtualization RD
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Managing Gluster from oVirt

2012-12-11 Thread Michael Pasternak

Very impressive Shireesh,

Note that now in addition to python sdk, you have java [1].

[1] http://www.ovirt.org/Java-sdk
(ovirt wiki has some issue with links to images, so it's look less pretty now)

On 12/11/2012 01:26 PM, Shireesh Anjal wrote:
 Hi all,
 
 Here is the link to the video of the talk I gave at FOSS.IN 2012 Bangalore on 
 the topic Managing Gluster from oVirt
 
 http://youtu.be/NBu3wAXxq-Q
 
 Regards,
 Shireesh
 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users


-- 

Michael Pasternak
RedHat, ENG-Virtualization RD
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] what happen to uploaded images at wiki?

2012-12-11 Thread Vinzenz Feenstra

On 12/11/2012 01:45 PM, Michael Pasternak wrote:

Looks like all images are gone/links are broken [1] and
page is added to Categories: * Pages with broken file links,
adding new files doesn't solve this issue.

Error creating thumbnail: convert: unable to open image 
`/var/lib/openshift/847edb45aea84198838f915be6faa066/app-root/runtime/repo/php/images/8/80/0jsdk.jpg':
 No such file
or directory @ blob.c/OpenBlob/2480.
convert: missing an image filename `/tmp/transform_12aa7b-1.jpg' @ 
convert.c/ConvertImageCommand/2800.

[1] http://www.ovirt.org/Java-sdk

There seems to have been an issue during the last down time

Quaid, is already aware of it. He needs to do some investigation.

--
Regards,

Vinzenz Feenstra | Senior Software Engineer
RedHat Engineering Virtualization R  D
Phone: +420 532 294 625
IRC: vfeenstr or evilissimo

Better technology. Faster innovation. Powered by community collaboration.
See how it works at redhat.com

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] iscsi mpio

2012-12-11 Thread Jonathan Horne
Sorry vered, i meant that i was using this:
ovirt-node-iso-2.5.5-0.1.fc17.iso

What i meant to say was, that i found that the root file system was read
only and was unable to even copy the equallogic driver there.  equallogic
driver needs python 2.6 and refuses to continue otherwise, so there is
many things preventing me from getting it working, far beyond the readonly
file system.

By highly customized, i didn't mean customized from my work, i meant that
that the node version is set up unlike any other linux i have ever seen.
the readonly file systems seem to be set that way on purpose to keep
people like me who know just enough to be dangerous from being... a danger.

JONATHAN HORNE  |  System Administrator  | Skopos Web
http://www.skopos.us
e:  jho...@skopos.us  t:  214.520.4600  f:  214.520.5079





On 12/11/12 12:32 AM, Vered Volansky ve...@redhat.com wrote:


You previously mentioned you're using package 2.5.5-0.fc17.
It looks like you have a typo, so please resend the exact package of
ovirt-node you're using.
Also - Where did you get the package from?
We'd like to try and reproduce here.

Did you make any changes to mount so that /var is now Read Only?

Please send us the output for the mount command on your system.

Please remember to reply-to-all next time(s)...

Thanks,
Vered

- Original Message -
 From: Jonathan Horne jho...@skopos.us
 To: Vered Volansky ve...@redhat.com
 Sent: Monday, December 10, 2012 4:24:05 PM
 Subject: Re: [Users] iscsi mpio

 Im using the ovirt node which is a prebuilt appliance-like version of
 ovirt.

 It is highly customized, and is not open to alteration. (to do so
 would be
 quite a bit of work).

 JONATHAN HORNE  |  Systems Administrator  | Skopos Web
 http://www.skopos.us/
 e:  jho...@skopos.us  t:  (972) 520-5042  f:  (214) 520-5079






 On 12/10/12 6:46 AM, Vered Volansky ve...@redhat.com wrote:

 Hi Jonathan,
 
 I'm trying to understand the context for your problem.
 
 As I understand it, your problem stems from the fact that you're
 working
 on a Read Only fs, long before the multipath issue.
 So you have root permissions on an RO fs?
 How come? Why is it RO to begin with?
 Are you working on RHEVM?
 Which OS, version?
 
 Maybe we can be of more help if we better understand the context.
 
 Thanks,
 Vered
 
 
 - Original Message -
  From: Jonathan Horne jho...@skopos.us
  To: users@ovirt.org
  Sent: Friday, December 7, 2012 7:09:08 PM
  Subject: Re: [Users] iscsi mpio
 
  Im using a Equallogic iscsi SAN, and it has a special multi path
  driver
  because it uses a virtual IP for the initiator to log into, and
  the
  actual
  traffic ip addresses are not exposed to the initiator.
 
  I tried to install the rpm but as far as i can get is:
 
  [root@vmnode02 x86_64]# rpm -Uvh
  equallogic-host-tools-1.2.0-2.el6.x86_64.rpm --nodeps
  warning: equallogic-host-tools-1.2.0-2.el6.x86_64.rpm: Header V4
  DSA/SHA1
  Signature, key ID 84fd3ef3: NOKEY
  error: can't create transaction lock on /var/lib/rpm/.rpm.lock
  (Read-only
  file system)
 
  Is there a way to unlock the file system so i can try to install
  and
  configure this driver?
 
 
  This is the current output of multipath -ll on my node:
 
  [root@vmnode02 x86_64]# multipath -ll
  36019cb3131d6f276d80a45bb6501f0c9 dm-10
  size=500G features='0' hwhandler='0' wp=rw
  36001e4f03dd42300183eaac404afd5ce dm-0 DELL,PERC 6/i
  size=279G features='0' hwhandler='0' wp=rw
  `-+- policy='round-robin 0' prio=1 status=active
`- 2:2:0:0 sda 8:0 active ready running
 
 
 
  The EQ san does show only 1 single tcp connection into the LUN, so
  i
  know
  its not multipathing at this time.  This will be a huge downer if
  i
  have
  to go to production without multi path support.
 
  Is there anything i can do here?
 
 
 
 
 
  On 12/7/12 8:42 AM, René Koch (ovido) r.k...@ovido.at wrote:
 
  Hi,
  
  I can give you some information on multipathing on RHEV-H, as I
  don't
  have ovirt-node installed at the moment.
  
  Multipath packages are installed on the hypervisor, but vdsm
  overwrites
  multipath.conf.
  
  To prevent this you have to set the following tags:
  # RHEV REVISION 0.7
  # RHEV PRIVATE
  
  Search for MPATH_CONF_TAG in multipath.py file to get correct
  RHEV
  REVISION number.
  
  After changing multipath.conf to fit your needs make it
  persistent
  for
  reboots:
  # persist /etc/multipath.conf
  
  
  You can check multipath status with:
  
  # multipath -ll
  mpathb (b00015521f5d4) dm-0 Intel,Multi-Flex
  size=96G features='0' hwhandler='0' wp=rw
  |-+- policy='round-robin 0' prio=50 status=active
  | `- 0:0:0:1 sdb 8:16 active ready running
  mpatha (222140001553601d1) dm-1 Intel,Multi-Flex
  size=20G features='0' hwhandler='0' wp=rw
  |-+- policy='round-robin 0' prio=50 status=active
  | `- 0:0:0:0 sda 8:0  active ready running
  
  I hope this helps.
  Don't really know if the tags are the same in oVirt, as I don't
  have
  a
  working oVirt setup at the moment.
  
  
  --
  

[Users] theoretical scenario

2012-12-11 Thread Jonathan Horne
My production deployment is approaching soon, so i am trying to get some final 
tasks and concepts completed before that day arrives.  Lets say, that i have a 
working domain, but that an impending disaster is about to destroy the whole 
thing.  How can i get the Vms out, and then how can i reverse this and get them 
into a completely new and unrelated/unconnected ovirt domain?

Any advice, or a doc or link would be much appreciated.

Thanks,
jonathan


This is a PRIVATE message. If you are not the intended recipient, please delete 
without copying and kindly advise us by e-mail of the mistake in delivery. 
NOTE: Regardless of content, this e-mail shall not operate to bind SKOPOS to 
any order or other contract unless pursuant to explicit written agreement or 
government initiative expressly permitting the use of e-mail for such purpose.
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] OpenLDAP Simple Authentication in Ovirt Engine

2012-12-11 Thread Charlie
True LDAP does not require a password encryption method and is
perfectly happy with cleartext storage and use.

In practice, one uses a secure channel (LDAPS or Starttls or encrypted
network) and most LDAP servers (such as OpenLDAP) will allow several
different kinds of password encryption.

An application, though, should not ever deal with this issue.  The
password should be validated by doing a BIND operation, and the
application should not do any READ operations on the userPassword
value at any time, only authenticate operations.  Let the LDAP server
manage authentication.

Groups are harder.  You cannot rely on the presence of a memberOf
attribute, unfortunately, and schema are contextually meaningless, so
you need a way for the directory administrator to tell the client code
how groups are being stored in the server.  Thierry gives one example,
another is groupOfNames using a member attribute containing DNs of
members.  Those are the two most common methods, but there are more.

--Charlie

On Tue, Dec 4, 2012 at 2:31 AM, Thierry Kauffmann
thierry.kauffm...@univ-montp2.fr wrote:

 Le 04/12/2012 00:51, Itamar Heim a écrit :

 On 11/30/2012 12:30 PM, Thierry Kauffmann wrote:

 Hi,

 I am currently testing Ovirt 3.1 standalone on Fedora 17.

 Until now, I could only use the default user admin@internal.

 Our Directory at the University is OpenLDAP. We use it for
 authentication WITHOUT Kerberos : Simple authentication.


 just wondering, i'm sure it is encrypted somehow, do you know which way?
 also, when using openldap, which scheme are you using?

 thanks,
Itamar


 Hi,

 the password is transmitted by the client encrypted (hashed) to the openldap 
 server.
 We use the standard schemes delivered by openldap : core, cosine, nis, 
 inetorgperson and samba

 A normal user dn is : uid=username,ou=Users,dc=example,dc=com
 A normal group dn is : cn=groupname,ou=Groups,dc=example,dc=com
 Group members are a list of values for the attribute memberUid of a group 
 dn.

 regards,

 Thierry


 I wonder how to use this backend to authenticate users and manage groups
 in Ovirt.

 Has anyone already set this up ?
 How to configure Ovirt to use Simple Authentication (No Kerberos).

 Cheers,

 --
 signature-TK Thierry Kauffmann
 Chef du Service Informatique // Faculté des Sciences // Université de
 Montpellier 2

 SIF - Service Informatique de la Faculté des Sciences
 http://sif.info-ufr.univ-montp2.fr/ UM2 - Université de Montpellier 2
 http://www.univ-montp2.fr/ Service informatique de la Faculté des
 Sciences (SIF)
 Université de Montpellier 2
 CC437 // Place Eugène Bataillon // 34095 Montpellier Cedex 5

 Tél : 04 67 14 31 58
 email : thierry.kauffm...@univ-montp2.fr
 mailto:thierry.kauffm...@univ-montp2.fr
 web : http://sif.info-ufr.univ-montp2.fr/ http://www.fdsweb.univ-montp2.fr/




 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users





 --
 Thierry Kauffmann
 Chef du Service Informatique // Faculté des Sciences // Université de 
 Montpellier 2

 Service informatique de la Faculté des Sciences (SIF)
 Université de Montpellier 2
 CC437 // Place Eugène Bataillon // 34095 Montpellier Cedex 5

 Tél : 04 67 14 31 58
 email : thierry.kauffm...@univ-montp2.fr
 web : http://sif.info-ufr.univ-montp2.fr/  http://www.fdsweb.univ-montp2.fr/


 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] theoretical scenario

2012-12-11 Thread Jonathan Horne
ok, so the process seems pretty obtuse, so let me run this by the list here and 
maybe I'm just not doing it the best way.

1) i connected an export domain called EXPORTNFS.  the nfs share is physically 
on my management server (as is iso)
2) exported 1 VM.
3) on the mgmt server, i run tar zxcf /root/test.tgz /opt/export/[UUID]/images 
/opt/export/[UUID]/master
4) for good measure, i use ovirt web gui to delete the exported VM from the 
export
5) run the command 'engine-image-uploader –u admin@internal upload test.tgz –v 
–e EXPORTNFS
6) after a while, it completes and i see the VM back in the export storage tab 
under VM Import.

i didn't run the vm yet, but I'm assuming thats a successful export and import.

so, it seems if i wanted to export each and every VM from one separate ovirt to 
another, i would export each VM, tar-gzip it, clear it from the webgui, and 
start the next one?   IE.. i mean it looks like engine-image-uploader would be 
pretty unhappy with finding more than one set of VM UUIDs inside?

is this the way it should be done, or am i doing it the hard way?

thanks!
jonathan



From: Jonathan Horne jho...@skopos.usmailto:jho...@skopos.us
Date: Tuesday, December 11, 2012 8:02 AM
To: users@ovirt.orgmailto:users@ovirt.org 
users@ovirt.orgmailto:users@ovirt.org
Subject: [Users] theoretical scenario

My production deployment is approaching soon, so i am trying to get some final 
tasks and concepts completed before that day arrives.  Lets say, that i have a 
working domain, but that an impending disaster is about to destroy the whole 
thing.  How can i get the Vms out, and then how can i reverse this and get them 
into a completely new and unrelated/unconnected ovirt domain?

Any advice, or a doc or link would be much appreciated.

Thanks,
jonathan


This is a PRIVATE message. If you are not the intended recipient, please delete 
without copying and kindly advise us by e-mail of the mistake in delivery. 
NOTE: Regardless of content, this e-mail shall not operate to bind SKOPOS to 
any order or other contract unless pursuant to explicit written agreement or 
government initiative expressly permitting the use of e-mail for such purpose.


This is a PRIVATE message. If you are not the intended recipient, please delete 
without copying and kindly advise us by e-mail of the mistake in delivery. 
NOTE: Regardless of content, this e-mail shall not operate to bind SKOPOS to 
any order or other contract unless pursuant to explicit written agreement or 
government initiative expressly permitting the use of e-mail for such purpose.
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Cannot find suitable CPU model for given data

2012-12-11 Thread Itamar Heim

On 12/11/2012 11:09 PM, Cristian Falcas wrote:




On Mon, Dec 10, 2012 at 2:22 PM, Roy Golan rgo...@redhat.com
mailto:rgo...@redhat.com wrote:

On 12/10/2012 02:04 PM, Cristian Falcas wrote:




On Mon, Dec 10, 2012 at 9:30 AM, Itamar Heim ih...@redhat.com
mailto:ih...@redhat.com wrote:

On 12/09/2012 11:22 PM, Cristian Falcas wrote:




On Sun, Dec 9, 2012 at 5:37 PM, Roy Golan
rgo...@redhat.com mailto:rgo...@redhat.com
mailto:rgo...@redhat.com mailto:rgo...@redhat.com wrote:

On 12/09/2012 05:17 PM, Cristian Falcas wrote:

Hi,

I get this error with the nightly builds when I
start a VM:


  please paste the output of the following command to
see if
Opteron_G3 is really supported:
   vdsClient 0 -s getVdsCaps


libvirtError: internal error Cannot find suitable
CPU model for
given data


Log data:
Thread-654::DEBUG::2012-12-09
17:14:18,120::libvirtvm::1485::vm.Vm::(_run)
vmId=`a4a8f349-7fdf-42f4-873e-e70f692c6ca2`::?xml
version=1.0
encoding=utf-8?
domain type=kvm
nameq/name
uuida4a8f349-7fdf-42f4-873e-e70f692c6ca2/uuid
memory524288/memory
currentMemory524288/currentMemory
vcpu2/vcpu
devices
channel type=unix
target
name=com.redhat.rhevm.vdsm
type=virtio/
source mode=bind

path=/var/lib/libvirt/qemu/channels/q.com.redhat.rhevm.vdsm/
/channel
channel type=unix
target
name=org.qemu.guest_agent.0
type=virtio/
source mode=bind

path=/var/lib/libvirt/qemu/channels/q.org.qemu.guest_agent.0/
/channel
input bus=ps2 type=mouse/
channel type=spicevmc
target
name=com.redhat.spice.0
type=virtio/
/channel
graphics autoport=yes
keymap=en-us listen=0
passwd=* passwdValidTo=1970-01-01T00:00:01
port=-1
tlsPort=-1 type=spice
channel mode=secure
name=main/
channel mode=secure
name=inputs/
channel mode=secure
name=cursor/
channel mode=secure
name=playback/
channel mode=secure
name=record/
channel mode=secure
name=display/
channel mode=secure
name=usbredir/
channel mode=secure
name=smartcard/
/graphics
console type=pty
target port=0
type=virtio/
/console
sound model=ac97/
video
model heads=1
type=qxl vram=65536/
/video
interface type=bridge
mac
address=00:1a:4a:6f:6f:f4/
model type=virtio/
source bridge=ovirtmgmt/
filterref
filter=vdsm-no-mac-spoofing/
/interface
memballoon model=virtio/
disk device=cdrom snapshot=no
type=file
source


file=/rhev/data-center/21ddcd50-aba8-461a-9ecf-c5762af89355/4f6a2b90-9c70-45e5-8b17-5274ee97ce73/images/----/CentOS-6.3-x86_64-bin-DVD1.iso
startupPolicy=optional/
   

Re: [Users] mislabelled template source

2012-12-11 Thread Jim Kinney
On Tue, Dec 11, 2012 at 4:10 AM, Eli Mesika emes...@redhat.com wrote:



 - Original Message -
  From: Jim Kinney jim.kin...@gmail.com
  To: users@ovirt.org
  Sent: Sunday, December 9, 2012 7:22:32 PM
  Subject: [Users] mislabelled template source
 
 
  Greetings,
 
  I've built several new templates from the blank template and a ISO
  install of various OS's. However, when I built a new VM using the
  new template(s), the new VM still says it's based from the blank
  template. I expected it to say it was from the template-foo U
  specified. The VM is correctly built from the template so I think
  it's a generation/database issue.

 Hi Jim
 Did you created the VM from the Web Admin UI or from the API ?


Hi Eli,

Yes. I used the web admin gui.


 
  --
  --
  James P. Kinney III
 
  Every time you stop a school, you will have to build a jail. What you
  gain at one end you lose at the other. It's like feeding a dog on
  his own tail. It won't fatten the dog.
  - Speech 11/23/1900 Mark Twain
 
  http://electjimkinney.org
  http://heretothereideas.blogspot.com/
 
 
  ___
  Users mailing list
  Users@ovirt.org
  http://lists.ovirt.org/mailman/listinfo/users
 




-- 
-- 
James P. Kinney III
*
*Every time you stop a school, you will have to build a jail. What you gain
at one end you lose at the other. It's like feeding a dog on his own tail.
It won't fatten the dog.
- Speech 11/23/1900 Mark Twain
*
http://electjimkinney.org
http://heretothereideas.blogspot.com/
*
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[Users] help with iSCSI storage domain needed - Ovirt -3.1

2012-12-11 Thread Aleksandr Arbitman
Hi, everybody !
I have installed  ovirt 3.1 engine and two nodes. I have setup iscsi storage on 
another box and tested it with windows system - I was able to add it to win7 
initiator, meaning the storage configured properly. But I can't add iscsi 
storage in ovirt-engine system. When I use DIscover Targets option and type 
IP address of my iscsi system - nothing is happening.
All my systems - engine, nodes and iscsi server - are on the same network. Is 
it a bug? Is there any way to fix it ? Did anyone have the same issue ? Please, 
help. Thanks in advance for any tips.


Alex
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] help with iSCSI storage domain needed - Ovirt -3.1

2012-12-11 Thread Mark Wu

On 12/12/2012 09:40 AM, Aleksandr Arbitman wrote:

Hi, everybody !
I have installed  ovirt 3.1 engine and two nodes. I have setup iscsi 
storage on another box and tested it with windows system - I was able 
to add it to win7 initiator, meaning the storage configured properly. 
But I can't add iscsi storage in ovirt-engine system. When I use 
DIscover Targets option and type IP address of my iscsi system - 
nothing is happening.
All my systems - engine, nodes and iscsi server - are on the same 
network. Is it a bug? Is there any way to fix it ? Did anyone have the 
same issue ? Please, help. Thanks in advance for any tips.



Alex




Is there any error related in /var/vdsm/vdsm.log ?

Did you try to manually discover and login the iscsi target by the 
following command?


iscsiadm --mode discoverydb --type sendtargets --portal 192.168.122.1 
--discover   // replace the portal address with your iscsi server's ip 
address


iscsiadm --mode node --targetname iqn.2001-05.com.doe:test --portal 
192.168.1.1:3260 --login  //replace the iqn with what returned by the 
above command, and also the portal address.







___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] theoretical scenario

2012-12-11 Thread Vered Volansky
First, your scenario is missing the actual import, you just have the data in 
the export domain, not the vms in the engine.

Second - A slightly simpler way you were looking for:

1. Export multiple vms using either a short script via RESTAPI or webadmin 
(select multiple vms and export).
2. Detach the export domain.
3. Backup the export domain with all its data.

4. Re-attach export domain when ready to.
5. Import vms.

Good luck,
Vered



- Original Message -
 From: Jonathan Horne jho...@skopos.us
 To: Jonathan Horne jho...@skopos.us, users@ovirt.org
 Sent: Tuesday, December 11, 2012 9:47:06 PM
 Subject: Re: [Users] theoretical scenario
 
 
 
 
 
 ok, so the process seems pretty obtuse, so let me run this by the
 list here and maybe I'm just not doing it the best way.
 
 
 1) i connected an export domain called EXPORTNFS. the nfs share is
 physically on my management server (as is iso)
 2) exported 1 VM.
 3) on the mgmt server, i run tar zxcf /root/test.tgz
 /opt/export/[UUID]/images /opt/export/[UUID]/master
 4) for good measure, i use ovirt web gui to delete the exported VM
 from the export
 5) run the command 'engine-image-uploader –u admin@internal upload
 test.tgz –v –e EXPORTNFS
 6) after a while, it completes and i see the VM back in the export
 storage tab under VM Import.
 
 
 i didn't run the vm yet, but I'm assuming thats a successful export
 and import.
 
 
 so, it seems if i wanted to export each and every VM from one
 separate ovirt to another, i would export each VM, tar-gzip it,
 clear it from the webgui, and start the next one? IE.. i mean it
 looks like engine-image-uploader would be pretty unhappy with
 finding more than one set of VM UUIDs inside?
 
 
 is this the way it should be done, or am i doing it the hard way?
 
 
 thanks!
 jonathan
 
 
 
 
 
 
 
 
 From: Jonathan Horne  jho...@skopos.us 
 Date: Tuesday, December 11, 2012 8:02 AM
 To:  users@ovirt.org   users@ovirt.org 
 Subject: [Users] theoretical scenario
 
 
 
 
 
 
 
 My production deployment is approaching soon, so i am trying to get
 some final tasks and concepts completed before that day arrives.
 Lets say, that i have a working domain, but that an impending
 disaster is about to destroy the whole thing. How can i get the Vms
 out, and then how can i reverse this and get them into a completely
 new and unrelated/unconnected ovirt domain?
 
 
 Any advice, or a doc or link would be much appreciated.
 
 
 Thanks,
 jonathan
 
 
 
 This is a PRIVATE message. If you are not the intended recipient,
 please delete without copying and kindly advise us by e-mail of the
 mistake in delivery. NOTE: Regardless of content, this e-mail shall
 not operate to bind SKOPOS to any order or other contract unless
 pursuant to explicit written agreement or government initiative
 expressly permitting the use of e-mail for such purpose.
 
 This is a PRIVATE message. If you are not the intended recipient,
 please delete without copying and kindly advise us by e-mail of the
 mistake in delivery. NOTE: Regardless of content, this e-mail shall
 not operate to bind SKOPOS to any order or other contract unless
 pursuant to explicit written agreement or government initiative
 expressly permitting the use of e-mail for such purpose.
 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] help with iSCSI storage domain needed - Ovirt -3.1

2012-12-11 Thread Aleksandr Arbitman
Mark.
running both commands on one of the nodes was successful, see below:

[root@ovirtnode1 ~]# iscsiadm --mode discoverydb --type sendtargets --portal 
10.45.201.22 --discover 

10.45.201.22:3260,1 iqn.2012-12.com.test:storage.target1

[root@ovirtnode1 ~]# iscsiadm --mode node --targetname 
iqn.2012-12.com.test:storage.target1 --portal 10.45.201.22:3260 --login

Logging in to [iface: default, target: iqn.2012-12.com.test:storage.target1, 
portal: 10.45.201.22,3260] (multiple)

Login to [iface: default, target: iqn.2012-12.com.test:storage.target1, portal: 
10.45.201.22,3260] successful.

[root@ovirtnode1 ~]#

##
When I run tail -f  /var/log/vdsm/vdsm.log that log shows the node is trying 
to access NFS based domain which I removed in engine before trying to add iscsi 
data domain. See here:

##
Traceback (most recent call last):
  File /usr/share/vdsm/storage/domainMonitor.py, line 103, in _monitorDomain
  File /usr/share/vdsm/storage/nfsSD.py, line 100, in selftest
StorageDomainFSNotMounted: Storage domain remote path not mounted: 
('/rhev/data-center/mnt/nfs-storage.fib.int.asurion.com:_home_iso-domain',)
Thread-31::ERROR::2012-12-12 
07:29:28,834::domainMonitor::120::Storage.DomainMonitor::(_monitorDomain) Error 
while collecting domain `f5adc0dc-7749-4d2c-b1ba-142ac4a0688c` monitoring 
information
Traceback (most recent call last):
  File /usr/share/vdsm/storage/domainMonitor.py, line 103, in _monitorDomain
  File /usr/share/vdsm/storage/nfsSD.py, line 100, in selftest
StorageDomainFSNotMounted: Storage domain remote path not mounted: 
('/rhev/data-center/mnt/nfs-storage.fib.int.asurion.com:_home_nfs-domain',)

##
Why can't I add iscsi storage using engine webGUI ?
What would you recommend ? Thank you very much in advance for your help.





--- On Tue, 12/11/12, Mark Wu wu...@linux.vnet.ibm.com wrote:

From: Mark Wu wu...@linux.vnet.ibm.com
Subject: Re: [Users] help with  iSCSI storage domain needed - Ovirt -3.1
To: Aleksandr Arbitman arbit...@pacbell.net
Cc: users@ovirt.org
Date: Tuesday, December 11, 2012, 10:36 PM


  


  
  
On 12/12/2012 09:40 AM, Aleksandr
  Arbitman wrote:



  

  
Hi, everybody !

  I have installed  ovirt 3.1 engine and two nodes. I have
  setup iscsi storage on another box and tested it with
  windows system - I was able to add it to win7 initiator,
  meaning the storage configured properly. But I can't add
  iscsi storage in ovirt-engine system. When I use DIscover
  Targets option and type IP address of my iscsi system -
  nothing is happening.

  All my systems - engine, nodes and iscsi server - are on
  the same network. Is it a bug? Is there any way to fix it
  ? Did anyone have the same issue ? Please, help. Thanks in
  advance for any tips.

  

  

  Alex


  

  
  

  
  


Is there any error related in /var/vdsm/vdsm.log ?



Did you try to manually discover and login the iscsi target by the
following command?



iscsiadm --mode discoverydb --type sendtargets --portal
192.168.122.1 --discover   // replace the portal address with your
iscsi server's ip address



iscsiadm --mode node --targetname iqn.2001-05.com.doe:test --portal
192.168.1.1:3260 --login  //replace the iqn with what returned by
the above command, and also the portal address.












  ___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users




  

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users