[Users] OvirtGuestAgent in windows

2013-05-13 Thread lof yer
I tried 'python OvirtGuestService.py install' || 'net start
OvirtGuestService', it just logged me out and no ip was reported to the
engine. However, when I logged as any user on Windows  using 'python
OvirtGuestService.py debug', it seemed to be working all fine(ip,
application... were reported) .

Someone said that the service must be started under a user, I tried make it
started with a user, like Administrator, LOCALSYSTEM, but an error reported.

Do I have other ways to make it run as a service?
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Vlan interface on top of bonding

2013-05-13 Thread René Koch (ovido)

On 05/09/2013 08:55 AM, Moti Asayag wrote:



- Original Message -

From: René Koch r.k...@ovido.at
To: Juan Pablo Lorier jplor...@gmail.com
Cc: users@ovirt.org
Sent: Wednesday, May 8, 2013 11:15:04 PM
Subject: Re: [Users] Vlan interface on top of bonding

Hi,

vlan tagging for ovirtmgmt interface is a bit tricky.

Here's how I do it:
- configure vlan tag on host(s) and switch - imho not necessary to have a
ovirtmgmt bridge available but vlan tagging configured for your ovirtmgmt
network on your ethx or bondx interface


ovirt-engine supports configuration of the ovirtmgmt as a non-vm network, 
untagged.
And on top of that nic (bond in this specific case) configure all of the vlans.

The advantage of this setting is not requiring to perform any manual 
configuration at all.
The disadvantage is the inability to connect VMs through the ovirtmgmt network, 
which
requires configuring at least one VM network on any of the hosts in order to be 
able to
configure nics on the VMs.



Thanks a lot. I never tried this before.

As there are repeating questions about networking I'll try to find some 
time this week to write a networking documentation (bonding, vlan 
tagging, non-vm networks,...) in oVirt wiki this week.







- create a new datacenter (without hosts in it!)


With the fix for https://bugzilla.redhat.com/909820 (merged), any network can 
be editing,
in spite of it's configured on hosts. It will result with network being marked 
as 'not synced'
on the host.


- edit ovirtmgmt logical network (if it's not possible: delete it and create
new interface ovirtmgmt with vlan tag)
- put host(s) in new datacenter
- configure network from oVirt webadmin gui (maybe you have to uncheck
verify connectivity between engine and hosts)

I can't say for sure if the steps above will work - maybe you have to do more
directly on the host.
Did a few setups with tagged ovirtmgmt interfaces in oVirt and RHEV but newer
wrote down a definitive guide for it :(


Regards,
René



-Original message-

From:Juan Pablo Lorier jplor...@gmail.com
Sent: Wednesday 8th May 2013 21:14
To: René Koch r.k...@ovido.at
Cc: users@ovirt.org
Subject: Re: [Users] Vlan interface on top of bonding

Hi René,

Tanks for your help. I've tried in the direction you pointed and I was
able to share the bond among other tagged networks. One of the problems
would be how to edit ovirtmgmt network now that it's created, I just
can't find in the way to do it by the web. I've tried starting a hole
new datacenter, but it creates the network and disables all changes.
Thus, I can't mark the ovirtmgmt network as tagged and add other tagged
networks to the bond.
I can't tag the management network neither not use it, so I'm kind of
stuck again.
Regards,


On 08/05/13 11:51, René Koch (ovido) wrote:

Hi,

first of all welcome to the oVirt project.

Did you configure vlan tagging for your ovirtmgmt network?
If you're using vlan tagging on (bonded) interfaces in oVirt you have to
add a vlan tag to all logical networks - can't mix tagged and untagged
logical networks.

e.g (same for bonds as well):
Name - VLAN- Network Name
eth0 - eth0.10 - ovirtmgmt
eth0.11 - lan1
eth0.12 - lan2

Hope this helps.






___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] How to add internal networks

2013-05-13 Thread Frank Wall

Hi René,

Am 13.05.2013 09:56, schrieb René Koch (ovido):

When using multiple logical networks on 1 physical nic you
will need most likely VLAN tagging, as all vm networks are
configured as a bridge in oVirt.


unfortunately, using VLAN tagging is not an option for me,
because I'm not the maintainer of the network devices (and
my hosting provider won't configure VLANs for me).

Is there another way to get multiple networks in oVirt up
and running?

FYI: The main purpose of these internal networks is a test
environment for some VMs. Those VMs should be able to reach
each other and to have internet access.


Thanks
- Frank
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] How to add internal networks

2013-05-13 Thread Assaf Muller
Hi Frank,

Without the ability to control the networking devices in your vicinity and 
setup VLANs, what you're trying to do isn't supported via oVirt.

However, assuming you do have root access to your host, I can suggest a 
workaround:
* Create two dummy interfaces on the host, and give them static IP addresses. 
For example: 192.168.1.254/24, and 192.168.2.254/24.
* Create two networks (Non-VM) called One and Two and attach them to the dummy 
NICs.
* Create VMs with virtual NICs in network One, and VMs with virtual NICs in 
network Two. 
  You can give them static IP addresses and supply the host's dummy interfaces 
as gateways, or enable a DHCP server on the host.
* Enable routing on the host, and setup the appropriate rules so that he acts 
as a default gateway for all of the VMs, and that he forwards traffic 
appropriately between the VM networks.

- Original Message -
From: Frank Wall f...@moov.de
To: users@ovirt.org
Sent: Monday, May 13, 2013 2:06:53 PM
Subject: Re: [Users] How to add internal networks

Hi René,

Am 13.05.2013 09:56, schrieb René Koch (ovido):
 When using multiple logical networks on 1 physical nic you
 will need most likely VLAN tagging, as all vm networks are
 configured as a bridge in oVirt.

unfortunately, using VLAN tagging is not an option for me,
because I'm not the maintainer of the network devices (and
my hosting provider won't configure VLANs for me).

Is there another way to get multiple networks in oVirt up
and running?

FYI: The main purpose of these internal networks is a test
environment for some VMs. Those VMs should be able to reach
each other and to have internet access.


Thanks
- Frank
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] How to add internal networks

2013-05-13 Thread Assaf Muller
Correction:
The two networks should be VM networks.

- Original Message -
From: Assaf Muller amul...@redhat.com
To: Frank Wall f...@moov.de
Cc: users@ovirt.org
Sent: Monday, May 13, 2013 4:05:16 PM
Subject: Re: [Users] How to add internal networks

Hi Frank,

Without the ability to control the networking devices in your vicinity and 
setup VLANs, what you're trying to do isn't supported via oVirt.

However, assuming you do have root access to your host, I can suggest a 
workaround:
* Create two dummy interfaces on the host, and give them static IP addresses. 
For example: 192.168.1.254/24, and 192.168.2.254/24.
* Create two networks (Non-VM) called One and Two and attach them to the dummy 
NICs.
* Create VMs with virtual NICs in network One, and VMs with virtual NICs in 
network Two. 
  You can give them static IP addresses and supply the host's dummy interfaces 
as gateways, or enable a DHCP server on the host.
* Enable routing on the host, and setup the appropriate rules so that he acts 
as a default gateway for all of the VMs, and that he forwards traffic 
appropriately between the VM networks.

- Original Message -
From: Frank Wall f...@moov.de
To: users@ovirt.org
Sent: Monday, May 13, 2013 2:06:53 PM
Subject: Re: [Users] How to add internal networks

Hi René,

Am 13.05.2013 09:56, schrieb René Koch (ovido):
 When using multiple logical networks on 1 physical nic you
 will need most likely VLAN tagging, as all vm networks are
 configured as a bridge in oVirt.

unfortunately, using VLAN tagging is not an option for me,
because I'm not the maintainer of the network devices (and
my hosting provider won't configure VLANs for me).

Is there another way to get multiple networks in oVirt up
and running?

FYI: The main purpose of these internal networks is a test
environment for some VMs. Those VMs should be able to reach
each other and to have internet access.


Thanks
- Frank
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] engine-image-uploader and /tmp size problem on fedora18

2013-05-13 Thread Omer Frenkel


- Original Message -
 From: Gianluca Cecchi gianluca.cec...@gmail.com
 To: Itamar Heim ih...@redhat.com
 Cc: Alon Bar-Lev alo...@redhat.com, users users@ovirt.org, Omer 
 Frenkel ofren...@redhat.com
 Sent: Sunday, May 12, 2013 7:14:00 PM
 Subject: Re: [Users] engine-image-uploader and /tmp size problem on fedora18
 
 On Sun, May 12, 2013 at 3:48 PM, Itamar Heim wrote:
 
  you can take a live snapshot.
  i don't remember if we allow exporting a snapshot of a running VM (no
  technical reason not to).
 
 I think there is no way. I tried on 3.2.1 and after a live snapshot if
 you select the line of the VM, the export is greyed out.
 If I further select Snapshots in bottom pane, then the details pane
 gets the line marked with
 
 2013-May-12, 18:03Ok  test for export
 
 already selected but there is no option to export anything...
 At the moment if you have only one snapshot you get two lines in
 Snapshots details pane
 
 2013-May-12, 18:03Ok  test for export
 Current   OkActive VM
 
 BTW: you can sort of select all the lines but the Active VM' one.
 It would be fine to have the export' link above selectable when you
 select a line different from the Active VM one.
 How to officially ask to implement this or something similar to export
 live snapshots?
 
  if we for some reason don't, you could clone the snapshot to a VM, then
  export that VM (ugly, so i hope we support exporting a snapshot of a
  running
  VM)
 
 yes, ugly and not feasible in my opinion.
 

yes but tested it's possible.

 Thanks,
 Gianluca
 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] drac5 power management test

2013-05-13 Thread Itamar Heim

On 05/13/2013 10:01 PM, Peter Reilly wrote:

I'm using ovirt-release-el6-5-3.1.noarch.rpm
 ovirt-node-iso-2.6.1-20120228.fc18.iso
I have a two host cluster, both hosts up and functioning correctly.
I can manually log into both hosts drac5 card.
Both hosts are in the same cluster/data center.

When I save a host the eventlog says:
Host power management was verified successfully.

When I test power management it saws:
Test Failed, Host Status is: unknown. The fence-agent script reported
the following error: There is no other host in the data center that can
be used to test the power management settings.

My settings are:
Enable Power management (yes)
Concurrent (no)
Address (an ip address)
Username (root)
password (verified correct password)
type (drac5)
Slot (blank)
Options (blank)
Secure (yes)
Source (blank)

Is anyone successfully using a drac5 fence in ovirt 3.1?

Thanks,



___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users



engine log for this?
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[Users] Ovirt CLI: Pipe is not working when reading from file

2013-05-13 Thread semjek
Hello,



I'm trying to script stopping all vms at once but when I'm using example 
given in documentation, it won't work. The problem is when I read the 
command containing pipe from file. When the same command is pasted into 
stdin, everything works fine.





[root@ovirt-administration ~]# ovirt-shell -c




 ==

  connected to oVirt manager 3.2.0.0 

 ==







 ++





           Welcome to oVirt shell




 ++






[oVirt shell (connected)]# list vms | grep test3

name       : test3






oVirt shell (connected)]# exit


[root@ovirt-administration ~]#









But when I read from file:







[root@ovirt-administration ~]# ovirt-shell -c -f /root/listall.txt






 ==

  connected to oVirt manager 3.2.0.0 

 ==




[oVirt shell (connected)]# list vms | grep lindev







id         : cd27d9fd-611e-4a3d-8eba-ae6e50c038dc


name       : test2




id         : 77cb6321-e21f-4bfb-aae6-ee178dbd9b8a

name       : test3




id         : eba23051-8285-4a46-936d-25bd37c6cf8f

name       : test4




[oVirt shell (connected)]# exit





[root@ovirt-administration ~]#





This looks like a bug in ovirt-shell. Any thought?




Best regards

Evgeny



___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] drac5 power management test

2013-05-13 Thread Itamar Heim

On 05/14/2013 12:58 AM, Peter Reilly wrote:

2013-05-13 17:57:33,355 ERROR [org.ovirt.engine.core.bll.FenceExecutor]
(ajp--127.0.0.1-8702-12) Illegal value in PM Proxy Preferences string ,
skipped.


this seems to be the culprit.
eli - thoughts?


2013-05-13 17:57:33,356 ERROR [org.ovirt.engine.core.bll.FenceExecutor]
(ajp--127.0.0.1-8702-12) Failed to run Power Management command on Host
, no running proxy Host was found.
2013-05-13 17:57:38,963 WARN
[org.ovirt.engine.core.compat.backendcompat.PropertyInfo]
(ajp--127.0.0.1-8702-4) Unable to get value of property: pmSecondaryUser
for class org.ovirt.engine.core.common.businessentities.VdsStatic
2013-05-13 17:57:38,965 WARN
[org.ovirt.engine.core.compat.backendcompat.PropertyInfo]
(ajp--127.0.0.1-8702-4) Unable to get value of property: pmSecondaryUser
for class org.ovirt.engine.core.common.businessentities.VdsStatic
2013-05-13 17:57:38,967 INFO
[org.ovirt.engine.core.bll.UpdateVdsCommand] (ajp--127.0.0.1-8702-4)
[2c6aea20] Running command: UpdateVdsCommand internal: false. Entities
affected :  ID: 6c8c87a1-b98b-46ea-b66e-81afa0d2e794 Type: VDS
2013-05-13 17:57:38,995 WARN
[org.ovirt.engine.core.compat.backendcompat.PropertyInfo]
(ajp--127.0.0.1-8702-4) Unable to get value of property: pmSecondaryUser
for class org.ovirt.engine.core.common.businessentities.VdsStatic
2013-05-13 17:57:38,996 WARN
[org.ovirt.engine.core.compat.backendcompat.PropertyInfo]
(ajp--127.0.0.1-8702-4) Unable to get value of property: pmSecondaryUser
for class org.ovirt.engine.core.common.businessentities.VdsStatic
2013-05-13 17:57:41,608 ERROR [org.ovirt.engine.core.bll.FenceExecutor]
(ajp--127.0.0.1-8702-4) [2c6aea20] Illegal value in PM Proxy Preferences
string , skipped.
2013-05-13 17:57:41,609 ERROR [org.ovirt.engine.core.bll.FenceExecutor]
(ajp--127.0.0.1-8702-4) [2c6aea20] Failed to run Power Management
command on Host moses, no running proxy Host was found.


--- On *Mon, 5/13/13, Itamar Heim /ih...@redhat.com/* wrote:


From: Itamar Heim ih...@redhat.com
Subject: Re: [Users] drac5 power management test
To: Peter Reilly preill...@yahoo.com
Cc: users@ovirt.org
Date: Monday, May 13, 2013, 3:42 PM

On 05/13/2013 10:01 PM, Peter Reilly wrote:
  I'm using ovirt-release-el6-5-3.1.noarch.rpm
   ovirt-node-iso-2.6.1-20120228.fc18.iso
  I have a two host cluster, both hosts up and functioning correctly.
  I can manually log into both hosts drac5 card.
  Both hosts are in the same cluster/data center.
 
  When I save a host the eventlog says:
  Host power management was verified successfully.
 
  When I test power management it saws:
  Test Failed, Host Status is: unknown. The fence-agent script reported
  the following error: There is no other host in the data center
that can
  be used to test the power management settings.
 
  My settings are:
  Enable Power management (yes)
  Concurrent (no)
  Address (an ip address)
  Username (root)
  password (verified correct password)
  type (drac5)
  Slot (blank)
  Options (blank)
  Secure (yes)
  Source (blank)
 
  Is anyone successfully using a drac5 fence in ovirt 3.1?
 
  Thanks,
 
 
 
  ___
  Users mailing list
  Users@ovirt.org /mc/compose?to=Users@ovirt.org
  http://lists.ovirt.org/mailman/listinfo/users
 

engine log for this?



___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users