Re: [Users] Vlan interface on top of bonding

2013-05-15 Thread Juan Pablo Lorier
Hi Lior

I did managed to get the mgmt network tagged so now I can use the same
interface for several networks. The thing now is that I also have two
networks I use for iscsi that I'd like to be able to use in the same
interface (not the mgmt one) in one of the hosts, but as this networks
are in vlan1 untagged, I can't share the same interface. One of the
things to try was marking the network as not VM (to see if I can share
the interface in that scenario as suggested before), but I can't get the
networks to be not-vm.
What I'm doing as a work arround is to have the networks in a tagged
vlan, but again, I can't have two networks in the same vlan :-(, thus,
I'll have to configure two different vlans in my switchers just to be
able to share the interface.
This is not the greatest scenario as network layer tools in linux give
all the needed options, but ovirt seems not to be able to use them yet.
I was evaluating Proxmox prior to move to ovirt and they had this quite
well implemented, I was able to do everything I needed with the network
like with XEN (my actual virt platform) but cluster was not that easy to
get going and I moved. Nothing is perfect :-)
Anyway, I'll keep an eye on ovirt evolution to see if this gets better
before I move to production.
Thank you all for your help, any ideas are always welcome.
Regards,

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] drac5 power management test

2013-05-15 Thread Thomas Scofield
Are you able to run the fence_drace5 command from the command line?  I had
some trouble getting the fence agent working on a drac6 management
interface, I made some notes in the wiki
http://www.ovirt.org/Automatic_Fencing#Troubleshooting.  When testing make
sure to specify an action, the default action is to reboot.
On May 14, 2013 1:37 AM, Itamar Heim ih...@redhat.com wrote:

 On 05/14/2013 12:58 AM, Peter Reilly wrote:

 2013-05-13 17:57:33,355 ERROR [org.ovirt.engine.core.bll.**FenceExecutor]
 (ajp--127.0.0.1-8702-12) Illegal value in PM Proxy Preferences string ,
 skipped.


 this seems to be the culprit.
 eli - thoughts?

  2013-05-13 17:57:33,356 ERROR [org.ovirt.engine.core.bll.**FenceExecutor]
 (ajp--127.0.0.1-8702-12) Failed to run Power Management command on Host
 , no running proxy Host was found.
 2013-05-13 17:57:38,963 WARN
 [org.ovirt.engine.core.compat.**backendcompat.PropertyInfo]
 (ajp--127.0.0.1-8702-4) Unable to get value of property: pmSecondaryUser
 for class org.ovirt.engine.core.common.**businessentities.VdsStatic
 2013-05-13 17:57:38,965 WARN
 [org.ovirt.engine.core.compat.**backendcompat.PropertyInfo]
 (ajp--127.0.0.1-8702-4) Unable to get value of property: pmSecondaryUser
 for class org.ovirt.engine.core.common.**businessentities.VdsStatic
 2013-05-13 17:57:38,967 INFO
 [org.ovirt.engine.core.bll.**UpdateVdsCommand] (ajp--127.0.0.1-8702-4)
 [2c6aea20] Running command: UpdateVdsCommand internal: false. Entities
 affected :  ID: 6c8c87a1-b98b-46ea-b66e-**81afa0d2e794 Type: VDS
 2013-05-13 17:57:38,995 WARN
 [org.ovirt.engine.core.compat.**backendcompat.PropertyInfo]
 (ajp--127.0.0.1-8702-4) Unable to get value of property: pmSecondaryUser
 for class org.ovirt.engine.core.common.**businessentities.VdsStatic
 2013-05-13 17:57:38,996 WARN
 [org.ovirt.engine.core.compat.**backendcompat.PropertyInfo]
 (ajp--127.0.0.1-8702-4) Unable to get value of property: pmSecondaryUser
 for class org.ovirt.engine.core.common.**businessentities.VdsStatic
 2013-05-13 17:57:41,608 ERROR [org.ovirt.engine.core.bll.**FenceExecutor]
 (ajp--127.0.0.1-8702-4) [2c6aea20] Illegal value in PM Proxy Preferences
 string , skipped.
 2013-05-13 17:57:41,609 ERROR [org.ovirt.engine.core.bll.**FenceExecutor]
 (ajp--127.0.0.1-8702-4) [2c6aea20] Failed to run Power Management
 command on Host moses, no running proxy Host was found.


 --- On *Mon, 5/13/13, Itamar Heim /ih...@redhat.com/* wrote:


 From: Itamar Heim ih...@redhat.com
 Subject: Re: [Users] drac5 power management test
 To: Peter Reilly preill...@yahoo.com
 Cc: users@ovirt.org
 Date: Monday, May 13, 2013, 3:42 PM

 On 05/13/2013 10:01 PM, Peter Reilly wrote:
   I'm using ovirt-release-el6-5-3.1.**noarch.rpm
ovirt-node-iso-2.6.1-20120228.**fc18.iso
   I have a two host cluster, both hosts up and functioning correctly.
   I can manually log into both hosts drac5 card.
   Both hosts are in the same cluster/data center.
  
   When I save a host the eventlog says:
   Host power management was verified successfully.
  
   When I test power management it saws:
   Test Failed, Host Status is: unknown. The fence-agent script
 reported
   the following error: There is no other host in the data center
 that can
   be used to test the power management settings.
  
   My settings are:
   Enable Power management (yes)
   Concurrent (no)
   Address (an ip address)
   Username (root)
   password (verified correct password)
   type (drac5)
   Slot (blank)
   Options (blank)
   Secure (yes)
   Source (blank)
  
   Is anyone successfully using a drac5 fence in ovirt 3.1?
  
   Thanks,
  
  
  
   __**_
   Users mailing list
   Users@ovirt.org /mc/compose?to=Users@ovirt.**orgUsers@ovirt.org
 
   
 http://lists.ovirt.org/**mailman/listinfo/usershttp://lists.ovirt.org/mailman/listinfo/users
  

 engine log for this?


 __**_
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/**mailman/listinfo/usershttp://lists.ovirt.org/mailman/listinfo/users

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[Users] getting strange error message on console and engine.log

2013-05-15 Thread Jonathan Horne
After removing and recreating some virtual disks today on a couple guests, I am 
seeing this on both the console and engine.log:

2013-05-15 19:52:57,539 INFO  [org.ovirt.engine.core.bll.EntityAsyncTask] 
(pool-3-thread-28) EntityAsyncTask::HandleEndActionResult [within thread]: 
EndAction for action type RemoveDisk hasnt succeeded, not clearing tasks, will 
attempt again next polling.

Any ideas what this issue is?

Thanks,
jonathan



This is a PRIVATE message. If you are not the intended recipient, please delete 
without copying and kindly advise us by e-mail of the mistake in delivery. 
NOTE: Regardless of content, this e-mail shall not operate to bind SKOPOS to 
any order or other contract unless pursuant to explicit written agreement or 
government initiative expressly permitting the use of e-mail for such purpose.
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[Users] OvirtGuestAgent in windows

2013-05-15 Thread lof yer
I installed it and made it an auto-start service, here is my logfile

Traceback (most recent call last): File
C:\Python27\lib\site-packages\win32\lib\win32serviceutil.py, line 802, in
ServiceCtrlHandlerEx self.SvcOtherEx(control, event_type, data) File
C:\ovirt-guest-agent\OVirtGuestService.py, line 95, in SvcOtherEx
self.SvcSessionChange(event_type) File
C:\ovirt-guest-agent\OVirtGuestService.py, line 85, in SvcSessionChange
self.vdsAgent.sessionLogon() File
C:\ovirt-guest-agent\OVirtAgentLogic.py, line 237, in sessionLogon
self.sendUserInfo() File C:\ovirt-guest-agent\OVirtAgentLogic.py, line
210, in sendUserInfo self.vio.write('active-user', {'name': cur_user}) File
C:\ovirt-guest-agent\VirtIoChannel.py, line 154, in write args =
_filter_object(args) File C:\ovirt-guest-agent\VirtIoChannel.py, line 92,
in _filter_object return filt(obj) File
C:\ovirt-guest-agent\VirtIoChannel.py, line 83, in filt return
dict(map(filt, o.iteritems())) File
C:\ovirt-guest-agent\VirtIoChannel.py, line 87, in filt return
tuple(map(filt, o)) File C:\ovirt-guest-agent\VirtIoChannel.py, line 89,
in filt return _filter_xml_chars(_string_check(o)) File
C:\ovirt-guest-agent\VirtIoChannel.py, line 51, in _string_check
str.encode(sys.stdout.encoding, 'strict') TypeError: encode() argument 1
must be string, not None
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users