Re: [Users] [Spice-devel] Keyboard keys issue!

2013-10-26 Thread Marc-André Lureau
Hi

- Original Message -
 On 10/18/2013 07:26 AM, Vishvendra Singh Chauhan wrote:
  Hello Friends,
 
 
  *I am working on Ovirt Data Center. Basically here in our DC we are
  providing virtual Machines to our clients, And they access virtual
  machine console using spiceX or spice-xpi package.
 
 
  *
  *But here i am facing a problem related keyboard keys. When i access any
  machine from Linux platform my all keyboard keys are working in guest
  OS. But when i access the same guest from windows platform, Then there
  some keys are not working in guest OS. _like (double code or single code
  )key is not working._So please help me in this matter ASAP.
  *

This reminds me of some old bug.

What is the version of virt-viewer ? What are the client and guest OS versions 
and keyboard layouts? 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] vdsmd seg fault

2013-10-26 Thread Dan Ferris

Unfortunatly, I was not correct.  Not fixed. :(

VDSM died randomly yesterday.  This was the message from systemctl:

vdsmd.service - Virtual Desktop Server Manager
   Loaded: loaded (/usr/lib/systemd/system/vdsmd.service; enabled)
   Active: failed (Result: exit-code) since Fri 2013-10-25 12:06:29 
EDT; 7s ago
  Process: 20937 ExecStop=/lib/systemd/systemd-vdsmd stop (code=exited, 
status=0/SUCCESS)
  Process: 21498 ExecStart=/lib/systemd/systemd-vdsmd start 
(code=exited, status=139)

 Main PID: 5205 (code=killed, signal=TERM)
   CGroup: name=systemd:/system/vdsmd.service

Oct 25 12:06:29 rs0-ovirt0 python[21572]: DIGEST-MD5 ask_user_info()
Oct 25 12:06:29 rs0-ovirt0 python[21572]: DIGEST-MD5 client step 2
Oct 25 12:06:29 rs0-ovirt0 python[21572]: DIGEST-MD5 ask_user_info()
Oct 25 12:06:29 rs0-ovirt0 python[21572]: DIGEST-MD5 make_client_response()
Oct 25 12:06:29 rs0-ovirt0 python[21572]: DIGEST-MD5 client step 3
Oct 25 12:06:29 rs0-ovirt0 systemd-vdsmd[21498]: libvirt: Network Filter 
Driver error : Requested operation is not valid: nwfilter is in use
Oct 25 12:06:29 rs0-ovirt0 systemd-vdsmd[21498]: 
/lib/systemd/systemd-vdsmd: line 186: 21572 Segmentation fault 
$VDSM_TOOL nwfilter
Oct 25 12:06:29 rs0-ovirt0 systemd[1]: vdsmd.service: control process 
exited, code=exited status=139
Oct 25 12:06:29 rs0-ovirt0 systemd[1]: Failed to start Virtual Desktop 
Server Manager.
Oct 25 12:06:29 rs0-ovirt0 systemd[1]: Unit vdsmd.service entered failed 
state.




On 10/22/2013 8:41 PM, Dan Ferris wrote:

So, just an update...

I upgraded to Ovirt 3.3.0.1 today and I have the latest libvirt.

I *THINK* the issue may be gone, but I will have to do a little more
testing.

Dan

On 10/18/2013 11:15 AM, Dan Ferris wrote:

That did work.  vdsmd decided it would start again.

Dan

On 10/17/2013 3:15 PM, Jason Brooks wrote:



- Original Message -

From: Dan Ferris dfer...@prometheusresearch.com
To: users@ovirt.org users@ovirt.org
Sent: Tuesday, October 15, 2013 9:24:44 AM
Subject: [Users] vdsmd seg fault

I updated to the latest Fedora 19 on two test servers, and now vdsmd
will not start.

Systedctl says this:

dsmd.service - Virtual Desktop Server Manager
 Loaded: loaded (/usr/lib/systemd/system/vdsmd.service; enabled)
 Active: failed (Result: exit-code) since Mon 2013-10-14 12:31:30
EDT; 23h ago
Process: 1788 ExecStart=/lib/systemd/systemd-vdsmd start
(code=exited, status=139)

Oct 14 12:31:30 rs0-ovirt0.rexdb.us python[1862]: DIGEST-MD5
ask_user_info()
Oct 14 12:31:30 rs0-ovirt0.rexdb.us python[1862]: DIGEST-MD5 client
step 2
Oct 14 12:31:30 rs0-ovirt0.rexdb.us python[1862]: DIGEST-MD5
ask_user_info()
Oct 14 12:31:30 rs0-ovirt0.rexdb.us python[1862]: DIGEST-MD5
make_client_response()
Oct 14 12:31:30 rs0-ovirt0.rexdb.us python[1862]: DIGEST-MD5 client
step 3
Oct 14 12:31:30 rs0-ovirt0.rexdb.us systemd-vdsmd[1788]:
/lib/systemd/systemd-vdsmd: line 185:  1862 Segmentation fault
$VDSM_TOOL nwfilter
Oct 14 12:31:30 rs0-ovirt0.rexdb.us systemd-vdsmd[1788]: vdsm:
Failed to
define network filters on libvirt[FAILED]
Oct 14 12:31:30 rs0-ovirt0.rexdb.us systemd[1]: vdsmd.service: control
process exited, code=exited status=139
Oct 14 12:31:30 rs0-ovirt0.rexdb.us systemd[1]: Failed to start Virtual
Desktop Server Manager.
Oct 14 12:31:30 rs0-ovirt0.rexdb.us systemd[1]: Unit vdsmd.service
entered failed state.

Has anyone else experienced this?


I just hit this on one of my test installs.

I did yum downgrade libvirt* and then vdsmd would start

Jason



Dan
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] [node-devel] GlusterFS on oVirt node

2013-10-26 Thread Vijay Bellur

On 10/25/2013 11:57 AM, Fabian Deutsch wrote:

Am Donnerstag, den 24.10.2013, 19:59 +0200 schrieb Saša Friedrich:

I reinstalled node and remounter / rw then I checked fs before
activating host (in oVirt Engine) and after (which files have been
changed)... The ro problem seems to be in /var/lib/glusterd/. Is there
any way I can change node so this directory would be mounted rw? And to
persist this setting after reboot.


Hey,

do you know if the data in /var/lib/glusterd needs to survive reboots?


/var/lib/glusterd does need to survive reboots.

-Vijay


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[Users] Not enough MAC addresses left in MAC Address Pool

2013-10-26 Thread Thomas Scofield
While building a virtual machine we ran into an error Not enough MAC
addresses left in MAC Address Pool.  In the engine log I see this message.

2013-10-26 14:47:16,590 WARN
 [org.ovirt.engine.core.bll.network.vm.AddVmInterfaceCommand] (ajp--127.0.0.
1-8702-12) [6fc05fa4] CanDoAction of action AddVmInterface failed.
Reasons:VAR__TYPE__INTERFACE,VAR__ACTI
ON__ADD,MAC_POOL_NOT_ENOUGH_MAC_ADDRESSES
2013-10-26 14:47:16,591 ERROR
[org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (ajp--127.0
.0.1-8702-12) Operation Failed: [Not enough MAC addresses left in MAC
Address Pool.]

This led me to look at the engine config where I see these
MacPoolRanges: 00:1A:4A:97:5E:00-00:1A:4A:97:5E:FF version: general
MaxMacsCountInPool: 10 version: general

The MacPoolRange would seem to be the limiting factor here, cutting us off
at 256 MAC addresses, which happens to be the number of virtual machine we
currently have. I assume that updating the MacPoolRange and restarting the
engine would resolve this issue. Has anybody experienced this issue?  Why
would the pool size have 256 and the Max entry be set to 10, that seems
like a large difference.
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users