Re: [ovirt-users] Sync Error on Master Domain after adding a second one

2015-03-04 Thread Stefano Stagnaro
Hi Liron,

I've reproduced the issue with a fresh deployment of oVirt 3.5.2rc. I've 
provided you with new screencasts and relevant logs for both cases (see inline 
comments):

screencast for case 1: 
https://www.dropbox.com/s/fdrcwmpy03v5xri/Screencast%20from%2004-03-2015%2010%3A53%3A32.webm?dl=1
screencast for case 2: 
https://www.dropbox.com/s/w72bf86n9v2pvdw/Screencast%20from%2004-03-2015%2015%3A18%3A45.webm?dl=1
logs for case 1: 
https://www.dropbox.com/sh/bl24umw0w1anclb/AAC0Oq7c6oXWetw-tp-55c37a?dl=0
logs for case 2: 
https://www.dropbox.com/sh/rp3pdda68nox099/AABtZGKDfFCH3sD6FZPvxRmEa?dl=0

Please note that I'm using different networks for Management (192.168.48.0/24) 
and GlusterFS replica (192.168.50.0/24):

management FQDN GlusterFS FQDN
node 1: s20.ovirt.prismas20gfs.ovirt.prisma
node 2: s21.ovirt.prismas21gfs.ovirt.prisma

On dom, 2015-03-01 at 04:55 -0500, Liron Aravot wrote:
 Hi Stefano,
 thanks for the great input!
 
 I went over the logs (is the screencast uses the same domains? i don't have 
 the logs from that run) - the master domain deactivation (and the master role 
 migration to the new domain) fails with the error to copy the master fs 
 content to the new domain on tar copy (see on [1] the error).
 
 1. Is there a chance that there is any problem inconsistent storage access 
 problem to any of the domains?
Storage domains rely on GlusterFS volumes created on purpose. VMs runs 
correctly.

 2. Does the issue reproduces always or only in some of the runs?
The issue reproduces always but:
case 1) if DATA and DATA_NEW are both created pointing to s20gfs the issue 
reproduces and Master role changes (Screencast 1).
case 2) if DATA is pointing to s20 and DATA_NEW to s20gfs the issue reproduces 
and Muster roles flips but does not change (Screencast 2).

 3. Have you tried to run a operation that creates a task? a creation of a 
 disk for example.
Every operations like creating or moving a disk are working correctly.

 
 thanks,
 Liron.
 
 
 
 [1]:
 Thread-9875::DEBUG::2015-02-25 
 15:06:57,969::clusterlock::349::Storage.SANLock::(release) Cluster lock for 
 domain 08298f60-4919-4f86-9233-827c1089779a success
 fully released
 Thread-9875::ERROR::2015-02-25 
 15:06:57,969::task::866::Storage.TaskManager.Task::(_setError) 
 Task=`2a434209-3e96-4d1e-8d1b-8c7463889f6a`::Unexpected error
 Traceback (most recent call last):
   File /usr/share/vdsm/storage/task.py, line 873, in _run
 return fn(*args, **kargs)
   File /usr/share/vdsm/logUtils.py, line 45, in wrapper
 res = f(*args, **kwargs)
   File /usr/share/vdsm/storage/hsm.py, line 1246, in deactivateStorageDomain
 pool.deactivateSD(sdUUID, msdUUID, masterVersion)
   File /usr/share/vdsm/storage/securable.py, line 77, in wrapper
 return method(self, *args, **kwargs)
   File /usr/share/vdsm/storage/sp.py, line 1097, in deactivateSD
 self.masterMigrate(sdUUID, newMsdUUID, masterVersion)
   File /usr/share/vdsm/storage/securable.py, line 77, in wrapper
 return method(self, *args, **kwargs)
   File /usr/share/vdsm/storage/sp.py, line 816, in masterMigrate
 exclude=('./lost+found',))
   File /usr/share/vdsm/storage/fileUtils.py, line 68, in tarCopy
 raise TarCopyFailed(tsrc.returncode, tdst.returncode, out, err)
 TarCopyFailed: (1, 0, '', '')
 Thread-9875::DEBUG::2015-02-25 
 15:06:57,969::task::885::Storage.TaskManager.Task::(_run) 
 Task=`2a434209-3e96-4d1e-8d1b-8c7463889f6a`::Task._run: 2a434209-3e96
 -4d1e-8d1b-8c7463889f6a ('62a034ca-63df-44f2-9a87-735ddd257a6b', 
 '0002-0002-0002-0002-022f', 
 '08298f60-4919-4f86-9233-827c1089779a', 34) {} failed
  - stopping task
 
 - Original Message -
  From: Stefano Stagnaro stefa...@prisma-eng.com
  To: Vered Volansky ve...@redhat.com
  Cc: users@ovirt.org
  Sent: Friday, February 27, 2015 4:54:31 PM
  Subject: Re: [ovirt-users] Sync Error on Master Domain after adding a 
  second one
  
  I think I finally managed to replicate the problem:
  
  1. deploy a datacenter with a virt only cluster and a gluster only cluster
  2. create a first GlusterFS Storage Domain (e.g. DATA) and activate it
  (should become Master)
  3. create a second GlusterFS Storage Domain (e.g. DATA_NEW) and activate it
  4. put DATA in maintenance
  
  Both Storage Domains flows between the following states:
  https://www.dropbox.com/s/x542q1epf40ar5p/Screencast%20from%2027-02-2015%2015%3A09%3A29.webm?dl=1
  
  Webadmin Events shows: Sync Error on Master Domain between Host v10 and
  oVirt Engine. Domain: DATA is marked as Master in oVirt Engine database but
  not on the Storage side. Please consult with Support on how to fix this
  issue.
  
  It seems DATA can be deactivated at the second attempt.
  
  --
  Stefano Stagnaro
  
  Prisma Engineering S.r.l.
  Via Petrocchi, 4
  20127 Milano – Italy
  
  Tel. 02 26113507 int 339
  e-mail: stefa...@prisma-eng.com
  skype: stefano.stagnaro
  
  On mer, 2015-02-25 at 15:41 

[ovirt-users] oVirt Weekly Meeting Minutes -- 2015-03-04

2015-03-04 Thread Yaniv Dary

Minutes: http://ovirt.org/meetings/ovirt/2015/ovirt.2015-03-04-15.03.html
Minutes (text): 
http://ovirt.org/meetings/ovirt/2015/ovirt.2015-03-04-15.03.txt

Log: http://ovirt.org/meetings/ovirt/2015/ovirt.2015-03-04-15.03.log.html

=
#ovirt: oVirt Weekly Sync
=


Meeting started by ydary at 15:03:12 UTC. The full logs are available at
http://ovirt.org/meetings/ovirt/2015/ovirt.2015-03-04-15.03.log.html .



Meeting summary
---
* Agenda and roll Call  (ydary, 15:03:24)
  * conferences and workshops  (ydary, 15:03:25)
  * infra update  (ydary, 15:03:25)
  * 3.5.z updates  (ydary, 15:03:25)
  * 3.6.0 status  (ydary, 15:03:25)
  * other topics  (ydary, 15:03:26)

* conferences and workshops  (ydary, 15:06:32)
  * mlipchuk and bkp will be attending FOSSAsia next week, each
delivering a talk, and hosting the half-day workshop on March 14.
(ydary, 15:07:50)
  * ACTION: Please push the workshop in #FOSSAsia on social media as you
can, and if you have colleagues in east Asia, ask them for some
social media love too!  (ydary, 15:08:13)
  * KVM Forum planning is proceeding apace. Registration is now open, so
pass the word along! Link:
http://events.linuxfoundation.org/events/kvm-forum/attend/register
(ydary, 15:08:42)
  * ACTION: If you want to speak at KVM Forum, CfP is open, too, at:
http://events.linuxfoundation.org/events/kvm-forum/program/cfp
Speakers, by the way. get free registration.  (ydary, 15:09:07)
  * we will be hosting another oVirt Workshop within the KVM Forum
event, but this time it will be an official track. This means if you
are speaking at the workshop, you will be an official KVM Forum
speaker. (So we won't have the whole pay for passes problem we had
last year in Duesseldorf.)  (ydary, 15:09:38)
  * we will be co-hosting a joint hackathon (Aug. 18) with the Xen
Project on the day before the official conference start on Aug. 19.
There will also be a join Xen/KVM social event on the evening of the
18th.  (ydary, 15:10:03)
  * Rene Koch will be speaking at Chemnitzer Linux Days on Sunday March,
22nd. gshereme will be speaking on Using Bootstrap with Google Web
Toolkit as POSSCON in South Carolina on April 14-15.  (ydary,
15:10:16)

* infra update  (ydary, 15:10:47)
  * Quiet week in infra. No major issues.  (ydary, 15:12:35)

* 3.5.z updates  (ydary, 15:13:58)
  * Update on 3.5.z status:
http://lists.ovirt.org/pipermail/users/2015-March/031663.html
(ydary, 15:15:00)
  * One blocker on 3.5.2 that will delay GA. Virt issue BZ #1176937.
(ydary, 15:17:30)
  * ACTION: ydary to review BZ #1176937 to make sure it is indeed a
blocker.  (ydary, 15:20:20)
  * sbonazzo created management page and tracker for oVirt 3.5.3. Please
update it with relevant bugs as needed.  (ydary, 15:21:41)

* 3.6 status  (ydary, 15:22:58)
  * oVirt 3.6.0 Status update:
http://lists.ovirt.org/pipermail/users/2015-March/031664.html
(ydary, 15:25:03)
  * The bug count stopped to increase and started going down.  (ydary,
15:25:18)
  * UX 3.6.0 Status Update: Nothing new to report from UX side, still a
bunch of pending patches.  (ydary, 15:25:50)
  * Infra 3.6.0 Status Update: Still working hard on pushing upgrade
manager, uniform SSO support, fencing refactoring, events mechanism
and other action items related to SPM removal and v2v.  (ydary,
15:26:46)
  * Integration 3.6 Status Update:  tiraboschi still working on
packaging vdsm for debian, now looking at libvirt.  (ydary,
15:28:24)
  * Network 3.6.0 Status Update: Not much progress since last week on
3.6. The big features, REST API and SR-IOV are moving along nicely.
(ydary, 15:30:03)
  * Gluster 3.6.0 Status Update: Network reviewed Gluster Network
feature patches should merge during the next week.  (ydary,
15:33:46)
  * Good progress on patch reviews for other features as well.  (ydary,
15:34:13)
  * ACTION: sahina  lvernia should merge Gluster Network feature in the
coming week.  (ydary, 15:34:52)
  * Storage 3.6.0 Status Update: Some progress on 3.6 features but not
too much, most of the team are occupied with the weekathon items,
going on this week.  (ydary, 15:37:05)
  * Virt 3.6.0 Status Update: Still working on 3.6 items, some small
features already in like migration enhancements. The major features
still have a way to go, like v2v, virtio console and more.  (ydary,
15:40:27)
  * Some WIP patches for major features already pushed to gerrit.
(ydary, 15:42:16)
  * Node 3.6.0 Status Update: No updates from last week.  (ydary,
15:45:44)
  * SLA 3.6.0 Status Update: Progress on hosted engine items for 3.6.
Editing an HE VM is doable and the research on that may take some
more time.  (ydary, 15:47:33)
  * Martin started working on taking host memory into account when doing
load-balancing.  (ydary, 15:48:22)
  * No updates on 

Re: [ovirt-users] Ovirt engine-setup fails, Cannot get JAVA_HOME

2015-03-04 Thread Carter Kindley
Hey folks,

Icedtea-7 allows engine-setup to complete - almost... 

The setup now fails on cleanup: [ ERROR ] Failed to execute stage 'Closing 
up': Command '/usr/bin/systemctl' failed to execute. The log files indicate 
that systemctl is attempting to start a unit file (presumably 
ovirt-engine.service) which does not exist. I'm happy to write my own, but it 
would be awesome to see what is used as best practice from the oVirt community. 

Thanks so much for the responses already. I appreciate it!

Carter Kindley
Network Qualified Technician
Deus Machine, LLC

-Original Message-
From: Yedidyah Bar David [mailto:d...@redhat.com] 
Sent: Tuesday, March 3, 2015 11:16 PM
To: Carter Kindley; Alon Bar-Lev
Cc: users@ovirt.org
Subject: Re: [ovirt-users] Ovirt engine-setup fails, Cannot get JAVA_HOME

- Original Message -
 From: Carter Kindley carter.kind...@deusmachine.com
 To: users@ovirt.org
 Sent: Tuesday, March 3, 2015 11:30:59 PM
 Subject: Re: [ovirt-users] Ovirt engine-setup fails, Cannot get JAVA_HOME
 
 Thanks, Didi!
 
 That really helped. I could not figure out what was getting parsed to 
 set JAVA_HOME, thanks for indicating those scripts. In my environment 
 there is a java-home.local;

Probably added by Alon.

 it pulls the home by running # exec java-config
 --select-vm=icedtea-7 --jre-home  , which outputs a warning message 
 because I have icedtea-bin-7 installed. I could change this script, or 
 emerge
 icedtea-7 from sources (which is what I'll do, since I am not partial 
 to binary builds).

Seems simplest to me.

 OVirt isn't in the main portage tree; I should contact the overlay 
 maintainer to correct this script.

That's Alon, iiuc...

Alon - any problem using the binary build?

Best regards,
--
Didi

 
 Cheers,
 
 Carter Kindley
 Network Qualified Technician
 Deus Machine, LLC
 
 -Original Message-
 From: Yedidyah Bar David [mailto:d...@redhat.com]
 Sent: Monday, March 2, 2015 11:05 PM
 To: Carter Kindley
 Cc: users@ovirt.org
 Subject: Re: [ovirt-users] Ovirt engine-setup fails, Cannot get JAVA_HOME
 
 - Original Message -
  From: Carter Kindley carter.kind...@deusmachine.com
  To: users@ovirt.org
  Sent: Tuesday, March 3, 2015 3:06:44 AM
  Subject: [ovirt-users] Ovirt engine-setup fails, Cannot get JAVA_HOME
  
  
  
  Hello folks,
  
  
  
  After a long, long time compiling permutations, I went to finish 
  setup of ovirt-engine on my Gentoo testbed. Running engine-setup, I 
  receive an error after answering all prompts:
  
  
  
  [ ERROR ] Failed to execute stage 'Setup validation': Cannot get 
  JAVA_HOME ([u'\x1b[01m\x1b[31;06m!!! ERROR: The vm could not be
  found\x1b[0m'])
  
  
  
  This machine has icedtea-bin-7.2.5.3, and # echo $JAVA_HOME yields 
  /etc/java-config-2/current-system-vm which is linked to the 
  icedtea-bin VM directory. Any thoughts to get me started?
 
 The jre to use is determined by the script java-home (usually in 
 /usr/share/ovirt-engine/bin, not sure about gentoo and/or your $PREFIX).
 IIRC only openjdk 1.7.0 is supported. If you look at this script, you 
 see that if you put in its directory a script called java-home.local 
 it will be called instead, thus letting you override that. Just add 
 there a script outputting the JAVA_HOME you want and retry.
 
 Best,
 --
 Didi
 
 
 This email has been scanned for viruses and private content.
 
 This message has been secured for compliance with the DM Cloud Mail 
 Filter Service.
 
 For details on inbound and outbound filtering please contact your 
 account specialist or primary technician.
 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
 

This email has been scanned for viruses and private content. 

This message has been secured for compliance with the DM Cloud Mail Filter 
Service. 

For details on inbound and outbound filtering please contact your account 
specialist or primary technician.
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] [ACTION REQUIRED] oVirt 3.5.2 and 3.5.3 status

2015-03-04 Thread Sandro Bonazzola
Hi,
We still have one open blocker for 3.5.2[1]:

Bug ID  Whiteboard  Status  Summary
1176937 virtASSIGNEDInstance type: delta icon (new 
configuration for next run) does not appear on running pool VMs.

ACTION: Tomas Jelinek to provide ETA for the blocker bug.

We also had 4 blockers fixed since 3.5.2 RC1[2] so a new RC will be scheduled 
when the last blocker will be fixed and GA postponed to one week later
as release criteria for RC1 are not met.

We still have 16 bugs in MODIFIED and 45 on QA[8]:

Whiteboard  MODIFIEDON_QA   Total
infra   8   15  23
integration 0   4   4
network 2   3   5
node1   0   1
sla 2   3   5
storage 3   13  16
virt0   7   7
Total   16  45  61

ACTION: Maintainers/Assignee: please move bugs to ON_QA if they're included in 
3.5.2 RC1
ACTION: Testers: you're welcome to verify bugs currently ON_QA.


All remaining bugs not marked as blockers have been moved to 3.5.3.
A release management entry has been added for tracking the schedule of 3.5.3[3]
A bug tracker [4] has been created for 3.5.3.
We have 33 bugs currently targeted to 3.5.3[5]:

Whiteboard  NEW ASSIGNEDPOSTTotal
doc 1   0   0   1
docs1   0   0   1
gluster 4   0   1   5
infra   2   2   0   4
integration 1   0   0   1
network 0   1   0   1
node3   0   1   4
ppc 0   0   1   1
sla 4   0   0   4
storage 8   0   0   8
ux  0   0   1   1
virt1   0   1   2
Total   25  3   5   33

ACTION: Maintainers / Assignee: to review the bugs targeted to 3.5.3 ensuring 
they're correctly targeted.
ACTION: Maintainers: to fill release notes for 3.5.2, the page has been created 
and updated here [6]
ACTION: Testers: please add yourself to the test page [7]

[1] https://bugzilla.redhat.com/1186161
[2] 
https://bugzilla.redhat.com/buglist.cgi?action=wrapbug_id=1179558%2C1188176%2C1194410%2C1196327
[3] http://www.ovirt.org/OVirt_3.5.z_Release_Management#oVirt_3.5.3
[4] https://bugzilla.redhat.com/1198142
[5] 
https://bugzilla.redhat.com/buglist.cgi?quicksearch=product%3Aovirt%20target_release%3A3.5.3
[6] http://www.ovirt.org/OVirt_3.5.2_Release_Notes
[7] http://www.ovirt.org/Testing/oVirt_3.5.2_Testing
[8] http://goo.gl/UEVTCf

-- 
Sandro Bonazzola
Better technology. Faster innovation. Powered by community collaboration.
See how it works at redhat.com
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] [QE] oVirt 3.6.0 status

2015-03-04 Thread Sandro Bonazzola
Hi, here's an update on 3.6 status on integration / rel-eng side
The tracker bug for 3.6.0 [1] currently shows no blockers.

There are 560 bugs [2] targeted to 3.6.0.

NEW ASSIGNEDPOSTTotal
docs11  0   0   11
gluster 29  2   2   33
i18n2   0   0   2
infra   81  8   7   96
integration 61  5   4   70
network 32  2   9   43
node27  4   3   34
ppc 0   0   1   1
sla 53  3   0   56
spice   1   0   0   1
storage 72  5   6   83
ux  34  0   8   42
virt72  6   10  88
Total   475 35  50  560

Features submission is still open until 2015-04-22 as per current release 
schedule.
Maintainers: be sure to have your features tracked in the google doc[3]


[1] https://bugzilla.redhat.com/1155425
[2] 
https://bugzilla.redhat.com/buglist.cgi?quicksearch=target_release%3A3.6.0%20Product%3AoVirt%20status%3Anew%2Cassigned%2Cpost
[3] http://goo.gl/9X3G49

-- 
Sandro Bonazzola
Better technology. Faster innovation. Powered by community collaboration.
See how it works at redhat.com
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Help understanding Gluster in oVirt

2015-03-04 Thread Eduardo Ramos
I have setup an environment with 8 glustefs nodes in 
distributed+replicated mode. Instead of CTDB, I'm using keepalived. It 
works pretty well.


On 02/04/2015 04:14 PM, Donny Davis wrote:


I have two nodes running the hosted engine and gluster setup for 
replicate between them. Mounting to localhost seems to be working so 
far. I have live migrated the engine, pulled the plug on a running 
node, and rebooted each node to ensure it all works properly. I have 
had few issues with this setup. I didn’t like ctdb because it adds 
another layer of complexity that is unnecessary for MY setup.


Node1 gluster drive on sdb

Node2 gluster drive on sdb

Both replicate and are the same make and model drive.

ovirt-ha running on both for hosted-engine

This setup is for hosted engine only, my actual storage for VM’s and 
what not do not run in this fashion.


Hope This helps

Donny D

*From:*users-boun...@ovirt.org [mailto:users-boun...@ovirt.org] *On 
Behalf Of *Groten, Ryan

*Sent:* Wednesday, February 4, 2015 10:11 AM
*To:* Sahina Bose; users@ovirt.org
*Subject:* Re: [ovirt-users] Help understanding Gluster in oVirt

Nope in fact I followed the guide and found CTDB works quite well.  I 
am just trying to figure out the benefit because that would be another 
component to consider in the architecture.


*From:*Sahina Bose [mailto:sab...@redhat.com]
*Sent:* Tuesday, February 03, 2015 4:09 AM
*To:* Groten, Ryan; users@ovirt.org mailto:users@ovirt.org
*Subject:* Re: [ovirt-users] Help understanding Gluster in oVirt

On 01/28/2015 08:59 AM, Groten, Ryan wrote:

I was planning on making a Gluster Data domain to test, and found
some great information on this page:
http://community.redhat.com/blog/2014/05/ovirt-3-4-glusterized/

The article the author uses the CTDB service for VIP failover.  Is
it possible/recommended to not do this, and just create a gluster
volume on all the hosts in a cluster, then create the Gluster data
domain as localhost:gluster_vol?


Theoretically, it should work - if you make sure that you have a 
replica 3 gluster volume spread across 3 nodes, and these 3 nodes are 
your compute nodes as well - you should be fine without CTDB setup for 
failover and mounting as localhost.


But I've not tried this to recommend it. Maybe if others have tried 
it, they can chime in?


Btw, is there any reason you do not want to set up CTDB?

Thanks,

Ryan

ThTh

___
Users mailing list
Users@ovirt.org  mailto:Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users



___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] Help problem with vm after create a sub template

2015-03-04 Thread nicola.gentile.to

Good morning,
after I create a new sub template several vm of a pool remain with state 
'Image Locked'


What I do to solve?

Thank you so much

Nick
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users