[ovirt-users] new version of qemu

2016-06-22 Thread qinglong.d...@horebdata.cn
Hi, all
I have found that the latest version of qemu has been updated to 2.6. 
In the latest version it supports a new virtio-gpu device which supprts 
accelerated 2D and 3D. Qemu 2.3 is used in ovirt 3.6 for now. So I wonder when 
the version of qemu will be updated in ovirt or if I can update the version of 
qemu in ovirt myself.
Anyone can help? Thanks!



___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] ?==?utf-8?q? vds.dispatcher ERROR SSL in ovirt 4.0

2016-06-22 Thread Claude Durocher

Here's a more complete log of vdsm with the error :

https://drive.google.com/file/d/0B1CFwOEG9nMtcTR1Y3VWYjdJMnM/view?usp=sharing

I inserted a few blank lines to highlight the errors.




Le Vendredi, Juin 10, 2016 04:57 EDT, Piotr Kliczewski 
 a écrit:
 Claude,

Please look for "ProtocolDetector.AcceptorImpl::(handle_accept)
Accepting connection from ". The last part of this log message
contains peername.
I should help to understand which client is connecting.

>From the message I see that the client is disconnecting and as a
result we get: 'Connection reset by peer'

Please let us know about your findings.

Thanks,
Piotr

On Wed, Jun 8, 2016 at 11:49 PM, Claude Durocher
 wrote:
> I'm testing ovirt 4.0 rc1 on centos 7 (hosted engine on nfs). Every 15
> seconds or so, I receive the following error:
>
> journal: vdsm vds.dispatcher ERROR SSL error during reading data: (104,
> 'Connection reset by peer')
>
> Any ideas on how to debug this?
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>

 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] User admin@internal can't login in oVirt 3.6

2016-06-22 Thread Julián Tete
Thanks again :)

2016-06-22 11:14 GMT-05:00 Ondra Machacek :

> On 06/22/2016 05:21 PM, Julián Tete wrote:
>
>> S-O-L-V-E-D!!!
>>
>> You are a Wizard Ondra Machacek!!!
>>
>> Thank you very much !!! How Apache says: "It works"
>>
>
> Great! You are welcome
>
>
>> A have a question for you
>>
>> In the command
>>
>> su - postgres -c "psql -t engine -c \"insert into permissions values
>> ('001b-001b-001b-001b-029f',
>> '----0001',
>> 'fdfc627c-d875-11e0-90f0-83df133b58cc',
>> 'aaa0----123456789aaa', 1);\"
>>
>> What's the meaning of:
>>
>> 001b-001b-001b-001b-029f
>>
>
> This one is id of permission. It's auto generated.
>
>
>> ----0001
>>
>
> This one is id of role. This is id of SuperUser as you can see by running:
>
>  select * from roles;
>
>
>> aaa0----123456789aaa
>>
>
> This one is object id, in this case it's id of system.
>
>
>> 1
>>
>
> This one represent object type, it is number that represent some object
> for example 1 represent
> system object, number 2 represent Vm, number 3 Host... etc
>
>
>> ¿?
>>
>> Thanks again
>>
>>
>> 2016-06-22 5:22 GMT-05:00 Ondra Machacek > >:
>>
>> On 06/21/2016 09:18 PM, Julián Tete wrote:
>>
>> Roger Ondra!
>>
>> 1) su - postgres -c "psql -t engine -c \"delete from users where
>> user_id='7f300f43-9972-4c0e-bfa9-e86df6f1659f';\""
>>
>> Output:
>>
>> DELETE 1
>>
>> 2) su - postgres -c "psql -t engine -c \"UPDATE users set
>> domain='internal-authz'  where
>> user_id='fdfc627c-d875-11e0-90f0-83df133b58cc';\""
>>
>> Output:
>>
>> ERROR:  duplicate key value violates unique constraint
>> "users_domain_external_id_unique"
>> DETAIL:  Key (domain, external_id)=(internal-authz,
>> fdfc627c-d875-11e0-90f0-83df133b58cc) already exists.
>>
>>
>> OK, this is really strange, because this shouldn't be printed as you
>> removed all contraints in step 1).
>>
>> So, can you please first stop ovirt-engine, before running steps
>> above? So the steps now
>> would be:
>>
>>  1) service ovirt-engine stop
>>
>>  2) remove admin@internal-authz
>> (c9dcda67-9b3e-4255-aa9f-d69043a02b2b) (note id
>> changed, from last time) If there is more admin users with domain
>> internal-authz, please
>> remove them all.
>>   $ su - postgres -c "psql -t engine -c \"delete from users
>> where user_id='c9dcda67-9b3e-4255-aa9f-d69043a02b2b';\""
>>
>>  3) rename admin@internal to admin@internal-authz
>>   $ su - postgres -c "psql -t engine -c \"UPDATE users set
>> domain='internal-authz'  where
>> user_id='fdfc627c-d875-11e0-90f0-83df133b58cc;\""
>>
>>   4) service ovirt-engine start
>>
>>
>> 3) systemctl restart ovirt-engine.service
>>
>> No login yet :(
>>
>> Look at this:
>>
>> ovirt-aaa-jdbc-tool user show admin
>>
>> Output:
>> -- User admin(fdfc627c-d875-11e0-90f0-83df133b58cc) --
>> Namespace: *
>> Name: admin
>> ID: fdfc627c-d875-11e0-90f0-83df133b58cc
>> Display Name:
>> Email:
>> First Name: admin
>> Last Name:
>> Department:
>> Title:
>> Description:
>> Account Disabled: false
>> Account Unlocked At: 1970-01-01 00:00:00Z
>> Account Valid From: 2015-10-01 00:00:00Z
>> Account Valid To: 2100-01-01 00:00:00Z
>> Account Without Password: false
>> Last successful Login At: 2016-06-21 19:15:59Z
>> Last unsuccessful Login At: 2016-06-20 17:33:24Z
>> Password Valid To: 2100-01-01 00:00:00Z
>>
>> su - postgres -c "psql -t engine -c \"select * from users;\""
>>
>> Output:
>>
>>  fdfc627c-d875-11e0-90f0-83df133b58cc | admin  |   |
>> internal | admin||
>> |  | t   |
>> fdfc627c-d875-11e0-90f0-83df133b58cc
>> | 2015-09-19 21:38:44.838161-
>> 05 | 2016-06-18 20:42:18.883738-05 | *
>>  16f666bb-b4c8-44c9-8264-30c3aff63a6e || Administrator |
>> udistritaloas.edu.co 
>>  | admin
>> || |  | f
>> | 41cd26a2-0e0a-11e6-aa00-001a4a160159 | 2016-06-19
>> 11:53:39.249812-
>> 05 | 2016-06-19 12:24:41.590162-05  | *
>>  c01c263a-78c5-4524-a94e-c9aa38141ea9 | Julian | Tete  |
>> internal-authz   | julian   ||
>> danteconra...@gmail.com 
>> > > |  | f
>>|
>> 1ad3dc19-b15a-493c-9610-2ccdd0dac6af | 2016-06-20 

Re: [ovirt-users] oVirt 3.6.7 Fifth Release Candidate is now available for testing

2016-06-22 Thread Yaniv Kaul
On Wed, Jun 22, 2016 at 7:11 PM,  wrote:

> Hi Rafael,
>
> do you have an ETA for the version?
>
> The USB problem is a bit of a problem for me.
> Or it is possible to go to the release candidate now and later to the
> final version?
>

Yes.
Y.


>
> Best regards
>
> Christoph
>
>
> Am 21.06.2016 um 16:54 schrieb Rafael Martins:
>
>> The oVirt Project is pleased to announce the availability of the Fifth
>> Release
>> Candidate of oVirt 3.6.7 for testing, as of June 21th, 2016
>>
>> This release is available now for:
>> * Fedora 22
>> * Red Hat Enterprise Linux 6.7 or later
>> * CentOS Linux (or similar) 6.7 or later
>>
>> * Red Hat Enterprise Linux 7.2 or later
>> * CentOS Linux (or similar) 7.2 or later
>>
>> This release supports Hypervisor Hosts running:
>> * Red Hat Enterprise Linux 7.2 or later
>> * CentOS Linux (or similar) 7.2 or later
>> * Fedora 22
>>
>> This release candidate includes the following updated packages:
>>
>> * ovirt-engine
>> * vdsm
>>
>> See the release notes [1] for installation / upgrade instructions and a
>> list
>> of new features and bugs fixed.
>>
>> Notes:
>> * A new oVirt Live ISO is available [2].
>> * A new oVirt Appliance is available.
>> * Mirrors[3] might need up to one day to synchronize.
>>
>> Additional Resources:
>> * Read more about the oVirt 3.6.7 release highlights:
>> http://www.ovirt.org/release/3.6.7/
>> * Get more oVirt Project updates on Twitter: https://twitter.com/ovirt
>> * Check out the latest project news on the oVirt blog:
>> http://www.ovirt.org/blog/
>>
>> [1] http://www.ovirt.org/release/3.6.7/
>> [2] http://resources.ovirt.org/pub/ovirt-3.6-pre/iso/ovirt-live/
>> [3] http://www.ovirt.org/Repository_mirrors#Current_mirrors
>>
>> --
>> Rafael Martins
>> ___
>> Users mailing list
>> Users@ovirt.org
>> http://lists.ovirt.org/mailman/listinfo/users
>>
>>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] User admin@internal can't login in oVirt 3.6

2016-06-22 Thread Ondra Machacek

On 06/22/2016 05:21 PM, Julián Tete wrote:

S-O-L-V-E-D!!!

You are a Wizard Ondra Machacek!!!

Thank you very much !!! How Apache says: "It works"


Great! You are welcome



A have a question for you

In the command

su - postgres -c "psql -t engine -c \"insert into permissions values
('001b-001b-001b-001b-029f',
'----0001',
'fdfc627c-d875-11e0-90f0-83df133b58cc',
'aaa0----123456789aaa', 1);\"

What's the meaning of:

001b-001b-001b-001b-029f


This one is id of permission. It's auto generated.



----0001


This one is id of role. This is id of SuperUser as you can see by running:

 select * from roles;



aaa0----123456789aaa


This one is object id, in this case it's id of system.



1


This one represent object type, it is number that represent some object 
for example 1 represent

system object, number 2 represent Vm, number 3 Host... etc



¿?

Thanks again


2016-06-22 5:22 GMT-05:00 Ondra Machacek >:

On 06/21/2016 09:18 PM, Julián Tete wrote:

Roger Ondra!

1) su - postgres -c "psql -t engine -c \"delete from users where
user_id='7f300f43-9972-4c0e-bfa9-e86df6f1659f';\""

Output:

DELETE 1

2) su - postgres -c "psql -t engine -c \"UPDATE users set
domain='internal-authz'  where
user_id='fdfc627c-d875-11e0-90f0-83df133b58cc';\""

Output:

ERROR:  duplicate key value violates unique constraint
"users_domain_external_id_unique"
DETAIL:  Key (domain, external_id)=(internal-authz,
fdfc627c-d875-11e0-90f0-83df133b58cc) already exists.


OK, this is really strange, because this shouldn't be printed as you
removed all contraints in step 1).

So, can you please first stop ovirt-engine, before running steps
above? So the steps now
would be:

 1) service ovirt-engine stop

 2) remove admin@internal-authz
(c9dcda67-9b3e-4255-aa9f-d69043a02b2b) (note id
changed, from last time) If there is more admin users with domain
internal-authz, please
remove them all.
  $ su - postgres -c "psql -t engine -c \"delete from users
where user_id='c9dcda67-9b3e-4255-aa9f-d69043a02b2b';\""

 3) rename admin@internal to admin@internal-authz
  $ su - postgres -c "psql -t engine -c \"UPDATE users set
domain='internal-authz'  where
user_id='fdfc627c-d875-11e0-90f0-83df133b58cc;\""

  4) service ovirt-engine start


3) systemctl restart ovirt-engine.service

No login yet :(

Look at this:

ovirt-aaa-jdbc-tool user show admin

Output:
-- User admin(fdfc627c-d875-11e0-90f0-83df133b58cc) --
Namespace: *
Name: admin
ID: fdfc627c-d875-11e0-90f0-83df133b58cc
Display Name:
Email:
First Name: admin
Last Name:
Department:
Title:
Description:
Account Disabled: false
Account Unlocked At: 1970-01-01 00:00:00Z
Account Valid From: 2015-10-01 00:00:00Z
Account Valid To: 2100-01-01 00:00:00Z
Account Without Password: false
Last successful Login At: 2016-06-21 19:15:59Z
Last unsuccessful Login At: 2016-06-20 17:33:24Z
Password Valid To: 2100-01-01 00:00:00Z

su - postgres -c "psql -t engine -c \"select * from users;\""

Output:

 fdfc627c-d875-11e0-90f0-83df133b58cc | admin  |   |
internal | admin||
|  | t   |
fdfc627c-d875-11e0-90f0-83df133b58cc
| 2015-09-19 21:38:44.838161-
05 | 2016-06-18 20:42:18.883738-05 | *
 16f666bb-b4c8-44c9-8264-30c3aff63a6e || Administrator |
udistritaloas.edu.co 
 | admin
|| |  | f
| 41cd26a2-0e0a-11e6-aa00-001a4a160159 | 2016-06-19 11:53:39.249812-
05 | 2016-06-19 12:24:41.590162-05  | *
 c01c263a-78c5-4524-a94e-c9aa38141ea9 | Julian | Tete  |
internal-authz   | julian   ||
danteconra...@gmail.com 
> |  | f   |
1ad3dc19-b15a-493c-9610-2ccdd0dac6af | 2016-06-20 11:22:56.483292-
05 | 2016-06-20 11:23:19.261686-05 | *
 c9dcda67-9b3e-4255-aa9f-d69043a02b2b | admin  |   |
internal-authz   | admin||
|  | f   |
fdfc627c-d875-11e0-90f0-83df133b58cc
| 2016-06-21 13:54:07.765767-
05 | 2016-06-21 14:15:59.352697-05 | *


su - postgres -c "psql -t engine -c \"select * from permissions;\""

Output:


Re: [ovirt-users] Hosted Engine - Storage Domain registration

2016-06-22 Thread Roy Golan
On Jun 21, 2016 11:01 PM, "Anantha Raghava" 
wrote:
>
> Hi,
>
> I was able to map the hosted_storage to default DC. This appeared & got
attached after I mapped another NFS Share as Master Data Domain. Even the
HostedEngine VM appeared under Virtual Machines Tab and status was set to
up.
>
> I could install ovirt guest agent and got all other information reported
from agent service.
>
> But I noticed that although I have installed CentOS 7.2 in Hosted Engine,
VM reports it is a Desktop and not a Server. I attempted to change these
values and also the Clock off set, but received error as locked parameters
cannot be changed etc. Does the Hosted Engine really use a Desktop Profile?
Can't we change it?
>

No it's not really a desktop profile and you can't change that. Can you
please open a bug and describe the use case, specifically for the clock
offset.
It's not at our top priority atm but we can consider that. Maybe you can
send a patch?

> --
>
> Thanks & Regards,
>
> Anantha Raghava
> On Tuesday 21 June 2016 08:01 PM, Anantha Raghava wrote:
>>
>> Hi,
>>
>> I was able to install Hosted Engine on CentOS 7.2 Host with NFS Storage.
I faced challenge in registering the NFS Storage Domain - hosted_storage -
on which the Hosted Engine VM was created. When I attempt to attach the
hosted_storage to Data Center, the process fails and it could not register.
Hosted_Engine_Host is registered and is up & running, but data center is
down resulting in the infrastructure going down.
>>
>> Another question is, if this storage is not registered in domain, how
would engine vm migrate in case of host failure?
>>
>> Can some one guide me on this?
>> --
>>
>> Thanks & Regards,
>>
>> Anantha Raghava
>
>
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] User admin@internal can't login in oVirt 3.6

2016-06-22 Thread Julián Tete
S-O-L-V-E-D!!!

You are a Wizard Ondra Machacek!!!

Thank you very much !!! How Apache says: "It works"

A have a question for you

In the command

su - postgres -c "psql -t engine -c \"insert into permissions values
('001b-001b-001b-001b-029f',
'----0001',
'fdfc627c-d875-11e0-90f0-83df133b58cc',
'aaa0----123456789aaa', 1);\"

What's the meaning of:

001b-001b-001b-001b-029f

----0001

aaa0----123456789aaa

1

¿?

Thanks again


2016-06-22 5:22 GMT-05:00 Ondra Machacek :

> On 06/21/2016 09:18 PM, Julián Tete wrote:
>
>> Roger Ondra!
>>
>> 1) su - postgres -c "psql -t engine -c \"delete from users where
>> user_id='7f300f43-9972-4c0e-bfa9-e86df6f1659f';\""
>>
>> Output:
>>
>> DELETE 1
>>
>> 2) su - postgres -c "psql -t engine -c \"UPDATE users set
>> domain='internal-authz'  where
>> user_id='fdfc627c-d875-11e0-90f0-83df133b58cc';\""
>>
>> Output:
>>
>> ERROR:  duplicate key value violates unique constraint
>> "users_domain_external_id_unique"
>> DETAIL:  Key (domain, external_id)=(internal-authz,
>> fdfc627c-d875-11e0-90f0-83df133b58cc) already exists.
>>
>
> OK, this is really strange, because this shouldn't be printed as you
> removed all contraints in step 1).
>
> So, can you please first stop ovirt-engine, before running steps above? So
> the steps now
> would be:
>
>  1) service ovirt-engine stop
>
>  2) remove admin@internal-authz (c9dcda67-9b3e-4255-aa9f-d69043a02b2b)
> (note id
> changed, from last time) If there is more admin users with domain
> internal-authz, please
> remove them all.
>   $ su - postgres -c "psql -t engine -c \"delete from users where
> user_id='c9dcda67-9b3e-4255-aa9f-d69043a02b2b';\""
>
>  3) rename admin@internal to admin@internal-authz
>   $ su - postgres -c "psql -t engine -c \"UPDATE users set
> domain='internal-authz'  where
> user_id='fdfc627c-d875-11e0-90f0-83df133b58cc;\""
>
>   4) service ovirt-engine start
>
>
>> 3) systemctl restart ovirt-engine.service
>>
>> No login yet :(
>>
>> Look at this:
>>
>> ovirt-aaa-jdbc-tool user show admin
>>
>> Output:
>> -- User admin(fdfc627c-d875-11e0-90f0-83df133b58cc) --
>> Namespace: *
>> Name: admin
>> ID: fdfc627c-d875-11e0-90f0-83df133b58cc
>> Display Name:
>> Email:
>> First Name: admin
>> Last Name:
>> Department:
>> Title:
>> Description:
>> Account Disabled: false
>> Account Unlocked At: 1970-01-01 00:00:00Z
>> Account Valid From: 2015-10-01 00:00:00Z
>> Account Valid To: 2100-01-01 00:00:00Z
>> Account Without Password: false
>> Last successful Login At: 2016-06-21 19:15:59Z
>> Last unsuccessful Login At: 2016-06-20 17:33:24Z
>> Password Valid To: 2100-01-01 00:00:00Z
>>
>> su - postgres -c "psql -t engine -c \"select * from users;\""
>>
>> Output:
>>
>>  fdfc627c-d875-11e0-90f0-83df133b58cc | admin  |   |
>> internal | admin||
>> |  | t   | fdfc627c-d875-11e0-90f0-83df133b58cc
>> | 2015-09-19 21:38:44.838161-
>> 05 | 2016-06-18 20:42:18.883738-05 | *
>>  16f666bb-b4c8-44c9-8264-30c3aff63a6e || Administrator |
>> udistritaloas.edu.co  | admin
>> || |  | f
>> | 41cd26a2-0e0a-11e6-aa00-001a4a160159 | 2016-06-19 11:53:39.249812-
>> 05 | 2016-06-19 12:24:41.590162-05 | *
>>  c01c263a-78c5-4524-a94e-c9aa38141ea9 | Julian | Tete  |
>> internal-authz   | julian   || danteconra...@gmail.com
>>  |  | f   |
>> 1ad3dc19-b15a-493c-9610-2ccdd0dac6af | 2016-06-20 11:22:56.483292-
>> 05 | 2016-06-20 11:23:19.261686-05 | *
>>  c9dcda67-9b3e-4255-aa9f-d69043a02b2b | admin  |   |
>> internal-authz   | admin||
>> |  | f   | fdfc627c-d875-11e0-90f0-83df133b58cc
>> | 2016-06-21 13:54:07.765767-
>> 05 | 2016-06-21 14:15:59.352697-05 | *
>>
>>
>> su - postgres -c "psql -t engine -c \"select * from permissions;\""
>>
>> Output:
>>
>>  0004-0004-0004-0004-025e |
>> def9----def9 |
>> eee0----123456789eee |
>> ---- |  4 |1447535033
>>  000f-000f-000f-000f-0293 |
>> defa----def00010 |
>> eee0----123456789eee |
>> 000e-000e-000e-000e-02d6 | 27 |1447535033
>>  0003-0003-0003-0003-009c |
>> ----0001 |
>> fdfc627c-d875-11e0-90f0-83df133b58cc |
>> aaa0----123456789aaa |  1 |1447535033
>>  0006-0006-0006-0006-00e3 |
>> ---0001-0002 |
>> fdfc627c-d875-11e0-90f0-83df133b58cc |
>> aaa0----123456789aaa |  1 |1447535033
>>  0011-0011-0011-0011-02a9 |
>> def9----def9 |
>> 

Re: [ovirt-users] Slow Export Domain

2016-06-22 Thread Christophe TREFOIS
Hi Yaniv,

I was referring to this: https://bugzilla.redhat.com/show_bug.cgi?id=1156115

But I guess it’s fixed sine 3.6.

Kind regards,

—
Christophe

On 22 Jun 2016, at 13:52, Yaniv Kaul 
> wrote:



On Wed, Jun 22, 2016 at 1:31 PM, Christophe TREFOIS 
> wrote:
Not true, we have seen significant slowness because of the way oVirt exports 
the VMs, as well as I/O.

Can you elaborate on 'the way oVirt exports the VMs' ?
Y.


Best,

Dr Christophe Trefois, Dipl.-Ing.
Technical Specialist / Post-Doc

UNIVERSITÉ DU LUXEMBOURG

LUXEMBOURG CENTRE FOR SYSTEMS BIOMEDICINE
Campus Belval | House of Biomedicine
6, avenue du Swing
L-4367 Belvaux
T: +352 46 66 44 6124
F: +352 46 66 44 6949
http://www.uni.lu/lcsb

[Facebook]  [Twitter] 
   [Google Plus] 
   [Linkedin] 
   [skype] 




This message is confidential and may contain privileged information.
It is intended for the named recipient only.
If you receive it in error please notify me and permanently delete the original 
message and any copies.




On 22 Jun 2016, at 10:07, Vinzenz Feenstra 
> wrote:


On Jun 22, 2016, at 9:39 AM, Sven Achtelik 
> wrote:

Hi Everyone,

I’m trying to export VMs to an Export Domain for Backup and noticed that all of 
this is running at max 100Mbit/s. Is this some limitation that comes with the 
Export Domain ? I’ve checked all network connections and all of them report at 
least 1000Mbits/s.  Am I missing something ?

So from our side there’s no limitation. So there might be a router, switch or 
anything in between that does not support 1 GBit on your network. You’re really 
just limited here by Storage and/or Network bandwith.


Thank you,

Sven
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Slow Export Domain

2016-06-22 Thread Yaniv Kaul
You can change the mount options of the storage domain to v4.
Y.

On Wed, Jun 22, 2016 at 3:26 PM, Sven Achtelik 
wrote:

> Hi,
>
>
>
> I’ve done some testing and it turns out that my NFS-Server seems to be the
> limiting factor in combination with the used NFS version. The Server is a
> Windows Server 2012 R2 with “Service for Network File System” installed. I
> mounted the share from ovrit with the default nfs version 3 and it work but
> not more than 100Mbit/s and I don’t know why. When mounting the share on
> the host manually like so “mount –t nfs4 –o minorversion=1 172.16.6.7:/test
> /mnt/test/” I was able to get to about 400Mbit/s. It’s still far away from
> full speed  but that’s ok for me. I tried to change the NFS version in
> ovirt to V4, but with these settings the mount fails. It has to be NFS4.1 –
> can that be done over the GUI somehow or are there any other options ?
>
>
>
> Thank you,
>
>
>
> Sven
>
>
>
> *Von:* Vinzenz Feenstra [mailto:vfeen...@redhat.com]
> *Gesendet:* Mittwoch, 22. Juni 2016 12:40
> *An:* Christophe TREFOIS 
> *Cc:* Sven Achtelik ; users@ovirt.org
> *Betreff:* Re: [ovirt-users] Slow Export Domain
>
>
>
>
>
> On Jun 22, 2016, at 12:31 PM, Christophe TREFOIS <
> christophe.tref...@uni.lu> wrote:
>
>
>
> Not true, we have seen significant slowness because of the way oVirt
> exports the VMs, as well as I/O.
>
>
>
> Well all I wanted to say with this is, that there is no artificial
> limitation of the speed. At least not that I know of, if there’s an issue
> with the speed which is caused by a software issue on our side please do
> report a bug.
>
>
>
>
>
> Best,
>
> *Dr Christophe Trefois, Dipl.-Ing.*
> Technical Specialist / Post-Doc
>
> *UNIVERSITÉ DU LUXEMBOURG*
>
> *LUXEMBOURG CENTRE FOR SYSTEMS BIOMEDICINE*
> Campus Belval | House of Biomedicine
> 6, avenue du Swing
> L-4367 Belvaux
> T: +352 46 66 44 6124
> F: +352 46 66 44 6949
> http://www.uni.lu/lcsb
>
> [image: Facebook]   [image: Twitter]
>   [image: Google Plus]
>   [image: Linkedin]
>   [image: skype]
> 
>
>
>
> 
> This message is confidential and may contain privileged information.
> It is intended for the named recipient only.
> If you receive it in error please notify me and permanently delete the
> original message and any copies.
> 
>
>
>
>
>
> On 22 Jun 2016, at 10:07, Vinzenz Feenstra  wrote:
>
>
>
>
>
> On Jun 22, 2016, at 9:39 AM, Sven Achtelik 
> wrote:
>
>
>
> Hi Everyone,
>
>
>
> I’m trying to export VMs to an Export Domain for Backup and noticed that
> all of this is running at max 100Mbit/s. Is this some limitation that comes
> with the Export Domain ? I’ve checked all network connections and all of
> them report at least 1000Mbits/s.  Am I missing something ?
>
>
>
> So from our side there’s no limitation. So there might be a router, switch
> or anything in between that does not support 1 GBit on your network. You’re
> really just limited here by Storage and/or Network bandwith.
>
>
>
>
>
> Thank you,
>
>
>
> Sven
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
>
>
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Slow Export Domain

2016-06-22 Thread Sven Achtelik
Hi,

I’ve done some testing and it turns out that my NFS-Server seems to be the 
limiting factor in combination with the used NFS version. The Server is a 
Windows Server 2012 R2 with “Service for Network File System” installed. I 
mounted the share from ovrit with the default nfs version 3 and it work but not 
more than 100Mbit/s and I don’t know why. When mounting the share on the host 
manually like so “mount –t nfs4 –o minorversion=1 172.16.6.7:/test /mnt/test/” 
I was able to get to about 400Mbit/s. It’s still far away from full speed  but 
that’s ok for me. I tried to change the NFS version in ovirt to V4, but with 
these settings the mount fails. It has to be NFS4.1 – can that be done over the 
GUI somehow or are there any other options ?

Thank you,

Sven

Von: Vinzenz Feenstra [mailto:vfeen...@redhat.com]
Gesendet: Mittwoch, 22. Juni 2016 12:40
An: Christophe TREFOIS 
Cc: Sven Achtelik ; users@ovirt.org
Betreff: Re: [ovirt-users] Slow Export Domain


On Jun 22, 2016, at 12:31 PM, Christophe TREFOIS 
> wrote:

Not true, we have seen significant slowness because of the way oVirt exports 
the VMs, as well as I/O.

Well all I wanted to say with this is, that there is no artificial limitation 
of the speed. At least not that I know of, if there’s an issue with the speed 
which is caused by a software issue on our side please do report a bug.



Best,
Dr Christophe Trefois, Dipl.-Ing.
Technical Specialist / Post-Doc
UNIVERSITÉ DU LUXEMBOURG

LUXEMBOURG CENTRE FOR SYSTEMS BIOMEDICINE
Campus Belval | House of Biomedicine
6, avenue du Swing
L-4367 Belvaux
T: +352 46 66 44 6124
F: +352 46 66 44 6949
http://www.uni.lu/lcsb
[https://s3.amazonaws.com/htmlsig-assets/rounded/facebook.png]
  [https://s3.amazonaws.com/htmlsig-assets/rounded/twitter.png] 
   
[https://s3.amazonaws.com/htmlsig-assets/rounded/googleplus.png] 
   
[https://s3.amazonaws.com/htmlsig-assets/rounded/linkedin.png] 
   
[https://s3.amazonaws.com/htmlsig-assets/rounded/skype.png] 



This message is confidential and may contain privileged information.
It is intended for the named recipient only.
If you receive it in error please notify me and permanently delete the original 
message and any copies.



On 22 Jun 2016, at 10:07, Vinzenz Feenstra 
> wrote:


On Jun 22, 2016, at 9:39 AM, Sven Achtelik 
> wrote:

Hi Everyone,

I’m trying to export VMs to an Export Domain for Backup and noticed that all of 
this is running at max 100Mbit/s. Is this some limitation that comes with the 
Export Domain ? I’ve checked all network connections and all of them report at 
least 1000Mbits/s.  Am I missing something ?

So from our side there’s no limitation. So there might be a router, switch or 
anything in between that does not support 1 GBit on your network. You’re really 
just limited here by Storage and/or Network bandwith.



Thank you,

Sven
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Slow Export Domain

2016-06-22 Thread Yaniv Kaul
On Wed, Jun 22, 2016 at 1:31 PM, Christophe TREFOIS <
christophe.tref...@uni.lu> wrote:

> Not true, we have seen significant slowness because of the way oVirt
> exports the VMs, as well as I/O.
>

Can you elaborate on 'the way oVirt exports the VMs' ?
Y.


>
> Best,
>
> Dr Christophe Trefois, Dipl.-Ing.
> Technical Specialist / Post-Doc
>
> UNIVERSITÉ DU LUXEMBOURG
>
> LUXEMBOURG CENTRE FOR SYSTEMS BIOMEDICINE
> Campus Belval | House of Biomedicine
> 6, avenue du Swing
> L-4367 Belvaux
> T: +352 46 66 44 6124
> F: +352 46 66 44 6949
> http://www.uni.lu/lcsb
>
> [image: Facebook]   [image: Twitter]
>   [image: Google Plus]
>   [image: Linkedin]
>   [image: skype]
> 
>
> 
> This message is confidential and may contain privileged information.
> It is intended for the named recipient only.
> If you receive it in error please notify me and permanently delete the
> original message and any copies.
> 
>
>
> On 22 Jun 2016, at 10:07, Vinzenz Feenstra  wrote:
>
>
> On Jun 22, 2016, at 9:39 AM, Sven Achtelik 
> wrote:
>
> Hi Everyone,
>
> I’m trying to export VMs to an Export Domain for Backup and noticed that
> all of this is running at max 100Mbit/s. Is this some limitation that comes
> with the Export Domain ? I’ve checked all network connections and all of
> them report at least 1000Mbits/s.  Am I missing something ?
>
>
> So from our side there’s no limitation. So there might be a router, switch
> or anything in between that does not support 1 GBit on your network. You’re
> really just limited here by Storage and/or Network bandwith.
>
>
> Thank you,
>
> Sven
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Slow Export Domain

2016-06-22 Thread Vinzenz Feenstra

> On Jun 22, 2016, at 12:31 PM, Christophe TREFOIS  
> wrote:
> 
> Not true, we have seen significant slowness because of the way oVirt exports 
> the VMs, as well as I/O.

Well all I wanted to say with this is, that there is no artificial limitation 
of the speed. At least not that I know of, if there’s an issue with the speed 
which is caused by a software issue on our side please do report a bug.

> 
> Best,
> Dr Christophe Trefois, Dipl.-Ing.  
> Technical Specialist / Post-Doc
> 
> UNIVERSITÉ DU LUXEMBOURG
> 
> LUXEMBOURG CENTRE FOR SYSTEMS BIOMEDICINE
> Campus Belval | House of Biomedicine  
> 6, avenue du Swing 
> L-4367 Belvaux  
> T: +352 46 66 44 6124 
> F: +352 46 66 44 6949  
> http://www.uni.lu/lcsb 
>        
>    
>    
> 
> 
> This message is confidential and may contain privileged information. 
> It is intended for the named recipient only. 
> If you receive it in error please notify me and permanently delete the 
> original message and any copies. 
> 
>   
> 
>> On 22 Jun 2016, at 10:07, Vinzenz Feenstra > > wrote:
>> 
>> 
>>> On Jun 22, 2016, at 9:39 AM, Sven Achtelik >> > wrote:
>>> 
>>> Hi Everyone, 
>>>  
>>> I’m trying to export VMs to an Export Domain for Backup and noticed that 
>>> all of this is running at max 100Mbit/s. Is this some limitation that comes 
>>> with the Export Domain ? I’ve checked all network connections and all of 
>>> them report at least 1000Mbits/s.  Am I missing something ? 
>> 
>> So from our side there’s no limitation. So there might be a router, switch 
>> or anything in between that does not support 1 GBit on your network. You’re 
>> really just limited here by Storage and/or Network bandwith.
>> 
>>>  
>>> Thank you, 
>>>  
>>> Sven  
>>> ___
>>> Users mailing list
>>> Users@ovirt.org 
>>> http://lists.ovirt.org/mailman/listinfo/users 
>>> 
>> ___
>> Users mailing list
>> Users@ovirt.org 
>> http://lists.ovirt.org/mailman/listinfo/users
> 

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Slow Export Domain

2016-06-22 Thread Christophe TREFOIS
Not true, we have seen significant slowness because of the way oVirt exports 
the VMs, as well as I/O.

Best,

Dr Christophe Trefois, Dipl.-Ing.
Technical Specialist / Post-Doc

UNIVERSITÉ DU LUXEMBOURG

LUXEMBOURG CENTRE FOR SYSTEMS BIOMEDICINE
Campus Belval | House of Biomedicine
6, avenue du Swing
L-4367 Belvaux
T: +352 46 66 44 6124
F: +352 46 66 44 6949
http://www.uni.lu/lcsb

[Facebook]  [Twitter] 
   [Google Plus] 
   [Linkedin] 
   [skype] 



This message is confidential and may contain privileged information.
It is intended for the named recipient only.
If you receive it in error please notify me and permanently delete the original 
message and any copies.




On 22 Jun 2016, at 10:07, Vinzenz Feenstra 
> wrote:


On Jun 22, 2016, at 9:39 AM, Sven Achtelik 
> wrote:

Hi Everyone,

I’m trying to export VMs to an Export Domain for Backup and noticed that all of 
this is running at max 100Mbit/s. Is this some limitation that comes with the 
Export Domain ? I’ve checked all network connections and all of them report at 
least 1000Mbits/s.  Am I missing something ?

So from our side there’s no limitation. So there might be a router, switch or 
anything in between that does not support 1 GBit on your network. You’re really 
just limited here by Storage and/or Network bandwith.


Thank you,

Sven
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] User admin@internal can't login in oVirt 3.6

2016-06-22 Thread Ondra Machacek

On 06/21/2016 09:18 PM, Julián Tete wrote:

Roger Ondra!

1) su - postgres -c "psql -t engine -c \"delete from users where
user_id='7f300f43-9972-4c0e-bfa9-e86df6f1659f';\""

Output:

DELETE 1

2) su - postgres -c "psql -t engine -c \"UPDATE users set
domain='internal-authz'  where
user_id='fdfc627c-d875-11e0-90f0-83df133b58cc';\""

Output:

ERROR:  duplicate key value violates unique constraint
"users_domain_external_id_unique"
DETAIL:  Key (domain, external_id)=(internal-authz,
fdfc627c-d875-11e0-90f0-83df133b58cc) already exists.


OK, this is really strange, because this shouldn't be printed as you 
removed all contraints in step 1).


So, can you please first stop ovirt-engine, before running steps above? 
So the steps now

would be:

 1) service ovirt-engine stop

 2) remove admin@internal-authz (c9dcda67-9b3e-4255-aa9f-d69043a02b2b) 
(note id
changed, from last time) If there is more admin users with domain 
internal-authz, please

remove them all.
  $ su - postgres -c "psql -t engine -c \"delete from users where 
user_id='c9dcda67-9b3e-4255-aa9f-d69043a02b2b';\""


 3) rename admin@internal to admin@internal-authz
  $ su - postgres -c "psql -t engine -c \"UPDATE users set 
domain='internal-authz'  where 
user_id='fdfc627c-d875-11e0-90f0-83df133b58cc;\""


  4) service ovirt-engine start



3) systemctl restart ovirt-engine.service

No login yet :(

Look at this:

ovirt-aaa-jdbc-tool user show admin

Output:
-- User admin(fdfc627c-d875-11e0-90f0-83df133b58cc) --
Namespace: *
Name: admin
ID: fdfc627c-d875-11e0-90f0-83df133b58cc
Display Name:
Email:
First Name: admin
Last Name:
Department:
Title:
Description:
Account Disabled: false
Account Unlocked At: 1970-01-01 00:00:00Z
Account Valid From: 2015-10-01 00:00:00Z
Account Valid To: 2100-01-01 00:00:00Z
Account Without Password: false
Last successful Login At: 2016-06-21 19:15:59Z
Last unsuccessful Login At: 2016-06-20 17:33:24Z
Password Valid To: 2100-01-01 00:00:00Z

su - postgres -c "psql -t engine -c \"select * from users;\""

Output:

 fdfc627c-d875-11e0-90f0-83df133b58cc | admin  |   |
internal | admin||
|  | t   | fdfc627c-d875-11e0-90f0-83df133b58cc
| 2015-09-19 21:38:44.838161-
05 | 2016-06-18 20:42:18.883738-05 | *
 16f666bb-b4c8-44c9-8264-30c3aff63a6e || Administrator |
udistritaloas.edu.co  | admin
|| |  | f
| 41cd26a2-0e0a-11e6-aa00-001a4a160159 | 2016-06-19 11:53:39.249812-
05 | 2016-06-19 12:24:41.590162-05 | *
 c01c263a-78c5-4524-a94e-c9aa38141ea9 | Julian | Tete  |
internal-authz   | julian   || danteconra...@gmail.com
 |  | f   |
1ad3dc19-b15a-493c-9610-2ccdd0dac6af | 2016-06-20 11:22:56.483292-
05 | 2016-06-20 11:23:19.261686-05 | *
 c9dcda67-9b3e-4255-aa9f-d69043a02b2b | admin  |   |
internal-authz   | admin||
|  | f   | fdfc627c-d875-11e0-90f0-83df133b58cc
| 2016-06-21 13:54:07.765767-
05 | 2016-06-21 14:15:59.352697-05 | *


su - postgres -c "psql -t engine -c \"select * from permissions;\""

Output:

 0004-0004-0004-0004-025e |
def9----def9 |
eee0----123456789eee |
---- |  4 |1447535033
 000f-000f-000f-000f-0293 |
defa----def00010 |
eee0----123456789eee |
000e-000e-000e-000e-02d6 | 27 |1447535033
 0003-0003-0003-0003-009c |
----0001 |
fdfc627c-d875-11e0-90f0-83df133b58cc |
aaa0----123456789aaa |  1 |1447535033
 0006-0006-0006-0006-00e3 |
---0001-0002 |
fdfc627c-d875-11e0-90f0-83df133b58cc |
aaa0----123456789aaa |  1 |1447535033
 0011-0011-0011-0011-02a9 |
def9----def9 |
eee0----123456789eee |
0010-0010-0010-0010-01d1 |  4 |1447535033
 0013-0013-0013-0013-031e |
def9----def9 |
eee0----123456789eee |
0012-0012-0012-0012-01c6 |  4 |1447535033
 0015-0015-0015-0015-03b8 |
def9----def9 |
eee0----123456789eee |
0014-0014-0014-0014-02fd |  4 |1447535033
 0017-0017-0017-0017-0388 |
def9----def9 |
eee0----123456789eee |
0016-0016-0016-0016-02b0 |  4 |1447535033
 0019-0019-0019-0019-03d5 |
def9----def9 |
eee0----123456789eee |
0018-0018-0018-0018-0314 |  4 |1447535033
 0027-0027-0027-0027-027e |
def00021----def00015 |

Re: [ovirt-users] Slow Export Domain

2016-06-22 Thread Vinzenz Feenstra

> On Jun 22, 2016, at 9:39 AM, Sven Achtelik  wrote:
> 
> Hi Everyone, 
>  
> I’m trying to export VMs to an Export Domain for Backup and noticed that all 
> of this is running at max 100Mbit/s. Is this some limitation that comes with 
> the Export Domain ? I’ve checked all network connections and all of them 
> report at least 1000Mbits/s.  Am I missing something ? 

So from our side there’s no limitation. So there might be a router, switch or 
anything in between that does not support 1 GBit on your network. You’re really 
just limited here by Storage and/or Network bandwith.

>  
> Thank you, 
>  
> Sven  
> ___
> Users mailing list
> Users@ovirt.org 
> http://lists.ovirt.org/mailman/listinfo/users 
> 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] Slow Export Domain

2016-06-22 Thread Sven Achtelik
Hi Everyone,

I'm trying to export VMs to an Export Domain for Backup and noticed that all of 
this is running at max 100Mbit/s. Is this some limitation that comes with the 
Export Domain ? I've checked all network connections and all of them report at 
least 1000Mbits/s.  Am I missing something ?

Thank you,

Sven
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] [ANN] oVirt 4.0 reporting deprecation

2016-06-22 Thread Sandro Bonazzola
As the virtualization market matures, IT organizations need to deploy
virtualization features that help to deliver services faster while driving
innovation and eliminating costly manual tasks. oVirt 4.0 introduces a new
seamless system dashboard that is suited for large scale virtualization
environments. The dashboard provides easy access monitoring information for
the infrastructure including a resource global utilization overview of CPU,
memory, and storage host resources.

oVirt 4.0 will not include a suite of previously available JasperReports
Server pre-built reports. In the interim, users accustomed to this
functionality will need to use the data warehouses SQL API either directly
or through an external Business Intelligence tool or remain with oVirt
Reporting 3.6 on a separate server which will still work with 4.0 oVirt
Data Warehouse. In upcoming releases, oVirt will continue to enhance the
user experience by providing a metric store solution and a visualization
tool. Together, these tools will provide better scale and a richer set of
metric data. In addition, there will be enhanced advanced analytics,
self-service dashboards and widget creation functionality.

-- 
Sandro Bonazzola
Better technology. Faster innovation. Powered by community collaboration.
See how it works at redhat.com
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users