Re: [ovirt-users] oVirt 4.0.4 and Active Directory Kerberos SSO for Administration/User Portal. Troubleshooting

2016-10-02 Thread aleksey . maksimov

Up

30.09.2016, 18:55, "aleksey.maksi...@it-kb.ru" :
> Any other ideas?
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] 4.0 - 2nd node fails on deploy

2016-10-02 Thread Jason Jeffrey
Hi,

 

I am trying to build a x3 HC cluster, with a self hosted engine using
gluster.

 

I have successful built the 1st node,  however when I attempt to run
hosted-engine -deploy on node 2, I get the following error

 

[WARNING] A configuration file must be supplied to deploy Hosted Engine on
an additional host.

[ ERROR ] 'version' is not stored in the HE configuration image

[ ERROR ] Unable to get the answer file from the shared storage

[ ERROR ] Failed to execute stage 'Environment customization': Unable to get
the answer file from the shared storage

[ INFO  ] Stage: Clean up

[ INFO  ] Generating answer file
'/var/lib/ovirt-hosted-engine-setup/answers/answers-20161002232505.conf'

[ INFO  ] Stage: Pre-termination

[ INFO  ] Stage: Termination

[ ERROR ] Hosted Engine deployment failed

 

Looking at the failure in the log file..

 

2016-10-02 23:25:05 WARNING
otopi.plugins.gr_he_common.core.remote_answerfile
remote_answerfile._customization:151 A configuration

file must be supplied to deploy Hosted Engine on an additional host.

2016-10-02 23:25:05 DEBUG otopi.plugins.gr_he_common.core.remote_answerfile
remote_answerfile._fetch_answer_file:61 _fetch_answer_f

ile

2016-10-02 23:25:05 DEBUG otopi.plugins.gr_he_common.core.remote_answerfile
remote_answerfile._fetch_answer_file:69 fetching from:

/rhev/data-center/mnt/glusterSD/dcastor02:engine/0a021563-91b5-4f49-9c6b-fff
45e85a025/images/f055216c-02f9-4cd1-a22c-d6b56a0a8e9b/7

8cb2527-a2e2-489a-9fad-465a72221b37

2016-10-02 23:25:05 DEBUG otopi.plugins.gr_he_common.core.remote_answerfile
heconflib._dd_pipe_tar:69 executing: 'sudo -u vdsm dd i

f=/rhev/data-center/mnt/glusterSD/dcastor02:engine/0a021563-91b5-4f49-9c6b-f
ff45e85a025/images/f055216c-02f9-4cd1-a22c-d6b56a0a8e9b

/78cb2527-a2e2-489a-9fad-465a72221b37 bs=4k'

2016-10-02 23:25:05 DEBUG otopi.plugins.gr_he_common.core.remote_answerfile
heconflib._dd_pipe_tar:70 executing: 'tar -tvf -'

2016-10-02 23:25:05 DEBUG otopi.plugins.gr_he_common.core.remote_answerfile
heconflib._dd_pipe_tar:88 stdout:

2016-10-02 23:25:05 DEBUG otopi.plugins.gr_he_common.core.remote_answerfile
heconflib._dd_pipe_tar:89 stderr:

2016-10-02 23:25:05 ERROR otopi.plugins.gr_he_common.core.remote_answerfile
heconflib.validateConfImage:111 'version' is not stored

in the HE configuration image

2016-10-02 23:25:05 ERROR otopi.plugins.gr_he_common.core.remote_answerfile
remote_answerfile._fetch_answer_file:73 Unable to get t

he answer file from the shared storage

 

Looking at the detected gluster path -
/rhev/data-center/mnt/glusterSD/dcastor02:engine/0a021563-91b5-4f49-9c6b-fff
45e85a025/images/f055216c-02f9-4cd1-a22c-d6b56a0a8e9b/

 

[root@dcasrv02 ~]# ls -al
/rhev/data-center/mnt/glusterSD/dcastor02:engine/0a021563-91b5-4f49-9c6b-fff
45e85a025/images/f055216c-02f9-4cd1-a22c-d6b56a0a8e9b/

total 1049609

drwxr-xr-x. 2 vdsm kvm   4096 Oct  2 04:46 .

drwxr-xr-x. 6 vdsm kvm   4096 Oct  2 04:46 ..

-rw-rw. 1 vdsm kvm 1073741824 Oct  2 04:46
78cb2527-a2e2-489a-9fad-465a72221b37

-rw-rw. 1 vdsm kvm1048576 Oct  2 04:46
78cb2527-a2e2-489a-9fad-465a72221b37.lease

-rw-r--r--. 1 vdsm kvm294 Oct  2 04:46
78cb2527-a2e2-489a-9fad-465a72221b37.meta  

 

78cb2527-a2e2-489a-9fad-465a72221b37 is  a 1 GB file, is this the engine VM
?

 

Copying the answers file form primary (/etc/ovirt-hosted-engine/answers.conf
) to  node 2 and rerunning produces the same error : (

(hosted-engine --deploy  --config-append=/root/answers.conf )

 

Also tried on node 3, same issues 

 

Happy to provide logs and other debugs

 

Thanks 

 

Jason 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] VM has paused due to no storage space error

2016-10-02 Thread Sandvik Agustin
hi,

thanks for the reply, *without user interaction.", yes, I still have free
space of 26.7TB out of 50TB, i'll try to attach some of the vdsm logs
related to this, but is there any chance that this can be cause of network
problem and, or system time not sync for each hypervisor and ovirt-engein?

Thanks Again,
Sandvik

On Sun, Oct 2, 2016 at 6:55 PM, Nir Soffer  wrote:

> On Sun, Oct 2, 2016 at 12:06 PM, Sandvik Agustin
>  wrote:
> > Hi users,
> >
> > I have this problem that sometimes 1 to 3 VM just automatically paused
> with
> > user interaction and getting this error "VM has paused due to no storage
> > space error". any inputs from you guys are very appreciated.
>
> This is expected - when there is no storage space :-)
>
> The vm is paused when there are some io pending io requests that
> could not be fulfilled since you don't have enough space.
>
> In a real machine the io requests would fail. In a vm, the vm can pause,
> you can fix the issue (extend the storage domain), and resume the vm.
>
> But I guess there is storage space available, otherwise you would
> not spend the time sending this mail.
>
> This can happen when using thin provisioned disks on block storage
> (iSCSI, FC). We provision such disk with 1G, and and extend the disk
> (add 1G) when it becomes too full (by default, free space < 0.5G).
>
> If we fail to extend the disk quick enough, the vm will pause before the
> extend was completed. Once the extend was completed, we resume
> the vm.
>
> So you may see very short pauses, but they should be rare.
>
> To understand the issue, we need to inspect vdsm logs from the host
> running the vm that paused, showing the timeframe when the vm
> was paused.
>
> You should see this message in the log each time a vm pauses:
>
> abnormal vm stop device  error ENOSPC
>
> Nir
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] VM has paused due to no storage space error

2016-10-02 Thread Nir Soffer
On Sun, Oct 2, 2016 at 12:06 PM, Sandvik Agustin
 wrote:
> Hi users,
>
> I have this problem that sometimes 1 to 3 VM just automatically paused with
> user interaction and getting this error "VM has paused due to no storage
> space error". any inputs from you guys are very appreciated.

This is expected - when there is no storage space :-)

The vm is paused when there are some io pending io requests that
could not be fulfilled since you don't have enough space.

In a real machine the io requests would fail. In a vm, the vm can pause,
you can fix the issue (extend the storage domain), and resume the vm.

But I guess there is storage space available, otherwise you would
not spend the time sending this mail.

This can happen when using thin provisioned disks on block storage
(iSCSI, FC). We provision such disk with 1G, and and extend the disk
(add 1G) when it becomes too full (by default, free space < 0.5G).

If we fail to extend the disk quick enough, the vm will pause before the
extend was completed. Once the extend was completed, we resume
the vm.

So you may see very short pauses, but they should be rare.

To understand the issue, we need to inspect vdsm logs from the host
running the vm that paused, showing the timeframe when the vm
was paused.

You should see this message in the log each time a vm pauses:

abnormal vm stop device  error ENOSPC

Nir
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] VM has paused due to no storage space error

2016-10-02 Thread Sandvik Agustin
Hi users,

I have this problem that sometimes 1 to 3 VM just automatically paused with
user interaction and getting this error "VM has paused due to no storage
space error". any inputs from you guys are very appreciated.

TIA
Sandvik
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users