Re: [ovirt-users] [Python SDK] Setup Host network with IP address

2017-03-23 Thread TranceWorldLogic .
Sorry, I made a stupid mistake. I given wrong IP itself ... it need to be 30 rather than 300. Please ignore mail. On Fri, Mar 24, 2017 at 10:12 AM, TranceWorldLogic . < tranceworldlo...@gmail.com> wrote: > Hi, > > I am trying to setup network via python sdk as shown below: > >

[ovirt-users] [Python SDK] Setup Host network with IP address

2017-03-23 Thread TranceWorldLogic .
Hi, I am trying to setup network via python sdk as shown below: myhost_service.setup_networks( modified_network_attachments = [ types.NetworkAttachment( host = myhost, host_nic =

[ovirt-users] ovirt Node Building

2017-03-23 Thread shubham dubey
Hello, I have recently build ovirt-engine from source using this link( http://www.ovirt.org/develop/developer-guide/engine/engine-development-environment/). Now I want to build ovirt node using this( http://www.ovirt.org/develop/projects/node/building/). I am confused that can I build that node on

[ovirt-users] Setting up hosted engine appliance on a bonded interface

2017-03-23 Thread Bryan Sockel
Hi, I am attempting to deploy an appliance to a bonded interface, and i getting this error when it attempts to setup the bridge: [ ERROR ] Failed to execute stage 'Misc configuration': Failed to setup networks {'ovirtmgmt': {'bonding': 'bond0', 'ipaddr': u'10.20.101.181', 'netmask':

[ovirt-users] Answer file key for "nonlocal postgres"

2017-03-23 Thread Jamie Lawrence
Hello, I’m working on an answerfile for an unattended Ovirt install. The engine and the data warehouse DBs live remotely. I think I have most of the relevant keys defined, but appear to be missing one, because the installer is attempting to manage a local Postgres. Log and error below. Keys

Re: [ovirt-users] Getting error when i try to assign logical networks to interfaces

2017-03-23 Thread Dan Kenigsberg
On Thu, Mar 23, 2017 at 9:25 AM, martin chamambo wrote: > I havent set up any hooks and when i try to assign logical networks to an > already existing interface on the host ,it gives me this error > > Hook error: Hook Error: ('Traceback (most recent call last):\n File >

[ovirt-users] strange behavior of ovirt-node ng update

2017-03-23 Thread Sergey Kulikov
I have one Ovirt Node in my test cluster(others are centos), I'm observing strange behavior of update checker in engine. In options I can see: engine=# select * from vdc_options where option_name='OvirtNodePackageNamesForCheckUpdate'; option_id | option_name |

[ovirt-users] Upgrade from 3.6 to 4.1

2017-03-23 Thread Brett Holcomb
I am currently running oVirt 3.6 on a physical server using hosted engine environment. I have one server since it's a lab setup. The storage is on a Synology 3615xs iSCSI LUN so that's where the vms are. I plan to upgrade to 4.1 and need to check to make sure I understand the procedure.

Re: [ovirt-users] ovirt-shell backup

2017-03-23 Thread Juan Hernández
On 03/23/2017 02:40 PM, Marcin Kruk wrote: > Hello is it possible to execute below actions from the ovirth-shell: > 1. Make snapshot > ( ovirt-shell -E 'add snapshot --parent-vm-name --description > ) > 2. Make clone from snaphot above > ( ? ) > 3. Export clone > ( ? ) > The ovirt-shell tools

[ovirt-users] VMs changing to unknown state

2017-03-23 Thread Michael Watters
I have an ovirt host running ovirt 4.0 which keeps putting the VMs running on that host into an unknown state. I checked the vdsm logs and there are several errors similar to below. Mar 20 10:16:11 ovirt-node-production3.example.com vdsm[17123]: vdsm root ERROR Unhandled exception Traceback

Re: [ovirt-users] Getting error when i try to assign logical networks to interfaces

2017-03-23 Thread martin chamambo
Planning on using ISCSI , and it seems like defining logical networks is a pre-requisite for your host to come online and that error is happening when i try to assign the ovirtmngmnt logical network to an interface On Thu, Mar 23, 2017 at 6:58 PM, Dominik Holler wrote: >

Re: [ovirt-users] Getting error when i try to assign logical networks to interfaces

2017-03-23 Thread Dominik Holler
Are you using Fibre Channel over Ethernet? On Thu, 23 Mar 2017 09:25:04 +0200 martin chamambo wrote: > I havent set up any hooks and when i try to assign logical networks > to an already existing interface on the host ,it gives me this error > > Hook error: Hook Error:

Re: [ovirt-users] Roadmap

2017-03-23 Thread Julián Tete
Mmmm Interesting There is not something in general for the project like this in Trello ?: https://trello.com/b/XBd0CmFk/rh-ovirt-4-0-ui-overhaul and https://trello.com/b/lqNXh8uI/ovirt-4-1-ovn I found this article also:

Re: [ovirt-users] NFS ISO domain from hosted-engine VM

2017-03-23 Thread Devin A. Bougie
On Mar 23, 2017, at 10:51 AM, Yedidyah Bar David wrote: > On Thu, Mar 23, 2017 at 4:12 PM, Devin A. Bougie > wrote: >> Hi, All. Are there any recommendations or best practices WRT whether or not >> to host an NFS ISO domain from the hosted-engine VM

Re: [ovirt-users] Cloud init and vms

2017-03-23 Thread Artyom Lukianov
Just be sure that the cloud-init service enabled before you create the template, otherwise it will fail to initialize a VM. Best Regards On Thu, Mar 23, 2017 at 1:06 PM, Endre Karlson wrote: > Hi, is there any prerequisite setup on a Ubuntu vm that is turned into a >

Re: [ovirt-users] NFS ISO domain from hosted-engine VM

2017-03-23 Thread Yedidyah Bar David
On Thu, Mar 23, 2017 at 4:12 PM, Devin A. Bougie wrote: > Hi, All. Are there any recommendations or best practices WRT whether or not > to host an NFS ISO domain from the hosted-engine VM (running the oVirt Engine > Appliance)? We have a hosted-engine 4.1.1 cluster

[ovirt-users] NFS ISO domain from hosted-engine VM

2017-03-23 Thread Devin A. Bougie
Hi, All. Are there any recommendations or best practices WRT whether or not to host an NFS ISO domain from the hosted-engine VM (running the oVirt Engine Appliance)? We have a hosted-engine 4.1.1 cluster up and running, and now just have to decide where to serve the NFS ISO domain from. Many

Re: [ovirt-users] OVS switch type for hosted-engine

2017-03-23 Thread Devin A. Bougie
Just to close this thread, we were able to manually convert our hosted-engine 4.1.1 cluster from the Legacy to OVS switch types. Very roughly: - Install first host and VM using "hosted-engine --deploy" - In the Engine UI, change Cluster switch type from Legacy to OVS - Shutdown the engine VM and

Re: [ovirt-users] hosted-engine with iscsi storage domain

2017-03-23 Thread Devin A. Bougie
Hi Simone, On Mar 21, 2017, at 4:06 PM, Simone Tiraboschi wrote: > Did you already add your first storage domain for regular VMs? > If also that one is on iSCSI, it should be connected trough a different iSCSI > portal. Sure enough, once we added the data storage the

[ovirt-users] ovirt-shell backup

2017-03-23 Thread Marcin Kruk
Hello is it possible to execute below actions from the ovirth-shell: 1. Make snapshot ( ovirt-shell -E 'add snapshot --parent-vm-name --description ) 2. Make clone from snaphot above ( ? ) 3. Export clone ( ? ) ___ Users mailing list Users@ovirt.org

Re: [ovirt-users] Python-SDK: ovirtsdk4.Connection object autologout?

2017-03-23 Thread nicolas
ovirt-engine-backend-4.1.0.4-1.el7.centos.noarch El 2017-03-23 12:53, Ravi Nori escribió: Can you give me the exact rpm version of ovirt-engine-backend, I can give you a replacement jar file to test On Thu, Mar 23, 2017 at 3:56 AM, wrote: Hi Ravi, Could you please tell

Re: [ovirt-users] Python-SDK: ovirtsdk4.Connection object autologout?

2017-03-23 Thread Ravi Nori
Can you give me the exact rpm version of ovirt-engine-backend, I can give you a replacement jar file to test On Thu, Mar 23, 2017 at 3:56 AM, wrote: > Hi Ravi, > > Could you please tell me what's the right way to apply this patch on an > already working oVirt instance? I

Re: [ovirt-users] ACTION_TYPE_FAILED_NO_SERVERS_FOR_CLUSTER

2017-03-23 Thread Davide Ferrari
Sorry for the delay, I've managed to fix it. It was all due to a permission error in the gluster volume which I created via CLI manually, I forgot to set the vdsm unix user UID and GID permissions to it. After doing that, I could import the new gluster volume as a data domain in the new cluster

Re: [ovirt-users] ACTION_TYPE_FAILED_NO_SERVERS_FOR_CLUSTER

2017-03-23 Thread Sahina Bose
Could you provide engine.log from engine and vdsm.log & supervdsm.log from this host? On Wed, Mar 22, 2017 at 8:02 PM, Davide Ferrari wrote: > I get this error when I click " > Gluster status is disconnected for this host. > Restart Glusterd service" in the Genral tab of a

[ovirt-users] How to attach Host device to VM ?

2017-03-23 Thread TranceWorldLogic .
Hi, I have created an LVM device( /dev/myvg/lvm1 ) in Host. I want that device to attach with VM. Can I attach device to VM via vdsClient ? If yes, please provide me example command that I need to run. Thanks, ~Rohit ___ Users mailing list

Re: [ovirt-users] Expand an ovirt+glusterfs cluster

2017-03-23 Thread Sahina Bose
On Wed, Mar 22, 2017 at 8:29 PM, Davide Ferrari wrote: > > > 2017-03-22 8:09 GMT+01:00 Sahina Bose : > > >> >> A gluster volume cannot span multiple clusters. If you want to create a >> separate cluster with the Broadwell nodes, then create a new gluster

Re: [ovirt-users] ovirt 4.1 - mount recovery iso for failing vm ?

2017-03-23 Thread Ian Neilsen
I should have been a little more specific.. a failing hosted engine vm. On 23 March 2017 at 20:24, Ian Neilsen wrote: > Guys > > I've spent the day reading any and all content on recovering a failing to > boot vm under ovirt 4.1 and am finding many cmds are deprecated ,

Re: [ovirt-users] Moving from fc based to iSCSI based

2017-03-23 Thread Gianluca Cecchi
On Mon, Mar 20, 2017 at 5:56 PM, Gianluca Cecchi wrote: > On Thu, Mar 9, 2017 at 1:01 PM, Fred Rolland wrote: > >> I don't think it will work. >> We rely heavily on LVM when working with iSCSI and FC and I am not sure >> how LVM will handle this

[ovirt-users] ovirt 4.1 - mount recovery iso for failing vm ?

2017-03-23 Thread Ian Neilsen
Guys I've spent the day reading any and all content on recovering a failing to boot vm under ovirt 4.1 and am finding many cmds are deprecated , old processes no longer work. What is the correct way to mount an iso to perform recovery on a boot partition of a failing VM in oVirt 4.1? vm.conf,

Re: [ovirt-users] how to handle mount options for hosted engine on glusterfs

2017-03-23 Thread Ian Neilsen
I Think I am going to have to go the "virsh" path and mount a guest based cdrom storage device using a live cd and fix the vm disk this way. Meanwhile fix up the fact that vnc and serial console have both been wiped out following the 4.1 upgrade. On 22 March 2017 at 11:52, Ian Neilsen

Re: [ovirt-users] How to set priority for HA VM via Python SDK ?

2017-03-23 Thread Juan Hernández
On 03/23/2017 08:59 AM, TranceWorldLogic . wrote: > Hi, > > I want to set priority of Highly Available VM as High via python SDK. > I provided information as shown below: > > vm = self.vms_service.add( > vm = types.Vm ( > high_availability =

Re: [ovirt-users] Roadmap

2017-03-23 Thread Yedidyah Bar David
On Wed, Mar 22, 2017 at 11:38 PM, Julián Tete wrote: > Hi Friends of oVirt > > Is there any roadmap for oVirt for 2017 and 2018? > > Any roadmap for oVirt by versions? 4.2.X, 4.3.X, 4.4.X You can get a clue as to what *might* be included by searching bugzilla. E.g. to

[ovirt-users] How to set priority for HA VM via Python SDK ?

2017-03-23 Thread TranceWorldLogic .
Hi, I want to set priority of Highly Available VM as High via python SDK. I provided information as shown below: vm = self.vms_service.add( vm = types.Vm ( high_availability = types.HighAvailability( enabled = True,

Re: [ovirt-users] Python-SDK: ovirtsdk4.Connection object autologout?

2017-03-23 Thread nicolas
Hi Ravi, Could you please tell me what's the right way to apply this patch on an already working oVirt instance? I already have applied some patches on *.py files, but it seems the *.java files are not there. Thanks! El 2017-03-22 16:06, Ravi Nori escribió: Hi Nicolás, There has been some

[ovirt-users] Getting error when i try to assign logical networks to interfaces

2017-03-23 Thread martin chamambo
I havent set up any hooks and when i try to assign logical networks to an already existing interface on the host ,it gives me this error Hook error: Hook Error: ('Traceback (most recent call last):\n File "/usr/libexec/vdsm/hooks/before_network_setup/50_fcoe", line 18, in \nfrom