Re: [ovirt-users] High latency on storage domains and sanlock renewal error

2017-05-12 Thread Juan Pablo
sorry to jump in, but what kernel version are you using? had similar issue with kernel 4.10/4.11 2017-05-12 16:36 GMT-03:00 Stefano Bovina : > Hi, > a little update: > > The command multipath -ll hung when executed on the host while the problem > occur (nothing logged in

[ovirt-users] Regenerating SSL keys

2017-05-12 Thread Jamie Lawrence
The key generated by the engine install ended up with a bad CN; it has a five-digit number appended to the host name, and no SAN. I've lived with this through setup, but now I'm getting close to prod use, and need to clean up so that it is usable for general consumption. And the SPICE HTML

[ovirt-users] The number of LVs on the domain VPLEX_DATA_DOMAIN exceeded 300, you are approaching the limit where performance may degrade.

2017-05-12 Thread Rogério Ceni Coelho
Hi oVirt Admins, I have two data domains using FC SAN, with 150 VMs. Each VM have 3 or 4 disks. A few time ago i saw the above message on Events. What can i do ? What are the alternatives ? What can i do ? The number of LVs on the domain VPLEX_DATA_DOMAIN exceeded 300, you are approaching the

[ovirt-users] About NFS in cluster and HA

2017-05-12 Thread 张 余歌
My environment: A for Engine,NFS server B for node1 C for nide2 Ovirt3.6.7 Everything is ready(Like ipmi).But.. 1.hot-migration whitin B and C I found It is okay,after migration ,B Or C Would change Its hostname,which caused failure next time to migration.(i Don't know whether firewall will

Re: [ovirt-users] High latency on storage domains and sanlock renewal error

2017-05-12 Thread Stefano Bovina
Hi, a little update: The command multipath -ll hung when executed on the host while the problem occur (nothing logged in /var/log/messages or dmesg). I tested latency with ioping: ioping /dev/6a386652-629d-4045-835b-21d2f5c104aa/metadata Usually it return "time=15.6 ms", sometimes return

Re: [ovirt-users] ansible and list of vms

2017-05-12 Thread Ondra Machacek
This worked for me: --- - hosts: localhost connection: local vars_files: - ../vars.yml tasks: - name: Obtain SSO token ovirt_auth: url: "{{ url }}" username: "{{ username }}" password: "{{ password }}" insecure: "{{ insecure }}" - name: List vms

Re: [ovirt-users] Ovirt nested in VMware

2017-05-12 Thread Mark Duggan
Thanks Gianluca, So I installed the engine into a separate VM, and didn't go down the hosted-engine path, although if I was to look at this with physical hosts, this seems like a really good approach. To answer Michal's question from earlier, the nested VM inside the oVirt Hypervisors has been

[ovirt-users] ovirtmgmt network out of sync

2017-05-12 Thread Alex R
Hi, I upgraded to the latest version (users@ovirt.org) a few weeks ago and ever since then I cannot open a console unless I am on the local network ( 10.3.1.0/24). I think it is related to the Ovirtmgmt interface being "out-of-sync". If I try to fix it in the gui, I get an error: "Error while

Re: [ovirt-users] Ovirt + Citrix Xenserver support?

2017-05-12 Thread Peter Wood
Thank you for replying. I must've hit Reply instead of Reply All. I copied the ML to this email. Your answer may be helpful to other people too. Thanks, -- Peter On Thu, May 11, 2017 at 10:37 PM, Sandro Bonazzola wrote: > > > On Thu, May 11, 2017 at 11:33 PM, Peter Wood

Re: [ovirt-users] ansible and list of vms

2017-05-12 Thread Nathanaël Blanchet
Great, it works like a charm! But how could I obtain a several map display? For example, I need to display the vm name ; its relative snaphost id and snaphot description. I tried to change filter, but notyhing works msg: "{{ ovirt_snapshots | map(attribute='description') |

Re: [ovirt-users] oVirt Hosted Engine Setup fails

2017-05-12 Thread Simone Tiraboschi
On Fri, May 12, 2017 at 1:31 PM, Manuel Luis Aznar < manuel.luis.az...@gmail.com> wrote: > Hello there, > > Sorry for the late response, but I haven been busy doing job things... > > I was looking at the email of Yaniv and here are the results from my > broken installation: > > Permission on

[ovirt-users] searching users and field mapping

2017-05-12 Thread Fabrice Bacchella
When I export a user I find values like: 39323336363566612D37622D346532612D396530632D316630396536643634636432 admin * admin admin@internal-authz internal-authz They are the same that one defined from the type in sdk

Re: [ovirt-users] slow kerberos authentication

2017-05-12 Thread Fabrice Bacchella
It works much better now. Goes from 6s to less than 500ms. Not blazing fast but much more usable, thanks a lot. > Le 12 mai 2017 à 15:58, Ondra Machacek a écrit : > > This is new feature in aaa-ldap tracked here[1]. > By default for AD profiles we use this feature, and it

Re: [ovirt-users] ovs-vswitchd high cpu usage

2017-05-12 Thread Arnaud Lauriou
Well its seems that I had config mismatch between 4.0.6 et 4.11, old ovs-vswitchd process was still running. I found the solution to my problem : reboot oVirt host and everything works fine now. On 05/12/2017 04:12 PM, Arnaud Lauriou wrote: I'm responding to myself ! For vdsm, it's seems that

Re: [ovirt-users] Migrate VirtualBox Vm into

2017-05-12 Thread Staniforth, Paul
Hi Gajendra, virt-v2v didn't support Debian/Ubuntu guests, it is apparently in a later version that is due to be included in RHEL/Centos 7.4 What I did to get a Metasploitable2 image into oVirt was. 1. convert vmdk disk qemu-img convert -f vmdk

Re: [ovirt-users] ovs-vswitchd high cpu usage

2017-05-12 Thread Arnaud Lauriou
I'm responding to myself ! For vdsm, it's seems that ovsdb-server needs to be up, not ovs-vswitchd. However, is there a way to reduce cpu load of ovs-vswitchd process ? Regards, Arnaud On 05/12/2017 03:29 PM, Arnaud Lauriou wrote: Hi, Just updated last week ovirt hosts from 4.0.6 to 4.1.1

Re: [ovirt-users] slow kerberos authentication

2017-05-12 Thread Ondra Machacek
This is new feature in aaa-ldap tracked here[1]. By default for AD profiles we use this feature, and it should increase performance in most cases. But if this is not the case for you, can you just try to change the profile from: include = to include = And see if it will be better? [1]

Re: [ovirt-users] Ovirt nested in VMware

2017-05-12 Thread Gianluca Cecchi
On Fri, May 12, 2017 at 1:06 PM, Michal Skrivanek < michal.skriva...@redhat.com> wrote: > > > On 11 May 2017, at 19:52, Mark Duggan wrote: > > > > Hi everyone, > > > > From reading through the mailing list, it does appear that it's possible > to have the ovirt nodes/hosts be

[ovirt-users] ovs-vswitchd high cpu usage

2017-05-12 Thread Arnaud Lauriou
Hi, Just updated last week ovirt hosts from 4.0.6 to 4.1.1 and I noticed ovs-vswitchd high cpu usage, around 100%. My cluster switch type is in legacy mode, so I decided to stop ovs-vswitchd process on each ovirt host. This morning, when trying to run a new VM and I've got the following

Re: [ovirt-users] slow kerberos authentication

2017-05-12 Thread Fabrice Bacchella
I found that: http://dunnry.com/blog/TransitiveLinkValueFilterEvaluation.aspx > Le 12 mai 2017 à 14:44, Fabrice Bacchella a > écrit : > > Ok, I found where it's slow, it's a ldapsearch on our AD: > > time ldapsearch -a never -E pr=100/noprompt -H ldap://ad1

Re: [ovirt-users] slow kerberos authentication

2017-05-12 Thread Fabrice Bacchella
Ok, I found where it's slow, it's a ldapsearch on our AD: time ldapsearch -a never -E pr=100/noprompt -H ldap://ad1 -b DC=... -s sub '(&(groupType:1.2.840.113556.1.4.803:=2147483648)(&(objectCategory=group)(member:1.2.840.113556.1.4.1941:=userdn)))' objectGUID name description # numResponses:

Re: [ovirt-users] slow kerberos authentication

2017-05-12 Thread Fabrice Bacchella
> Le 12 mai 2017 à 13:35, Ondra Machacek a écrit : > > > > On Fri, May 12, 2017 at 1:18 PM, Fabrice Bacchella > > wrote: > The request is indeed quite slow within ovirt, using the setup given by Juan: > >

Re: [ovirt-users] slow kerberos authentication

2017-05-12 Thread Ondra Machacek
On Fri, May 12, 2017 at 1:18 PM, Fabrice Bacchella < fabrice.bacche...@orange.fr> wrote: > The request is indeed quite slow within ovirt, using the setup given by > Juan: > > /ovirt-engine/sso/oauth/token-http-auth 7001ms > > I was not able to authenticate jboss-cli.sh, I don't know why: >

Re: [ovirt-users] Ovirt nested in VMware

2017-05-12 Thread Michal Skrivanek
> On 12 May 2017, at 13:16, Mark Duggan wrote: > > Michal > > I certainly seem to be able to get that far, I can provide screen grabs if > you think it'd be useful. > > I'm OK with hopelessly slow, for now. It's really just to POC the interface, > and work flows. I'm

Re: [ovirt-users] slow kerberos authentication

2017-05-12 Thread Fabrice Bacchella
The request is indeed quite slow within ovirt, using the setup given by Juan: /ovirt-engine/sso/oauth/token-http-auth 7001ms I was not able to authenticate jboss-cli.sh, I don't know why: 'admin@internal-authz': No valid profile found in credentials. So I tried to modifie

Re: [ovirt-users] Ovirt nested in VMware

2017-05-12 Thread Mark Duggan
Michal I certainly seem to be able to get that far, I can provide screen grabs if you think it'd be useful. I'm OK with hopelessly slow, for now. It's really just to POC the interface, and work flows. I'm hoping to get my hands on a couple of servers soon so that I can do a more full blooded

[ovirt-users] [ANN] oVirt 4.1.2 Second Release Candidate is now available

2017-05-12 Thread Sandro Bonazzola
The oVirt Project is pleased to announce the availability of the Second Release Candidate of oVirt 4.1.2 for testing, as of May 12th, 2017 This is pre-release software. Please take a look at our community page[1] to know how to ask questions and interact with developers and users. All issues or

Re: [ovirt-users] Ovirt nested in VMware

2017-05-12 Thread Michal Skrivanek
> On 11 May 2017, at 19:52, Mark Duggan wrote: > > Hi everyone, > > From reading through the mailing list, it does appear that it's possible to > have the ovirt nodes/hosts be VMware virtual machines, once I enable the > appropriate settings on the VMware side. All seems

Re: [ovirt-users] Migrate VirtualBox Vm into

2017-05-12 Thread Michal Skrivanek
> On 12 May 2017, at 11:36, Uwe Laverenz wrote: > > Hi, > > Am 09.05.2017 um 12:01 schrieb Gajendra Ravichandran: > >> I tried to convert using virt-v2v >> as http://libguestfs.org/virt-v2v.1.html. However, I get error as >> (Debian/ Linux cannot be converted). > > Yes,

Re: [ovirt-users] Python-SDK4: Shutdown a machine with a specific message?

2017-05-12 Thread nicolas
El 2017-05-12 10:11, Juan Hernández escribió: On 05/12/2017 09:46 AM, nico...@devels.es wrote: Hi, Using Python-SDK4, is there a way to shutdown a machine with a specific message? In code I just see this definition: def shutdown( self, async=None, headers=None,

Re: [ovirt-users] slow kerberos authentication

2017-05-12 Thread Juan Hernández
On 05/12/2017 11:45 AM, Juan Hernández wrote: > On 05/12/2017 10:04 AM, Yaniv Kaul wrote: >> >> >> On May 11, 2017 8:25 PM, "Fabrice Bacchella" >> > wrote: >> >> I'm using kerberos authentication in ovirt for the URL >>

Re: [ovirt-users] slow kerberos authentication

2017-05-12 Thread Juan Hernández
On 05/12/2017 10:04 AM, Yaniv Kaul wrote: > > > On May 11, 2017 8:25 PM, "Fabrice Bacchella" > > wrote: > > I'm using kerberos authentication in ovirt for the URL > /sso/oauth/token-http-auth, but kerberos is done in

Re: [ovirt-users] Migrate VirtualBox Vm into

2017-05-12 Thread Uwe Laverenz
Hi, Am 09.05.2017 um 12:01 schrieb Gajendra Ravichandran: I tried to convert using virt-v2v as http://libguestfs.org/virt-v2v.1.html. However, I get error as (Debian/ Linux cannot be converted). Yes, virt-v2v only supports a limited number of operating systems, Debian is just not supported.

Re: [ovirt-users] Python-SDK4: Shutdown a machine with a specific message?

2017-05-12 Thread Juan Hernández
On 05/12/2017 09:46 AM, nico...@devels.es wrote: > Hi, > > Using Python-SDK4, is there a way to shutdown a machine with a specific > message? > > In code I just see this definition: > > def shutdown( > self, > async=None, > headers=None, > query=None, >

[ovirt-users] IPv6 with legacy (linux bridge) networking.

2017-05-12 Thread Eduardo Mayoral
Hi, First of all, sorry for the rookie question. Because of my network setup my compute nodes (CentOS 7.3) are in a network segment without IPv6 routing, however IPv6 is enabled on the hosts (just the default setup in CentOS 7). This leads to problems when I try to install or update

Re: [ovirt-users] slow kerberos authentication

2017-05-12 Thread Yaniv Kaul
On May 11, 2017 8:25 PM, "Fabrice Bacchella" wrote: I'm using kerberos authentication in ovirt for the URL /sso/oauth/token-http-auth, but kerberos is done in Apache using auth_gssapi_module and it's quite slow, about 6s for a request. I'm trying to understand if

Re: [ovirt-users] slow kerberos authentication

2017-05-12 Thread Ondra Machacek
I am not aware of anything, but debug log of all aaa stuff would help, to understand what takes the most time. - org.ovirt.engineextensions.aaa.ldap - org.ovirt.engineextensions.aaa.misc - org.ovirt.engine.core.aaa - org.ovirt.engine.core.sso To enable it in runtime, please follow: