[ovirt-users] how update the network name of a vmnic with API SDK python ?

2018-03-20 Thread Nicolas Vaye
Hi, i want to change the network name of the existing nic for a VM with python SDK API ? Can i have some help please ? the VM name is testnico the nic name is nic1 the new network name is vlan_NEW and here is the source file written by me (which doesn't work) : #!/usr/bin/env python # -*-

Re: [ovirt-users] Q: Copying VMs between Export domains of different data centres

2018-03-20 Thread Eyal Shenitzky
Exactly. On Tue, Mar 20, 2018 at 5:51 PM, Andrei Verovski wrote: > On Tue, Mar 20, 2018 at 4:26 PM, Eyal Shenitzky > wrote: > >> Hi Andrei, >> >> I think you miss understand the concept of export domain. >> >> Export domain allows you to pass

Re: [ovirt-users] Change ovirtmgmt ip from dhcp to static in a

2018-03-20 Thread zois roupas
Hi again all, "Unless i miss understood you here, do you use a different IP address when switching to static or the same IP that you got from dhcp? if yes, then this is another flow.." To answer your question Michael , i'm trying to configure a different ip outside of my dhcp pool. The

Re: [ovirt-users] Fw: Network issues with oVirt 4.2 and cloud-init

2018-03-20 Thread Berger, Sandy
* I have a base VM that was created with a normal kickstart. * I shut the VM down in preparation for a snapshot. * I snapshot it so I can put it back to its original state. * I start the VM and install https://people.redhat.com/rmccabe/cloud-init/cloud-init-0.7.9-20.el7.x86_64.rpm

Re: [ovirt-users] Network issues with oVirt 4.2 and cloud-init

2018-03-20 Thread Berger, Sandy
Thanks for the suggestion. I was hoping to avoid that but will consider doing it as a last resort. -Original Message- From: Luca 'remix_tj' Lorenzetto [mailto:lorenzetto.l...@gmail.com] Sent: Monday, March 19, 2018 10:56 AM To: Berger, Sandy Cc: users@ovirt.org Subject:

Re: [ovirt-users] Network issues with oVirt 4.2 and cloud-init

2018-03-20 Thread Berger, Sandy
Yes, I had the checkbox marked when I made the template. From: Michael Burman [mailto:mbur...@redhat.com] Sent: Tuesday, March 20, 2018 1:37 AM To: Berger, Sandy Cc: users@ovirt.org; Luca 'remix_tj' Lorenzetto Subject: Re: [ovirt-users] Network issues

Re: [ovirt-users] storage domain ovirt-image-repository doesn't work

2018-03-20 Thread Nicolas Vaye
Hi Daniel, I have checked again this morning, and no it's the same result. How can i do to investigate with more debug in order to solve this issue ? Nicolas Message initial Date: Mon, 19 Mar 2018 11:39:27 + Objet: Re: [ovirt-users] storage domain ovirt-image-repository

[ovirt-users] Fiber Channel Storage not coming up

2018-03-20 Thread Jean Pickard
Hello, Today I noticed that most of my VMs weren't accessible. Once i checked the system, I noticed my FC channel SAN data domain is inactive. 2018-03-19 16:01:05,308-0700 ERROR (periodic/32) [virt.vm] (vmId='43700e39-8812-41c6-9cd6-e555a2f19e35') Unable to get watermarks for drive vda: failed

Re: [ovirt-users] Iso upload success, no GUI popup option

2018-03-20 Thread Jamie Lawrence
> On Mar 20, 2018, at 5:00 AM, Alexander Wels wrote: > > On Monday, March 19, 2018 7:47:00 PM EDT Jamie Lawrence wrote: >> So, uploading from one of the hosts to an ISO domain claims success, and >> manually checking shows the ISO uploaded just fine, perms set correctly to >>

[ovirt-users] Adding host to hosted-engine /w gluster cluster. (On ovirt Node 4.2.1.1)

2018-03-20 Thread Hanson Turner
Hi Guys, I've a 3 machine pool running gluster with replica 3 and want to add two more machines. This would change to a replica 5... In ovirt 4.0, I'd done everything manually. No problem there. In ovirt 4.2, I'd used the wizard for the hosted-engine. It looks like the fourth node has been

[ovirt-users] GPG Key of evilissimo repo for ovirt-guest-agent is expired

2018-03-20 Thread Florian Schmid
Hi, it looks like for this repo, the GPG key is expired. http://download.opensuse.org/repositories/home:/evilissimo:/ubuntu:/16.04/xUbuntu_16.04/ Does someone know, whom I should contact, that this key will be renewed? Or does someone know another repo, where I can download the latest

Re: [ovirt-users] Hosted engine deployment error

2018-03-20 Thread spfma . tech
Just to be sure I hadn't altered something, I renamed "mnt" in something else and it was indeed recreated. Le 20-Mar-2018 16:57:22 +0100, stira...@redhat.com a crit: On Tue, Mar 20, 2018 at 4:12 PM, wrote: I tried to make a cleaner install : after cleanup, I recreated

Re: [ovirt-users] Hosted engine deployment error

2018-03-20 Thread Simone Tiraboschi
On Tue, Mar 20, 2018 at 4:12 PM, wrote: > I tried to make a cleaner install : after cleanup, I recreated > "/rhev/data-center/mnt/" and ran the installer again. > It should be automatically created by vdsm, can you please avoid that? > > As you can see, it crashed again

Re: [ovirt-users] Q: Copying VMs between Export domains of different data centres

2018-03-20 Thread Andrei Verovski
> On Tue, Mar 20, 2018 at 4:26 PM, Eyal Shenitzky > wrote: > Hi Andrei, > > I think you miss understand the concept of export domain. > > Export domain allows you to pass entities from one data center to another. OK, now I’ve got it. Thanks

Re: [ovirt-users] Hosted engine deployment error

2018-03-20 Thread spfma . tech
I tried to make a cleaner install : after cleanup, I recreated "/rhev/data-center/mnt/" and ran the installer again. As you can see, it crashed again with the same access denied error on this file :[ INFO ] TASK [Copy configuration archive to storage] [ ERROR ] fatal: [localhost]: FAILED!

Re: [ovirt-users] Q: Removing stuff from EXPORT domain

2018-03-20 Thread Andrei Verovski
> On 20 Mar 2018, at 16:29, Eyal Shenitzky wrote: > > Please try to press on the storage domain name while you are at the storage > domains list. OK, that works, yet it really not intuitive. Extra button in the top bar, something like “more options…”, or extra menu

Re: [ovirt-users] help, ovirt 4.2

2018-03-20 Thread Yedidyah Bar David
On Tue, Mar 20, 2018 at 3:50 PM, Marcos Michel Martinez Perez wrote: > Name: ovirt-engine-setup-plugin-ovirt-engine > Version : 4.2.0.2 > Release : 1.el7.centos > Architecture: noarch > Install Date: lun 19 mar 2018 12:21:46 CDT > Group :

Re: [ovirt-users] Q: Removing stuff from EXPORT domain

2018-03-20 Thread Eyal Shenitzky
Please try to press on the storage domain *name* while you are at the storage domains list. On Tue, Mar 20, 2018 at 4:22 PM, Andrei Verovski wrote: > > > On 20 Mar 2018, at 16:01, Eyal Shenitzky wrote: > > Attached screen-shot for deleting a VM from

Re: [ovirt-users] Q: Copying VMs between Export domains of different data centres

2018-03-20 Thread Eyal Shenitzky
On Tue, Mar 20, 2018 at 4:26 PM, Eyal Shenitzky wrote: > Hi Andrei, > > I think you miss understand the concept of export domain. > > Export domain allows you to pass entities from one data center to another. > > The flow is: > > 1) Create an export domain in DC-A > 2)

Re: [ovirt-users] Q: Removing stuff from EXPORT domain

2018-03-20 Thread Andrei Verovski
> On 20 Mar 2018, at 16:01, Eyal Shenitzky wrote: > > Attached screen-shot for deleting a VM from an export domain: > > 1) go to storage domains list > 2) select the export domain > 3) In the export domain - navigate to 'VM Import' tab > 4) select VM and press 'remove'

Re: [ovirt-users] Change ovirtmgmt ip from dhcp to static in a

2018-03-20 Thread Michael Burman
Then you need to remove the host from engine, change the IP manually on the host, via ifcfg-file, restart network service and install the host again via the new IP address. On Tue, Mar 20, 2018 at 2:50 PM, zois roupas wrote: > Hi again all, > > > "Unless i miss

Re: [ovirt-users] Gluster: VM disk stuck in transfer; georep gone wonky

2018-03-20 Thread Sahina Bose
On Mon, Mar 19, 2018 at 10:08 PM, Jim Kusznir wrote: > Hi all: > > Sorry for yet another semi-related message to the list. In my attempts to > troubleshoot and verify some suspicions on the nature of the performance > problems I posted under "Major Performance Issues with

[ovirt-users] Q: Copying VMs between Export domains of different data centres

2018-03-20 Thread Andrei Verovski
Hi, I have 2 data centers (with 1 node each because 1 have local data domain) Copied exported from DC #1, exports -> 1d7208ce-d3a1-4406-9638-fe7051562994 -> images -> 12f48f07-7e93-4c66-b0e9-00efc1fec418, with 2 files inside fc469474-94fd-416b-b921-58604f46411c - 171 GB (seems like disk image)

Re: [ovirt-users] help, ovirt 4.2

2018-03-20 Thread Yedidyah Bar David
On Tue, Mar 20, 2018 at 3:21 PM, Marcos Michel Martinez Perez < mmartin...@uci.cu> wrote: > I recently installed oVirt 4.2 on centos 7 and it turns out that it gave > me the following error when trying to execute the command engine-setup > Which version? What's the output of: rpm -qi

[ovirt-users] help, ovirt 4.2

2018-03-20 Thread Marcos Michel Martinez Perez
I recently installed oVirt 4.2 on centos 7 and it turns out that it gave me the following error when trying to execute the command engine-setup [root@localhost ~]# engine-setup [ INFO  ] Stage: Initializing [ INFO  ] Stage: Environment setup   Configuration files:

Re: [ovirt-users] Q: Removing stuff from EXPORT domain

2018-03-20 Thread Eyal Shenitzky
It doesn't behave differently than removing a disk from Storage domains -> Storage domain - > disks, The entities do not belong to any data center so it must be inside the storage domain view. On Tue, Mar 20, 2018 at 2:05 PM, Sandro Bonazzola wrote: > > > Il mar 20 mar

Re: [ovirt-users] Q: Removing stuff from EXPORT domain

2018-03-20 Thread Sandro Bonazzola
Il mar 20 mar 2018, 12:32 Eyal Shenitzky ha scritto: > The export domain should contain entities for export: VMs, Template etc.. > > You can remove them from the domain via Storage -> Export Domain -> Import > Virtual Machine(s) / Templates -> select the unsed entetiy ->

Re: [ovirt-users] Iso upload success, no GUI popup option

2018-03-20 Thread Alexander Wels
On Monday, March 19, 2018 7:47:00 PM EDT Jamie Lawrence wrote: > Hello, > > I'm trying to iron out the last few oddities of this setup, and one of them > is the iso upload process. This worked in the last rebuild, but... well. > > So, uploading from one of the hosts to an ISO domain claims

Re: [ovirt-users] Q: Removing stuff from EXPORT domain

2018-03-20 Thread Eyal Shenitzky
The export domain should contain entities for export: VMs, Template etc.. You can remove them from the domain via Storage -> Export Domain -> Import Virtual Machine(s) / Templates -> select the unsed entetiy -> remove (upper right side of the window). On Tue, Mar 20, 2018 at 1:17 PM, Andrei

Re: [ovirt-users] Hosted engine deployment error

2018-03-20 Thread Simone Tiraboschi
On Tue, Mar 20, 2018 at 11:44 AM, wrote: > > Hi, > > > > In fact it is a workaround coming from you I found in the bugtrack that > helped me : > > > > > chmod 644 /var/cache/vdsm/schema/* > > > > As the only thing looking like a weird error I have found was : > > > > ERROR

Re: [ovirt-users] Q: Removing stuff from EXPORT domain

2018-03-20 Thread Andrei Verovski
> On 20 Mar 2018, at 12:59, Eyal Shenitzky wrote: > > Hi Andrei, > > You can remove entities from export domain via the UI. in 4.2 Storage -> Disks - exported image is not visible here Storage -> Storage Domains -> Manage Domains - nothing that allows to see content of

Re: [ovirt-users] Q: Removing stuff from EXPORT domain

2018-03-20 Thread Eyal Shenitzky
Hi Andrei, You can remove entities from export domain via the UI. On Tue, Mar 20, 2018 at 12:54 PM, Andrei Verovski wrote: > Hi ! > > > What is the proper oVirt way to remove unused stuff from EXPORT domain ? > Simply "rm -Rv xxx" and "rm -Rv xxx.meta" > via SSH inside

[ovirt-users] Q: Removing stuff from EXPORT domain

2018-03-20 Thread Andrei Verovski
Hi ! What is the proper oVirt way to remove unused stuff from EXPORT domain ? Simply "rm -Rv xxx" and "rm -Rv xxx.meta" via SSH inside export -> 1d7208ce-d3a1-4406-9638-fe7051562994 -> images ? Thanks Andrei ___ Users mailing list Users@ovirt.org

Re: [ovirt-users] Hosted engine deployment error

2018-03-20 Thread spfma . tech
Hi, In fact it is a workaround coming from you I found in the bugtrack that helped me : chmod 644 /var/cache/vdsm/schema/* As the only thing looking like a weird error I have found was : ERROR Exception raised#012Traceback (most recent call last):#012 File

Re: [ovirt-users] Disk upload cancel/remove

2018-03-20 Thread Eyal Shenitzky
Idan/Daniel, Can you please take a look? Thanks, On Tue, Mar 20, 2018 at 11:44 AM, Alex K wrote: > Hi All, > > I was trying to upload a VM disk at data storage domain using a python > script. > I did cancel the upload twice and at the third time the upload was >

[ovirt-users] Disk upload cancel/remove

2018-03-20 Thread Alex K
Hi All, I was trying to upload a VM disk at data storage domain using a python script. I did cancel the upload twice and at the third time the upload was successful, but I see two disks from the previous attempts with status "transferring via API" (see attached). This status of for more then 8

Re: [ovirt-users] Change ovirtmgmt ip from dhcp to static in a

2018-03-20 Thread Ales Musil
One thing to note if you are changing the IP to different one that was assigned by DHCP you should uncheck "Verify connectivity between Host and Engine". This makes sure that the engine won't lost connectivity and in case of switching IP it happens. On Tue, Mar 20, 2018 at 10:15 AM, Michael

Re: [ovirt-users] Change ovirtmgmt ip from dhcp to static in a

2018-03-20 Thread Michael Burman
Indeed very odd, this shouldn't behave this way, just tested it my self and it is working as expected. Unless i miss understood you here, do you use a different IP address when switching to static or the same IP that you got from dhcp? if yes, then this is another flow.. Can you please share the

Re: [ovirt-users] Hosted engine deployment error

2018-03-20 Thread spfma . tech
By the way, should NetworkManager be enabled or disabled when using latest versions of oVirt ? I have found contradictory informations, but some are from two years ago. Regards Le 19-Mar-2018 16:56:50 +0100, spfma.t...@e.mail.fr a crit: Hi, I wanted to rebuild a new hosted engine

Re: [ovirt-users] Failing to upload qcow2 disk image

2018-03-20 Thread Daniel Erez
Hi Anantha, The issue seems similar to https://bugzilla.redhat.com/1554226 Please try to increase to value of ImageTransferClientTicketValidityInSeconds configuration value. E.g. # engine-config -s

Re: [ovirt-users] Fw: Network issues with oVirt 4.2 and cloud-init

2018-03-20 Thread Eitan Raviv
Hi Sandy, Can you elaborate some more about the steps you have taken? Specifically, how\where do you apply cloud-init-0.7.9-20 rpm? Can you make sure that rpm -q cloud-init after VM reboot is still this one? How do you apply the static IP settings that do persist to the VM - via oVirt

Re: [ovirt-users] Gluster: VM disk stuck in transfer; georep gone wonky

2018-03-20 Thread Jim Kusznir
Thank you for the replies. While waiting, I found one more google responce that said to run engine-setup. I did that, and it fixed the issue. the VM is now running again. As to checking the logs, I'm not sure which ones to check...there are so many in so many different places. I was not able

Re: [ovirt-users] Gluster: VM disk stuck in transfer; georep gone wonky

2018-03-20 Thread Tony Brian Albers
I read somewhere about clearing out wrong stuff from the UI by manually editing the database, maybe you can try searching for something like that. With regards to the VM, I'd probably just delete it, edit the DB and remove all sorts of references to it and then recover it from backup. Is there

Re: [ovirt-users] Gluster: VM disk stuck in transfer; georep gone wonky

2018-03-20 Thread Eyal Shenitzky
Can you please check if you can detach the disk from the VM and attach it to the created VM? On Tue, Mar 20, 2018 at 8:48 AM, Jim Kusznir wrote: > Unfortunately, I came under heavy pressure to get this vm back up. So, i > did more googling and attempted to recover myself.

Re: [ovirt-users] Gluster: VM disk stuck in transfer; georep gone wonky

2018-03-20 Thread Eyal Shenitzky
Hi, Can you please send the VDSM and Engine log? Thanks On Mon, Mar 19, 2018 at 6:38 PM, Jim Kusznir wrote: > Hi all: > > Sorry for yet another semi-related message to the list. In my attempts to > troubleshoot and verify some suspicions on the nature of the performance

Re: [ovirt-users] Gluster: VM disk stuck in transfer; georep gone wonky

2018-03-20 Thread Jim Kusznir
Unfortunately, I came under heavy pressure to get this vm back up. So, i did more googling and attempted to recover myself. I've gotten closer, but still not quite. I found this post: http://lists.ovirt.org/pipermail/users/2015-November/035686.html Which gave me the unlock tool, which was

Re: [ovirt-users] Change ovirtmgmt ip from dhcp to static in a

2018-03-20 Thread Michael Burman
Hello Zois, It pretty easy to do, via the webadmin UI , go to Hosts main tab > Choose host > go to 'Network Interfaces' sub tab > Press the 'Setup Host Networks' button > press the pencil icon on your management network > and choose Static IP > press OK and OK to approve the operation. - Note

Re: [ovirt-users] Network issues with oVirt 4.2 and cloud-init

2018-03-20 Thread Michael Burman
Hi Berger, Have you sealed the template? if you didn't sealed the template on creation, then your new VM has the same ifcfg-eth0 settings as your origin VM. In order to avoid this, you need to check the 'Seal Template (Linux only)' checkbox in the New Template dialog. Cheers) On Mon, Mar 19,