[ovirt-users] [ANN] oVirt 4.3.8 First Release Candidate is now available for testing

2019-12-05 Thread Sandro Bonazzola
The oVirt Project is pleased to announce the availability of the oVirt
4.3.8 First Release Candidate for testing, as of December 6th, 2019.

This update is a release candidate of the eighth in a series of
stabilization updates to the 4.3 series.
This is pre-release software. This pre-release should not to be used in
production.

This release is available now on x86_64 architecture for:
* Red Hat Enterprise Linux 7.7 or later (but <8)
* CentOS Linux (or similar) 7.7 or later (but <8)

This release supports Hypervisor Hosts on x86_64 and ppc64le architectures
for:
* Red Hat Enterprise Linux 7.7 or later (but <8)
* CentOS Linux (or similar) 7.7 or later (but <8)
* oVirt Node 4.3 (available for x86_64 only) has been built consuming
CentOS 7.7 Release

See the release notes [1] for known issues, new features and bugs fixed.

Notes:
- oVirt Appliance is already available
- oVirt Node is already available

Additional Resources:
* Read more about the oVirt 4.3.8 release highlights:
http://www.ovirt.org/release/4.3.8/
* Get more oVirt Project updates on Twitter: https://twitter.com/ovirt
* Check out the latest project news on the oVirt blog:
http://www.ovirt.org/blog/

[1] http://www.ovirt.org/release/4.3.8/
[2] http://resources.ovirt.org/pub/ovirt-4.3-pre/iso/

-- 

Sandro Bonazzola

MANAGER, SOFTWARE ENGINEERING, EMEA R RHV

Red Hat EMEA 

sbona...@redhat.com
*Red Hat respects your work life balance.
Therefore there is no need to answer this email out of your office hours.*
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/site/privacy-policy/
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/36C2QSQDWNUCLDEURWHXX4QGWVUDT2YA/


[ovirt-users] Re: VLANs with one NIC in ovirt

2019-12-05 Thread Joseph Goldman

Yes, under networks you can create new and specify VLAN tags.

When you add NIC's under the VM, you choose the new Network you chose 
and the interface on the VM will be automatically then on that VLAN.


On 6/12/19 3:59 pm, siove...@gmail.com wrote:

Hi, is it possible to use different VLANs with one NIC in ovirt?

Regards
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/site/privacy-policy/
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/WM7KB4ZSVQIO5YZVKRI3CDQH74GCYAQF/

___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/site/privacy-policy/
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/UNZV7VOAP7OGUTJ2NNN4HQJRAPOVZ3FT/


[ovirt-users] VLANs with one NIC in ovirt

2019-12-05 Thread siovelrm
Hi, is it possible to use different VLANs with one NIC in ovirt?

Regards
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/site/privacy-policy/
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/WM7KB4ZSVQIO5YZVKRI3CDQH74GCYAQF/


[ovirt-users] Re: Windows Sluggish Performance

2019-12-05 Thread Michal Skrivanek
On 4 Dec 2019, at 04:16, Vijay Sachdeva  wrote:

Hey,



The problem what I have found is when I am using SPICE as default console
option, the  console performance is very sluggish. So what I understand
here is one needs to install additional spice guest tools to improve the
performance as it includes QLX video driver.


Yes. So did you do that?



https://www.spice-space.org/download.html



The moment I switched to VNC console options, performance improved but not
far better as it should be when taking a console of machine.



So still any suggestions to improve console access?



Thanks



Vijay Sachdeva





*From: *Strahil 
*Date: *Wednesday, 4 December 2019 at 5:12 AM
*To: *users , Vijay 
*Subject: *Re: [ovirt-users] Re: Windows Sluggish Performance



What is your virtual GPU ?
I'm using QLX, and despite being sluggish, when you tune windows for best
performance -it is workable.

Of course, if you passthrough a GPU, performance will be completely
different.

Best Regards,
Strahil Nikolov

On Dec 3, 2019 21:19, Vijay Sachdeva  wrote:

Anyone?



On Tue, 3 Dec 2019 at 11:21 PM, Vijay Sachdeva 
wrote:

Hello Everyone,



I managed to install Windows Server 2016 server on Ovirt node using ovirt
engine.All virtio-Win drivers also installed, but the performance of
Windows using console is very sluggish and mouse pointer is not at all
responsive.



Can anyone let me know, what could be the reason. Not able to to even add
IP to VM as mouse doesn’t work at all.



Thanks

___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/site/privacy-policy/
oVirt Code of Conduct:
https://www.ovirt.org/community/about/community-guidelines/
List Archives:
https://lists.ovirt.org/archives/list/users@ovirt.org/message/SCW3GKSIVIHL6O32FQQW4CGYXJZMYB4T/
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/site/privacy-policy/
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/AJ65IF3JJKAGI4Y5RRBPP4GAN5P2WGCE/


[ovirt-users] Re: Importing a Virtual Machine from a KVM Host

2019-12-05 Thread Michal Skrivanek
> On 5 Dec 2019, at 12:10, Dirk Streubel  wrote:
>
> Hello everbody,
>
> i am just a little bit confused about importing Qemu Images from my KVM Host.
>
> At home, and at work i am using a ovirt engine in a VM. The Version is 4.3.7 
> and on bare metal my host.
>
> Everything works fine but i have the same problem at home and on work. I want 
> to import my qcow2
> Images from a KVM Host but i
>
> will not work.
>
> The command  virsh -r -c 'qemu+tcp://r...@host1.example.org/system' list 
> --all shows me akk my VMs.
>
> But when i want to load the images in the GUI, nothing happens. I follow this 
> instruction:
>
> https://www.ovirt.org/develop/release-management/features/virt/KvmToOvirt.html
>
> After that, i take a look on the official 4.3 Rhev Documentation from Red 
> Hat. There stand this:
>
> Log in to the proxy host and generate SSH keys for the vdsm user.
>
> sudo -u vdsm ssh-keygen
>
> So, i have no proxy host.  So i want to do this on my ovirt-engine. Is this 
> right?

No, proxy host is the host you select to use for import. One of your
virtualization hosts

>
> Next thing: the user vdsm is locked on the ovirt-engine machine and the host.
>
> So, do i have to unlocked the account of the user vdsm or what is the best 
> way.
>
> My Problem is i found nothing that would help me to solve this problem.
>
> Maybe somebody here do me a favour and help me to solve this "challenge"
>
> Regards
>
> Dirk
>
>
>
>
>
>
> ___
> Users mailing list -- users@ovirt.org
> To unsubscribe send an email to users-le...@ovirt.org
> Privacy Statement: https://www.ovirt.org/site/privacy-policy/
> oVirt Code of Conduct: 
> https://www.ovirt.org/community/about/community-guidelines/
> List Archives: 
> https://lists.ovirt.org/archives/list/users@ovirt.org/message/WSDZ3E4VN5HMHMYV2CSDC5GCIZTMS2ED/
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/site/privacy-policy/
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/E7ZRNPIBKAMVYHXUU674SM7V3WWGOXSR/


[ovirt-users] Re: Unable to attach ISO domain to Datacenter

2019-12-05 Thread Strahil
Hi Ivan,

Which file is this ?

Contact me in private and I will send you my copy for comparison.

Best Regards,
Strahil NikolovOn Dec 4, 2019 18:55, Ivan Apolonio  wrote:
>
> I've tried to commenting out this line on /etc/pam.d/password-auth: 
>
> auth    requisite pam_succeed_if.so uid >= 1000 quiet_success 
>
> However, although it has stopped complaining about "requirement uid >= 1000 
> not met by user vdsm" on /var/log/secure , the error trying to attach ISO 
> Domain to Datacenter still persists, showing the same error message, so it 
> looks that this was not the cause of the problem :-( 
>
> Going back to stage zero.
> ___
> Users mailing list -- users@ovirt.org
> To unsubscribe send an email to users-le...@ovirt.org
> Privacy Statement: https://www.ovirt.org/site/privacy-policy/
> oVirt Code of Conduct: 
> https://www.ovirt.org/community/about/community-guidelines/
> List Archives: 
> https://lists.ovirt.org/archives/list/users@ovirt.org/message/TTD4PH2FIUK23427RSEWYQOGJSM7C7KB/
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/site/privacy-policy/
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/HWDBPUIULPIOFKEWP422GUTZJNSFIOMB/


[ovirt-users] Re: Importing a Virtual Machine from a KVM Host

2019-12-05 Thread Dirk Streubel
Hello Paul,

thanks a lot for your answer.

If i have any other questions during the import maybe i can asked again?

And i let you know the result :)

Regards

Dirk




Am 05.12.19 um 13:22 schrieb Staniforth, Paul:
> Hello Dirk,
> The link you are using is old developer docs, try the following.
> https://www.ovirt.org/documentation/admin-guide/chap-External_Providers.html
>
> You need to setup an external provider and use a proxy host in the datacentre 
> (not the engine host) you want to import into, this needs to be on the same 
> network as your KVM host and have the virt-v2v package installed.
>
> Regards,
>Paul S.
>
> -Original Message-
> From: Dirk Streubel 
> Sent: 05 December 2019 11:10
> To: users 
> Subject: [ovirt-users] Importing a Virtual Machine from a KVM Host
>
> Hello everbody,
>
> i am just a little bit confused about importing Qemu Images from my KVM Host.
>
> At home, and at work i am using a ovirt engine in a VM. The Version is 4.3.7 
> and on bare metal my host.
>
> Everything works fine but i have the same problem at home and on work. I want 
> to import my qcow2 Images from a KVM Host but i
>
> will not work.
>
> The command  virsh -r -c 'qemu+tcp://r...@host1.example.org/system' list 
> --all shows me akk my VMs.
>
> But when i want to load the images in the GUI, nothing happens. I follow this 
> instruction:
>
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ovirt.org%2Fdevelop%2Frelease-management%2Ffeatures%2Fvirt%2FKvmToOvirt.htmldata=02%7C01%7Cp.staniforth%40leedsbeckett.ac.uk%7C44f2fc1e1e5644fbc17008d7797444c4%7Cd79a81124fbe417aa112cd0fb490d85c%7C0%7C0%7C637111412591121899sdata=L0oVqmTjUoaYQlpmIN8AK9JjNvq8ZVVMP0LQusnbsuU%3Dreserved=0
>
> After that, i take a look on the official 4.3 Rhev Documentation from Red 
> Hat. There stand this:
>
> Log in to the proxy host and generate SSH keys for the vdsm user.
>
> sudo -u vdsm ssh-keygen
>
> So, i have no proxy host.  So i want to do this on my ovirt-engine. Is this 
> right?
>
> Next thing: the user vdsm is locked on the ovirt-engine machine and the host.
>
> So, do i have to unlocked the account of the user vdsm or what is the best 
> way.
>
> My Problem is i found nothing that would help me to solve this problem.
>
> Maybe somebody here do me a favour and help me to solve this "challenge"
>
> Regards
>
> Dirk
>
>
>
>
>
>
> ___
> Users mailing list -- users@ovirt.org
> To unsubscribe send an email to users-le...@ovirt.org Privacy Statement: 
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ovirt.org%2Fsite%2Fprivacy-policy%2Fdata=02%7C01%7Cp.staniforth%40leedsbeckett.ac.uk%7C44f2fc1e1e5644fbc17008d7797444c4%7Cd79a81124fbe417aa112cd0fb490d85c%7C0%7C0%7C637111412591121899sdata=w6%2F%2BeZV0YE4wpBvuOpvhP7Hsmy1qq0Hi%2BlAorTulFJA%3Dreserved=0
> oVirt Code of Conduct: 
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ovirt.org%2Fcommunity%2Fabout%2Fcommunity-guidelines%2Fdata=02%7C01%7Cp.staniforth%40leedsbeckett.ac.uk%7C44f2fc1e1e5644fbc17008d7797444c4%7Cd79a81124fbe417aa112cd0fb490d85c%7C0%7C0%7C637111412591121899sdata=BeGD%2BsSRku6cUqWKc2gWaFNHMzBHDn%2B7LwcKUxZ19W8%3Dreserved=0
> List Archives: 
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists.ovirt.org%2Farchives%2Flist%2Fusers%40ovirt.org%2Fmessage%2FWSDZ3E4VN5HMHMYV2CSDC5GCIZTMS2ED%2Fdata=02%7C01%7Cp.staniforth%40leedsbeckett.ac.uk%7C44f2fc1e1e5644fbc17008d7797444c4%7Cd79a81124fbe417aa112cd0fb490d85c%7C0%7C0%7C637111412591121899sdata=dczZYqEApc6RyM%2BwC2dt29DuRgNUePfeaoYuoloYuTk%3Dreserved=0
> To view the terms under which this email is distributed, please go to:-
> http://leedsbeckett.ac.uk/disclaimer/email/
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/site/privacy-policy/
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/CC5BGONOGTIAXTLXSHVXYVPUKEAZCBXI/


[ovirt-users] Importing a Virtual Machine from a KVM Host

2019-12-05 Thread Dirk Streubel
Hello everbody,

i am just a little bit confused about importing Qemu Images from my KVM Host.

At home, and at work i am using a ovirt engine in a VM. The Version is 4.3.7 
and on bare metal my host.

Everything works fine but i have the same problem at home and on work. I want 
to import my qcow2
Images from a KVM Host but i

will not work.

The command  virsh -r -c 'qemu+tcp://r...@host1.example.org/system' list --all 
shows me akk my VMs.

But when i want to load the images in the GUI, nothing happens. I follow this 
instruction:

https://www.ovirt.org/develop/release-management/features/virt/KvmToOvirt.html

After that, i take a look on the official 4.3 Rhev Documentation from Red Hat. 
There stand this:

Log in to the proxy host and generate SSH keys for the vdsm user.

sudo -u vdsm ssh-keygen

So, i have no proxy host.  So i want to do this on my ovirt-engine. Is this 
right?

Next thing: the user vdsm is locked on the ovirt-engine machine and the host.

So, do i have to unlocked the account of the user vdsm or what is the best way.

My Problem is i found nothing that would help me to solve this problem.

Maybe somebody here do me a favour and help me to solve this "challenge"

Regards

Dirk






___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/site/privacy-policy/
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/WSDZ3E4VN5HMHMYV2CSDC5GCIZTMS2ED/


[ovirt-users] Re: Possible sources of cpu steal and countermeasures

2019-12-05 Thread Klaas Demter
Hi,
Thanks for the quick response.

On Thu, Dec 5, 2019, 01:10 Nir Soffer  wrote:

> On Wed, Dec 4, 2019 at 6:15 PM  wrote:
> >
> > Hi,
> >
> > I'm having performance issues with a ovirt installation. It is showing
> > high steal (5-10%) for a cpu intensive VM. The hypervisor however has
> > more than 65% of his resources idle while the steal is seen inside of
> > the VM.
> >
> > Even when placing only a single VM on a hypervisor it still receives
> > steal (0-2%), even though the hypervisor is not overcommited.
> >
> >
> > Hypervisor:
> >
> > 2 Socket system in total 2*28(56HT) cores
> >
> >
> > VM:
> >
> > 30vCPUs (ovirt seems to think its a good idea to make that 15 sockets *
> > 2 cores)
>
> I think you can control this in oVirt.
>

Yes, I'm saying ovirt defaults to using 15 sockets * 2 cores if you don't
specify a different "advanced" configuration. This also leads to a funny
behavior that you can't increase the VMs from 30 to 35 cores online.


> > My questions are:
> >
> > a) Could it be that the hypervisor is trying to schedule all 30 cores on
> > a single numa node, ie using the HT cores instead of "real" ones and
> > this shows up as steal?
> >
> > b) Do I need to make VMs this big numa-aware and spread the vm over both
> > numa nodes?
> >
> > c) Would using the High Performance VM type help in this kind of
> situation?
> >
> > d) General advise: how do I reduce steal in an environment where the
> > hypervisor has idle resources
> >
> >
> > Any advise would be appreciated.
>
> These questions are mainly about qemu, so adding qemu-discuss.
>
> I think it will help if you share your vm qemu command line, found in:
> /var/log/libvit/qemu/vm-name.log
>

Log:

2019-11-16 22:33:33.487+: starting up libvirt version: 4.5.0, package:
10.el7_6.6 (Red Hat, Inc. ,
2019-02-21-14:30:01, x86-038.build.eng.bos.redhat.com), qemu version:
2.12.0qemu-kvm-rhev-2.12.0-18.el7_6.3, kernel: 3.10.0-957.10.1.el7.x86_64,
hostname: hypervisor.tld

LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
QEMU_AUDIO_DRV=spice /usr/libexec/qemu-kvm -name guest=vm,debug-threads=on
-S -object
secret,id=masterKey0,format=raw,file=/var/lib/libvirt/qemu/domain-24-vm/master-key.aes
-machine pc-i440fx-rhel7.5.0,accel=kvm,usb=off,dump-guest-core=off -cpu
Broadwell,spec-ctrl=on,ssbd=on,rtm=on,hle=on -m
size=534773760k,slots=16,maxmem=629145600k -realtime mlock=off -smp
30,maxcpus=32,sockets=16,cores=2,threads=1 -object iothread,id=iothread1
-numa node,nodeid=0,cpus=0-29,mem=522240 -uuid
95285008-8efb-446c-b75c-771f020cf494 -smbios
'type=1,manufacturer=oVirt,product=RHEV
Hypervisor,version=7.6-4.el7,serial=4c4c4544-004b-3510-805a-c3c04f485032,uuid=95285008-8efb-446c-b75c-771f020cf494'
-no-user-config -nodefaults -chardev
socket,id=charmonitor,fd=51,server,nowait -mon
chardev=charmonitor,id=monitor,mode=control -rtc
base=2019-11-16T22:33:33,driftfix=slew -global
kvm-pit.lost_tick_policy=delay -no-hpet -no-shutdown -global
PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot strict=on -device
piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device
virtio-scsi-pci,iothread=iothread1,id=ua-98c9be1a-c830-4718-9936-28a81e9a07b6,bus=pci.0,addr=0x5
-device
virtio-serial-pci,id=ua-3f6418a3-8b1a-49c3-b79b-ca5f1864cf47,max_ports=16,bus=pci.0,addr=0x4
-drive
if=none,id=drive-ua-641b4623-d2b3-4f7f-a31d-65959f5ffc9b,werror=report,rerror=report,readonly=on
-device
ide-cd,bus=ide.1,unit=0,drive=drive-ua-641b4623-d2b3-4f7f-a31d-65959f5ffc9b,id=ua-641b4623-d2b3-4f7f-a31d-65959f5ffc9b
-drive
file=/rhev/data-center/mnt/storage-domain/0f623c51-66c8-4a5b-a12f-95ab9c6184b4/images/88901d29-e223-457d-a80e-384b1f147cea/0f994c76-d525-4a4f-9513-c6220fe7c31c,format=raw,if=none,id=drive-ua-88901d29-e223-457d-a80e-384b1f147cea,serial=88901d29-e223-457d-a80e-384b1f147cea,werror=stop,rerror=stop,cache=none,aio=threads
-device
scsi-hd,bus=ua-98c9be1a-c830-4718-9936-28a81e9a07b6.0,channel=0,scsi-id=0,lun=0,drive=drive-ua-88901d29-e223-457d-a80e-384b1f147cea,id=ua-88901d29-e223-457d-a80e-384b1f147cea,bootindex=1,write-cache=on
-netdev
tap,fds=54:55:56:57,id=hostua-1fad81fe-8c0b-41dd-8015-7498ebbc2710,vhost=on,vhostfds=58:59:60:61
-device
virtio-net-pci,mq=on,vectors=10,host_mtu=1500,netdev=hostua-1fad81fe-8c0b-41dd-8015-7498ebbc2710,id=ua-1fad81fe-8c0b-41dd-8015-7498ebbc2710,mac=22:44:66:00:00:d0,bus=pci.0,addr=0x3
-chardev socket,id=charchannel0,fd=62,server,nowait -device
virtserialport,bus=ua-3f6418a3-8b1a-49c3-b79b-ca5f1864cf47.0,nr=1,chardev=charchannel0,id=channel0,name=ovirt-guest-agent.0
-chardev socket,id=charchannel1,fd=63,server,nowait -device
virtserialport,bus=ua-3f6418a3-8b1a-49c3-b79b-ca5f1864cf47.0,nr=2,chardev=charchannel1,id=channel1,name=org.qemu.guest_agent.0
-chardev spicevmc,id=charchannel2,name=vdagent -device
virtserialport,bus=ua-3f6418a3-8b1a-49c3-b79b-ca5f1864cf47.0,nr=3,chardev=charchannel2,id=channel2,name=com.redhat.spice.0
-spice