[ovirt-users] Re: CEPH - Opinions and ROI

2020-09-30 Thread matthew.st...@fujitsu.com
If you can’t go direct, how about round about, with an iSCSI gateway. From: Jeremey Wise Sent: Wednesday, September 30, 2020 11:33 PM To: users Subject: [ovirt-users] CEPH - Opinions and ROI I have for many years used gluster because..well. 3 nodes.. and so long as I can pull a drive out..

[ovirt-users] Re: Gluster Volumes - Correct Peer Connection

2020-09-30 Thread penguin pages
I think this is the issue. When HCI deployed nodes. and consumed the drives and setup "engine" "data" and "vmstore" The GUI was set for "storage" network via hostsnames correctly. And I think, based on watching replication traffic it is using 10Gb "storage" network. CLI shows peers on that

[ovirt-users] CEPH - Opinions and ROI

2020-09-30 Thread Jeremey Wise
I have for many years used gluster because..well. 3 nodes.. and so long as I can pull a drive out.. I can get my data.. and with three copies.. I have much higher chance of getting it. Downsides to gluster: Slower (its my home..meh... and I have SSD to avoid MTBF issues ) and with VDO.. and thin

[ovirt-users] Re: Version 4.4.2.6-1.el8 -Console Error: java.lang.reflect.UndeclaredThrowableException

2020-09-30 Thread Jeremey Wise
Ok.. made a backup.. ran from ovirt-engin the command " taskcleaner.sh -R -o -A" This cleared out issue.. but scared me a bit as it just terminated the connections / vm. I had to power vm off "hosted-engine --vm-shutdown" and then back on "hosted-engine --vm-start" Off to find the next

[ovirt-users] Re: VM AutoStart

2020-09-30 Thread Derek Atkins
I did. years ago. When 4.0 was current. Some of the work to implement that went into 4.4, where it will recover state on a crash (i.e., if you have VMs marked as auto-start and you have a power outage, it will restart them). However, I believe there is no order to it, and it will only start

[ovirt-users] Re: VM AutoStart

2020-09-30 Thread Jeremey Wise
Ya.. that is a lot easier. Someone should put this in as a feature request. I don't want HA (and have errors on getting that to work) I just want VMs to boot on initial cluster start. this was standard in libvirt :) I am trying to convert to oVirt ways... On Wed, Sep 30, 2020 at 4:10 PM

[ovirt-users] Re: VM AutoStart

2020-09-30 Thread Derek Atkins
HI, On Wed, September 30, 2020 3:50 pm, Jeremey Wise wrote: > As the three servers are Centos8 minimal installs. + oVirt HCI wizard to > keep them lean and mean... a couple questions Note that you run this on the Engine VM, not on a host. > 1) which version of python would I need for this (note

[ovirt-users] Re: Version 4.4.2.6-1.el8 -Console Error: java.lang.reflect.UndeclaredThrowableException

2020-09-30 Thread Jeremey Wise
I found this note from RedHat on bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1827033 Seems like this could be my issue This could be where had issue with rebuild of ovirt-engine. And then had to scrape out the disk files to then import them back in. I then moved the "old files" into

[ovirt-users] Re: VM AutoStart

2020-09-30 Thread Jeremey Wise
As the three servers are Centos8 minimal installs. + oVirt HCI wizard to keep them lean and mean... a couple questions 1) which version of python would I need for this (note in script about python 2 but isn't that deprecated?) [root@thor /]# yum install python Last metadata expiration check:

[ovirt-users] Re: VM AutoStart

2020-09-30 Thread Derek Atkins
I run it out of rc.local: /usr/local/sbin/start_vms.py > /var/log/start_vms 2>&1 & The script is smart enough to wait for the engine to be fully active. -derek On Wed, September 30, 2020 3:11 pm, Jeremey Wise wrote: > i would like to eventually go ansible route.. and was starting down that >

[ovirt-users] Re: VM AutoStart

2020-09-30 Thread Jeremey Wise
i would like to eventually go ansible route.. and was starting down that path but this is fabulous. I will modify and post how it went. One question: How /where do you set this saved new and delicious script so once oVirt-engine comes up... it runs? Thanks On Wed, Sep 30, 2020 at 2:42 PM

[ovirt-users] Re: update to 4.4 fails with "Domain format is different from master storage domain format" (v4.3 cluster with V4 NFS storage domains)

2020-09-30 Thread Sergey Kulikov
No, this is fresh storage(completely empty dir) and hosted-engine deploy creates V5 format domain in V4 DC, where master domain is also V4, I can see this in web available from local deploy VM. And storage is automatically renamed by deploy script. -- Wednesday, September 30, 2020,

[ovirt-users] Re: VM AutoStart

2020-09-30 Thread Derek Atkins
Hi, I had a script based around ovirt-shell which I re-wrote as a script around the Python SDK4 which I run on my engine during the startup sequence. The script will wait for the engine to come up and ensure the storage domains are up before it tries to start the VMs. Then it will go ahead and

[ovirt-users] Re: Power on VM - CLI / API

2020-09-30 Thread Klaas Demter
I would suggest to do it via one of the sdks, for example python https://github.com/oVirt/ovirt-engine-sdk/blob/master/sdk/examples/start_vm.py - you can create a simple python script you can start from cli. Alternatively use ansible, you can also call that from cli. Greetings Klaas On

[ovirt-users] Power on VM - CLI / API

2020-09-30 Thread Jeremey Wise
Can anyone post link. (with examples.. as most documentation for oVirt lacks this).. where I can power on a VM via CLI or API. As of now I cannot login to oVirt-Engine. No errors when I restart it.. https://lists.ovirt.org/archives/list/users@ovirt.org/thread/45KKF5TN5PRQ3R7MDOWIQTSYZXZRVDIZ/

[ovirt-users] Re: VM AutoStart

2020-09-30 Thread Strahil Nikolov via Users
Also consider setting a reasonable 'TimeoutStartSec=' in your systemd service file when you create the service... Best Regards, Strahil Nikolov В сряда, 30 септември 2020 г., 20:18:01 Гринуич+3, Strahil Nikolov via Users написа: I would create an ansible playbook that will be

[ovirt-users] Re: Gluster Volumes - Correct Peer Connection

2020-09-30 Thread Strahil Nikolov via Users
If you can do it from cli - use the cli as it has far more control over what the UI can provide. Usually I use UI for monitoring and basic stuff like starting/stopping the brick or setting the 'virt'group via the 'optimize for Virt' (or whatever it was called). Best Regards, Strahil Nikolov

[ovirt-users] Re: VM AutoStart

2020-09-30 Thread Strahil Nikolov via Users
I would create an ansible playbook that will be running from the engine: 1. Check the engine's health page via uri module and wait_for (maybe with a regex) Healthpage is : https://engine_FQDN/ovirt-engine/services/health 2. Use ansible ovirt_vm module to start your vms in the order you want 3.

[ovirt-users] Re: Replica Question

2020-09-30 Thread C Williams
Thank You Strahil !! On Wed, Sep 30, 2020 at 12:21 PM Strahil Nikolov wrote: > In your case it seems reasonable, but you should test the 2 stripe sizes > (128K vs 256K) before running in production. The good thing about replica > volumes is that you can remove a brick , recreate it from cli and

[ovirt-users] Re: adminstration portal wont complete load, looping

2020-09-30 Thread Philip Brown
to be clear: I dont have any special plugins loaded, and it USED to work in this browser just fine. - Original Message - From: "Philip Brown" To: "Strahil Nikolov" Cc: "users" Sent: Wednesday, September 30, 2020 9:55:20 AM Subject: [ovirt-users] Re: adminstration portal wont

[ovirt-users] Re: adminstration portal wont complete load, looping

2020-09-30 Thread Philip Brown
Hmm. used google chrome's "clear cache"... but still loops in my normal browser, even though it works in incognito Any tips for making regular browser happy again? ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to

[ovirt-users] Re: adminstration portal wont complete load, looping

2020-09-30 Thread Philip Brown
Huh! it works with incognito mode! O.o Thanks for that tip. Guess I need to figure out how to fully purge cache or something. - Original Message - From: "Strahil Nikolov" To: "users" , "Philip Brown" Sent: Wednesday, September 30, 2020 9:07:50 AM Subject: Re: [ovirt-users]

[ovirt-users] Re: Gluster Volumes - Correct Peer Connection

2020-09-30 Thread penguin pages
I have a network called "Storage" but not called "gluster logical network" Front end 172.16.100.0/24 for mgmt and vms (1Gb) "ovirtmgmt" Back end 172.16.101.0/24 for storage (10Gb) "Storage" and yes.. I was never able to figure out how to us UI to create bricks.. so I just was bad and

[ovirt-users] Re: Replica Question

2020-09-30 Thread Strahil Nikolov via Users
In your case it seems reasonable, but you should test the 2 stripe sizes (128K vs 256K) before running in production. The good thing about replica volumes is that you can remove a brick , recreate it from cli and then add it back. Best Regards, Strahil Nikolov В сряда, 30 септември 2020

[ovirt-users] Re: Is it possible to change scheduler optimization settings of cluster using ansible or some other automation way

2020-09-30 Thread Strahil Nikolov via Users
You can use this ansible module and assign your scheduling policy: https://docs.ansible.com/ansible/latest/collections/ovirt/ovirt/ovirt_cluster_module.html Best Regards, Strahil Nikolov В сряда, 30 септември 2020 г., 11:36:01 Гринуич+3, Kushagra Agarwal написа: I was hoping if i

[ovirt-users] Re: update to 4.4 fails with "Domain format is different from master storage domain format" (v4.3 cluster with V4 NFS storage domains)

2020-09-30 Thread Strahil Nikolov via Users
Are you trying to use the same storage domain ? I hope not, as this is not supposed to be done like that.As far as I remember - you need fresh storage. Best Regards, Strahil NIkolov В вторник, 29 септември 2020 г., 20:07:51 Гринуич+3, Sergey Kulikov написа: Hello, I'm trying to

[ovirt-users] Re: adminstration portal wont complete load, looping

2020-09-30 Thread Strahil Nikolov via Users
I got the same behaviour with adblock plus add-on. Try in incognito mode (or with disabled plugins/ new fresh browser). Best Regards, Strahil Nikolov В вторник, 29 септември 2020 г., 18:50:05 Гринуич+3, Philip Brown написа: I have an odd situation: When I go to

[ovirt-users] VM AutoStart

2020-09-30 Thread Jeremey Wise
When I have to shut down cluster... ups runs out etc.. I need a sequence set of just a small number of VMs to "autostart" Normally I just use DNS FQND to connect to oVirt engine but as two of my VMs are a DNS HA cluster.. as well as NTP / SMTP /DHCP etc... I need those two infrastructure VMs

[ovirt-users] Re: Replica Question

2020-09-30 Thread C Williams
Hello, I am planning to use (6) 1 TB disks in a hardware RAID 6 array which will yield 4 data disks per oVirt Gluster brick. However. https://access.redhat.com/documentation/en-us/red_hat_gluster_storage/3.5/html-single/administration_guide/index#sect-Disk_Configuration --- states "For RAID 6,

[ovirt-users] java.lang.reflect.UndeclaredThrowableException - oVirt engine UI

2020-09-30 Thread Jeremey Wise
I tried to post on website but .. it did not seem to work... so sorry if this is double posting. oVirt login this AM. accepted username and password but got java error. Restarted oVirt engine ## hosted-engine --set-maintenance --mode=global hosted-engine --vm-shutdown hosted-engine

[ovirt-users] Re: adminstration portal wont complete load, looping

2020-09-30 Thread Philip Brown
Where is "server.log"? A quick google search didnt seem to tell me about it. - Original Message - From: "Sharon Gratch" To: "Philip Brown" Cc: "users" Sent: Wednesday, September 30, 2020 1:51:18 AM Subject: Re: [ovirt-users] adminstration portal wont complete load, looping Hi, could

[ovirt-users] Version 4.4.2.6-1.el8 -Console Error: java.lang.reflect.UndeclaredThrowableException

2020-09-30 Thread penguin pages
Got message this AM when tried to login to oVirt Engine which up till now has been working fine. I can supply username and password and get portal to choose "Administration Portal" or "VM Portal" I have tested both.. both have same response about

[ovirt-users] Re: Latest ManagedBlockDevice documentation

2020-09-30 Thread Benny Zlotnik
Not sure about this, adding +Yedidyah Bar David On Wed, Sep 30, 2020 at 3:04 PM Michael Thomas wrote: > > I hadn't installed the necessary packages when the engine was first > installed. > > However, running 'engine-setup --reconfigure-optional-components' > doesn't work at the moment because

[ovirt-users] Re: adminstration portal wont complete load, looping

2020-09-30 Thread Philip Brown
output from engine.log when I try to access the admin page is as follows: 2020-09-30 06:33:03,324-07 INFO [org.ovirt.engine.core.sso.utils.AuthenticationUtils] (default task-16) [] User xx successfully logged in with scopes: ovirt-app-admin ovirt-app-api ovirt-app-portal

[ovirt-users] Re: Problem with Cluster-wise BIOS Settings in oVirt 4.4

2020-09-30 Thread Arik Hadas
On Wed, Sep 30, 2020 at 1:29 PM Rodrigo G. López wrote: > Hi Arik, > > Ok, we'll try with that one. > That's just to prevent your hosted engine from being corrupted > > The oVirt version we use is 4.4.1. > We made several fixes in that area since then, however I see this still happens on

[ovirt-users] Re: Latest ManagedBlockDevice documentation

2020-09-30 Thread Michael Thomas
I hadn't installed the necessary packages when the engine was first installed. However, running 'engine-setup --reconfigure-optional-components' doesn't work at the moment because (by design) my engine does not have a network route outside of the cluster. It fails with: [ INFO ] DNF

[ovirt-users] Re: Problem with Cluster-wise BIOS Settings in oVirt 4.4

2020-09-30 Thread Rodrigo G . López
The problem we face right now is that, since the engine is a VM of itself, we can't bring it back up to apply the new configuration. Is there any way to fix this? Without reinstalling preferably. On 9/30/20 12:25 PM, Rodrigo G. López wrote: Hi Arik, Ok, we'll try with that one. The oVirt

[ovirt-users] Re: update to 4.4 fails with "Domain format is different from master storage domain format" (v4.3 cluster with V4 NFS storage domains)

2020-09-30 Thread Sergey Kulikov
I was able to finish update manually creating hosted_storage domain from new engine web interface after first failure, in this case it was created with format V4 and ansible playbook doesn't recreate it, after updating engine and host updating cluster compatibility level to 4.4 also updated

[ovirt-users] Re: Problem with Cluster-wise BIOS Settings in oVirt 4.4

2020-09-30 Thread Rodrigo G . López
Hi Arik, Ok, we'll try with that one. The oVirt version we use is 4.4.1. On 9/30/20 11:55 AM, Arik Hadas wrote: On Wed, Sep 30, 2020 at 12:30 PM Rodrigo G. López mailto:r.gonza...@telfy.com>> wrote: Hi all, We are running an oVirt 4.4 Hosted Engine as a VM, and after

[ovirt-users] Re: Problem with Cluster-wise BIOS Settings in oVirt 4.4

2020-09-30 Thread Arik Hadas
On Wed, Sep 30, 2020 at 12:30 PM Rodrigo G. López wrote: > Hi all, > > We are running an oVirt 4.4 Hosted Engine as a VM, and after changing the > Cluster's BIOS type from Q35 with Legacy BIOS (the default one after > installation) to Preexistent, the VM fails with the following error: > > XML

[ovirt-users] Problem with Cluster-wise BIOS Settings in oVirt 4.4

2020-09-30 Thread Rodrigo G . López
Hi all, We are running an oVirt 4.4 Hosted Engine as a VM, and after changing the Cluster's BIOS type from Q35 with Legacy BIOS (the default one after installation) to Preexistent, the VM fails with the following error: XML error: The device at PCI address :00:02.0 cannot be plugged into

[ovirt-users] Re: adminstration portal wont complete load, looping

2020-09-30 Thread Sharon Gratch
Hi, could you please share your engine.log and server.log? Did you try restarting the engine and re-login from https://ovengine/ovirt-engine? Thanks, Sharon On Tue, Sep 29, 2020 at 6:49 PM Philip Brown wrote: > I have an odd situation: > When I go to >

[ovirt-users] Is it possible to change scheduler optimization settings of cluster using ansible or some other automation way

2020-09-30 Thread Kushagra Agarwal
I was hoping if i can get some help with the below oVirt scenario: *Problem Statement*:- Is it possible to change scheduler optimization settings of cluster using ansible or some other automation way *Description*:- Do we have any ansible module or any other CLI based approach which can help us

[ovirt-users] Re: Latest ManagedBlockDevice documentation

2020-09-30 Thread Benny Zlotnik
When you ran `engine-setup` did you enable cinderlib preview (it will not be enabled by default)? It should handle the creation of the database automatically, if you didn't you can enable it by running: `engine-setup --reconfigure-optional-components` On Wed, Sep 30, 2020 at 1:58 AM Michael

[ovirt-users] Is it possible to change scheduler optimization settings of cluster using ansible or some other automation way

2020-09-30 Thread kushagra2agarwal
Do we have any ansible module or any other CLI based approach which can help us to change 'scheduler optimization' settings of cluster in oVIrt. Scheduler optimization settings of cluster can be found under Scheduling Policy tab ( Compute -> Clusters(select the cluster) -> click on edit and