[ovirt-users] Re: For data integrity make sure that the server is configured with Quorum (both client and server Quorum)

2021-01-21 Thread Ahmad Khiet
added Ritesh Chikatwar,
what do you think?

On Thu, Jan 21, 2021 at 12:32 PM tommy  wrote:

> *I get the current setting:*
>
>
>
> [root@gluster1 ~]# gluster volume info all
>
>
>
> Volume Name: volume1
>
> Type: Disperse
>
> Volume ID: 237f7379-cd03-44ef-af39-f6065d01d520
>
> Status: Started
>
> Snapshot Count: 0
>
> Number of Bricks: 1 x (2 + 1) = 3
>
> Transport-type: tcp
>
> Bricks:
>
> Brick1: gluster1:/data/glusterfs/myvolume/mybrick1/brick
>
> Brick2: gluster2:/data/glusterfs/myvolume/mybrick1/brick
>
> Brick3: gluster3:/data/glusterfs/myvolume/mybrick1/brick
>
> Options Reconfigured:
>
> transport.address-family: inet
>
> nfs.disable: on
>
>
>
>
>
> *Then I enable the quorum on the server side:*
>
>
>
> [root@gluster1 ~]# gluster volume set all cluster.server-quorum-ratio 51%
>
> volume set: success
>
> [root@gluster1 ~]#
>
> [root@gluster1 ~]# gluster volume set volume1 cluster.server-quorum-type
> server
>
> volume set: success
>
> [root@gluster1 ~]#
>
>
>
>
>
> *Now, the configure is :*
>
>
>
> [root@gluster1 ~]# gluster volume info volume1
>
>
>
> Volume Name: volume1
>
> Type: Disperse
>
> Volume ID: 237f7379-cd03-44ef-af39-f6065d01d520
>
> Status: Started
>
> Snapshot Count: 0
>
> Number of Bricks: 1 x (2 + 1) = 3
>
> Transport-type: tcp
>
> Bricks:
>
> Brick1: gluster1:/data/glusterfs/myvolume/mybrick1/brick
>
> Brick2: gluster2:/data/glusterfs/myvolume/mybrick1/brick
>
> Brick3: gluster3:/data/glusterfs/myvolume/mybrick1/brick
>
> Options Reconfigured:
>
> *cluster.server-quorum-type: server*
>
> transport.address-family: inet
>
> nfs.disable: on
>
> *cluster.server-quorum-ratio: 51%*
>
> [root@gluster1 ~]#
>
>
>
>
>
> I want know ,the server quorum is about setting the percen of numbers of
> the active-connected nodes,  no matter what type of the volumes , is this
> right ?
>
>
>
> But if I use the client quorum, the the type of volumes now mounting is
> acting, only duplicated type volume can use the client quorum, is this
> right ?
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> *From:* users-boun...@ovirt.org  *On Behalf Of *Ahmad
> Khiet
> *Sent:* Thursday, January 21, 2021 2:48 AM
> *To:* tommy 
> *Cc:* users 
> *Subject:* [ovirt-users] Re: For data integrity make sure that the server
> is configured with Quorum (both client and server Quorum)
>
>
>
> Hi,
>
> as shown in the alert message, that Quorum must be configured with
> GlusterFs in the server side and client side.
>
> please see this resource to configure it for client side and server side
> https://access.redhat.com/documentation/en-us/red_hat_gluster_storage/3.1/html/administration_guide/sect-managing_split-brain
>
>
>
> Have a nice day
>
>
>
> On Wed, Jan 20, 2021 at 10:37 AM tommy  wrote:
>
> When I want to create a glusterFS domain, the above words appear.
>
>
>
> What’s meaning of these words?
>
>
>
> _______
> Users mailing list -- users@ovirt.org
> To unsubscribe send an email to users-le...@ovirt.org
> Privacy Statement: https://www.ovirt.org/privacy-policy.html
> oVirt Code of Conduct:
> https://www.ovirt.org/community/about/community-guidelines/
> List Archives:
> https://lists.ovirt.org/archives/list/users@ovirt.org/message/UMTB5A6AODYZJU26ILP4ZL3CNOX5D6KC/
>
>
>
>
> --
>
> *Ahmad Khiet*
>
> Red Hat <https://www.redhat.com/>
>
> akh...@redhat.com
> M: +972-54-6225629
>
> <https://red.ht/sig>
>
>
>


-- 

Ahmad Khiet

Red Hat <https://www.redhat.com/>

akh...@redhat.com
M: +972-54-6225629
<https://red.ht/sig>
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/HKRHP6DGTEQYFP2WUPWDJQEYKV322E6M/


[ovirt-users] Re: For data integrity make sure that the server is configured with Quorum (both client and server Quorum)

2021-01-20 Thread Ahmad Khiet
Hi,
as shown in the alert message, that Quorum must be configured with
GlusterFs in the server side and client side.
please see this resource to configure it for client side and server side
https://access.redhat.com/documentation/en-us/red_hat_gluster_storage/3.1/html/administration_guide/sect-managing_split-brain

Have a nice day

On Wed, Jan 20, 2021 at 10:37 AM tommy  wrote:

> When I want to create a glusterFS domain, the above words appear.
>
>
>
> What’s meaning of these words?
>
>
>
> ___
> Users mailing list -- users@ovirt.org
> To unsubscribe send an email to users-le...@ovirt.org
> Privacy Statement: https://www.ovirt.org/privacy-policy.html
> oVirt Code of Conduct:
> https://www.ovirt.org/community/about/community-guidelines/
> List Archives:
> https://lists.ovirt.org/archives/list/users@ovirt.org/message/UMTB5A6AODYZJU26ILP4ZL3CNOX5D6KC/
>


-- 

Ahmad Khiet

Red Hat <https://www.redhat.com/>

akh...@redhat.com
M: +972-54-6225629
<https://red.ht/sig>
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/IEQ5VNZ2JFULHCX4IOGDNDX2F7ODA5FM/


[ovirt-users] Re: Why cannot create new volume ?

2021-01-20 Thread Ahmad Khiet
I think that creating a volume must be done under gluster storage domain.
what's your goal? maybe what you need is to create a storage domain and
disks?

Have a nice day

On Wed, Jan 20, 2021 at 10:40 AM tommy  wrote:

> ___
> Users mailing list -- users@ovirt.org
> To unsubscribe send an email to users-le...@ovirt.org
> Privacy Statement: https://www.ovirt.org/privacy-policy.html
> oVirt Code of Conduct:
> https://www.ovirt.org/community/about/community-guidelines/
> List Archives:
> https://lists.ovirt.org/archives/list/users@ovirt.org/message/3NVUWMQPOESIEJFUA6LZPSI4C6DOC53P/
>


-- 

Ahmad Khiet

Red Hat <https://www.redhat.com/>

akh...@redhat.com
M: +972-54-6225629
<https://red.ht/sig>
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/5NFO4PG23IR5MNSXIR5LI6HMBDM6RXOZ/


[ovirt-users] Re: Moving VM disks from one storage domain to another. Automate?

2020-09-16 Thread Ahmad Khiet
Hi,

I suggest using REST API to do what you described. or the python sdk.

have a nice day


On Tue, Sep 15, 2020 at 10:53 PM Green, Jacob Allen /C <
jacob.a.gr...@exxonmobil.com> wrote:

>I am looking for an automated way, via Ansible to move a VM
> disk from one storage domain to another. I found the following,
> https://docs.ansible.com/ansible/latest/modules/ovirt_disk_module.html
> and while it mentions copying a VM disk image from one domain to another it
> does not mention a live storage migration. Which is what I am looking to
> do. I want to take roughly 100 VMs and move their disk images from one
> domain to another that is available to the datacenter in some
> automated/scripted fashion. I am just curious if anyone out there has had
> to do this and how they tackled it. Or perhaps I am missing some easy
> obvious way, other than clicking all the disks and clicking move. However
> from the looks of it, if I did click all the disk and selected move, it
> appears RHV tries to do them all at once, which is probably not ideal, I
> would like it to move the disks in a serial One after another fashion, to
> conserve throughput and IO.
>
>
>
> I also did not see anything on Ansible galaxy or the ovirt github that
> would do this.
>
>
>
>
>
>
>
> Thank you.
> ___
> Users mailing list -- users@ovirt.org
> To unsubscribe send an email to users-le...@ovirt.org
> Privacy Statement: https://www.ovirt.org/privacy-policy.html
> oVirt Code of Conduct:
> https://www.ovirt.org/community/about/community-guidelines/
> List Archives:
> https://lists.ovirt.org/archives/list/users@ovirt.org/message/DRKDNUBXH7HXKPNBIW6ZO2U36XIANLGO/
>


-- 

Ahmad Khiet

Red Hat <https://www.redhat.com/>

akh...@redhat.com
M: +972-54-6225629
<https://red.ht/sig>
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/KYY7D3TYYOEQ7NDQITKOZLJLJTIHZM32/


[ovirt-users] Re: Bad volume specification

2020-09-16 Thread Ahmad Khiet
988b4dc7985b', 'poolID':
> '0001-0001-0001-0001-0311', 'volumeID':
> 'bd714f21-8eed-43ee-a2d4-3d2ef1ee4c3f', 'path':
> '/rhev/data-center/mnt/blockSD/55327311-e47c-46b5-b168-258c5924757b/images/f5bd2e15-a1ab-4724-883a-988b4dc7985b/bd714f21-8eed-43ee-a2d4-3d2ef1ee4c3f',
> 'discard': False, 'format': 'cow', 'propagateErrors': 'off', 'cache':
> 'none', 'iface': 'virtio', 'name': 'vda', 'serial':
> 'f5bd2e15-a1ab-4724-883a-988b4dc7985b', 'index': 0}",)]]'
> 2020-09-15 20:10:38,295-03 INFO
>  [org.ovirt.engine.core.vdsbroker.vdsbroker.HotPlugDiskVDSCommand]
> (EE-ManagedThreadFactory-engine-Thread-36528)
> [dd72c8e8-cdbe-470f-8e32-b3d14b96f37a] HostName = nodo2
> 2020-09-15 20:10:38,295-03 ERROR
> [org.ovirt.engine.core.vdsbroker.vdsbroker.HotPlugDiskVDSCommand]
> (EE-ManagedThreadFactory-engine-Thread-36528)
> [dd72c8e8-cdbe-470f-8e32-b3d14b96f37a] Command
> 'HotPlugDiskVDSCommand(HostName = nodo2,
> HotPlugDiskVDSParameters:{hostId='1c24c269-76c3-468d-a7ce-d0332beb7aef',
> vmId='71db02c2-df29-4552-8a7e-cb8bb429a2ac',
> diskId='f5bd2e15-a1ab-4724-883a-988b4dc7985b', addressMap='null'})'
> execution failed: VDSGenericException: VDSErrorException: Failed to
> HotPlugDiskVDS, error = General Exception: ("Bad volume specification
> {'device': 'disk', 'type': 'disk', 'diskType': 'block', 'specParams': {},
> 'alias': 'ua-f5bd2e15-a1ab-4724-883a-988b4dc7985b', 'domainID':
> '55327311-e47c-46b5-b168-258c5924757b', 'imageID':
> 'f5bd2e15-a1ab-4724-883a-988b4dc7985b', 'poolID':
> '0001-0001-0001-0001-0311', 'volumeID':
> 'bd714f21-8eed-43ee-a2d4-3d2ef1ee4c3f', 'path':
> '/rhev/data-center/mnt/blockSD/55327311-e47c-46b5-b168-258c5924757b/images/f5bd2e15-a1ab-4724-883a-988b4dc7985b/bd714f21-8eed-43ee-a2d4-3d2ef1ee4c3f',
> 'discard': False, 'format': 'cow', 'propagateErrors': 'off', 'cache':
> 'none', 'iface': 'virtio', 'name': 'vda', 'serial':
> 'f5bd2e15-a1ab-4724-883a-988b4dc7985b', 'index': 0}",), code = 100
> 2020-09-15 20:10:38,296-03 INFO
>  [org.ovirt.engine.core.vdsbroker.vdsbroker.HotPlugDiskVDSCommand]
> (EE-ManagedThreadFactory-engine-Thread-36528)
> [dd72c8e8-cdbe-470f-8e32-b3d14b96f37a] FINISH, HotPlugDiskVDSCommand,
> return: , log id: f57ee9e
> 2020-09-15 20:10:38,296-03 ERROR
> [org.ovirt.engine.core.bll.storage.disk.HotPlugDiskToVmCommand]
> (EE-ManagedThreadFactory-engine-Thread-36528)
> [dd72c8e8-cdbe-470f-8e32-b3d14b96f37a] Command
> 'org.ovirt.engine.core.bll.storage.disk.HotPlugDiskToVmCommand' failed:
> EngineException:
> org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException:
> VDSGenericException: VDSErrorException: Failed to HotPlugDiskVDS, error =
> General Exception: ("Bad volume specification {'device': 'disk', 'type':
> 'disk', 'diskType': 'block', 'specParams': {}, 'alias':
> 'ua-f5bd2e15-a1ab-4724-883a-988b4dc7985b', 'domainID':
> '55327311-e47c-46b5-b168-258c5924757b', 'imageID':
> 'f5bd2e15-a1ab-4724-883a-988b4dc7985b', 'poolID':
> '0001-0001-0001-0001-0311', 'volumeID':
> 'bd714f21-8eed-43ee-a2d4-3d2ef1ee4c3f', 'path':
> '/rhev/data-center/mnt/blockSD/55327311-e47c-46b5-b168-258c5924757b/images/f5bd2e15-a1ab-4724-883a-988b4dc7985b/bd714f21-8eed-43ee-a2d4-3d2ef1ee4c3f',
> 'discard': False, 'format': 'cow', 'propagateErrors': 'off', 'cache':
> 'none', 'iface': 'virtio', 'name': 'vda', 'serial':
> 'f5bd2e15-a1ab-4724-883a-988b4dc7985b', 'index': 0}",), code = 100 (Failed
> with error GeneralException and code 100)
> 2020-09-15 20:10:38,307-03 ERROR
> [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector]
> (EE-ManagedThreadFactory-engine-Thread-36528)
> [dd72c8e8-cdbe-470f-8e32-b3d14b96f37a] EVENT_ID:
> USER_FAILED_HOTPLUG_DISK(2,001), Failed to plug disk owncloud_Disk0 to VM
> owncloud (User: admin@internal-authz).
> ___
> Users mailing list -- users@ovirt.org
> To unsubscribe send an email to users-le...@ovirt.org
> Privacy Statement: https://www.ovirt.org/privacy-policy.html
> oVirt Code of Conduct:
> https://www.ovirt.org/community/about/community-guidelines/
> List Archives:
> https://lists.ovirt.org/archives/list/users@ovirt.org/message/TA26UYTTRJBMOKAL4KJKMTIQ6M6VB4RK/
> ___
> Users mailing list -- users@ovirt.org
> To unsubscribe send an email to users-le...@ovirt.org
> Privacy Statement: https://www.ovirt.org/privacy-policy.html
> oVirt Code of Conduct:
> https://www.ovirt.org/community/about/community-guidelines/
> List Archives:
> https://lists.ovirt.org/archives/list/users@ovirt.org/message/UQKTWNSNQAJ6UXPYHRZPR4IEFYNVQV7K/
>


-- 

Ahmad Khiet

Red Hat <https://www.redhat.com/>

akh...@redhat.com
M: +972-54-6225629
<https://red.ht/sig>
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/TOZCR7HNZE7GLHCE7WIEQY7UTXNH6OYM/


[ovirt-users] Re: Strange SD problem

2020-07-16 Thread Ahmad Khiet
Hi,
if its the same LUN, then why not remove and import back?


On Thu, Jul 16, 2020 at 3:21 PM Arsène Gschwind 
wrote:

> Hi,
>
> We did compare engine backups and found some differences in the LUNs
>
> "public"."luns"  (restored db from 2020.04.09)
> 
>
> physical_volume_id  lun_idvolume_group_id 
>   serial lun_mapping  
> vendor_id   product_id   device_sizediscard_max_size
>
> wEx3tY-OELy-gOtD-CFDp-az4D-EyYO-1SAAqd  repl_HanaDB_osd_01
> a1q5Jr-Bd7h-wEVJ-9b0C-Ggnr-M1JI-kyXeDV
> SHUAWEI_XSG1_2102350RMG10HC210053  6HUAWEI  XSG1 
> 4096   268435456
>
> DPUtaW-Q5zp-aZos-HriP-5Z0v-hiWO-w7rmwG  repl_HanaLogs_osd_01  
> 4TCXZ7-R1l1-xkdU-u0vx-S3n4-JWcE-qksPd1
> SHUAWEI_XSG1_2102350RMG10HC200035  7HUAWEI  XSG1 
> 2048   268435456
>
>
> "public"."luns"  (current db)
>
> 
>
> physical_volume_id  lun_idvolume_group_id 
>   serial lun_mapping  
> vendor_id   product_id   device_sizediscard_max_size
>
> wEx3tY-OELy-gOtD-CFDp-az4D-EyYO-1SAAqd  repl_HanaDB_osd_01
> a1q5Jr-Bd7h-wEVJ-9b0C-Ggnr-M1JI-kyXeDV
> SHUAWEI_XSG1_2102350RMG10HC210053  6HUAWEI  XSG1 
> 4096   268435456
>
> repl_HanaLogs_osd_01  
>   SHUAWEI_XSG1_2102350RMG10HC210054  7
> HUAWEI  XSG1 2548   268435456
>
>
> We observed that the physical_volume_id and volume_group_id is missing
> from the corrupt SD.
> We also observed that the serial has changed on the corrupted SD/LUN.
> Is the serial calculated or read somewhere?
> Would it be possible to inject the missing values in the engine DB to
> recover to a consistent state?
>
> Thanks for any help.
> Arsene
>
>
> On Wed, 2020-07-15 at 13:24 +0300, Ahmad Khiet wrote:
>
> Hi Arsène,
>
> can you please send which version are you referring to?
>
> as shown in the log: Storage domains with IDs 
> [6b82f31b-fa2a-406b-832d-64d9666e1bcc]
> could not be synchronized. To synchronize them, please move them to
> maintenance and then activate.
> can you put them in maintenance and then activate them back so it will be
> synced?
> I guess that it is out of sync, that's why the "Add" button appears to
> already added LUNs
>
>
>
> On Tue, Jul 14, 2020 at 4:58 PM Arsène Gschwind 
> wrote:
>
> Hi Ahmad,
>
> I did the following:
>
> 1. Storage -> Storage Domains
> 2 Click the existing Storage Domain and click "Manage Domain"
> and then I see next to the LUN which is already part of the SD the "Add"
> button
>
> I do not want to click add since it may destroy the existing SD or the
> content of the LUNs.
> In the Engine Log I see the following:
>
> 020-07-14 09:57:45,131+02 WARN  
> [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] 
> (EE-ManagedThreadFactory-engine-Thread-20) [277145f2] EVENT_ID: 
> STORAGE_DOMAINS_COULD_NOT_BE_SYNCED(1,046), Storage domains with IDs 
> [6b82f31b-fa2a-406b-832d-64d9666e1bcc] could not be synchronized. To 
> synchronize them, please move them to maintenance and then activate.
>
>
> Thanks a lot
>
> On Tue, 2020-07-14 at 16:07 +0300, Ahmad Khiet wrote:
>
> Hi Arsène Gschwind,
>
> it's really strange that you see "Add" on a LUN that already has been
> added to the database.
> to verify the steps you did make at first,
> 1- Storage -> Storage Domains
> 2- New Domain - [ select iSCSI ]
> 3- click on "+" on the iscsi target, then you see the "Add" button is
> available
> 4- after clicking add and ok, then this error will be shown in the logs
> is that right?
>
> can you also attach vdsm log?
>
>
>
>
> On Tue, Jul 14, 2020 at 1:15 PM Arsène Gschwind 
> wrote:
>
> Hello all,
>
> I've checked all my multipath configuration and everything seems korrekt.
> Is there a way to correct this, may be in the DB?
>
> I really need some help, thanks a lot.
> Arsène
>
> On Tue, 2020-07-14 at 00:29 +, Arsène Gschwind wrote:
>
> HI,
>
> I'm having a strange behavior with a SD. When trying to manage the SD I
> see they "Add" button for the LUN which should already be the one use for
> that SD.
> In the Logs I see t

[ovirt-users] Re: Strange SD problem

2020-07-15 Thread Ahmad Khiet
Hi Arsène,

can you please send which version are you referring to?

as shown in the log: Storage domains with IDs
[6b82f31b-fa2a-406b-832d-64d9666e1bcc]
could not be synchronized. To synchronize them, please move them to
maintenance and then activate.
can you put them in maintenance and then activate them back so it will be
synced?
I guess that it is out of sync, that's why the "Add" button appears to
already added LUNs



On Tue, Jul 14, 2020 at 4:58 PM Arsène Gschwind 
wrote:

> Hi Ahmad,
>
> I did the following:
>
> 1. Storage -> Storage Domains
> 2 Click the existing Storage Domain and click "Manage Domain"
> and then I see next to the LUN which is already part of the SD the "Add"
> button
>
> I do not want to click add since it may destroy the existing SD or the
> content of the LUNs.
> In the Engine Log I see the following:
>
> 020-07-14 09:57:45,131+02 WARN  
> [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] 
> (EE-ManagedThreadFactory-engine-Thread-20) [277145f2] EVENT_ID: 
> STORAGE_DOMAINS_COULD_NOT_BE_SYNCED(1,046), Storage domains with IDs 
> [6b82f31b-fa2a-406b-832d-64d9666e1bcc] could not be synchronized. To 
> synchronize them, please move them to maintenance and then activate.
>
>
> Thanks a lot
>
> On Tue, 2020-07-14 at 16:07 +0300, Ahmad Khiet wrote:
>
> Hi Arsène Gschwind,
>
> it's really strange that you see "Add" on a LUN that already has been
> added to the database.
> to verify the steps you did make at first,
> 1- Storage -> Storage Domains
> 2- New Domain - [ select iSCSI ]
> 3- click on "+" on the iscsi target, then you see the "Add" button is
> available
> 4- after clicking add and ok, then this error will be shown in the logs
> is that right?
>
> can you also attach vdsm log?
>
>
>
>
> On Tue, Jul 14, 2020 at 1:15 PM Arsène Gschwind 
> wrote:
>
> Hello all,
>
> I've checked all my multipath configuration and everything seems korrekt.
> Is there a way to correct this, may be in the DB?
>
> I really need some help, thanks a lot.
> Arsène
>
> On Tue, 2020-07-14 at 00:29 +, Arsène Gschwind wrote:
>
> HI,
>
> I'm having a strange behavior with a SD. When trying to manage the SD I
> see they "Add" button for the LUN which should already be the one use for
> that SD.
> In the Logs I see the following:
>
> 2020-07-13 17:48:07,292+02 ERROR
> [org.ovirt.engine.core.dal.dbbroker.BatchProcedureExecutionConnectionCallback]
> (EE-ManagedThreadFactory-engine-Thread-95) [51091853] Can't execute batch:
> Batch entry 0 select * from public.insertluns(CAST ('repl_HanaLogs_osd_01'
> AS varchar),CAST ('DPUtaW-Q5zp-aZos-HriP-5Z0v-hiWO-w7rmwG' AS varchar),CAST
> ('4TCXZ7-R1l1-xkdU-u0vx-S3n4-JWcE-qksPd1' AS varchar),CAST
> ('SHUAWEI_XSG1_2102350RMG10HC200035' AS varchar),CAST (7 AS int4),CAST
> ('HUAWEI' AS varchar),CAST ('XSG1' AS varchar),CAST (2548 AS int4),CAST
> (268435456 AS int8)) as result was aborted: ERROR: duplicate key value
> violates unique constraint "pk_luns"
>   Detail: Key (lun_id)=(repl_HanaLogs_osd_01) already exists.
>   Where: SQL statement "INSERT INTO LUNs (
> LUN_id,
> physical_volume_id,
> volume_group_id,
> serial,
> lun_mapping,
> vendor_id,
> product_id,
> device_size,
> discard_max_size
> )
> VALUES (
> v_LUN_id,
> v_physical_volume_id,
> v_volume_group_id,
> v_serial,
> v_lun_mapping,
> v_vendor_id,
> v_product_id,
> v_device_size,
> v_discard_max_size
> )"
> PL/pgSQL function insertluns(character varying,character varying,character
> varying,character varying,integer,character varying,character
> varying,integer,bigint) line 3 at SQL statement  Call getNextException to
> see other errors in the batch.
> 2020-07-13 17:48:07,292+02 ERROR
> [org.ovirt.engine.core.dal.dbbroker.BatchProcedureExecutionConnectionCallback]
> (EE-ManagedThreadFactory-engine-Thread-95) [51091853] Can't execute batch.
> Next exception is: ERROR: duplicate key value violates unique constraint
> "pk_luns"
>   Detail: Key (lun_id)=(repl_HanaLogs_osd_01) already exists.
>   Where: SQL statement "INSERT INTO LUNs (
> LUN_id,
> physical_volume_id,
> volume_group_id,
> serial,
> lun_mapping,
> vendor_id,
> product_id,
> device_size,
> discard_max_size
> )
> VALUES (
> v_LUN_id,
> v_physical_volume_id,
> v_volume_group_id,
> v_seria

[ovirt-users] Re: Strange SD problem

2020-07-14 Thread Ahmad Khiet
> v_product_id,
> v_device_size,
> v_discard_max_size
> )"
>
> It looks like the engine will add a LUN to an SD and it already exist...
> Any Idea how to resolve that problem?
>
> Thanks a lot
>
>
> --
>
>
> Arsène Gschwind 
> Universitaet Basel
>
> ___
>
> Users mailing list --
>
> users@ovirt.org
>
>
> To unsubscribe send an email to
>
> users-le...@ovirt.org
>
>
> Privacy Statement:
>
> https://www.ovirt.org/privacy-policy.html
>
>
> oVirt Code of Conduct:
>
> https://www.ovirt.org/community/about/community-guidelines/
>
>
> List Archives:
>
> https://lists.ovirt.org/archives/list/users@ovirt.org/message/2YE7ZX53W4WDLHJW34P5CQTGTHW4RJGY/
>
>
> --
>
> Arsène Gschwind 
> Universitaet Basel
> ___
> Users mailing list -- users@ovirt.org
> To unsubscribe send an email to users-le...@ovirt.org
> Privacy Statement: https://www.ovirt.org/privacy-policy.html
> oVirt Code of Conduct:
> https://www.ovirt.org/community/about/community-guidelines/
> List Archives:
> https://lists.ovirt.org/archives/list/users@ovirt.org/message/4UNSPGYZPYRQDZNF4GMFROK4GIDYPHS7/
>


-- 

Ahmad Khiet

Red Hat <https://www.redhat.com/>

akh...@redhat.com
M: +972-54-6225629
<https://red.ht/sig>
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/PQYOUQZ3HNWQ3LF5WCWPAQMYYI4WZKB3/


[ovirt-users] Re: Unable to attach ISO domain to Datacenter

2019-11-17 Thread Ahmad Khiet
Hi Ivan,

can you please provide ovirt engine log and vdsm logs?



On Sun, Nov 17, 2019 at 9:19 AM Ivan de Gusmão Apolonio <
i...@apolonio.com.br> wrote:

> I'm having trouble to create a storage ISO Domain and attach it to a
> Datacenter. It just give me this error message:
>
> Error while executing action Attach Storage Domain: Could not obtain lock
>
> Also the oVirt's Engine log files show this error message: "setsid: failed
> to execute /usr/bin/ionice: Permission denied", but I was unable to
> identify what exactly it's trying to do to get this permission denied.
>
> 2019-11-14 16:46:07,779-03 ERROR
> [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector]
> (EE-ManagedThreadFactory-engine-Thread-7388)
> [86161370-2aaa-4eff-9aab-c184bdf5bb98] EVENT_ID:
> IRS_BROKER_COMMAND_FAILURE(10,803), VDSM command AttachStorageDomainVDS
> failed: Cannot obtain lock: u"id=e6b34c42-0ca6-41f4-be3e-3c9b2af1747b,
> rc=1, out=[], err=['setsid: failed to execute /usr/bin/ionice: Permission
> denied']"
>
> This behavior just happens on ISO Domains, while Data Domains works fine.
> I have read oVirt documentation and searched everywhere but I was unable to
> find the solution for this issue.
>
> I'm using CentOS 7 with last update of all packages (oVirt version
> 4.3.6.7). Please help!
>
> Thanks,
> Ivan de Gusmão Apolonio
> ___
> Users mailing list -- users@ovirt.org
> To unsubscribe send an email to users-le...@ovirt.org
> Privacy Statement: https://www.ovirt.org/site/privacy-policy/
> oVirt Code of Conduct:
> https://www.ovirt.org/community/about/community-guidelines/
> List Archives:
> https://lists.ovirt.org/archives/list/users@ovirt.org/message/6Z5LCA77NHWLKHUYJDANIUCAHXX466MD/
>


-- 

Ahmad Khiet

Red Hat <https://www.redhat.com/>

akh...@redhat.com
M: +972-54-6225629
<https://red.ht/sig>
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/site/privacy-policy/
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/WMI4ICUMQUOFBOWBOK2PUYOPX3I5NWIU/