Re: [ovirt-users] iSCSI

2016-09-21 Thread Aharon Canan
Does it happen on all your hosts ?

Did you check the lunmasking ? (that the server IQN is the one you set on
the storage array? )


On Tue, Sep 20, 2016 at 6:31 PM, Dan Yasny  wrote:

> Maybe it's an EMC thing? I know they always recommend using their own
> multipathing client (aka powerpath), so you either need to make sure the
> SAN accepts Linux multipath, and that EMC devices aren't blocked in your
> multipath.conf
>
> I remember Clariions used to require some explicit aLUA related settings,
> should be easy enough to google or maybe call the SAN vendor
>
> On Tue, Sep 20, 2016 at 11:26 AM, Budur Nagaraju 
> wrote:
>
>> Noting more configuration ,if I configure openfiler  as a iSCSI Lun able
>> to detect the lun , moment I configure EMC Lun unable to detect the Lun ID .
>>
>> Any other configs do I need to do in Host ? any comands to delete the old
>> Lun ID ?
>>
>> .[root@pbuovirt3 ~]# cat /proc/scsi/scsi
>> Attached devices:
>> Host: scsi0 Channel: 03 Id: 00 Lun: 00
>>   Vendor: HP   Model: P410iRev: 2.00
>>   Type:   RAID ANSI  SCSI revision: 00
>> Host: scsi0 Channel: 00 Id: 00 Lun: 00
>>   Vendor: HP   Model: LOGICAL VOLUME   Rev: 2.00
>>   Type:   Direct-AccessANSI  SCSI revision: 05
>> Host: scsi1 Channel: 00 Id: 00 Lun: 00
>>   Vendor: Optiarc  Model: DVD RW AD-7561S  Rev: AH52
>>   Type:   CD-ROM   ANSI  SCSI revision: 05
>> Host: scsi8 Channel: 00 Id: 00 Lun: 00
>>   Vendor: DGC  Model: LUNZ Rev: 3103
>>   Type:   Direct-AccessANSI  SCSI revision: 04
>> [root@pbuovirt3 ~]#
>>
>>
>>
>>
>>
>> On Tue, Sep 20, 2016 at 8:51 PM, Dan Yasny  wrote:
>>
>>> It looks like iscsi does the job, bu multipath doesn't. What do you use
>>> on the hosts? How is multipath.conf configured? Any other special
>>> configuration you use?
>>>
>>> Also, can you paste /proc/scsi/scsi and blkid
>>>
>>> On Tue, Sep 20, 2016 at 11:18 AM, Budur Nagaraju 
>>> wrote:
>>>

 Below are the details,

 http://pastebin.com/aLBMH3Q6

 On Tue, Sep 20, 2016 at 8:27 PM, Dan Yasny  wrote:

> Try this on the host:
>
> iscsiadm -m discovery -t st -p 10.206.67.46
> iscsiadm -m node -L all
> iscsiadm -m node
> iscsiadm -m session
> multipath -ll
>
> and pastebin the output
>
> On Tue, Sep 20, 2016 at 10:54 AM, Budur Nagaraju 
> wrote:
>
>> Yes I did that too but no luck :(
>>
>> Thanks,
>> Nagaraju
>>
>>
>> On Tue, Sep 20, 2016 at 8:06 PM, Dan Yasny  wrote:
>>
>>> After you discover, did you also click the login button?
>>>
>>> On Tue, Sep 20, 2016 at 10:28 AM, Budur Nagaraju 
>>> wrote:
>>>
 Below are the Steps,

 Under Storage Tab:New Domain -->Name>Domain
 Type-->Data/iSCSi-->Select the Host -->Discover the Targets ,

 After giving all the info able to detect the iSCSI targets but
 uable to get the Lun id ,below are the details of the logs.


 http://pastebin.com/ph1YSqhH

 Thanks,
 Nagaraju


 On Tue, Sep 20, 2016 at 6:47 PM, Dan Yasny 
 wrote:

> Can you describe what you tried to do and how it failed?
>
> On Tue, Sep 20, 2016 at 5:54 AM, Budur Nagaraju  > wrote:
>
>> HI All,
>>
>> While configuring iSCSI LUN is not getting detected any documents
>> to configure iSCSI in oVirt ?
>>
>> Thanks,
>> Nagaraju
>>
>>
>> ___
>> Users mailing list
>> Users@ovirt.org
>> http://lists.ovirt.org/mailman/listinfo/users
>>
>>
>

>>>
>>
>

>>>
>>
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Wishlist - Mix gluster and local storage in same data center

2015-11-01 Thread Aharon Canan
No... 

when creating DC you choose shared/local (where gluster is shared) 

You can mix shared (gluster/iscsi/nfs etc) but not local. 

Regards, 
__ 
Aharon Canan 

- Original Message -

> From: "Liam Curtis" <lcur...@datto.com>
> To: Users@ovirt.org
> Sent: Sunday, November 1, 2015 5:17:58 PM
> Subject: [ovirt-users] Wishlist - Mix gluster and local storage in same data
> center

> Hello all...

> Would like to be able to use both local storage and gluster within same host
> / data center.

> Wondering if this is something being worked on?

> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] New storage domain on nfs share

2015-08-30 Thread Aharon Canan
don't you have an option to create data NFS domain? 

Regards, 
__ 
Aharon Canan 

- Original Message -

 From: gregor gregor_fo...@catrix.at
 To: users@ovirt.org
 Sent: Friday, August 28, 2015 8:37:59 PM
 Subject: [ovirt-users] New storage domain on nfs share

 Hi,

 what is the right way to create a storage on an NFS share to use as data
 storage for virtual machines?

 It is only possible to create a storage ISO/NFS or Export/NFS where
 I can not create disks for a virtual machine.

 cheers
 gregor
 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Storage question: single node gluster?

2015-07-14 Thread Aharon Canan
AFAIK it is not the best practice from Gluster. 

I tested it using single node and it should work fine. 
everything depend on your traffic and configuration. 

For example, 
Single node with only one NIc is not the same as with multiple nics 
Using only one HDD for both OS and volumes or SSD for OS and another SSD for 
volumes. 

so... it depends on the setup... 

Regards, 
__ 
Aharon Canan 
int phone - 8272036 
ext phone - +97297692036 
email - aca...@redhat.com 

- Original Message -

 From: Alan Murrell li...@murrell.ca
 To: users@ovirt.org
 Sent: Tuesday, July 14, 2015 7:18:31 AM
 Subject: [ovirt-users] Storage question: single node gluster?

 Hi There,

 This is not strictly oVirt, but is storage-related, so hopefully you
 will indulge me?

 Is there any detriment (performance or otherwise) in setting up a
 single-node glusterFS storage? I know glusterFS is designed to be used
 with multiple nodes, but I am wondering if there are any ill-effects in
 configuring current storage as a single-node cluster, with the idea of
 possibly adding future nodes in the future?

 Thanks! :-)

 -Alan

 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] storage domain don't go active anymore after 3.5.3 update

2015-06-17 Thread Aharon Canan
Can you attach engine and vdsm logs ? 

Regards, 
__ 
Aharon Canan 

- Original Message -

 From: Nathanaël Blanchet blanc...@abes.fr
 To: users@ovirt.org
 Sent: Wednesday, June 17, 2015 4:03:29 PM
 Subject: [ovirt-users] storage domain don't go active anymore after 3.5.3
 update

 Hello, since the update to 3.5.3, my master data domain fails to activate.
 I don't know what to do, and it is critical for production.
 Vms are still up but I can't interacte with them anymore
 If I shutdown any of them, I won't be able to recover them.

 My datacenter is a FC one, and all of my hosts have been upgraded to
 vdsm 4.16.20, I restarted vdsmd and engine, but nothing has changed.

 Thank you for your help.

 --
 Nathanaël Blanchet

 Supervision réseau
 Pôle Infrastrutures Informatiques
 227 avenue Professeur-Jean-Louis-Viala
 34193 MONTPELLIER CEDEX 5
 Tél. 33 (0)4 67 54 84 55
 Fax 33 (0)4 67 54 84 14
 blanc...@abes.fr

 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] storage domain don't go active anymore after 3.5.3 update

2015-06-17 Thread Aharon Canan
Hi 

from logs it seems like StorageDomain ID 229c74b0-75b0-48a5-b017-d794343b535b 
is missing 

engine - 
2015-06-17 14:37:49,918 INFO 
[org.ovirt.engine.core.vdsbroker.irsbroker.ActivateStorageDomainVDSCommand] 
(org.ovirt.thread.pool-8-thread-45) [7dc07cff] START, 
ActivateStorageDomainVDSCommand( storagePoolId = 
1a71a643-8234-4137-800e-d7a9957857d3, ignoreFailoverLimit = false, 
storageDomainId = 229c74b0-75b0-48a5-b017-d794343b535b), log id: 72ff5345 

vdsm - 
Thread-80::ERROR::2015-06-17 
15:14:17,907::domainMonitor::256::Storage.DomainMonitorThread::(_monitorDomain) 
Error while collecting domain 229c74b0-75b0-48a5-b017-d794343b535b monitoring 
information 
Traceback (most recent call last): 
File /usr/share/vdsm/storage/domainMonitor.py, line 232, in _monitorDomain 
self.domain.selftest() 
File /usr/share/vdsm/storage/sdc.py, line 49, in __getattr__ 
return getattr(self.getRealDomain(), attrName) 
File /usr/share/vdsm/storage/sdc.py, line 52, in getRealDomain 
return self._cache._realProduce(self._sdUUID) 
File /usr/share/vdsm/storage/sdc.py, line 122, in _realProduce 
domain = self._findDomain(sdUUID) 
File /usr/share/vdsm/storage/sdc.py, line 141, in _findDomain 
dom = findMethod(sdUUID) 
File /usr/share/vdsm/storage/sdc.py, line 171, in _findUnfetchedDomain 
raise se.StorageDomainDoesNotExist(sdUUID) 
StorageDomainDoesNotExist: Storage domain does not exist: 
(u'229c74b0-75b0-48a5-b017-d794343b535b',) 

Can you please check if this VG ('229c74b0-75b0-48a5-b017-d794343b535b') exist 
in the host and all it's PVs exist as well? 
if one is missing try to check if the host can see the missing lun. 

Regards, 
__ 
Aharon Canan 
int phone - 8272036 
ext phone - +97297692036 
email - aca...@redhat.com 

- Original Message -

 From: Nathanaël Blanchet blanc...@abes.fr
 To: Aharon Canan aca...@redhat.com
 Cc: users@ovirt.org
 Sent: Wednesday, June 17, 2015 4:33:21 PM
 Subject: Re: [ovirt-users] storage domain don't go active anymore after 3.5.3
 update

 Just to specify that in addition of this datacenter (cines), I have a second
 FC data center (abes) in the same engine but which deals only with el6 hosts
 and upgrade to vdsm was fine for itself.

 Le 17/06/2015 15:17, Nathanaël Blanchet a écrit :

  Hello Aharon, I have 3 hosts in that domain : fuji, fuego, siple.
 
  thank you for your help
 

  Le 17/06/2015 15:10, Aharon Canan a écrit :
 

   Can you attach engine and vdsm logs ?
  
 

   Regards,
  
 
   __
  
 
   Aharon Canan
  
 

   - Original Message -
  
 

From: Nathanaël Blanchet blanc...@abes.fr
   
  
 
To: users@ovirt.org
   
  
 
Sent: Wednesday, June 17, 2015 4:03:29 PM
   
  
 
Subject: [ovirt-users] storage domain don't go active anymore after
3.5.3
update
   
  
 

Hello, since the update to 3.5.3, my master data domain fails to
activate.
   
  
 
I don't know what to do, and it is critical for production.
   
  
 
Vms are still up but I can't interacte with them anymore
   
  
 
If I shutdown any of them, I won't be able to recover them.
   
  
 

My datacenter is a FC one, and all of my hosts have been upgraded to
   
  
 
vdsm 4.16.20, I restarted vdsmd and engine, but nothing has changed.
   
  
 

Thank you for your help.
   
  
 

--
   
  
 
Nathanaël Blanchet
   
  
 

Supervision réseau
   
  
 
Pôle Infrastrutures Informatiques
   
  
 
227 avenue Professeur-Jean-Louis-Viala
   
  
 
34193 MONTPELLIER CEDEX 5
   
  
 
Tél. 33 (0)4 67 54 84 55
   
  
 
Fax 33 (0)4 67 54 84 14
   
  
 
blanc...@abes.fr
   
  
 

___
   
  
 
Users mailing list
   
  
 
Users@ovirt.org
   
  
 
http://lists.ovirt.org/mailman/listinfo/users
   
  
 

  --
 
  Nathanaël Blanchet
 

  Supervision réseau
 
  Pôle Infrastrutures Informatiques
 
  227 avenue Professeur-Jean-Louis-Viala
 
  34193 MONTPELLIER CEDEX 5
 
  Tél. 33 (0)4 67 54 84 55
 
  Fax  33 (0)4 67 54 84 14 blanc...@abes.fr
 

  ___
 
  Users mailing list Users@ovirt.org
  http://lists.ovirt.org/mailman/listinfo/users
 

 --
 Nathanaël Blanchet

 Supervision réseau
 Pôle Infrastrutures Informatiques
 227 avenue Professeur-Jean-Louis-Viala
 34193 MONTPELLIER CEDEX 5
 Tél. 33 (0)4 67 54 84 55
 Fax  33 (0)4 67 54 84 14 blanc...@abes.fr
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Local Storage

2015-05-03 Thread Aharon Canan
you can't 

Host is part of cluster which is part of DC. 
DC can be shared or local only, can't be both. 

Regards, 
__ 
Aharon Canan 
int phone - 8272036 
ext phone - +97297692036 
email - aca...@redhat.com 

- Original Message -

 From: Marcin Fabiańczyk marcin.fabianc...@enicom.pl
 To: users@ovirt.org
 Sent: Friday, May 1, 2015 1:48:54 PM
 Subject: [ovirt-users] Local Storage

 Hello

 I have create DC with a shared storage but I would like also add my servers
 local resources . I t is possible in ovirt - hypervisior ?

 Regards.
 MF

 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Move/Migrate Storage Domain to new devices

2015-04-21 Thread Aharon Canan
Hi 

Did you try to copy the template to the new storage domain? 
Under Template tab - Disks sub-tab - copy 

Regards, 
__ 
Aharon Canan 

- Original Message -

 From: Dael Maselli dael.mase...@lnf.infn.it
 To: users@ovirt.org
 Sent: Monday, April 20, 2015 5:48:03 PM
 Subject: [ovirt-users] Move/Migrate Storage Domain to new devices

 Hi,

 I have a data storage domain that use one FC LUN. I need to move all
 data to a new storage server.

 I tried by move single disks to a new storage domain but some cannot be
 moved, I think because they are thin-cloned by template.

 When I worked with LVM I use to do a simple pvmove leaving the VG
 intact, is there something similar (online or in maintenance) in oVirt?
 Can I just do a pvmove from the SPM host o it's going to destroy everything?

 Thank you very much.

 Regards,
 Dael Maselli.

 --
 ___

 Dael Maselli --- INFN-LNF Computing Service -- +39.06.9403.2214
 ___

 * http://www.lnf.infn.it/~dmaselli/ *
 ___

 Democracy is two wolves and a lamb voting on what to have for lunch
 ___

 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] expanding a master lun storage domain on the san side

2015-03-03 Thread Aharon Canan
without maintenance , I am not sure it will update the DB - you won't see the 
update on the engine. 

Regards, 
__ 
Aharon Canan 
int phone - 8272036 
ext phone - +97297692036 
email - aca...@redhat.com 

- Original Message -

 From: Nathanaël Blanchet blanc...@abes.fr
 To: Aharon Canan aca...@redhat.com
 Cc: users@ovirt.org, Pôle infrastructures informatiques p...@abes.fr
 Sent: Tuesday, March 3, 2015 4:59:42 PM
 Subject: Re: [ovirt-users] expanding a master lun storage domain on the san
 side

 Hello,

 Since I can live migrate the storage to another lun so as to put the master
 domain in maintenance, it is quite very long (2,5To) and I will have to do
 the same in the other side.
 Is it a risk to Resize the relevant PV without putting the domain in
 maintenance?
 In my memory, it is not a risk to expand a physical volume while it not
 recommended to shrink the volume...

 Le 03/03/2015 14:30, Aharon Canan a écrit :

  Hi
 

  The flow should be like below -
 

  * Put the relevant domain in maintenance
 
  * Extend the lun (from storage side)
 
  * Resize the relevant PV (f or example -  pvresize
  --setphysicalvolumesize
  125G  /dev/mapper/3600601601282300056f0075c3f81e311
 
  * Activate the domain
 
  Check the storage domain total size, It should have the new size.
 

  https://bugzilla.redhat.com/show_bug.cgi?id=961532
 

  Regards,
 
  __
 
  Aharon Canan
 

  - Original Message -
 

   From: Nathanaël Blanchet blanc...@abes.fr
  
 
   To: users@ovirt.org
  
 
   Cc: Pôle infrastructures informatiques p...@abes.fr
  
 
   Sent: Tuesday, March 3, 2015 2:11:24 PM
  
 
   Subject: Re: [ovirt-users] expanding a master lun storage domain on the
   san
   side
  
 

   Can anybody help me with this?
  
 
   When the domain storage is recognized with the good size by the host, is
  
 
   there something to do for engine to recognize this size?
  
 

   Le 02/03/2015 17:35, Nathanaël Blanchet a écrit :
  
 
Hi all,
  
 
   
  
 
I've just expanded the lun used as master by the domain storage.
  
 
fdisk on the SPM is able to see the multipath device with its new
  
 
size, but engine reports the old size.
  
 
How to refresh this?
  
 
   
  
 
   
  
 
___
  
 
Users mailing list
  
 
Users@ovirt.org
  
 
http://lists.ovirt.org/mailman/listinfo/users
  
 

   ___
  
 
   Users mailing list
  
 
   Users@ovirt.org
  
 
   http://lists.ovirt.org/mailman/listinfo/users
  
 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Storage Domain ISCSI Inactive

2015-03-03 Thread Aharon Canan
Hi 

How did you remove the lun? 
from the storage side? 

Regards, 
__ 
Aharon Canan 
- Original Message -

 From: aditya hilman adityahilman3...@gmail.com
 To: users@ovirt.org
 Sent: Tuesday, March 3, 2015 6:03:40 AM
 Subject: [ovirt-users] Storage Domain ISCSI Inactive

 Hi folks,

 I'm already searching on internet and any related documentation with ovirt,
 but i'm still facing the problem.

 I've 3 hosts and 1 storage using netapp. After create new LUN and deleting
 the new one. The Data Centers is down, but VM guests still running.

 Step to reproduce :
 1. Create new LUN.
 2. Attach new LUN to existing iscsi storage data (master)
 3. The space on the existing iscsi storage would be increase
 4. Remove the new LUN from existing iscsi storage
 5. Storage domain would be Non-Responsive

 I've already reboot the rhev-m and also rhev-host. But the Data Centers
 status is still Non-Responsive.
 Below the related log :

 engine.log
 2015-03-02 07:55:47,884 WARN
 [org.ovirt.engine.core.bll.storage.ExtendSANStorageDomainCommand]
 (ajp-/127.0.0.1:8702-4) [70555e6d] CanDoAction of action
 ExtendSANStorageDomain failed.
 Reasons:VAR__TYPE__STORAGE__DOMAIN,VAR__ACTION__EXTEND,ERROR_CANNOT_EXTEND_CONNECTION_FAILED,$lun

 2015-03-02 08:05:35,214 ERROR
 [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStatusVDSCommand]
 (DefaultQuartzScheduler_Worker-5) [241bd724] Failed in SpmStatusVDS method
 2015-03-02 08:05:35,214 ERROR
 [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStatusVDSCommand]
 (DefaultQuartzScheduler_Worker-5) [241bd724] Error code GeneralException and
 error message VDSGenericException: VDSErrorException: Failed to
 SpmStatusVDS, error = [Errno 19] Could not find dm device named `unknown
 device`
 2015-03-02 08:05:35,214 ERROR
 [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStatusVDSCommand]
 (DefaultQuartzScheduler_Worker-5) [241bd724] Command SpmStatusVDS execution
 failed. Exception: VDSErrorException: VDSGenericException:
 VDSErrorException: Failed to SpmStatusVDS, error = [Errno 19] Could not find
 dm device named `unknown device`

 2015-03-02 08:05:49,332 ERROR
 [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand]
 (DefaultQuartzScheduler_Worker-92) [65ea552c] SPM Init: could not find
 reported vds or not up - pool:ISCSI_DATA_CENTER vds_spm_id: 2

 Thanks.

 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] expanding a master lun storage domain on the san side

2015-03-03 Thread Aharon Canan
Hi 

The flow should be like below - 

* Put the relevant domain in maintenance 
* Extend the lun (from storage side) 
* Resize the relevant PV (f or example -  pvresize 
--setphysicalvolumesize 125G  /dev/mapper/3600601601282300056f0075c3f81e311 
* Activate the domain 

Check the storage domain total size, It should have the new size. 

https://bugzilla.redhat.com/show_bug.cgi?id=961532 

Regards, 
__ 
Aharon Canan 

- Original Message -

 From: Nathanaël Blanchet blanc...@abes.fr
 To: users@ovirt.org
 Cc: Pôle infrastructures informatiques p...@abes.fr
 Sent: Tuesday, March 3, 2015 2:11:24 PM
 Subject: Re: [ovirt-users] expanding a master lun storage domain on the san
 side

 Can anybody help me with this?
 When the domain storage is recognized with the good size by the host, is
 there something to do for engine to recognize this size?

 Le 02/03/2015 17:35, Nathanaël Blanchet a écrit :
  Hi all,
 
  I've just expanded the lun used as master by the domain storage.
  fdisk on the SPM is able to see the multipath device with its new
  size, but engine reports the old size.
  How to refresh this?
 
 
  ___
  Users mailing list
  Users@ovirt.org
  http://lists.ovirt.org/mailman/listinfo/users

 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Glusterfs storage

2015-03-02 Thread Aharon Canan
Hi 

First, You need to create gluster volume. Do not forget to start the volume. 
then the chown 36:36 volume directory name 

now you need to create new glusterfs domain, and to point to the gluster 
server name:/volume name 

Regards, 
__ 
Aharon Canan 
int phone - 8272036 
ext phone - +97297692036 
email - aca...@redhat.com 

- Original Message -

 From: supo...@logicworks.pt
 To: Users@ovirt.org
 Sent: Monday, March 2, 2015 5:55:33 PM
 Subject: [ovirt-users] Glusterfs storage

 Hi,

 I have setup up 2 hosts, host1 with hosted engine, and on host 2, since I
 have a spare disk, I want to setup a glusterfs domain storage.
 I'm using Centos7 and ovirt 3.5.1.
 The 2 hosts and hosted engine are up and running.
 How can I configure the glusterfs storage?
 I installed glusterfs server on host2:
 glusterfs-api-3.6.2-1.el7.x86_64
 glusterfs-fuse-3.6.2-1.el7.x86_64
 glusterfs-libs-3.6.2-1.el7.x86_64
 glusterfs-3.6.2-1.el7.x86_64
 glusterfs-rdma-3.6.2-1.el7.x86_64
 glusterfs-server-3.6.2-1.el7.x86_64
 glusterfs-cli-3.6.2-1.el7.x86_64

 Do I need first configure a Volume with a brick? I tried that but no success.
 Also tried to ad a Data domains of type glusterfs but no success.
 What am I missing?

 Thanks

 --

 Jose Ferradeira
 http://www.logicworks.pt

 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Glusterfs storage

2015-03-02 Thread Aharon Canan
forget to mention, 

You need the glusterfs pkg on all hosts that should access the glusterfs 
domain, 

Also, you can check below link. 
http://www.ovirt.org/Features/GlusterFS_Storage_Domain 

Regards, 
__ 
Aharon Canan 
int phone - 8272036 
ext phone - +97297692036 
email - aca...@redhat.com 

- Original Message -

 From: Aharon Canan aca...@redhat.com
 To: supo...@logicworks.pt
 Cc: Users@ovirt.org
 Sent: Monday, March 2, 2015 6:00:40 PM
 Subject: Re: [ovirt-users] Glusterfs storage

 Hi

 First, You need to create gluster volume. Do not forget to start the volume.
 then the chown 36:36 volume directory name

 now you need to create new glusterfs domain, and to point to the gluster
 server name:/volume name

 Regards,
 __
 Aharon Canan
 int phone - 8272036
 ext phone - +97297692036
 email - aca...@redhat.com

 - Original Message -

  From: supo...@logicworks.pt
 
  To: Users@ovirt.org
 
  Sent: Monday, March 2, 2015 5:55:33 PM
 
  Subject: [ovirt-users] Glusterfs storage
 

  Hi,
 

  I have setup up 2 hosts, host1 with hosted engine, and on host 2, since I
  have a spare disk, I want to setup a glusterfs domain storage.
 
  I'm using Centos7 and ovirt 3.5.1.
 
  The 2 hosts and hosted engine are up and running.
 
  How can I configure the glusterfs storage?
 
  I installed glusterfs server on host2:
 
  glusterfs-api-3.6.2-1.el7.x86_64
 
  glusterfs-fuse-3.6.2-1.el7.x86_64
 
  glusterfs-libs-3.6.2-1.el7.x86_64
 
  glusterfs-3.6.2-1.el7.x86_64
 
  glusterfs-rdma-3.6.2-1.el7.x86_64
 
  glusterfs-server-3.6.2-1.el7.x86_64
 
  glusterfs-cli-3.6.2-1.el7.x86_64
 

  Do I need first configure a Volume with a brick? I tried that but no
  success.
  Also tried to ad a Data domains of type glusterfs but no success.
 
  What am I missing?
 

  Thanks
 

  --
 

  Jose Ferradeira
 
  http://www.logicworks.pt
 

  ___
 
  Users mailing list
 
  Users@ovirt.org
 
  http://lists.ovirt.org/mailman/listinfo/users
 

 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] [STORAGE] Remove detached storage from list

2015-02-08 Thread Aharon Canan
Hi 

I tried to reproduce your issue and failed (Using POSIX domain), I can destroy 
the SD even if it is unattached. 

Can you provide some more info? 

Regards, 
__ 
Aharon Canan 
int phone - 8272036 
ext phone - +97297692036 
email - aca...@redhat.com 

- Original Message -

 From: Julian De Marchi jul...@jdcomputers.com.au
 To: users@ovirt.org
 Sent: Friday, February 6, 2015 4:27:02 AM
 Subject: [ovirt-users] [STORAGE] Remove detached storage from list

 Heya--

 I currently have two storage domains in the detach list in Ovirt 3.5.
 These are old storage domains that can no longer me mounted.

 I'm trying to find a way to remove these as I can't just attach them
 again to destroy them.

 Any help would be awesome!

 --julian
 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] importing iscsi storage domain

2015-02-03 Thread Aharon Canan
What version are you using? 

Regards, 
__ 
Aharon Canan 
int phone - 8272036 
ext phone - +97297692036 
email - aca...@redhat.com 

- Original Message -

 From: Steven M. Bellistri sbellis...@ldirx.com
 To: Aharon Canan aca...@redhat.com
 Cc: users@ovirt.org
 Sent: Monday, February 2, 2015 8:12:00 PM
 Subject: RE: [ovirt-users] importing iscsi storage domain

 Thank you for the response.

 I went thru the steps 1-9, and when I get to step 10 there is no import vms
 or import templates sub-tabs. I am including the vdsm.log from the host.
 Also, when I do a lvs on the host, I can see the disks that reside in the
 imported SD, one is 30gb and the other is 40gb. The storage domain I am
 importing is called iSCSI.

 From: Aharon Canan [mailto:aca...@redhat.com]
 Sent: Sunday, February 1, 2015 9:55 AM
 To: Steven M. Bellistri
 Cc: users@ovirt.org
 Subject: Re: [ovirt-users] importing iscsi storage domain

 Hi

 Please check below link for info, ovirt version should be 3.5

 http://www.ovirt.org/Features/ImportStorageDomain

 please be aware to step 10 under  Work flow for Import block Storage Domain
 - UI flow 

 In case it is not working, please add exact steps and engine/vdsm logs so we
 will be able to check

 Regards,
 __
 Aharon Canan
 int phone - 8272036
 ext phone - +97297692036
 email - aca...@redhat.com

 - Original Message -

  From: Steven M. Bellistri  sbellis...@ldirx.com 
 
  To:  users@ovirt.org   users@ovirt.org 
 
  Sent: Friday, January 30, 2015 12:18:54 AM
 
  Subject: [ovirt-users] importing iscsi storage domain
 

  I am trying to test failing over to a DR site using the storage domain
  import. The DR site shows that it imported the iscsi storage domain, and
  activates it in the datacenter, but none of the vm’s or anything shows up.
  What am I missing.
 

  thanks
 

  Steven Bellistri
 

  This email and its attachments may contain privileged and confidential
  information and/or protected health information (PHI) intended solely for
  the use of LDI Integrated Pharmacy Services and the recipient(s) named
  above. If you are not the recipient, or the employee or agent responsible
  for delivering this message to the intended recipient, you are hereby
  notified that any review, dissemination, distribution, printing or copying
  of this email message and/or any attachments is strictly prohibited. If you
  have received this transmission in error, please notify the sender
  immediately at 1-866-516-3121 and permanently delete this email and any
  attachments.
 
  ___
 
  Users mailing list
 
  Users@ovirt.org
 
  http://lists.ovirt.org/mailman/listinfo/users
 

 This email and its attachments may contain privileged and confidential
 information and/or protected health information (PHI) intended solely for
 the use of LDI Integrated Pharmacy Services and the recipient(s) named
 above. If you are not the recipient, or the employee or agent responsible
 for delivering this message to the intended recipient, you are hereby
 notified that any review, dissemination, distribution, printing or copying
 of this email message and/or any attachments is strictly prohibited. If you
 have received this transmission in error, please notify the sender
 immediately at 1-866-516-3121 and permanently delete this email and any
 attachments.___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Adding multiple NFS storage and migrate volumes to other

2015-02-01 Thread Aharon Canan
Yes, there are 2 options, migrate and live migrate (live = VM is up and 
running) 

http://www.ovirt.org/Features/Design/StorageLiveMigration 

Regards, 
__ 
Aharon Canan 
int phone - 8272036 
ext phone - +97297692036 
email - aca...@redhat.com 

- Original Message -

 From: mad Engineer themadengin...@gmail.com
 To: users users@ovirt.org
 Sent: Sunday, February 1, 2015 5:27:58 PM
 Subject: [ovirt-users] Adding multiple NFS storage and migrate volumes to
 other

 Hello All,
 We are using NFS shared storage between hosts,and have running vms.
 Now we are planning to remove existing disks and replace it with with
 different disks.
 Is there any way we can add one more NFS say NFS2 and migrate all
 volumes to NFS2 while we upgrade primary NFS,is it supported?
 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] importing iscsi storage domain

2015-02-01 Thread Aharon Canan
Hi 

Please check below link for info, ovirt version should be 3.5 
http://www.ovirt.org/Features/ImportStorageDomain 

please be aware to step 10 under  Work flow for Import block Storage Domain - 
UI flow  

In case it is not working, please add exact steps and engine/vdsm logs so we 
will be able to check 

Regards, 
__ 
Aharon Canan 
int phone - 8272036 
ext phone - +97297692036 
email - aca...@redhat.com 

- Original Message -

 From: Steven M. Bellistri sbellis...@ldirx.com
 To: users@ovirt.org users@ovirt.org
 Sent: Friday, January 30, 2015 12:18:54 AM
 Subject: [ovirt-users] importing iscsi storage domain

 I am trying to test failing over to a DR site using the storage domain
 import. The DR site shows that it imported the iscsi storage domain, and
 activates it in the datacenter, but none of the vm’s or anything shows up.
 What am I missing.

 thanks

 Steven Bellistri

 This email and its attachments may contain privileged and confidential
 information and/or protected health information (PHI) intended solely for
 the use of LDI Integrated Pharmacy Services and the recipient(s) named
 above. If you are not the recipient, or the employee or agent responsible
 for delivering this message to the intended recipient, you are hereby
 notified that any review, dissemination, distribution, printing or copying
 of this email message and/or any attachments is strictly prohibited. If you
 have received this transmission in error, please notify the sender
 immediately at 1-866-516-3121 and permanently delete this email and any
 attachments.
 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] iSCSI Storage - sda failue - how to move VMs?

2015-01-21 Thread Aharon Canan
Hi 

sounds like you have 1 ISCSI storage domain which includes the disks. 
You can create another ISCSI storage domain and then to migrate the disks to 
it. 

This way all the disks will move to the new domain and you will be able to 
remove the old SD without losing the disks. 





Regards, 
__ 
Aharon Canan 
int phone - 8272036 
ext phone - +97297692036 
email - aca...@redhat.com 

- Original Message -

From: shimano shim...@go2.pl 
To: users@ovirt.org 
Sent: Wednesday, January 21, 2015 3:57:26 PM 
Subject: [ovirt-users] iSCSI Storage - sda failue - how to move VMs? 

Hi guys, 

I have some VMs with preallocated disks on - still green - iSCSI Storage 
domain, where one of disks is going to die, which caused to change iscsi mount 
to read only. Of course all VMs allocated on this storage has been paused or 
turned off. 

Is there any way to save these VMs (disks)? 

___ 
Users mailing list 
Users@ovirt.org 
http://lists.ovirt.org/mailman/listinfo/users 

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] [STORAGE] Adding posix compliant FS

2014-12-15 Thread Aharon Canan
Did you chown 36:36 the folder to get the right permissions for adding to 
ovirt? 




Regards, 
__ 
Aharon Canan 
int phone - 8272036 
ext phone - +97297692036 
email - aca...@redhat.com 

- Original Message -

From: Julian De Marchi jul...@jdcomputers.com.au 
To: users@ovirt.org 
Sent: Tuesday, December 16, 2014 4:40:04 AM 
Subject: Re: [ovirt-users] [STORAGE] Adding posix compliant FS 

On 12/16/14 08:57, Julian De Marchi wrote: 
 Heya-- 
 
 I'm using ovirt 3.5 and trying to add a posix compliant FS to a node in 
 my cluster. 
 
 The storage I'm trying to add is contained within LVM. Below is a link 
 to my log files on the node where I'm trying to attach the storage. 
 
 http://pastebin.com/fzN9ktAX 
 
 I've read the ovirt manual for adding posix compliant storage and 
 believe I'm doing everything correct. 
 
 Any help to get this storage added would be great thanks and if I forgot 
 to include any info please ask. 

More info to add. I was doing an ls on the dir it does the mount in 
and saw the dir was owned by root:root with different perms to the ones 
mounted via NFS. 

[root@blade01 libvirt]# ls /rhev/data-center/mnt/ -lh 
total 20K 
drwxrwxrwx 4 root root 4.0K Dec 11 09:00 10.106.200.100:_VM__IMAGES 
drwxrwxrwx 3 root root 4.0K Oct 17 09:42 10.106.200.22:_opt_vmexport 
drwxrwxrwx 4 root root 4.0K Oct 17 09:39 
10.106.200.22:_var_lib_libvirt_images 
drwxr-xr-x 3 root root 4.0K Dec 15 16:52 _dev_mapper_VolGroup-lv__images 

This could explain why the touch command fails. 

Still at a loss over the issue though. 
___ 
Users mailing list 
Users@ovirt.org 
http://lists.ovirt.org/mailman/listinfo/users 

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Ovirt snapshot failing on one VM

2014-04-22 Thread Aharon Canan
hi 

please check https://bugzilla.redhat.com/show_bug.cgi?id=1017289 
I know that snapshot on gluster domain has few issues... 



Regards, 
__ 
Aharon Canan 


- Original Message -

From: Steve Dainard sdain...@miovision.com 
To: d...@redhat.com 
Cc: users users@ovirt.org 
Sent: Tuesday, April 22, 2014 5:31:18 PM 
Subject: Re: [ovirt-users] Ovirt snapshot failing on one VM 

Sorry for the confusion. 

I attempted to take a live snapshot of a running VM. After that failed, I 
migrated the VM to another host, and attempted the live snapshot again without 
success, eliminating a single host as the cause of failure. 

Ovirt is 3.3.4, storage domain is gluster 3.4.2.1, OS is CentOS 6.5. 

Package versions: 
libvirt-0.10.2-29.el6_5.5.x86_64 
libvirt-lock-sanlock-0.10.2-29.el6_5.5.x86_64 
qemu-img-rhev-0.12.1.2-2.415.el6.nux.3.x86_64 
qemu-kvm-rhev-0.12.1.2-2.415.el6.nux.3.x86_64 
qemu-kvm-rhev-tools-0.12.1.2-2.415.el6.nux.3.x86_64 
vdsm-4.13.3-4.el6.x86_64 
vdsm-gluster-4.13.3-4.el6.noarch 


I made another live snapshot attempt at 10:21 EST today, full vdsm.log 
attached, and a truncated engine.log. 

Thanks, 

Steve 


On Tue, Apr 22, 2014 at 9:48 AM, Dafna Ron  d...@redhat.com  wrote: 


please explain the flow of what you are trying to do, are you trying to live 
migrate the disk (from one storage to another), are you trying to migrate the 
vm and after vm migration is finished you try to take a live snapshot of the 
vm? or are you trying to take a live snapshot of the vm during a vm migration 
from host1 to host2? 

Please attach full vdsm logs from any host you are using (if you are trying to 
migrate the vm from host1 to host2) + please attach engine log. 

Also, what is the vdsm, libvirt and qemu versions, what ovirt version are you 
using and what is the storage you are using? 

Thanks, 

Dafna 




On 04/22/2014 02:12 PM, Steve Dainard wrote: 

blockquote

I've attempted migrating the vm to another host and taking a snapshot, but I 
get this error: 

6efd33f4-984c-4513-b5e6- fffdca2e983b::ERROR::2014-04- 22 
01:09:37,296::volume::286:: Storage.Volume::(clone) Volume.clone: can't clone: 
/rhev/data-center/9497ef2c- 8368-4c92-8d61-7f318a90748f/ 
95b9d922-4df7-4d3b-9bca- 467e2fd9d573/images/466d9ae9- 
e46a-46f8-9f4b-964d8af0675b/ 1a67de4b-aa1c-4436-baca- ca55726d54d7 to 
/rhev/data-center/9497ef2c- 8368-4c92-8d61-7f318a90748f/ 
95b9d922-4df7-4d3b-9bca- 467e2fd9d573/images/466d9ae9- 
e46a-46f8-9f4b-964d8af0675b/ b230596f-97bc-4532-ba57- 5654fa9c6c51 

A bit more of the vdsm log is attached. 

Other vm's are snapshotting without issue. 



Any help appreciated, 

*Steve 
* 


__ _ 
Users mailing list 
Users@ovirt.org 
http://lists.ovirt.org/ mailman/listinfo/users 




-- 
Dafna Ron 

/blockquote



___ 
Users mailing list 
Users@ovirt.org 
http://lists.ovirt.org/mailman/listinfo/users 

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users