[ovirt-users] Re: Issue upgrading 4.4 to 4.5 Gluster HCG

2022-04-26 Thread Alessandro De Salvo
Hi, the error with XML and gluster is the same I reported with a possible fix in vdsm in another thread. The following fix worked for me, i.e. replacing the following line in /usr/lib/python3.6/site-packages/vdsm/gluster/cli.y 429c429 < if (el.find('stripeCount')):

[ovirt-users] Re: Installing new self-hosted engine v4.5.0 on gluster 10

2022-04-26 Thread Alessandro De Salvo
Regards, Strahil Nikolov On Mon, Apr 25, 2022 at 14:16, Alessandro De Salvo wrote: ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to users-le...@ovirt.org Privacy Statement: https://www.ovirt.org/privacy

[ovirt-users] Re: failed to mount hosted engine gluster storage - how to debug?

2022-04-25 Thread Alessandro De Salvo
Hi, please try this workaround, replace the following line in /usr/lib/python3.6/site-packages/vdsm/gluster/cli.py value['stripeCount'] = el.find('stripeCount').text with: if (el.find('stripeCount')): value['stripeCount'] = el.find('stripeCount').text Then restart vdsmd and supervdmsd

[ovirt-users] Re: Installing new self-hosted engine v4.5.0 on gluster 10

2022-04-25 Thread Alessandro De Salvo
proper way upstream. Cheers,     Alessandro Il 25/04/22 09:41, Alessandro De Salvo ha scritto: Hi, thanks, unfortunately I’ve done it already, otherwise it would not even start the engine. This error appears after the engine is up with the downgraded postgresql-jdbc. Cheers,    Alessand

[ovirt-users] Re: failed to mount hosted engine gluster storage - how to debug?

2022-04-25 Thread Alessandro De Salvo
Hi, I think it may be a problem with vdsm and gluster 10, I’ve reported a similar issue in another thread. Vdsm is throwing an exception when parsing the XML from the gluster volume info when using the latest gluster version 10. This is particularly bad when the gluster server updates have been

[ovirt-users] Re: Error 500 on Hosted Engine admin portal!!!

2022-04-25 Thread Alessandro De Salvo
Hi, I’m not sure if it works with the web installer, but if you deploy with CLI you can use the following to ask the installer to pause before running engine-setup: hosted-engine --deploy --ansible-extra-vars=he_pause_before_engine_setup=true This gives you the time to ssh and exclude the

[ovirt-users] Re: Installing new self-hosted engine v4.5.0 on gluster 10

2022-04-25 Thread Alessandro De Salvo
e it's worth trying to downgrade postgresql-jdbc and try again. > > Best Regards, > Strahil Nikolov > > On Mon, Apr 25, 2022 at 4:52, Alessandro De Salvo > wrote: > To complete the diagnosis, in vdsm.log I see the following error: > > > vdsm.gluster.exception.Glu

[ovirt-users] Re: Installing new self-hosted engine v4.5.0 on gluster 10

2022-04-24 Thread Alessandro De Salvo
-io-threads\n off\n \n  \n nfs-ganesha\n disable\n \n  \n cluster.enable-shared-storage\n disable\n \n    \n \n  1\n \n  \n'] Thanks,     Alessandro Il 25/04/22 01:02, Alessandro De Salvo ha scritto: Hi, I'm trying to install a new self-hosted engine 4.5.0 on an upgr

[ovirt-users] Installing new self-hosted engine v4.5.0 on gluster 10

2022-04-24 Thread Alessandro De Salvo
Hi, I'm trying to install a new self-hosted engine 4.5.0 on an upgraded gluster v10.1, but the deployment fails at the domain activation stage, with this error: [ INFO  ] TASK [ovirt.ovirt.hosted_engine_setup : Activate storage domain] [ ERROR ] ovirtsdk4.Error: Fault reason is "Operation

[ovirt-users] Re: Best Openstack version to integrate with oVirt 4.2.7

2018-12-04 Thread Alessandro De Salvo
Hi, we're also extensively using ceph via cinder on docker (Kolla project), but we're stuck on Pike for the missing keystone v3 support. While cinderlib is desirable and it's a good solution for simple uses, adding support for keystone v3 and keeping the native cinder interface would also

[ovirt-users] Re: Upgrade from 4.1.9 to 4.2.3 fails to upgrade postgresql

2018-05-17 Thread Alessandro De Salvo
Hi Ian, I had the very same problem, but the upgrade was complaining for a different locale. Try to add the following line at the beginning of the file /opt/rh/rh-postgresql95/root/usr/bin/postgresql-setup, after the initial comments and before the code: export

Re: [ovirt-users] Hosted Engine VM not imported

2018-02-26 Thread Alessandro De Salvo
ha scritto: On Sat, Feb 24, 2018 at 2:32 PM, Alessandro De Salvo <alessandro.desa...@roma1.infn.it <mailto:alessandro.desa...@roma1.infn.it>> wrote: Hi, I have just migrated my dev cluster to the latest master, reinstalling the engine VM and reimporting from a pre

Re: [ovirt-users] Hosted Engine VM not imported

2018-02-26 Thread Alessandro De Salvo
ERROR [org.ovirt.engine.core.bll.HostedEngineImporter] (EE-ManagedThreadFactory-engine-Thread-97153) [796a8bc5] Failed importing the Hosted Engine VM Any help? Thanks,       Alessandro Il 24/02/18 14:32, Alessandro De Salvo ha scritto: Hi, I have just migrated my dev cluster

[ovirt-users] Hosted Engine VM not imported

2018-02-24 Thread Alessandro De Salvo
Hi, I have just migrated my dev cluster to the latest master, reinstalling the engine VM and reimporting from a previous backup. I'm trying with 4.3.0-0.0.master.20180222192611.git01e6ace.el7.centos I had a few problems: - the documentation seems to be outdated, and I just find by searching

Re: [ovirt-users] Enabling libgfapi disk access with oVirt 4.2

2017-11-09 Thread Alessandro De Salvo
, Alessandro De Salvo ha scritto: Hi, where should I enable gfapi via the UI? The only command I tried was engine-config -s LibgfApiSupported=true but the result is what is shown in my output below, so it’s set to true for v4.2. Is it enough? I’ll try restarting the engine. Is it really needed to stop all

Re: [ovirt-users] Enabling libgfapi disk access with oVirt 4.2

2017-11-09 Thread Alessandro De Salvo
e gfapi is below. > > 1) stop all the vms running > 2) Enable gfapi via UI or using engine-config command > 3) Restart ovirt-engine service > 4) start the vms. > > Hope you have not missed any !! > > Thanks > kasturi > >> On Wed, Nov 8, 2017 at 11:58 PM, A

[ovirt-users] Enabling libgfapi disk access with oVirt 4.2

2017-11-08 Thread Alessandro De Salvo
Hi, I'm using the latest 4.2 beta release and want to try the gfapi access, but I'm currently failing to use it. My test setup has an external glusterfs cluster v3.12, not managed by oVirt. The compatibility flag is correctly showing gfapi should be enabled with 4.2: # engine-config -g

Re: [ovirt-users] WebUI error with nightly 4.0.7

2016-12-19 Thread Alessandro De Salvo
Oh, that's good news, but then why it's in the nightly release of 4.0.7 if it's fixed in 4.0.6? Thanks, Alessandro Il 19/12/16 19:15, Maton, Brett ha scritto: Sounds very much like the issue that was recently fixed in 4.0.6 On 19 December 2016 at 17:02, Alessandro De Salvo

[ovirt-users] WebUI error with nightly 4.0.7

2016-12-19 Thread Alessandro De Salvo
Hi, since a few days, after the upgrade my dev machine to the nightly repo of 4.0.7, I'm getting these kind of errors from the WebUI after a few minutes the ovirt-engine is up: Error while executing action: A Request to the Server failed: java.lang.reflect.InvocationTargetException The errors go

Re: [ovirt-users] Ovirt & Ceph

2016-12-18 Thread Alessandro De Salvo
moving from standard NFS to something else, like gluster. Cheers, Alessandro > Il giorno 18 dic 2016, alle ore 18:56, rajatjpatel <rajatjpa...@gmail.com> ha > scritto: > > > >> On Sun, Dec 18, 2016 at 9:31 PM, Alessandro De Salvo >> <alessandro.desa...

Re: [ovirt-users] Ovirt & Ceph

2016-12-18 Thread Alessandro De Salvo
gt; Regards, > Rajat Patel > > http://studyhat.blogspot.com > FIRST THEY IGNORE YOU... > THEN THEY LAUGH AT YOU... > THEN THEY FIGHT YOU... > THEN YOU WIN... > > >> On Sun, Dec 18, 2016 at 9:17 PM, Alessandro De Salvo >> <alessandro.desa...@roma

Re: [ovirt-users] Ovirt & Ceph

2016-12-18 Thread Alessandro De Salvo
> > > Regards, > Rajat Patel > > http://studyhat.blogspot.com > FIRST THEY IGNORE YOU... > THEN THEY LAUGH AT YOU... > THEN THEY FIGHT YOU... > THEN YOU WIN... > > >> On Sun, Dec 18, 2016 at 8:49 PM, Alessandro De Salvo >> <alessandro.desa...

Re: [ovirt-users] Ovirt & Ceph

2016-12-18 Thread Alessandro De Salvo
Hi Yaniv, > Il giorno 18 dic 2016, alle ore 17:37, Yaniv Kaul <yk...@redhat.com> ha > scritto: > > > >> On Sun, Dec 18, 2016 at 6:21 PM, Alessandro De Salvo >> <alessandro.desa...@roma1.infn.it> wrote: >> Hi, >> having a 3-node ce

Re: [ovirt-users] Ovirt & Ceph

2016-12-18 Thread Alessandro De Salvo
guest running and creating ceph block storage and > which will be presented to ovirt as storage. Gluster is not is use right now > bcoz we have DB will be running on guest. > > Regard > Rajat > >> On Sun, Dec 18, 2016 at 8:21 PM Alessandro De Salvo >> <alessandro.d

Re: [ovirt-users] Ovirt & Ceph

2016-12-18 Thread Alessandro De Salvo
Hi, sorry, forgot to mention you may have both gluster and ceph on the same machines, as long as you have enough disk space. Cheers, Alessandro > Il giorno 18 dic 2016, alle ore 17:07, Yaniv Kaul ha > scritto: > > > >> On Sun, Dec 18, 2016 at 3:29 PM, rajatjpatel

Re: [ovirt-users] Ovirt & Ceph

2016-12-18 Thread Alessandro De Salvo
Hi, having a 3-node ceph cluster is the bare minimum you can have to make it working, unless you want to have just a replica-2 mode, which is not safe. It's not true that ceph is not easy to configure, you might use very easily ceph-deploy, have puppet configuring it or even run it in

Re: [ovirt-users] Error while extending a cinder/ceph disk

2016-07-21 Thread Alessandro De Salvo
Hi Daniel, On Thu, 2016-07-21 at 17:34 +0300, Daniel Erez wrote: > > > On Thu, Jul 21, 2016 at 4:21 PM, Alessandro De Salvo > <alessandro.desa...@roma1.infn.it> wrote: > Hi, > when trying to extend a ceph disk in ovirt 4 (Virtual Machines >

Re: [ovirt-users] Exporting VMs using cinder disks and importing ceph disks from cinder

2016-07-21 Thread Alessandro De Salvo
Hi Nir, On Thu, 2016-07-21 at 17:25 +0300, Nir Soffer wrote: > On Thu, Jul 21, 2016 at 4:58 PM, Alessandro De Salvo > <alessandro.desa...@roma1.infn.it> wrote: > > Hi, > > I'm trying to export VMs using ceph disks on ovirt 4. The export itself > > works, but the dis

[ovirt-users] Exporting VMs using cinder disks and importing ceph disks from cinder

2016-07-21 Thread Alessandro De Salvo
Hi, I'm trying to export VMs using ceph disks on ovirt 4. The export itself works, but the disks are not saved in the export domains, only the VM definition is stored. Also, I cannot easily re-import them, unless I clone the VM instead of importing it, it just fails. Cinder itself can backup

[ovirt-users] Error while extending a cinder/ceph disk

2016-07-21 Thread Alessandro De Salvo
Hi, when trying to extend a ceph disk in ovirt 4 (Virtual Machines => Edit Virtual Machine => Instance images => Edit => Extend size by) I get the following error: Error while executing action: interface is required In engine.log I see the following errors as well: 2016-07-21 15:14:55,266 ERROR

Re: [ovirt-users] oVirt and Ceph

2016-06-27 Thread Alessandro De Salvo
Hi, the cinder container is broken since a while, since when the kollaglue changed the installation method upstream, AFAIK. Also, it seems that even the latest ovirt 4.0 pulls down the "kilo" version of openstack, so you will need to install yours if you need a more recent one. We are using a

Re: [ovirt-users] Using ceph volumes with ovirt

2016-05-30 Thread Alessandro De Salvo
. Cheers, Alessandro Il 30/05/16 10:55, Alessandro De Salvo ha scritto: Hi, I'm happily using our research cluster in Italy via gluster, and now I'm trying to hotplug a ceph disk on a VM of my cluster, without success. The ceph cluster is managed via openstack cinder and I can create correctly

[ovirt-users] Using ceph volumes with ovirt

2016-05-30 Thread Alessandro De Salvo
Hi, I'm happily using our research cluster in Italy via gluster, and now I'm trying to hotplug a ceph disk on a VM of my cluster, without success. The ceph cluster is managed via openstack cinder and I can create correctly the disk via ovirt (3.6.6.2-1 on CentOS 7.2). The problem comes when