Re: [ovirt-users] change tmp directory when importing VMs

2016-08-30 Thread Cam Mac
Sure, will do Yaniv, thanks! On Tue, Aug 30, 2016 at 9:52 PM, Yaniv Kaul <yk...@redhat.com> wrote: > Can you please file a bug about this? I assume we could add a vdsm.conf > entry to use a different temp dir. > TIA, > Y. > > On Tue, Aug 30, 2016 at 6:16 PM, Cam Mac &

[ovirt-users] installing node on Fedora 23 failing

2016-08-30 Thread Cam Mac
Hi, I'm trying to add a Fedora 23 node to an existing cluster, but it fails with the errors below. I installed python2-dnf (and I saw that there was bug report https://bugzilla.redhat.com/1297835) but it still does not work. Does anyone know what needs to be done to get this to work? Thanks in

Re: [ovirt-users] change tmp directory when importing VMs

2016-08-30 Thread Cam Mac
rt-v2v` indirectly: > > # cp /usr/bin/virt-v2v /usr/bin/virt-v2v-original > # cat > /usr/bin/virt-v2v < > #!/usr/bin/sh > > env TMPDIR=/path/to/custom/tmp /usr/bin/virt-v2v-original $@ > > EOF > > This solution will only survive till next virt-v2v update. > > J

Re: [ovirt-users] Import of exported VMware VM fails

2016-08-30 Thread Cam Mac
<shav...@redhat.com> wrote: > Check for permissions, > All the directory hierarchy and the images as well as the ovf needs to > reached > by the vdsm user, its best to change the owner to vdsm:kvm (e.g. 36:36). > > Shahar. > > > On 29.08.16 16:05, Cam Mac wrote:

[ovirt-users] Import of exported VMware VM fails

2016-08-29 Thread Cam Mac
Hi, I've use ovftool to create an .ova of a VMWare guest (in this case W2012), and then have converted it with virt-v2v, outputting to the oVirt export domain (virt-v2v -i ova /space/w2012-test.ova -o ovirt -os ovirt-engine:/mnt/export-vm -of qcow2). This appears to work, though it reports a

Re: [ovirt-users] change tmp directory when importing VMs

2016-08-25 Thread Cam Mac
seen it anywhere. Cam On Thu, Aug 25, 2016 at 12:28 PM, Cam Mac <iuco...@gmail.com> wrote: > Hi, > > I'm importing VMs in ova format, and the size of the disk images (vmdk) is > such that it fills up the partition where /var/tmp is located when > untarring the ova. Can thi

[ovirt-users] change tmp directory when importing VMs

2016-08-25 Thread Cam Mac
Hi, I'm importing VMs in ova format, and the size of the disk images (vmdk) is such that it fills up the partition where /var/tmp is located when untarring the ova. Can this be set to somewhere else? Thanks, Cam ___ Users mailing list Users@ovirt.org

Re: [ovirt-users] Import of ova failed

2016-07-21 Thread Cam Mac
Bug ID 1358828. I can do another for the direct import of the OVF (without virt-v2v) if needed. Cheers, Cam On Thu, Jul 21, 2016 at 2:56 PM, Shahar Havivi <shav...@redhat.com> wrote: > On 21.07.16 14:38, Cam Mac wrote: > > I tried that already, and it fails. I gave it another t

Re: [ovirt-users] Import of ova failed

2016-07-21 Thread Cam Mac
and try to view the VMs in the export domain > > >> 3. etc... > > >> > > >> If you can attach the ova without the disk it will be great. > > > And please attach the engine.log as well. > > >> > > >> Shahar. > > >> > > >>

Re: [ovirt-users] Import of ova failed

2016-07-21 Thread Cam Mac
Sent, thanks Shahar. On Thu, Jul 21, 2016 at 10:05 AM, Shahar Havivi <shav...@redhat.com> wrote: > On 21.07.16 10:03, Cam Mac wrote: > OK, > Can you please share the engine.log > > Hi Shahar, > > > > Doesn't appear to be there: > > > > engine=> s

Re: [ovirt-users] Import of ova failed

2016-07-21 Thread Cam Mac
Wed, Jul 20, 2016 at 07:16:32PM +0100, Cam Mac wrote: > > > > > > > > The import doesn't happen automatically, you have to do the final > step > > > > manually (when using the command line). See: > > > > > > > > http://libguestfs.org/v

Re: [ovirt-users] Import of ova failed

2016-07-20 Thread Cam Mac
> > The import doesn't happen automatically, you have to do the final step > manually (when using the command line). See: > > http://libguestfs.org/virt-v2v.1.html#output-to-rhev > > However that error shouldn't happen. It looks like the name is the > same as the name of an existing VM. From

Re: [ovirt-users] Import of ova failed

2016-07-20 Thread Cam Mac
...@redhat.com> wrote: > On Wed, Jul 20, 2016 at 03:40:16PM +0100, Cam Mac wrote: > > Hi Rich, > > > > > > > > > > > > > > > > > I can try this but I'm not quite sure how to go about it. The ovf I > > > created > > > >

Re: [ovirt-users] Import of ova failed

2016-07-20 Thread Cam Mac
I tried the GUI first (in 3.6 and later 4.0 after upgrading) and it fails. I posted to the list about this here: http://lists.ovirt.org/pipermail/users/2016-June/040442.html No solution was found so far. Thanks, Cam On Tue, Jul 19, 2016 at 8:51 PM, Richard W.M. Jones

Re: [ovirt-users] Import of ova failed

2016-07-20 Thread Cam Mac
Hi Rich, > > > > > > > I can try this but I'm not quite sure how to go about it. The ovf I > created > > via guest-image-ovf-creator is on an NFS mount > > on the engine: do I need to run virt-v2v on one of the nodes? If so, I > > assume I need to set the output to an export domain. > > Does '-o

Re: [ovirt-users] Import of ova failed

2016-07-19 Thread Cam Mac
Hi Shahar, > I'm trying to import some .ova images from VMWare that have been copied to > > a node. In both cases they fail with the error: > > > > "Conversion of VM from exteral enironment failed: copy-disk stream closed > > unexpectedly" > First you need to look at vdsm log to see more details

[ovirt-users] Import of ova failed

2016-07-14 Thread Cam Mac
Hi, I'm trying to import some .ova images from VMWare that have been copied to a node. In both cases they fail with the error: "Conversion of VM from exteral enironment failed: copy-disk stream closed unexpectedly" (the message above is copied verbatim from the log, including the misspellings)

Re: [ovirt-users] best way to migrate VMs from VMware to oVirt

2016-06-17 Thread Cam Mac
Hi Pavel, Just to clarify: I've read on the virt-v2v page that you should remove the VMware tools from the Windows VM before migration - for step 13 in your list, does that apply only to non-windows VMs? Cheers, Cam On Fri, Jun 17, 2016 at 10:54 AM, Cam Mac <iuco...@gmail.com> wrote:

Re: [ovirt-users] Issues importing VMs in oVirt

2016-06-17 Thread Cam Mac
from this view. Cheers, Campbell On Fri, Jun 17, 2016 at 12:25 PM, Pavel Gashev <p...@acronis.com> wrote: > So there is no Systems folder? > > > > Try: > > vpx://ARDA%5ccam@nssesxi-mgmt/North%20Sutton%20Street/nssesxi/ > nssesxi04-mgmt.ldn.arda.net?no_verify=1 &

[ovirt-users] Fwd: Issues importing VMs in oVirt

2016-06-17 Thread Cam Mac
; > > It's another error. Now there is an issue with esxi server name – > 'nssesxi04-mgmt'. It must be the same as appears in vcenter. A screenshot > of vcenter tree would help. > > > > Please note, there is no need to double escape the URL. > > > > On 17/06/16

Re: [ovirt-users] Issues importing VMs in oVirt

2016-06-17 Thread Cam Mac
erify=1 > > > > > > On 09/06/16 20:28, "users-boun...@ovirt.org on behalf of Cam Mac" < > users-boun...@ovirt.org on behalf of iuco...@gmail.com> wrote: > > > > Hi, > > > > I am trying to import and convert some VMWare guests from a VMW

Re: [ovirt-users] best way to migrate VMs from VMware to oVirt

2016-06-17 Thread Cam Mac
bd61-d15abbc5c482 --vdsm-vol-uuid > 2f56c6cd-a212-44e6-a792-447787f5b073 --vdsm-vm-uuid > 421e93a8-33d2-fc0e-4cfc-ac45a35db8c9 > > 12. Fix resulting disk pemissions (chown 36:36 / chmod 0660) > > 13. Now you can start VM in oVirt. Remove vmware tools, and install oVirt > tools and d

Re: [ovirt-users] best way to migrate VMs from VMware to oVirt

2016-06-16 Thread Cam Mac
<shav...@redhat.com> wrote: > On 15.06.16 22:23, Nir Soffer wrote: > > On Wed, Jun 15, 2016 at 8:41 PM, Cam Mac <iuco...@gmail.com> wrote: > > > Hi, > > > > > > I haven't had any luck using the oVirt GUI or virt-v2v (see earlier > email), &g

Re: [ovirt-users] best way to migrate VMs from VMware to oVirt

2016-06-16 Thread Cam Mac
suggestions too, and post the results. Cheers, Cam On Wed, Jun 15, 2016 at 9:29 PM, Brett I. Holcomb <biholc...@l1049h.com> wrote: > > > On 06/15/2016 01:41 PM, Cam Mac wrote: > > Hi, > > I haven't had any luck using the oVirt GUI or virt-v2v (see earlier > em

Re: [ovirt-users] best way to migrate VMs from VMware to oVirt

2016-06-16 Thread Cam Mac
sof...@redhat.com> wrote: > On Wed, Jun 15, 2016 at 8:41 PM, Cam Mac <iuco...@gmail.com> wrote: > > Hi, > > > > I haven't had any luck using the oVirt GUI or virt-v2v (see earlier > email), > > and I need to find a way to migrate quite a few Windows hosts (Window

Re: [ovirt-users] Issues importing VMs in oVirt

2016-06-16 Thread Cam Mac
Hi Rich, > I'm not sure what the problem is, although you are going about > diagnosing the problem in the right way. > > I would try not escaping the spaces, double escaping them (%2520), and > also removing elements from the path (especially "/Systems" which does > not seem to be necessary)

[ovirt-users] best way to migrate VMs from VMware to oVirt

2016-06-15 Thread Cam Mac
Hi, I haven't had any luck using the oVirt GUI or virt-v2v (see earlier email), and I need to find a way to migrate quite a few Windows hosts (Windows 7, 2012, 2008, 2k3 etc) into my test oVirt cluster as a PoC so I can make a compelling case for getting rid of VMware. Using OVF files looks like

[ovirt-users] ipxe and nslookup

2016-06-01 Thread Cam Mac
Hi, I am using pxeboot with oVirt, which I believe uses ipxe as it's pxe implementation. In our kickstart menu, we need to do a hostname lookup to choose the appropriate local server as there are different boot servers in different global locations. For this, we are currently relying upon the

Re: [ovirt-users] SELinux and oVirt

2016-05-26 Thread Cam Mac
Hi Michal, I re-installed the OS and then oVirt on that node, with SELinux enabled, and that has resolved the issue. Thanks for your help. Cheers, Cam On Wed, May 25, 2016 at 7:24 PM, Michal Skrivanek <mskri...@redhat.com> wrote: > > > On 25 May 2016, at 19:29, Cam Mac <

Re: [ovirt-users] SELinux and oVirt

2016-05-25 Thread Cam Mac
again perhaps. Thanks, Campbell On Wed, May 25, 2016 at 6:15 PM, Michal Skrivanek <mskri...@redhat.com> wrote: > > > On 25 May 2016, at 19:12, Cam Mac <iuco...@gmail.com> wrote: > > I'll try that - presumably on the paths it is complaining about, and the > qemu bi

Re: [ovirt-users] SELinux and oVirt

2016-05-25 Thread Cam Mac
I'll try that - presumably on the paths it is complaining about, and the qemu binarys? On Wed, May 25, 2016 at 4:59 PM, Michal Skrivanek < michal.skriva...@redhat.com> wrote: > > On 25 May 2016, at 17:35, Cam Mac <iuco...@gmail.com> wrote: > > Hi Michal, > > I cho

Re: [ovirt-users] SELinux and oVirt

2016-05-25 Thread Cam Mac
tion, though I'd prefer to fix than restart entirely from scratch. Thanks for any help. regards, Campbell On Wed, May 11, 2016 at 3:13 PM, Cam Mac <iuco...@gmail.com> wrote: > Ah, ok that makes sense. For the node, is it enough to use the 'reinstall > node' option from th

Re: [ovirt-users] SELinux and oVirt

2016-05-11 Thread Cam Mac
16, at 15:24, Cam Mac <iuco...@gmail.com> wrote: > > Thanks Michal, if reinstalling the engine, (which also had SELinux > disabled at install), would the best way be to backup the engine and then > restore just the ovirt config? > > > for engine..well, VM security is

Re: [ovirt-users] SELinux and oVirt

2016-05-11 Thread Cam Mac
On 11 May 2016, at 15:02, Cam Mac <iuco...@gmail.com> wrote: > > > > Hi, > > > > In the oVirt guide, it says that "SELinux is being used by default on > oVirt Node", but then goes on to say that if you have problems you should > set it to permiss

[ovirt-users] SELinux and oVirt

2016-05-11 Thread Cam Mac
Hi, In the oVirt guide, it says that "SELinux is being used by default on oVirt Node", but then goes on to say that if you have problems you should set it to permissive mode. I have had a few things fail due to being blocked by SELinux on a node I later enabled SELinux on, as it was off at

Re: [ovirt-users] vioscsi.sys BSOD with Win 7

2016-05-11 Thread Cam Mac
Hi Ladi, > > We will try just the win 7 drivers that shipped with 3.6.3 rather than the > SHA-2 signed FC23 drivers and I'll get back to you. I have a question: > if I try to build a Win2k12 server via WDS, I assume I will have to add > the 2k12 drivers and then remove them again if I go to

Re: [ovirt-users] vioscsi.sys BSOD with Win 7

2016-05-11 Thread Cam Mac
Thanks, Cam > > > - Original Message - > >> From: "Arman Khalatyan" <arm2...@gmail.com> > >> To: "Cam Mac" <iuco...@gmail.com> > >> Cc: "Tomas Jelinek" <tjeli...@redhat.com>, "users" <user

Re: [ovirt-users] vioscsi.sys BSOD with Win 7

2016-05-10 Thread Cam Mac
Hi Tomas, The install went ok, but Windows complains: "File: \windows\system32\drivers\vioscsi.sys status: 0xc428 Windows cannot verify the digital signature for this file" Regards, Campbell On Tue, May 10, 2016 at 6:29 PM, Cam Mac <iuco...@gmail.com> wrote: > Hi T

Re: [ovirt-users] vioscsi.sys BSOD with Win 7

2016-05-10 Thread Cam Mac
guest-tools-iso-3.6-3.fc23.noarch.rpm > > Also please make sure you point windows to the correct driver in the > sub-directory for w7 > > Tomas > > ----- Original Message - > > From: "Cam Mac" <iuco...@gmail.com> > > To: users@ovirt.org > >

Re: [ovirt-users] node unresponsive after reboot

2016-05-05 Thread Cam Mac
the connectivity issue and the node is now back online. Many thanks to Piotr for all his help. Cheers, Cam On Mon, May 2, 2016 at 3:35 PM, Cam Mac <iuco...@gmail.com> wrote: > Hi Piotr, > > Attached are the vdsm log, the engine log and the supervdsm log. I've > attached them as a .

Re: [ovirt-users] node unresponsive after reboot

2016-05-02 Thread Cam Mac
, May 2, 2016 at 1:38 PM, Piotr Kliczewski <piotr.kliczew...@gmail.com > wrote: > Cam, > > Please provide engine and failing vdsm logs. > > Thanks, > Piotr > > On Sun, May 1, 2016 at 4:05 PM, Cam Mac <iuco...@gmail.com> wrote: > > Hi, > > > > I

[ovirt-users] node unresponsive after reboot

2016-05-01 Thread Cam Mac
Hi, I have a two node + engine ovirt setup, and I was having problems doing a live migration between nodes. I looked in the vdsm logs and noticed selinux errors, so I checked the selinux config, and both the ovirt-engine host and one of the nodes had selinux disabled. So I thought I would enable