Re: [ovirt-users] Virt-viewer not working over VPN

2018-02-09 Thread Frank Thommen



On 02/09/2018 07:55 PM, Vincent Royer wrote:
Hi, I asked this on the virt-viewer list, but it appears to be dead, so 
my apologies if this isn't the right place for this question.


When I access my vm's locally using virt-viewer on windows clients, 
everything works fine, spice or vnc.


When I access the same vm's remotely over a site-to-site VPN (setup 
between the two firewalls), it fails with an error: unable to connect to 
libvirt with uri: [none].  Similarly I cannot connect in a browser-based 
vnc session (cannot connect to host).


I can resolve the DNS of the server from my remote client (domain 
override in the firewall pointing to the DNS server locally) and 
everything else I do seems completely unaware of the vpn link (SSH, RDP, 
etc).  For example connecting to https://ovirt-enginr.mydomain.com works 
as expected.   The only function not working remotely is virt-viewer.


Any clues would be appreciated!


Probably not all ports have been made accessible for VPN users in your 
internal network. E.g. our VPN setup blocks most ports with the 
exception of the usual SSH and http/s ports.  Hence virt-viewer doesn't 
work.


If you have the possibility, connect to a virtual desktop within your 
organization and run your session there.


frank
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] oVirt Upgrade 4.1 -> 4.2 fails with YUM dependency problems (CentOS)

2018-02-05 Thread Frank Thommen
Following the minor release upgrade instructions on 
https://www.ovirt.org/documentation/upgrade-guide/chap-Updates_between_Minor_Releases/ 
solved this issue.  Now we are bumping into an other issue, for which 
I'll probably open an other thread.


frank


On 02/02/2018 05:33 PM, Chas Hockenbarger wrote:
I haven't tried this yet, but looking at the detailed error, the 
implication is that your current install is less than 4.1.7, which is 
where the conflict is. Have you tried updating to > 4.1.7 before upgrading?



___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] oVirt Upgrade 4.1 -> 4.2 fails with YUM dependency problems (CentOS)

2018-02-02 Thread Frank Thommen

On 02/02/18 17:33, Chas Hockenbarger wrote:
I haven't tried this yet, but looking at the detailed error, the 
implication is that your current install is less than 4.1.7, which is 
where the conflict is. Have you tried updating to > 4.1.7 before upgrading?


I had tried with `yum upgrade` to no avail and just realized, that this 
has to be done with ovirt-engine commands.  I'll do this after the weekend.


frank

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] oVirt Upgrade 4.1 -> 4.2 fails with YUM dependency problems (CentOS)

2018-02-02 Thread Frank Thommen

Hi,

following the oVirt upgrade procedure on a CentOS system 
(https://www.ovirt.org/release/4.2.0/#centos--rhel) I fail at step `yum 
update "ovirt-*-setup*"` with a YUM dependency problem:



$ yum update "ovirt-*-setup*"
[...]
ovirt-engine-setup-plugin-ovirt-engine conflicts with 
ovirt-engine-4.1.3.5-1.el7.centos.noarch

[...]
$

For the complete yum update output see below.

I also noticed, that after having installed ovirt-release42, the old 
oVirt 4.1 repos were still present on the system.  I disabled them 
manually to no avail.


`yum update ovirt-engine` results in "No packages marked for update".


Does anyone know, how we can fix this problem?

Cheers
frank

- complete yum update output -
$ yum update "ovirt-*-setup*"
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
 * base: centos.alpha-labs.net
 * extras: centos.mirror.iphh.net
 * ovirt-4.2: ftp.nluug.nl
 * ovirt-4.2-epel: epel.besthosting.ua
 * updates: centos.mirror.iphh.net
Resolving Dependencies
--> Running transaction check
---> Package ovirt-engine-dwh-setup.noarch 0:4.1.9-1.el7.centos will be 
updated
---> Package ovirt-engine-dwh-setup.noarch 0:4.2.1-1.el7.centos will be 
an update
--> Processing Dependency: rh-postgresql95-postgresql-server for 
package: ovirt-engine-dwh-setup-4.2.1-1.el7.centos.noarch
---> Package ovirt-engine-setup.noarch 0:4.1.9.1-1.el7.centos will be 
updated
---> Package ovirt-engine-setup.noarch 0:4.2.0.2-1.el7.centos will be an 
update
---> Package ovirt-engine-setup-base.noarch 0:4.1.9.1-1.el7.centos will 
be updated
---> Package ovirt-engine-setup-base.noarch 0:4.2.0.2-1.el7.centos will 
be an update
--> Processing Dependency: otopi >= 1.7.1 for package: 
ovirt-engine-setup-base-4.2.0.2-1.el7.centos.noarch
--> Processing Dependency: ovirt-engine-lib >= 4.2.0.2-1.el7.centos for 
package: ovirt-engine-setup-base-4.2.0.2-1.el7.centos.noarch
---> Package ovirt-engine-setup-plugin-ovirt-engine.noarch 
0:4.1.9.1-1.el7.centos will be updated
---> Package ovirt-engine-setup-plugin-ovirt-engine.noarch 
0:4.2.0.2-1.el7.centos will be an update
--> Processing Dependency: openvswitch-ovn-central >= 2.7 for package: 
ovirt-engine-setup-plugin-ovirt-engine-4.2.0.2-1.el7.centos.noarch
--> Processing Dependency: ovirt-provider-ovn for package: 
ovirt-engine-setup-plugin-ovirt-engine-4.2.0.2-1.el7.centos.noarch
---> Package ovirt-engine-setup-plugin-ovirt-engine-common.noarch 
0:4.1.9.1-1.el7.centos will be updated
---> Package ovirt-engine-setup-plugin-ovirt-engine-common.noarch 
0:4.2.0.2-1.el7.centos will be an update
---> Package ovirt-engine-setup-plugin-vmconsole-proxy-helper.noarch 
0:4.1.9.1-1.el7.centos will be updated
---> Package ovirt-engine-setup-plugin-vmconsole-proxy-helper.noarch 
0:4.2.0.2-1.el7.centos will be an update
---> Package ovirt-engine-setup-plugin-websocket-proxy.noarch 
0:4.1.9.1-1.el7.centos will be updated
---> Package ovirt-engine-setup-plugin-websocket-proxy.noarch 
0:4.2.0.2-1.el7.centos will be an update
---> Package ovirt-imageio-proxy-setup.noarch 
0:1.0.0-0.201701151456.git89ae3b4.el7.centos will be updated
---> Package ovirt-imageio-proxy-setup.noarch 0:1.2.0-1.el7.centos will 
be an update

--> Running transaction check
---> Package openvswitch-ovn-central.x86_64 1:2.7.3-1.1fc27.el7 will be 
installed
--> Processing Dependency: openvswitch-ovn-common for package: 
1:openvswitch-ovn-central-2.7.3-1.1fc27.el7.x86_64
--> Processing Dependency: openvswitch for package: 
1:openvswitch-ovn-central-2.7.3-1.1fc27.el7.x86_64

---> Package otopi.noarch 0:1.6.3-1.el7.centos will be updated
--> Processing Dependency: otopi = 1.6.3-1.el7.centos for package: 
otopi-java-1.6.3-1.el7.centos.noarch

---> Package otopi.noarch 0:1.7.5-1.el7.centos will be an update
---> Package ovirt-engine-lib.noarch 0:4.1.9.1-1.el7.centos will be updated
---> Package ovirt-engine-lib.noarch 0:4.2.0.2-1.el7.centos will be an 
update
---> Package ovirt-provider-ovn.noarch 0:1.2.2-1.el7.centos will be 
installed
--> Processing Dependency: python-openvswitch >= 2.7 for package: 
ovirt-provider-ovn-1.2.2-1.el7.centos.noarch
--> Processing Dependency: python2-ovsdbapp for package: 
ovirt-provider-ovn-1.2.2-1.el7.centos.noarch
---> Package rh-postgresql95-postgresql-server.x86_64 0:9.5.9-1.el7 will 
be installed
--> Processing Dependency: rh-postgresql95-postgresql-libs(x86-64) = 
9.5.9-1.el7 for package: 
rh-postgresql95-postgresql-server-9.5.9-1.el7.x86_64
--> Processing Dependency: rh-postgresql95-postgresql(x86-64) = 
9.5.9-1.el7 for package: 
rh-postgresql95-postgresql-server-9.5.9-1.el7.x86_64
--> Processing Dependency: rh-postgresql95-runtime for package: 
rh-postgresql95-postgresql-server-9.5.9-1.el7.x86_64
--> Processing Dependency: /usr/bin/scl_source for package: 
rh-postgresql95-postgresql-server-9.5.9-1.el7.x86_64
--> Processing Dependency: libpq.so.rh-postgresql95-5()(64bit) for 
package: rh-postgresql95-postgresql-server-9.5.9-1.el7.x86_64

--> Running transaction 

Re: [ovirt-users] Looking for Python-SDK documentation

2016-04-12 Thread Frank Thommen

On 12.04.16 13:57, Alexander Wels wrote:

On Monday, April 11, 2016 05:03:28 PM Brett I. Holcomb wrote:

On Mon, 2016-04-11 at 20:41 +0200, Frank Thommen wrote:

On 11.04.16 20:17, Brett I. Holcomb wrote:
[...]

I'm in the same boat as Frank.  I've done programming in various
languages since Fortran without the numbers  but only when needed
for my job as an Engineer so I'm not a professional but just trying to
get a job done.  It would be nice to have a full reference so we know
what to provide.  When trying to connect with the api I finally figured
out to use ca_file (like ca-file on the command line).  Raz's reference
is more complete but still leaves a lot out.  The newer equivalent of
Raz's reference seems to be http://www.ovirt.org/develop/release-manage
ment/features/infra/python-sdk/.


The Python/Java/Ruby SDKs are simply language specific wrappers around the REST
api. So if you want a full list of all the options available check out the
REST api documentation. You will have to translate a particular REST api
field/feature to the SDK, but all the SDKs are generated from the REST api
interface definition so the naming and everything should be the same.


That makes sense, thanks.  On the other hand I could also not find any 
REST api reference.  Just some pages with examples a la "find it out 
yourself from there"...


frank
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Looking for Python-SDK documentation

2016-04-11 Thread Frank Thommen

On 11.04.16 20:17, Brett I. Holcomb wrote:

On Mon, 2016-04-11 at 14:38 -0300, Amador Pahim wrote:


On 04/11/2016 02:07 PM, Brett I. Holcomb wrote:

On Mon, 2016-04-11 at 17:27 +0200, Frank Thommen wrote:

Dear all,

I'm currently lost at finding any documentation about the Python SDK
(http://www.ovirt.org/develop/release-management/features/infra/python-sdk/)
like provided classes, functions etc..  There are some examples on the
mentioned page, but I cannot find a complete documentation.  Our oVirt
server is running CentOS 7 with ovirt-engine-sdk-python installed.
However there doesn't seem to exist an ovirt-engine-sdk-python-docs
package and I couldn't find any appropriate link on the oVirt
documentation pages (http://www.ovirt.org/documentation/).

Any ideas, where the documentation is available?

Cheers
Frank
___
Users mailing list
Users@ovirt.org <mailto:Users@ovirt.org>
http://lists.ovirt.org/mailman/listinfo/users
<http://lists.ovirt.org/mailman/listinfo/users%0A>


Other than what you found I found this but that's all.  Doesn't seem
to be much other than examples an the one that shows what to import.
 I, too would like to find what your are looking for so I can use it.


There is this RHEV documentation that can be helpful:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.3/html/Developer_Guide/chap-Python_Quick_Start_Example.html



http://www.ovirt.org/develop/api/pythonapi/


___
Users mailing list
Users@ovirt.org <mailto:Users@ovirt.org>
http://lists.ovirt.org/mailman/listinfo/users
<http://lists.ovirt.org/mailman/listinfo/users >


Thanks.  That is helpful but as Frank said it would be nice to have an
api reference for each class and function that gives the parameters,
return values, and other stuff usually found in an API reference.  The
examples are helpful but don't give all the information abut a function
or class.


Thanks to all who answered.  Brett brings it to the point:  All sent 
links so far are indeed helpful - thanks a lot - but not the reference I 
expected. 
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Python_SDK_Guide/chap-Python_Reference_Documentation.html#Python_Reference_Documentation 
mentions `pydoc`, but this documentation seems to be provided only for 
some modules or to be incomplete.  Also for me not being a software 
developper and newish to Python, the `pydoc` information is not very 
useful.  Where can I e.g. find the documentation for vms.get() and 
vms.add() (just to name teo concrete examples)?


Frank
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] Looking for Python-SDK documentation

2016-04-11 Thread Frank Thommen

Dear all,

I'm currently lost at finding any documentation about the Python SDK 
(http://www.ovirt.org/develop/release-management/features/infra/python-sdk/) 
like provided classes, functions etc..  There are some examples on the 
mentioned page, but I cannot find a complete documentation.  Our oVirt 
server is running CentOS 7 with ovirt-engine-sdk-python installed. 
However there doesn't seem to exist an ovirt-engine-sdk-python-docs 
package and I couldn't find any appropriate link on the oVirt 
documentation pages (http://www.ovirt.org/documentation/).


Any ideas, where the documentation is available?

Cheers
Frank
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users