[ovirt-users] Re: Cannot delete snapshot

2021-04-12 Thread Giulio Casella
Hi, a colleague has submitted a bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1948599 Regards, Giulio Casella On 12/04/2021 14:33, Nir Soffer wrote: > On Mon, Apr 12, 2021 at 11:19 AM Giulio Casella wrote: >> >> Hi, >> I'm having (another) issue working with s

[ovirt-users] Cannot delete snapshot

2021-04-12 Thread Giulio Casella
in ovirt database. I'm pretty sure vProtect use ovirt API to operate, it doesn't directly interact with ovirt database. That's why I'm talking to you and not to storware guys. Is there a (safe) way to get rid of that snapshot? TIA Regards, Giulio Casella

[ovirt-users] Re: Locked disks

2021-03-31 Thread Giulio Casella
FYI: after upgrading to ovirt 4.4.5 (both manager and ovirt nodes) the issue seems fixed (or at least it didn't happen in about a week, with 4.4.4 I had the problem every couple of day). Regards, gc On 04/02/2021 09:08, Giulio Casella wrote: > I've not been able to reproduce, if happens ag

[ovirt-users] Re: Locked disks

2021-02-04 Thread Giulio Casella
n, please open a bug in Bugzilla > (https://bugzilla.redhat.com <https://bugzilla.redhat.com>) with engine > and vdsm logs, > so we'll be able to investigate it. > > *Regards, > * > *Shani Leviim > * > > > On Wed, Feb 3, 2021 at 5:39 PM Giulio Casella

[ovirt-users] Re: Locked disks

2021-02-03 Thread Giulio Casella
. In ovirt 4.4 a failure in snapshot removal leave the whole disk in locked state (maybe a bug?), preventing any further action. Does it make sense? On 03/02/2021 12:25, Giulio Casella wrote: > Hi Shani, > no tasks listed in UI, and now "taskcleaner.sh -o" reports no task (just

[ovirt-users] Re: Locked disks

2021-02-03 Thread Giulio Casella
; > [2] > https://github.com/oVirt/ovirt-engine/blob/master/packaging/setup/dbutils/unlock_entity.sh > <https://github.com/oVirt/ovirt-engine/blob/master/packaging/setup/dbutils/unlock_entity.sh> > > *Regards, > * > *Shani Leviim > * > > > On Wed, Feb 3,

[ovirt-users] Locked disks

2021-02-03 Thread Giulio Casella
Since yesterday I found a couple VMs with locked disk. I don't know the reason, I suspect some interaction made by our backup system (vprotect, snapshot based), despite it's working for more than a year. I'd give a chance to unlock_entity.sh script, but it reports: CAUTION, this operation may

[ovirt-users] Re: ovirt node 4.4 and infiniband

2020-05-26 Thread Giulio Casella
Hi Dominik, > > Does installing mlnx-ofed-basic enables a CentOS 8 based oVirt host to > use Infiniband? it should. After a fresh CentOS install ("minimal install") I enable Mellanox repo, dnf install mlnx-ofed-basic -y, and I can see ib0 device (and I can get IP via DHCP for example). I still

[ovirt-users] ovirt node 4.4 and infiniband

2020-05-25 Thread Giulio Casella
Hi all, I have in production a 4.3.9 setup of ovirt, based on a standalone engine, not HE. I have 3 datacenters (an 3 clusters). One of these clusters is composed of many tenth of HP blades, accessing storage via InfiniBand (used as normal NICs, via ipoib). They're not the state of the art, but I

[ovirt-users] Re: Bridge not forwarding frames on node.

2020-05-14 Thread Giulio Casella
org/privacy-policy.html oVirt Code of Conduct: https://www.ovirt.org/community/about/community-guidelines/ List Archives: https://lists.ovirt.org/archives/list/users@ovirt.org/message/WCD554AXHF7TQH7CMZ5QXK37HLRWF2G2/ -- Giulio Casellagiulio at di.unimi.it

[ovirt-users] Fedora 30 guest - kernel issue

2019-10-25 Thread Giulio Casella
Hi everybody, yesterday I updated some of my fedora 30 ovirt guest, and after reboot I wasn't able to control consoles via spice: I could see desktop, but mouse and keyboard were not working (nor were key command in remote-viewer menu, like ctrl-alt-F2 and so on). Let me specify it's not strictly

[ovirt-users] Re: Cloud Init static route

2019-10-09 Thread Giulio Casella
You can try adding something like this (taken from official cloud-init docs): network: version: 1 config: - type: route destination: 192.168.24.0/24 gateway: 192.168.24.2 metric: 2 to "custom script" field in the "initial run" section of the "Run once" dialog. Or in

[ovirt-users] Re: python sdk create a windows machine with initial run sysprep

2019-08-29 Thread Giulio Casella
That option has to be passed when you start the VM, not in the creation phase: api.vms.get(NEW_VM_NAME).start(use_sysprep=true) Il 29/08/2019 12:45, Harry Conings ha scritto: > Hi > i am trying to create virtual machines from a template but i cannot seem to > find how to ad the inital run

[ovirt-users] storware vProtect

2019-06-05 Thread Giulio Casella
Hi everyone, I'm evaluating some datacenter backup solution, and finally I'm going to give a chance to storware vprotect for my ovirt DC (2 clusters, 3+32 hypervisors, about 100+ VMs). How many of you are using it? Any suggestion? Any caveat not immediately visible? Hints? Drawbacks? For example

[ovirt-users] Re: VM info after upgrade to 4.3.2

2019-03-22 Thread Giulio Casella
Il 22/03/2019 09:28, Simone Tiraboschi ha scritto: > > > On Fri, Mar 22, 2019 at 9:18 AM Giulio Casella <mailto:giu...@di.unimi.it>> wrote: > > Hi guys, > I noticed a strange behaviour after updating (part of) my setup to 4.3.2 > (previously

[ovirt-users] VM info after upgrade to 4.3.2

2019-03-22 Thread Giulio Casella
, are fine, reporting correct informations. For completeness: VMs are a mix of CentOS 7, Fedora, Windows 10, Windows server, ..., with ovirt-guest-agent installed, but the OS seems to make no difference. Any ideas? TIA, Giulio Casella ___ Users mailing lis

[ovirt-users] Re: Mounting ISO in subfolder

2019-02-01 Thread Giulio Casella
Il 01/02/2019 13:19, Gianluca Cecchi ha scritto: > On Fri, Feb 1, 2019 at 12:47 PM Giulio Casella <mailto:giu...@di.unimi.it>> wrote: > > > This could be a (partially satisfying solution), but I can have only one > storage domain for ISOs, right? > AFAIK

[ovirt-users] Re: Mounting ISO in subfolder

2019-02-01 Thread Giulio Casella
Il 01/02/2019 12:12, Greg Sheremeta ha scritto: > ISO domains are deprecated, so my guess is it will be closed. > And storage domains aren't intended for the user to edit manually. > > Perhaps the best way for you to organize is to make a few separate > storage domains for your subsets of ISOs. >

[ovirt-users] Re: Mounting ISO in subfolder

2019-02-01 Thread Giulio Casella
Il 31/01/2019 18:14, Sandro Bonazzola ha scritto: > As far as I can tell, there are no tools that creates subdirectories > within storage domains. > Did you manually upload the iso into the nfs mount creating a > subdirectory there? > I think this layout is not supported at all. Yes, I did (sorry

[ovirt-users] Mounting ISO in subfolder

2019-01-30 Thread Giulio Casella
Hi, I noticed that if I create a directory in root of ISO domain and put an image in it, you can see it in admin portal image list (listed as "foo/bar.iso"), but mounting that iso in a VM ("change CD") fails "Error while executing action Change CD: Drive image file could not be found" I can

[ovirt-users] Re: oVirt Node 4.2.7 upgrade fails with broken dependencies ?

2018-12-19 Thread Giulio Casella
t; > > > > On Wed, Nov 14, 2018 at 11:07 AM Giulio Casella <mailto:giu...@di.unimi.it>> wrote: > > It's due to a update of collectd in epel, but ovirt repos > contain also > collectd-write_http and collectd-disk (still not u

[ovirt-users] Re: oVirt Node 4.2.7 upgrade fails with broken dependencies ?

2018-11-14 Thread Giulio Casella
It's due to a update of collectd in epel, but ovirt repos contain also collectd-write_http and collectd-disk (still not updated). We have to wait for ovirt guys to release updated versions in ovirt-4.2-centos-opstools repo. I think it'll be a matter of few days. Ciao, Giulio Il 14/11/2018

[ovirt-users] Re: cloud-init behaviour after reboot and growpart

2018-10-23 Thread Giulio Casella
Maybe you can try disabling unused data sources. In /etc/cloud/cloud.cfg of el7 vm: datasource_list: ["NoCloud", "ConfigDrive"] If I remember correctly ovirt use ConfigDrive to pass data to VM cloud-init. Hope this helps. Bye, gc Il 23/10/2018 12:37, Nathanaël Blanchet ha scritto: > Hi all,

[ovirt-users] Re: IPoIB broken with ovirt 4.2.6

2018-10-09 Thread Giulio Casella
> Thanks for the heads up! We are preparing oVirt 4.2.7 RC2 today, > I'll issue a oVirt Node 4.2.6 Async 2 in parallel, should both go > out tomorrow. > > > Released You rock! Upgraded and working fine. Thanks, gc ___ Users mailing list

[ovirt-users] Re: IPoIB broken with ovirt 4.2.6

2018-10-03 Thread Giulio Casella
Il 04/09/2018 12:54, Sandro Bonazzola ha scritto: > > > 2018-09-03 16:22 GMT+02:00 Giulio Casella <mailto:giu...@di.unimi.it>>: > > Hi, > latest ovirt node stable (4.2.6 today) introduced a bug in kernel: IP > over infiniband is not workingh anymore a

[ovirt-users] IPoIB broken with ovirt 4.2.6

2018-09-03 Thread Giulio Casella
Hi, latest ovirt node stable (4.2.6 today) introduced a bug in kernel: IP over infiniband is not workingh anymore after an upgrade, due to kernel 3.10.0-862.11.6.el7.x86_64. You can find some detail here: https://bugs.centos.org/view.php?id=15193 dmesg is full of "failed to modify QP to RTR:

Re: [ovirt-users] ovirt-guest-agent behaviour

2018-03-23 Thread Giulio Casella
Fixed! It was a problem independent from ovirt/ovirt agent. It was a problem in writing to /var/run/utmp, causing /usr/bin/users (used by ovirt-guest-agent) to show an emtpy list of connected users. Cheers, g Il 23/03/2018 14:30, Giulio Casella ha scritto: Hi, I just installed a Fedora 27

[ovirt-users] ovirt-guest-agent behaviour

2018-03-23 Thread Giulio Casella
Hi, I just installed a Fedora 27 guest, with ovirt-guest-agent. This VM runs on oVirt (to say the truth is RedHat Virtualization version 4.1.9.2-0.1.el7). I noticed a strange behaviour: in the guest tab "Logged-in user" is always reported as None, but agent seems to be running correctly (other

Re: [ovirt-users] Shutdown all VM's command line

2018-01-16 Thread Giulio Casella
Il 16/01/2018 02:02, Wesley Stewart ha scritto: I am using the default certificates.   Took me a second to find out where they are stored, but after pointing directly to it, everything is working like a champ. If I remember correctly, if you use option "insecure=True", you can omit ca_file

Re: [ovirt-users] Python-SDK4: How to list VM user sessions?

2017-04-11 Thread Giulio Casella
and domain, instead of not reporting at all. Thank you again. Bye, Giulio On 04/10/2017 01:18 PM, Juan Hernández wrote: On 04/10/2017 11:10 AM, Giulio Casella wrote: On 07/04/2017 16:00, Juan Hernández wrote: I have been trying to reproduce this and I wasn't able. In theory the 404 error that you

Re: [ovirt-users] Python-SDK4: How to list VM user sessions?

2017-04-10 Thread Giulio Casella
that should appear after the "HTTP 404 Not Found" message? No problem, find attached a snippet of server.log. Bye, Giulio On 03/31/2017 10:25 AM, Giulio Casella wrote: On 30/03/2017 20:05, Juan Hernández wrote: On 03/30/2017 01:01 PM, Giulio Casella wrote: Hi, I'm trying to obtain a lis

[ovirt-users] Desktop virtualization and thin clients

2017-04-04 Thread Giulio Casella
Hi, I'm evaluating some thin client to connect to ovirt VMs, used as desktop workstations. I really don't care about native client support, I distribute via PXE a custom linux OS launching remote viewer. I'd like to have good multimedia performance, at a reasonable price. Googling a little, I

Re: [ovirt-users] Python-SDK4: How to list VM user sessions?

2017-03-31 Thread Giulio Casella
On 30/03/2017 20:05, Juan Hernández wrote: On 03/30/2017 01:01 PM, Giulio Casella wrote: Hi, I'm trying to obtain a list of users connected to a VM, using python SDK v4. Here's what I'm doing: vm = vms_service.list(search="name=vmname")[0] vm_service = vms_service.vm_service(vm.id

Re: [ovirt-users] Python-SDK4: How to list VM user sessions?

2017-03-30 Thread Giulio Casella
, shutdown, ...) El 2017-03-30 12:01, Giulio Casella escribió: Hi, I'm trying to obtain a list of users connected to a VM, using python SDK v4. Here's what I'm doing: vm = vms_service.list(search="name=vmname")[0] vm_service = vms_service.vm_service(vm.id

[ovirt-users] Python-SDK4: How to list VM user sessions?

2017-03-30 Thread Giulio Casella
Hi, I'm trying to obtain a list of users connected to a VM, using python SDK v4. Here's what I'm doing: vm = vms_service.list(search="name=vmname")[0] vm_service = vms_service.vm_service(vm.id) sessions = vm_service.sessions_service().list() But "sessions" is None. Same result using: s =

[ovirt-users] ovirt 4 reboot behaviour

2017-01-17 Thread Giulio Casella
Hi, I noticed a different behaviour after upgrading my entire setup from rhev 3.6.9 to rhev 4.0.5. A virtual machine reboot changes the host where the VM is running, also if the VM was started in "run once" mode with a payload specifying a placement policy. In version 3 the VM didn't change

Re: [ovirt-users] Error deleting template

2016-05-02 Thread Giulio Casella
and vdsm, so we can investigate this issue. Feel free to ask anything if you got further questions. Regards Idan On Mon, May 2, 2016 at 2:36 PM, Giulio Casella <giu...@di.unimi.it <mailto:giu...@di.unimi.it>> wrote: Hi Idan, you can find attached some snippet of my logs (vdsm.

[ovirt-users] Error deleting template

2016-04-27 Thread Giulio Casella
Hi all, I have a problem deleting a template from admin portal. In file /var/log/vdsm/vdsm.log (on SPM hypervisor) I got: jsonrpc.Executor/4::ERROR::2016-04-27 10:19:57,122::hsm::1518::Storage.HSM::(deleteImage) Empty or not found image in SD [...] Looking in the (data) storage domain the

Re: [ovirt-users] python floppy in RunOnce mode

2016-01-07 Thread Giulio Casella
) vm.start(action) Nice, use_sysprep=True did the trick! I noticed also the flag use_cloud_init, I guess with same logic. I have to update my code accordingly. Thank you again, Giulio Casella ___ Users mailing list Users@ovirt.org http

[ovirt-users] Power Management with python SDK

2015-12-01 Thread Giulio Casella
Hi everybody, I'm trying to enable power management on a host using python, but I'm stuck. Previously (ovirt 3.5) I directly wrote power management parameters into PowerManagement structure (and everything was working fine), but starting from 3.6 this is not possible. This is what I do now:

Re: [ovirt-users] Power Management with python SDK

2015-12-01 Thread Giulio Casella
Hi Juan, Il 01/12/2015 16:48, Juan Hernández ha scritto: On 12/01/2015 03:16 PM, Giulio Casella wrote: Hi everybody, I'm trying to enable power management on a host using python, but I'm stuck. Previously (ovirt 3.5) I directly wrote power management parameters into PowerManagement structure

Re: [ovirt-users] python floppy in RunOnce mode

2014-12-24 Thread Giulio Casella
I can see this behaviour in ovirt 3.5 environment (ovirt-engine-3.5.0.1-1.el6) and in rhev 3.4 environment (rhevm-3.4.3-1.2.el6ev). I'm stuck, what I'm doing wrong? :-( Il 23/12/2014 10:16, Giulio Casella ha scritto: Yes, the VM is windows 7: print myvm.get_os().get_type() shows

Re: [ovirt-users] python floppy in RunOnce mode

2014-12-23 Thread Giulio Casella
Yes, the VM is windows 7: print myvm.get_os().get_type() shows windows_7x64 Anyway I tried to force it, as you suggested, but with no luck... Il 22/12/2014 17:52, Juan Hernández ha scritto: On 12/22/2014 01:21 PM, Giulio Casella wrote: Hi Juan, I tried to use builtin sysprep files

Re: [ovirt-users] python floppy in RunOnce mode

2014-10-24 Thread Giulio Casella
Il 23/10/2014 20:59, Juan Hernandez ha scritto: On 10/23/2014 09:40 AM, Giulio Casella wrote: Hi, I'm trying to boot a vm with non persistent floppy using python ovirt sdk (the RunOnce way in administrator portal), but guest OS can't see floppy drive. The ultimate goal is to deploy floppy

[ovirt-users] python floppy in RunOnce mode

2014-10-23 Thread Giulio Casella
Hi, I'm trying to boot a vm with non persistent floppy using python ovirt sdk (the RunOnce way in administrator portal), but guest OS can't see floppy drive. The ultimate goal is to deploy floppy with sysprep unattend.xml file for windows 7 pools of vm. Here is a snippet of code I use:

Re: [ovirt-users] async vm start (python)

2014-10-15 Thread Giulio Casella
... Ciao, gc Il 14/10/2014 16:53, Juan Hernandez ha scritto: On 10/14/2014 01:04 PM, Giulio Casella wrote: Hi everybody, I'm trying to start a VM (using python sdk) asynchronously, but I obtain synchronous behaviour. The engine is RHEV-M version 3.4.1-0.31.el6ev. Here a snippet of code

[ovirt-users] async vm start (python)

2014-10-14 Thread Giulio Casella
Hi everybody, I'm trying to start a VM (using python sdk) asynchronously, but I obtain synchronous behaviour. The engine is RHEV-M version 3.4.1-0.31.el6ev. Here a snippet of code: - myvm = api.vms.get(name=VMNAME) retval =