[ovirt-users] Re: How to make oVirt + GlusterFS bulletproof

2020-10-16 Thread Jarosław Prokopowski
Thanks! That was very interesting conversation :-) ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to users-le...@ovirt.org Privacy Statement: https://www.ovirt.org/privacy-policy.html oVirt Code of Conduct:

[ovirt-users] Re: How to make oVirt + GlusterFS bulletproof

2020-10-14 Thread Jarosław Prokopowski
Thanks. I will get rid of multipath. I did not set performance.strict-o-direct specifically, only changed permissions of the volume to vdsm.kvm and applied the virt gourp. Now is see performance.strict-o-direct was off. Could it be the reason of the data loss? Direct I/O is enabled in oVirt by

[ovirt-users] Re: How to make oVirt + GlusterFS bulletproof

2020-10-13 Thread Jarosław Prokopowski
Hi Nikolov, Thanks for the very interesting answer :-) I do not use any raid controller. I was hoping glusterfs would take care of fault tolerance but apparently it failed. I have one Samsung 1TB SSD drives in each server for VM storage. I see it is of type "multipath". There is XFS

[ovirt-users] Re: How to make oVirt + GlusterFS bulletproof

2020-10-10 Thread Jarosław Prokopowski
Thanks Alex. I actually think that the issue was caused by power loss on the switch socket. ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to users-le...@ovirt.org Privacy Statement: https://www.ovirt.org/privacy-policy.html

[ovirt-users] Re: How to make oVirt + GlusterFS bulletproof

2020-10-10 Thread Jarosław Prokopowski
Thanks Strahil The data center is remote so I will definitely ask the lab guys to ensure the switch is connected to battery supported power socket. So the gluster's weak point is actually the switch in the network? Can it have difficulty finding out which version of data is correct after the

[ovirt-users] Re: How to make oVirt + GlusterFS bulletproof

2020-10-09 Thread Jarosław Prokopowski
Hmm, I'm not sure. I just created glusterfs volumes on LVM volumes, changed ownership to vdsm.kvm and applied virt group. Then I added it to oVirt as storage for VMs ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to

[ovirt-users] Re: How to make oVirt + GlusterFS bulletproof

2020-10-09 Thread Jarosław Prokopowski
Hi Strahil, I remember during after creating the volume I applied the virt group to it. Volume info: Volume Name: data Type: Replicate Volume ID: 05842cd6-7f16-4329-9ffd-64a0b4366fbe Status: Started Snapshot Count: 0 Number of Bricks: 1 x 3 = 3 Transport-type: tcp Bricks:

[ovirt-users] Re: How to make oVirt + GlusterFS bulletproof

2020-10-08 Thread Jarosław Prokopowski
Hi Jayme, there is UPS but anyway the outages happened. We have also Raritan KVM but it is not supported by oVirt. The setup is 6 hosts - Tow pairs of 3 hosts each using one replica 3 volume. BTW what would be the best gluster volume solution for 6+ hosts?

[ovirt-users] How to make oVirt + GlusterFS bulletproof

2020-10-08 Thread Jarosław Prokopowski
Hi Guys, I had a situation 2 times that due to unexpected power outage something went wrong and VMs on glusterfs where not recoverable. Gluster heal did not help and I could not start the VMs any more. Is there a way to make such setup bulletproof? Does it matter which volume type I choose -

[ovirt-users] Re: enabling vPMU for virtual machine

2019-05-23 Thread Jarosław Prokopowski
Ok, so I found it myself: 1. Edit VM 2. Show Advanced options and go to Hosts tab 3. Set the VM to run on specific host 3. Enable "Pass-Through Host CPU" option - this is the magic ___ Users mailing list -- users@ovirt.org To unsubscribe send an email

[ovirt-users] enabling vPMU for virtual machine

2019-05-22 Thread Jarosław Prokopowski
Hi Guys, Is there a way to enable vPMU for VM in oVirt? I already enabled Nested Virtualization on hosts and installed vdsm-hook-nestedvt. In libvirt it is possible to set This blog post shows how to set it in libvirt xml vm config:

[ovirt-users] Re: active directory: how to replace u...@corp.mydomain.com with u...@mydomain.com

2019-04-16 Thread Jarosław Prokopowski
Finally I was able to login successfully. It came out that mapping module was not necessary. I just needed to use full email address as user name. Even though my domain user name is short "username" I had to use: name.surn...@mydomain.com to make it working.

[ovirt-users] Re: active directory: how to replace u...@corp.mydomain.com with u...@mydomain.com

2019-04-16 Thread Jarosław Prokopowski
Ok, so I figured out that the line: ovirt.engine.aaa.authn.mapping.plugin = mapping should go to: /etc/ovirt-engine/extensions.d/corp.mydomain.com-authn.properties Now when I run: ovirt-engine-extensions-tool --log-level=FINEST aaa login-user --profile=corp.mydomain.com --user-name=a_user I

[ovirt-users] active directory: how to replace u...@corp.mydomain.com with u...@mydomain.com

2019-04-16 Thread Jarosław Prokopowski
I configured active directory authentication but the problem is I need to replace u...@corp.mydomain.com with u...@mydomain.com to be able to authenticate. ovirt-engine-extension-aaa-misc has been installed and I configured it as shown below but still it is not working. Do you have any idea

[ovirt-users] accessing ovirt-image-repository from behind proxy?

2019-04-10 Thread Jarosław Prokopowski
Hi, Is there a way to connect to ovirt-image-repository from ovirt-engine through proxy server? I tried to set http_proxy in /etc/profile of the hosted-engine VM and restarted the VM but it does not help... Errors I get while testing the connection: 2019-04-10 12:36:49,590+03 ERROR

[ovirt-users] Re: Installing VM - Fedora installer stuck on "Setting up installation source..."

2019-04-10 Thread Jarosław Prokopowski
Unfortunately I do not know about the ovirt-image-repository. I haven't been able to make ovirt-image-repository working behind proxy server. Setting system wide proxy in ovirt-engine VM does not help :-( ___ Users mailing list -- users@ovirt.org To

[ovirt-users] Re: Installing VM - Fedora installer stuck on "Setting up installation source..."

2019-04-09 Thread Jarosław Prokopowski
In case someone had the same problem I did 2 things: 1. Decreased the number of cpu cores and memory for the VM 2. Disabled network interfaces in the installer (I think this actually helped but I will confirm tomorrow. One interface had IP from DHCP but no internet connection without proxy)

[ovirt-users] Installing VM - Fedora installer stuck on "Setting up installation source..."

2019-04-09 Thread Jarosław Prokopowski
Hello, I installed oVirt 4.3.2, added NFS ISO domain and trying to create Fedora 26 VM. The installer starts but is stuck on "Installation Source Setting up installation source..." on the "INSTALLATION SUMMARY" screen. I cannot find any useful information in logs. Do you have any idea what can

[ovirt-users] converting oVirt host to be able to hosts to a Self-Hosted Environment

2019-01-28 Thread Jarosław Prokopowski
Hi Guys, Is there a way to convert existing oVirt node (CentOS) to be able to host a Self-Hosted Environment? If so how can I do that? Thanks Jaroson ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to users-le...@ovirt.org

[ovirt-users] Re: how to allow VM to query external DHCP server

2018-11-16 Thread Jarosław Prokopowski
It came out it was the OS fault. Some Linux distributions do not send correct DHCP client identifier. To fix this I had to create /etc/dhcp/dhclient.conf file with: send dhcp-client-identifier = hardware; Jarek On Thu, Nov 15, 2018 at 3:39 PM Jarosław Prokopowski wrote: > Hi, > > It

[ovirt-users] how to allow VM to query external DHCP server

2018-11-15 Thread Jarosław Prokopowski
Hi, It seems my VMs are not able to send DHCP requests to external DHCP server located in the same network as oVirt hosts. Can anyone tell me how I can enable this? Thanks Jarek ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to

[ovirt-users] Re: corrupted hosted engine

2018-11-15 Thread Jarosław Prokopowski
-11-07 at 16:05 +0000, Jarosław Prokopowski wrote: > > I was able to find the correct disk images in the glusterfs volume > > and > > uploaded one of them through the web interface and attached to > > corresponding imported virtual machine. > > The VM does not start c

[ovirt-users] wrong vm disk size after uploading and attaching to VM

2018-11-08 Thread Jarosław Prokopowski
Hi, After uploading virutal machine disk to storage domain and attaching it to virtual machine the disk size is shown in properties as 0 and the VM boots to dracut complaining about the disk size. The disk is "thin provision" Device /dev/sda2 has size of 22528 sectors which is smaller than

[ovirt-users] Re: corrupted hosted engine

2018-11-07 Thread Jarosław Prokopowski
not start completely. It complains now about disk size: Device /dev/sda2 has size of 22528 sectors which is smaller than corresponding PV size of 166746122 This is thin provision disk. Do you have any ideas? On Wed, Nov 7, 2018 at 12:22 PM Jarosław Prokopowski wrote: > Actually the VM

[ovirt-users] Re: corrupted hosted engine

2018-11-07 Thread Jarosław Prokopowski
Actually the VM is in Compute -> Virtual Machines but it does not have any Instance Images attached. How can I attach its original disk image? On Wed, Nov 7, 2018 at 12:12 PM Jarosław Prokopowski wrote: > Thanks for your responses. > > VM was up but network was down in it so I could

[ovirt-users] Re: corrupted hosted engine

2018-11-07 Thread Jarosław Prokopowski
Thanks for your responses. VM was up but network was down in it so I could not use ssh. I didn't know the trick with with VNC password. Thanks Simone it may come handy in the future. I recreated the self hosted engine and imported the Data storage domain. Now I have another problem. The VMs are

[ovirt-users] corrupted hosted engine

2018-11-06 Thread Jarosław Prokopowski
Hi, It looks like after host restart my hosted engine VM is not accessible any more. The storage is glusterfs. The gluster volume is healthy. The VM status is: {"reason": "failed liveliness check", "health": "bad", "vm": "up", "detail": "Up"} hosted-engine --console The engine VM is running on

[ovirt-users] GlusterFS distributed replicated with arbiter on 4 nodes - settings

2018-11-04 Thread Jarosław Prokopowski
Hi Guys, I would like to use GlusterFS distributed-replicated with arbiter volume on 4 nodes for oVirt. Can you tell me what tuning parameters should I set for such volume for best VM performance? Does it make any sense to upgrade from Glusterfs 3.12 to 4.1 or even 5.0? Thanks! Jarek

[ovirt-users] Re: oVirt hyperconverged via cockpit error

2018-10-25 Thread Jarosław Prokopowski
25, 2018 at 3:37 PM Jarosław Prokopowski wrote: > Yes, bq817 is the one with cockpit. Yes I can ssh locally by using full > host name too. > I checked with tcpdump and there isn't any ssh connection try during the > deployment on any of the network interfaces. Strange... > > On

[ovirt-users] Re: oVirt hyperconverged via cockpit error

2018-10-25 Thread Jarosław Prokopowski
ror the same host you are running cockpit from? Make > sure you can ssh not to localhost by to the hostname from the host. I.e. > on bq817storage.example.com try ssh'ing to r...@bq817storage.example.com > > On Thu, Oct 25, 2018 at 9:06 AM Jarosław Prokopowski < > jprokopo

[ovirt-users] Re: oVirt hyperconverged via cockpit error

2018-10-25 Thread Jarosław Prokopowski
And because I sometimes ssh through the main (non-storage) network interface i have local .ssh/config file on the root account with: Host * StrictHostKeyChecking no On Thu, Oct 25, 2018 at 2:03 PM Jarosław Prokopowski wrote: > Hi, > > Yes ssh keys have been distributed and ro

[ovirt-users] Re: oVirt hyperconverged via cockpit error

2018-10-25 Thread Jarosław Prokopowski
>> On Thu, Oct 25, 2018, 7:29 AM Jarosław Prokopowski, < >> jprokopow...@gmail.com> wrote: >> >>> Hi, >>> >>> Please help! :-) I couldn't find any solution via google. >>> >>> I followed this document to create oVirt hype

[ovirt-users] oVirt hyperconverged via cockpit error

2018-10-25 Thread Jarosław Prokopowski
Hi, Please help! :-) I couldn't find any solution via google. I followed this document to create oVirt hyperconverged on 3 hosts using cockpit wizard: https://ovirt.org/blog/2018/02/up-and-running-with-ovirt-4-2-and-gluster-storage/ System: CentOS Linux release 7.5.1804 All hosts can resolve