[ovirt-users] Re: vGPU VM not starting

2018-05-18 Thread Martin Polednik
On 18/05/18 13:42 +0200, Francesco Romani wrote: Hi, On 05/17/2018 10:56 AM, Callum Smith wrote: In an attempt not to mislead you guys as well, there appears to be a separate, vGPU specific, issue. https://www.dropbox.com/s/hlymmf9d6rn12tq/vdsm.vgpu.log?dl=0 I've uploaded the full vdsm.log

Re: [ovirt-users] Nvidia vGPU in KVM Ovirt

2018-04-16 Thread Martin Polednik
On Mon, Apr 16, 2018 at 8:19 PM, codignotto wrote: > Hi everyone, has anyone successfully used an NVIDIA Tesla M10, M60 or other > board to make vGPU? I'm trying a few months ago because I can not run mdev, > the system does not recognize it, I think I'm doing something

Re: [ovirt-users] oVirt 4.2: hostdev passthrough not working any more

2018-02-22 Thread Martin Polednik
On 22/02/18 10:40 +0200, Alexandr Krivulya wrote: Hello, the same problem after upgrade to 4.2.1 :( 18.01.2018 11:53, Daniel Helgenberger пишет: Hello, yesterday I upgraded to 4.2.0 from 4.1.8. Now I notice I cannot assign host dev pass though any more; in the GUI the 'Pinnded to host' list

Re: [ovirt-users] Documentation about vGPU in oVirt 4.2

2018-02-06 Thread Martin Polednik
On 05/02/18 14:38 +0100, Gianluca Cecchi wrote: On Fri, Feb 2, 2018 at 12:13 PM, Jordan, Marcel wrote: Hi, i have some NVIDIA Tesla P100 and V100 gpu in our oVirt 4.2 cluster and searching for a documentation how to use the new vGPU feature. Is there any

Re: [ovirt-users] Nvidia Tesla M60 Direct GPU-Passthrough giving issues + VNC

2018-01-30 Thread Martin Polednik
On 30/01/18 11:15 +0800, Ravyu Sivakumaran wrote: Hi, I am running an Ovirt host on a SuperMicro SuperServer 2028GR-TRH equipped with 2x2 Tesla M60s (they are dual GPU Cards). I've followed this guide- https://www.ovirt.org/develop/release-management/features/virt/hostdev-passthrough/ and

Re: [ovirt-users] About vGPU in oVirt

2018-01-04 Thread Martin Polednik
On 04/01/18 10:04 +0800, lofyer wrote: It seems to be that no M10/M60 vGPU host driver for RHEL7 available on NVIDIA site. Where should I get the driver or just wait for NVIDIA to release? Wait for (or try asking) NVIDIA. oVirt can't provide the host/guest vGPU driver.

Re: [ovirt-users] VM resource allocation and IO Threads

2017-10-30 Thread Martin Polednik
As stated previously, 1 IO thread is somewhat sane choice. Multiple IO threads make sense if you have multiple storage devices across different NUMA nodes. mpolednik On Mon, Oct 30, 2017 at 4:29 PM, Darrell Budic wrote: > Best explanation I’ve found is >

Re: [ovirt-users] Huge pages in guest with newer oVirt versions

2017-09-18 Thread Martin Polednik
The hugepages are no longer a hook, but part of the code base. They can be configured via engine property `hugepages`, where the value of property is size of the pages in KiB (1048576 = 1G, 2048 = 2M). Specifying any other size not supported by the architecture (or just "1") will use platform's

Re: [ovirt-users] oVirt v4.1.2 error: Failed to start service 'vdsmd'

2017-05-30 Thread Martin Polednik
On 30/05/17 15:56 +0300, Nadav Goldin wrote: Are you trying to setup the nodes in VMs? if so, which hypervisor are you using? You need to have 'vmx' flag on the VMs - not only on the physical host. On Tue, May 30, 2017 at 3:51 PM, wrote: After rebooting the oVirt

Re: [ovirt-users] Question about Huge Pages

2017-04-19 Thread Martin Polednik
On 19/04/17 14:01 +0200, Gianluca Cecchi wrote: On Wed, Apr 19, 2017 at 8:03 AM, Michal Skrivanek wrote: Why not reserving regular hugepages for VMs on boot? Do you mean at hypervisor level? In this case it is what I'm doing normally for physical servers where I

Re: [ovirt-users] How to passthrough GPU to windows guest

2017-03-28 Thread Martin Polednik
to maybe work with the hook to also disable hyperv and whatever you find around the internet. It looks like everyone's card needs something different. To be on the safe side, quadro k2200 seem to work fine. Thanks in advance. 2017-03-28 15:17 GMT+08:00 Martin Polednik <mpoled...@redhat.com>:

Re: [ovirt-users] How to passthrough GPU to windows guest

2017-03-28 Thread Martin Polednik
On 28/03/17 02:12 +0800, yimao wrote: Hi, I'm trying to passthrough gpu card to windows 7 guest, but I got the error code 43. I use ovirt node: ovirt-node-ng-installer-ovirt-4.1-2017032304.iso and ovirt-engine-appliance-4.1-20170322.1.el7.centos.noarch.rpm I have added options "intel_iommu=on

[ovirt-users] yet another blogpost - hostdev passthrough

2017-03-20 Thread Martin Polednik
Heya, I've put together another blog post, now on a slightly more advanced topic of hostdev passthrough. Currently only looking into generic PCI devices, but I hope to summarize other passthrough related technologies soon! https://mpolednik.github.io/2017/03/19/hostdev-passthrough-pci/

Re: [ovirt-users] virtio-scsi drive order?

2017-03-16 Thread Martin Polednik
On 16/03/17 08:23 +0100, gflwqs gflwqs wrote: Hi list! When we upgraded our ovirt environment to 4.1 we get the virtio-scsi interface as default for virtual disks. We have seen a difference in drive order from when we used the virtio interface. Before when we added disks the order of the drives

Re: [ovirt-users] gpu passthrough

2017-02-21 Thread Martin Polednik
On 21/02/17 17:26 +0800, qinglong.d...@horebdata.cn wrote: Hi, all: I want to assign the gpu card of one host to the vm which is running in the host. After I click "OK", I got nothing. Anyone can help? Thanks! Hi, Please define nothing. Did the VM not start? Or has it started

[ovirt-users] blog post: virtio-blk vs virtio-scsi

2017-01-23 Thread Martin Polednik
Hi! It's time for another blog post -- virtio-blk VS virtio-scsi. The topic isn't chosen at random, master branch of oVirt now uses virito-scsi as the default interface for drives instead of virtio-blk. The decision to do so wasn't just about flipping a code-switch -- get reading to see why. :)

Re: [ovirt-users] Host Device Mapping

2017-01-22 Thread Martin Polednik
On 20/01/17 14:38 -0600, Bryan Sockel wrote: Hi, I am trying to map a host device to a VM, I am able to get the host device mapped to the VM, but i am unable to start the vm. I receive the following Error: Error while executing action: VM: Cannot run VM. There is no host that satisfies

Re: [ovirt-users] Lowering the bar for wiki contribution?

2017-01-04 Thread Martin Polednik
On 04/01/17 09:57 +0200, Roy Golan wrote: I'm getting the feeling I'm not alone in this, authoring and publishing a wiki page isn't as used to be for long time. I want to suggest a bit lighter workflow: 1. Everyone can merge their page - (it's a wiki) Same as with (public and open) code, no

Re: [ovirt-users] Fwd: [Call for feedback] anybody gave 4.1 beta a try?

2017-01-02 Thread Martin Polednik
On 23/12/16 10:42 +0100, Nathanaël Blanchet wrote: Le 22/12/2016 à 17:17, Yaniv Kaul a écrit : On Thu, Dec 22, 2016 at 12:50 PM, Nathanaël Blanchet > wrote: Hi, sebool unconfigured module prevents vdsm from starting: We always run with

Re: [ovirt-users] feedback and questions about SR-IOV feature

2016-12-06 Thread Martin Polednik
://www.ovirt.org/develop/release-management/features/engine/sr-iov/ Regards, On Tue, Dec 6, 2016 at 4:23 PM, Nathanaël Blanchet <blanc...@abes.fr> wrote: Le 06/12/2016 à 13:19, Martin Polednik a écrit : On 06/12/16 12:14 +0100, Nathanaël Blanchet wrote: Hello, My new 10G NICS support now

Re: [ovirt-users] feedback and questions about SR-IOV feature

2016-12-06 Thread Martin Polednik
On 06/12/16 15:23 +0100, Nathanaël Blanchet wrote: Le 06/12/2016 à 13:19, Martin Polednik a écrit : On 06/12/16 12:14 +0100, Nathanaël Blanchet wrote: Hello, My new 10G NICS support now SR-IOV, and I've played with this new feature as passthrough device, so as to reduce my host CPU

Re: [ovirt-users] feedback and questions about SR-IOV feature

2016-12-06 Thread Martin Polednik
On 06/12/16 12:14 +0100, Nathanaël Blanchet wrote: Hello, My new 10G NICS support now SR-IOV, and I've played with this new feature as passthrough device, so as to reduce my host CPU consumption. At the origin, I set up a bond on both 10G PF nics. After many configurations, the only way I

Re: [ovirt-users] hostdev passthrough

2016-12-06 Thread Martin Polednik
On 05/12/16 21:12 -0500, Charles Kozler wrote: If you're not using SRIOV then what do you need passthrough for? If it's for something like connecting a port that is connected to a mirror port on a switch then you can bridge it then add the nic to the VM. I've done this for security onion and

Re: [ovirt-users] ovirt homeserver

2016-10-31 Thread Martin Polednik
On 28/10/16 17:46 +0100, david caughey wrote: Hi, I'm building a homeserver to run ovirt and wanted to get opinions on the best approach. The server will be used as a test/studybed for ovirt/kvm/vcloud/openstack/ceph. The server will be based around a Xeon E5 10 core with 128GB ram. Option 1:

Re: [ovirt-users] status update: running containers alongside VMs

2016-10-13 Thread Martin Polednik
On 13/10/16 06:40 -0400, Francesco Romani wrote: Hi everyone, I'm happy to share some progress about the former "convirt"[1] project, which aims to let Vdsm containers alongside VMs, on bare metal. In the last couple of months I kept updating the patch series, which is approaching the

Re: [ovirt-users] Failed to read hardware information

2016-10-13 Thread Martin Polednik
On 13/10/16 09:01 +0300, Dan Kenigsberg wrote: On Thu, Oct 13, 2016 at 11:52:17AM +1100, David Pinkerton wrote: Nir, Looks like its crashing on the dmidecode system call. I've attached the output from gbd as well as a dmidecode text dump, dmidecode binary dump and each keywords run

[ovirt-users] blog - real time oVirt host

2016-09-27 Thread Martin Polednik
Hello oVirt users! For the past week-or-so, I've been playing with real time hosts in oVirt. I'm thrilled to say that it works*! * Now the important bits. There is a lot of configuration that has to be done manually and some caveats such as no graphics console or virtio if you want to respect

Re: [ovirt-users] Edit default vdsm.conf

2016-09-05 Thread Martin Polednik
On 05/09/16 23:06 +1000, mailingli...@mooash.com wrote: For my own peace of mind (and just in case these defaults don't work with our network setup), is there any info on the proper way to achieve this? On Mon, 5 Sep 2016, at 10:59 PM, Yaniv Kaul wrote: On Thu, Sep 1, 2016 at 11:58 AM,

Re: [ovirt-users] Attaching a physical DVD drive

2016-08-25 Thread Martin Polednik
On 23/08/16 16:57 +0300, Yaniv Kaul wrote: On Tue, Aug 23, 2016 at 4:50 PM, Maor Lipchuk wrote: - On Tue, Aug 23, 2016 at 4:32 PM, Niksa Baldun wrote: Hi Maor, thanks for the reply. So, to be clear, it is not possible to install from physical

Re: [ovirt-users] Is it possible to disable qxl video?

2016-07-12 Thread Martin Polednik
*** On Mon, Jul 11, 2016 at 5:30 PM, Martin Polednik <mpoled...@redhat.com> wrote: On 11/07/16 17:16 +0200, Arman Khalatyan wrote: Yes I have a BusID inside the xorg.conf. I just tested with virt-manager and indeed it is not a ovirt f

Re: [ovirt-users] Is it possible to disable qxl video?

2016-07-11 Thread Martin Polednik
any *** On Mon, Jul 11, 2016 at 11:55 AM, Martin Polednik <mpoled...@redhat.com> wrote: On 11/07/16 09:46 +, Karli Sjöberg wrote: Den 11 jul 2016 11:37 fm skrev Arman Khalatyan <arm2...@gmail.com>: I just testing several GPUs with pci-passthrough: GTX630, Tesla

Re: [ovirt-users] Is it possible to disable qxl video?

2016-07-11 Thread Martin Polednik
itut für Astrophysik Potsdam (AIP) An der Sternwarte 16, 14482 Potsdam, Germany ******* On Mon, Jul 11, 2016 at 9:06 AM, Martin Polednik <mpoled...@redhat.com> wrote: On 08/07/16 11:29 +0200, Michal Skrivanek wrote: On 06 Jul 2016,

Re: [ovirt-users] Is it possible to disable qxl video?

2016-07-11 Thread Martin Polednik
On 08/07/16 11:29 +0200, Michal Skrivanek wrote: On 06 Jul 2016, at 14:06, Francesco Romani wrote: From: "Arman Khalatyan" To: "users" Sent: Monday, July 4, 2016 11:52:24 AM Subject: [ovirt-users] Is it possible to disable qxl video?

Re: [ovirt-users] host usb

2016-06-16 Thread Martin Polednik
On 15/06/16 23:39 -0500, Fernando Fuentes wrote: I am now getting this when I try to start it: VM methub is down with error. Exit message: Hook Error. To get the hostusb setup I did: engine-config -s "UserDefinedVMProperties=hostusb=^0x[0-9a-fA-F]{4}:0x[0-9a-fA-F]{4}$" ovirt-engine

Re: [ovirt-users] Solution for the multiple incompatible GPUs

2016-06-15 Thread Martin Polednik
On 15/06/16 09:53 +0200, Arman Khalatyan wrote: Hi, I am looking for some solution with multiple GPUs(FX5600quadro and TESLA2050) The drivers are not compatible in the bare metal, Therefore I was trying to use passthrough as described here:

Re: [ovirt-users] Problem accessing to hosted-engine after wrong network config

2016-06-08 Thread Martin Polednik
On 08/06/16 17:00 +0200, Alexis HAUSER wrote: Wouldn't there be another way to access console from the hypervisor to the hosted-engine (without X) ? Not really if you don't have network afaik. Have you done the virsh command with root permissions? sudo virsh list sudo virsh console vm If

Re: [ovirt-users] Problem accessing to hosted-engine after wrong network config

2016-06-08 Thread Martin Polednik
On 08/06/16 11:54 +0200, Alexis HAUSER wrote: hi, I made a terrible and stupid mistake : I changed the VLAN of the wrong ovirt network interface : ovirtmgmt... I now don't have anymore access to my hosted engine. I can still access to the host hypervisor anyway. Any idea how I can change

Re: [ovirt-users] video memory in virtual machine

2016-06-08 Thread Martin Polednik
On 08/06/16 09:55 +0800, qinglong.d...@horebdata.cn wrote: I have found that playing video is not fluent in the virtual machine. So I thought maybe too small video memory in virtual machines led to this. Some parameters have been found when I was trying to check some information. So I wonder

Re: [ovirt-users] PCI Passthrough problem

2016-06-07 Thread Martin Polednik
On 07/06/16 16:50 +0200, Jérôme Chapelle wrote: We are no more able to give a pci device to one VM. Here is the process we used to assign one device to one VM: - Click on the VM, and then on the tab "Host devices" - In the tab, click on "pin to host" and select the host that will give the pci

Re: [ovirt-users] qemu cgroup_controllers

2016-06-06 Thread Martin Polednik
already working. It should be working. -- Dmitry Glushenok Jet Infosystems http://www.jet.msk.su <http://www.jet.msk.su/>+7-495-411-7601 (ext. 1237) 6 июня 2016 г., в 13:35, Martin Polednik <mpoled...@redhat.com> написал(а): On 06/06/16 13:26 +0300, Дмитрий Глушенок wrote: Hello Martin

Re: [ovirt-users] qemu cgroup_controllers

2016-06-06 Thread Martin Polednik
fixed. Hoping so! -- Dmitry Glushenok Jet Infosystems http://www.jet.msk.su <http://www.jet.msk.su/>+7-495-411-7601 (ext. 1237) 6 июня 2016 г., в 12:33, Martin Polednik <mpoled...@redhat.com> написал(а): On 03/06/16 14:05 +0300, Дмитрий Глушенок wrote: Thank you Martin! Actu

Re: [ovirt-users] qemu cgroup_controllers

2016-06-06 Thread Martin Polednik
pendChild(custom_partition(domxml)) hooking.write_domxml(domxml) -- Dmitry Glushenok Jet Infosystems http://www.jet.msk.su +7-495-411-7601 (ext. 1237) 3 июня 2016 г., в 12:24, Martin Polednik <mpoled...@redhat.com> написал(а): On 03/06/16 11:48 +0300, Дмитрий Глушенок wrote: Hello!

Re: [ovirt-users] qemu cgroup_controllers

2016-06-03 Thread Martin Polednik
On 03/06/16 11:48 +0300, Дмитрий Глушенок wrote: Hello! Is it possible to tell libvirt to add specific devices to qemu cgroup? By somehow enumerating the devices in XML using a hook for example. I'm passing scsi-generic disks (/dev/sgX) to VM using qemucmdline hook and it doesn't work until I

Re: [ovirt-users] Changing Cluster CPU Type in a single Host with Hosted Engine environment

2016-05-26 Thread Martin Polednik
hitting cached values). And for the Bug report this should be done here https://bugzilla.redhat.com/enter_bug.cgi?classification=oVirt ? Yes (ovirt-engine, virt team). Best Regards Ralf Brändli Am 26.05.2016 um 14:42 schrieb Martin Polednik <mpoled...@redhat.com>: On 26/05/16 07:12

Re: [ovirt-users] Changing Cluster CPU Type in a single Host with Hosted Engine environment

2016-05-26 Thread Martin Polednik
On 26/05/16 07:12 +, Ralf Braendli wrote: Hi I have the Problem that I selected the wrong CPU Type throw the setup process. Is it posible to change it without an new installation ? Hi! I'm afraid this may not be possible using "regular" approach. You could do this by directly changing

Re: [ovirt-users] USB

2016-05-15 Thread Martin Polednik
- Original Message - > From: "Nisim Simsolo" > To: biholc...@l1049h.com > Cc: users@ovirt.org > Sent: Sunday, May 15, 2016 1:40:07 PM > Subject: Re: [ovirt-users] USB > > Hi > > You can attach host device directly from virtual machines tab -> select VM > -> host

Re: [ovirt-users] restore-nets failing (was: Fresh install failing (Hosted Engine))

2016-03-07 Thread Martin Polednik
On 07/03/16 11:09 -0500, Jonathan Sherman wrote: Thanks for your time on this Dan! The output from the hostdev looks like it may be unparseable, so I'm hoping this is the issue (and that it can be easily remedied). I've also create a log of the other items you asked for, available at:

Re: [ovirt-users] Mixing CPU types

2016-02-03 Thread Martin Polednik
- Original Message - > From: "Matthew Trent" > To: "Yaniv Kaul" > Cc: users@ovirt.org > Sent: Wednesday, February 3, 2016 8:10:35 PM > Subject: Re: [ovirt-users] Mixing CPU types > > ?Actually it works great! It's been supported by

Re: [ovirt-users] Nested KVM - vdsm-hook-nestedvt

2016-01-04 Thread Martin Polednik
On 04/01/16 09:52 +0100, Simone Tiraboschi wrote: On Fri, Jan 1, 2016 at 3:32 PM, Winfried de Heiden wrote: Hi all and happy new year! I'm running oVirt 3.6 on EL7. In order to test nested-kvm I installed vdsm-hook-nestedvt on the hypervisor and put "fake_kvm_support = true" in

Re: [ovirt-users] Nested KVM - vdsm-hook-nestedvt

2016-01-04 Thread Martin Polednik
- Original Message - > From: "Martin Polednik" <mpoled...@redhat.com> > To: w...@dds.nl > Cc: "users" <users@ovirt.org>, "Martin Polednik" <mpoled...@redhat.com> > Sent: Monday, January 4, 2016 2:52:03 PM > Subject: Re: [ovir

Re: [ovirt-users] upgrade from 3.5 to 3.6 causing problems with migration

2015-11-13 Thread Martin Polednik
On 09/11/15 14:00 -0500, Jason Keltz wrote: Hi Shmuel, Thanks very much for looking into my problem! I installed 3.6 on the engine. I rebooted the engine. The 3 hosts were still running vdsm from 3.5. I checked back in the yum log, and it was 4.16.26-0.el7. On the first host upgrade

Re: [ovirt-users] Directly connect NIC or other cards to VM?

2015-02-16 Thread Martin Polednik
- Original Message - From: Lior Vernia lver...@redhat.com To: David Smith dsm...@mypchelp.com Cc: users users@ovirt.org, Martin Polednik mpole...@redhat.com Sent: Monday, February 16, 2015 9:15:41 AM Subject: Re: [ovirt-users] Directly connect NIC or other cards to VM? Hi David

Re: [ovirt-users] When will ovirt add GPU/vGPU support in the admin portal ?

2015-01-19 Thread Martin Polednik
- Original Message - From: Daniel Helgenberger daniel.helgenber...@m-box.de To: Martin Polednik mpoled...@redhat.com, Jorick Astrego j.astr...@netbulae.eu Cc: users@ovirt.org Sent: Monday, January 19, 2015 3:45:01 PM Subject: Re: [ovirt-users] When will ovirt add GPU/vGPU support

Re: [ovirt-users] When will ovirt add GPU/vGPU support in the admin portal ?

2015-01-19 Thread Martin Polednik
- Original Message - From: Jorick Astrego j.astr...@netbulae.eu To: users@ovirt.org Sent: Monday, January 19, 2015 10:14:35 AM Subject: Re: [ovirt-users] When will ovirt add GPU/vGPU support in the admin portal ? On 01/19/2015 02:33 AM, lof yer wrote: Since I recently saw

Re: [ovirt-users] USB Modem in a VM

2015-01-16 Thread Martin Polednik
- Original Message - From: VONDRA Alain avon...@unicef.fr To: Alon Bar-Lev alo...@redhat.com, Michal Skrivanek mskri...@redhat.com Cc: users@ovirt.org Sent: Thursday, January 15, 2015 10:33:19 PM Subject: Re: [ovirt-users] USB Modem in a VM Hi, I've tried also to inject the

Re: [ovirt-users] USB Modem in a VM

2015-01-16 Thread Martin Polednik
- Original Message - From: VONDRA Alain avon...@unicef.fr To: Martin Polednik mpoled...@redhat.com Cc: Alon Bar-Lev alo...@redhat.com, Michal Skrivanek mskri...@redhat.com, users@ovirt.org Sent: Friday, January 16, 2015 12:10:35 PM Subject: RE: [ovirt-users] USB Modem in a VM

Re: [ovirt-users] USB Modem in a VM

2015-01-16 Thread Martin Polednik
- Original Message - From: VONDRA Alain avon...@unicef.fr To: Martin Polednik mpoled...@redhat.com Cc: users@ovirt.org, Michal Skrivanek mskri...@redhat.com Sent: Friday, January 16, 2015 12:30:10 PM Subject: Re: [ovirt-users] USB Modem in a VM Ok Martin, I'll try the python

Re: [ovirt-users] USB Modem in a VM

2015-01-16 Thread Martin Polednik
- Original Message - From: VONDRA Alain avon...@unicef.fr To: Martin Polednik mpoled...@redhat.com Cc: users@ovirt.org, Michal Skrivanek mskri...@redhat.com Sent: Friday, January 16, 2015 2:45:09 PM Subject: Re: [ovirt-users] USB Modem in a VM Hi Martin, That's what I've done

Re: [ovirt-users] USB Modem in a VM

2015-01-16 Thread Martin Polednik
- Original Message - From: VONDRA Alain avon...@unicef.fr To: Martin Polednik mpoled...@redhat.com Cc: users@ovirt.org, Michal Skrivanek mskri...@redhat.com Sent: Friday, January 16, 2015 4:00:28 PM Subject: RE: [ovirt-users] USB Modem in a VM I've replaced with openReadOnly(0