[ovirt-users] Re: Can't install Ovirt from cockpit - ERROR: cannot retrieve iSCSI luns

2020-12-02 Thread Patrick Lomakin
Hi Asaf. Thanks for quick answer. I am sorry, but I have installed HE a week 
ago using console installer. 
Do you see this thread? 
https://lists.ovirt.org/archives/list/users@ovirt.org/thread/2XKKX2O763XKYUTHLDY5NON6ZUCE6Y3V/
I think the problem fixed yesteday.
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/HVHJEH2A6NMOOXDG466O2GRZ6TP4N2RY/


[ovirt-users] Can't to update cluster to 4.5

2020-12-01 Thread Patrick Lomakin
I have a message: 
"Data Center Default compatibility version is 4.4, which is lower than latest 
available version 4.5. Please upgrade your Data Center to latest version to 
successfully finish upgrade of your setup".
 When I try to update datacenter Default I got an error: Error while executing 
action: Cannot update Data Center compatibility version to a value that is 
greater than its cluster's version. The following clusters should be upgraded: 
Default. Next step for me is to try to upgrade compatibility of Cluster. But I 
have tried to do this by editing Cluster compatibility version from 4.4 to 4.5, 
but got an error: Error while executing action: Cannot change Cluster 
Compatibility Version to higher version when there are active Hosts with lower 
version. Please, give me some advices how to fix problem.
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/NUJPUVEBAR5ZDWVL3OMQJXGQY2FP5HPH/


[ovirt-users] Re: Failed upgrade from SHE 4.3.10 to 4.4.3 - Host set to Non-Operational - missing networks

2020-12-01 Thread Patrick Lomakin
Try this command on the host: vdsm-tool remove-config, vdsm-tool configure 
--force; If it will not work, you can stop your VMs with virsh, install a 
"clean" setup of the hosted engine and import your storage with all VMs. I 
think if it possible, installing a new HE and manually set some parameters, 
IMHO, a "little bit" faster, that trying to restore HE with different major 
releases.  
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/DZTGWTESHHFHEEHOPNIBBMFM2DAYG7Q4/


[ovirt-users] Can't install Ovirt from cockpit - ERROR: cannot retrieve iSCSI luns

2020-11-24 Thread Patrick Lomakin
Latest version of Ovirt - 4.4.3
Hi everyboby. I have tryed to install hosted engine from ovirt cockpit, but 
when select iSCSI target I give the same error - Error: Cannot retrieve iSCSI 
LUNs. After that I have installed hosted engine from console with command - 
"hosted-engine --deploy" and than installed successfully. From console was able 
 to retrieve iSCSI luns and select one there. Who can try to deploy ovirt from 
cockpit?
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/BZWZNMREXMU3HU4AX3IGWZGW5YLHCK7Q/


[ovirt-users] Re: iSCSI multipath with separate subnets... still not possible in 4.4.x?

2020-07-20 Thread Patrick Lomakin
I don't quite understand what multipath is, but when I deployed it in my iSCSI 
repository, only one ip address is specified when installing hosted-engine. 
However, in order to specify the second subnet, I went to my host portal where 
I was deploying the engine and added the second subnet in the Storage -> iSCSi 
targets section. It should be noted that the storage is connected to hosts 
directly. However, after that when adding subsequent hosts through the engine I 
saw through their administration panels that in Storage -> iScsi section there 
are also two targets with different subnets and the command on the host 
multipath -ll also showed the normal operation of the two targets. I hope this 
helps you in any way.  
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/6XUZLGQVE2DNFD5VYMRN3F6RKELYWK5L/


[ovirt-users] Re: Ovirt Hosted Engine Setup

2020-07-20 Thread Patrick Lomakin
I have also seen this. Long time later the hosted-engine setup threw an error, 
but after install from cockpit panel an error disappeared. Try this too) 
Regards!
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/S4BRO44ETSZPMF42RGWOENXZDJWHPYBN/


[ovirt-users] Error: missing groups or modules: javapackages-tools in EL 8.2

2020-07-13 Thread Patrick Lomakin
I'm take an error after executing "dnf module enable -y javapackages-tools 
pki-deps postgresql:12 389-ds". 
Error message: 
"Error: Problems in request:
missing groups or modules: javapackages-tools"
Installed system - Red Hat Enterprise Linux 8.2
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/N6TVJWE3M5NSHSIKIVWMLDTXFNLGJE5T/


[ovirt-users] Hosted engine can't start after changing cluster settings

2020-07-07 Thread Patrick Lomakin
I changed the BIOS Type settings in the cluster settings section to UEFI BIOS, 
and hosted-engine does not start after rebooting.  Although, before I made the 
changes, I looked in the engine at the /boot partition, which has the /efi 
directory.  Is there any way to change the engine settings manually, and how 
can I connect to it (or to its partitions) to perform actions?  I can't imagine 
how you can reinstall the engine without unplugging storage to import all 
virtual machines later.  Losing data in virtual machines is a disaster for me.
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/HYBHKETECQVAFGWNBM563P4NHR7IGVZW/


[ovirt-users] Re: oVirt 4.4 HE on Copy local VM disk to shared storage (NFS) failing

2020-05-27 Thread Patrick Lomakin
I think the problem with a storage connection. Verify your IP addresses on the 
storage adapter port. Are they connected? After install my ports for storage 
was deactivated by defaut. Try to connect your iSCSI manually with iscsiadm 
command and then check your storage connection in storage tab using a host 
admin portal.
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/KNQTADDDEIK2V35TSNPSE7JNC6JNF4N3/


[ovirt-users] How to upgrade my cluster to 4.4 without pain (it will be useful not only to me)

2020-05-25 Thread Patrick Lomakin
We have four hosts with self-hosted engines.   Installed version of the engine 
4.3.9. I have the power reserve to migrate all virtual machines to three hosts 
and spend on construction on the remaining host. I really want someone to help 
me make a plan to upgrade and upgrade to version 4.4 without pain. I will 
describe the configuration in more detail: 4 hosts where ovirt node 4.3.9 was 
deployed, and then one of them has an ovirt engine with a control panel 
deployed. In the process the storage was added and everything works fine. In 
the ovirt settings, when adding a host, I deployed a backup engine (gray crown 
icon). Backup engine is available on each host and was specially tested when 
one of the hosts was turned off. "Now as I think it will update and there will 
be questions immediately." 1. My first step is to remove a free host from the 
control panel and deploy ovirt node (4.4) on it 2. Next, the question arises: 
since I have to restore the new engine from backup 4.3.9, will it not
  show a version incompatibility? 3. If I need to restore the backup, then 
logically I have to disable all my engines and then restore? 4. When I restore 
the engine, will my hosts and virtual machines go nowhere? Will hosts with old 
version 4.3.9 be available?
Please do not criticize me and understand correctly - there are over 100 
virtual machines with important data. A rough plan could help me minimize 
serious errors. In addition, I could share my upgrade experience with the real 
configuration, which could help both developers and administrators. Regards! 
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/X5P6R65OLJBV42CVC2BF4PQ2SIXEPLVH/


[ovirt-users] Re: Migrate engine to another storage domain without losing engine settings?

2020-04-16 Thread Patrick Lomakin
You can use two ways to do that: if your new environment has the same version 
try to use engine-backup/restore, or save your backup and try to use 
hosted-engine --deploy --restore-configuration=your-backup, see more info in 
documentation
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/VVSG5IB3IGVUPZ2UXL47ZCLJDBT6KHDN/


[ovirt-users] Re: Problem with connecting the Storage Domain (Host host2 cannot access the Storage Domain(s) )

2020-04-05 Thread Patrick Lomakin
I don't know how to delete this thread, but problem was - the diffrent 
addresses in my storage configuration. I setted the same address to all ports 
such as 10.42.0.10 and my host have installed successfully.
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/PMV46GJH25NV2C5H5LZ3TEL2A2GS2ANW/


[ovirt-users] Re: ISO and Export domains deprecated

2020-04-05 Thread Patrick Lomakin
> Hi all
> 
> I'm trying to understand how ISO and Export domains going away  is going to
> affect us.
> 
> We have four RHV instances:
> - Prod DC1 (RHV4.1)
> - Prod DC2 (RHV4.1)
> - DEV (RHV4.3)
> - TEST (RHV4.3)
> 
> Prod DC1, DEV and TEST all share export and ISO domains.
> 
> Prod DC2 is remote and currently has its own ISO and Export domains.
> 
> When ISO and Export domains go away, can I still share ISO domains between
> the RHV instances?
> 
> Thanks
If you are using VM with Windows there is no available way to install virtio 
driver from diskette to use storage. In Ovirt 4.3.9 I use ISO domain only to 
load drivers to install windows VM. For attach any ISO image to virtual machine 
you can simply upload ISO as a disk to storage domain (iSCSI for example). But 
what about your question, if you have nfs server on your ovirt (rhv) host try 
to mount your share path to another host with follow example:
# mount -t nfs 10.10.0.10:/backups /var/backups 
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/66LZROBSTAUB6POE674J3OLP3IRJZ5MN/


[ovirt-users] Re: How to install Ovirt Node without ISO

2020-03-31 Thread Patrick Lomakin
Why do this? You can install Ovirt as a package using yum. Ovirt Node is simply 
CentOs with included repos and ovirt install package. See Ovirt documentation 
how to setup host on download page
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/MFOHNXY3I7KEZK5J4W25WIOSTXIXGOEB/


[ovirt-users] Problem with connecting the Storage Domain (Host host2 cannot access the Storage Domain(s) )

2020-03-31 Thread Patrick Lomakin
Hello, everyone! I need specialist help, because I'm already desperate. My 
company has four hosts that are connected to the vault. Each host has its own 
IP to access the storage, which means host 1 has an ip 10.42.0.10 and 
10.42.1.10 -> host 2 has an ip 10.42.0.20 and 10.42.0.20 respectively. Host 1 
cannot ping the address 10.42.0.20. Hardware I tried to explain in more detail. 
Host 1 has ovirt node 4.3.9 installed and hosted-engine deployed.
When trying to add host 2 to a cluster it is installed, but not activated. 
There is an error in ovirt manager - "Host host2 cannot access the Storage 
Domain(s) " and host 2 goes to "Not operational" status. On host 2, it 
writes "connect to 10.42.1.10:3260 failed (No route to host)" in the logs and 
repeats indefinitely. I manually connected host 2 to the storage using iscsiadm 
to ip 10.42.0.20. But the error is not missing(. At the same time, when the 
host tries to activate it, I can run virtual machines on it until the host 
shows an error message. VMs that have been run on host 2 continue to run even 
when the host has "Not operational" status.
I assume that when adding host 2 to a cluster, ovirt tries to connect it to the 
same repository host 1 is connected to from ip 10.42.1.10. There may be a way 
to get ovirt to connect to another ip address instead of the ip domain address 
for the first host. I'm attaching logs: 
> /var/log/ovirt-engine/engine.log
2020-03-31 09:13:03,866+03 WARN  
[org.ovirt.engine.core.dal.dbbroker.auditloghan 

dling.AuditLogDirector] 
(EE-ManagedThreadFactory-engineScheduled-Thread-90) [7fa128f4] EVENT_ID: 
VDS_SET_NONOPERATIONAL_DOMAIN(522), Host host2.school34.local c 

annot access the 
Storage Domain(s)  attached to the Data Center DataCenter. Setting 
Host state to Non-Operational.

2020-03-31 10:40:04,883+03 INFO  
[org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] 
(EE-ManagedThreadFactory-engineScheduled-Thread-12) [7a48ebb7] START, 
ConnectStorageServerVDSCommand(HostName = host2.school34.local, 
StorageServerConnectionManagementVDSParameters:{hostId='d82c3a76-e417-4fe4-8b08-a29414e3a9c1',
 storagePoolId='6052cc0a-71b9-11ea-ba5a-00163e10c7e7', storageType='ISCSI', 
connectionList='[StorageServerConnections:{id='c8a05dc2-f8a2-4354-96ed-907762c29761',
 connection='10.42.0.10', iqn='iqn.2002-09.com.lenovo:01.array.00c0ff3bfcb0', 
vfsType='null', mountOptions='null', nfsVersion='null', nfsRetrans='null', 
nfsTimeo='null', iface='null', netIfaceName='null'}, 
StorageServerConnections:{id='0ec6f34e-01c8-4ecc-9bd4-7e2a250d589d', 
connection='10.42.1.10', iqn='iqn.2002-09.com.lenovo:01.array.00c0ff3bfcb0', 
vfsType='null', mountOptions='null', nfsVersion='null', nfsRetrans='null', 
nfsTimeo='null', iface='null', netIfaceName='null'}]', sendNetworkEventOnF
 ailure='true'}), log id: 2c1a22b5
2020-03-31 10:43:05,061+03 ERROR 
[org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] 
(EE-ManagedThreadFactory-engineScheduled-Thread-12) [7a48ebb7] EVENT_ID: 
VDS_BROKER_COMMAND_FAILURE(10,802), VDSM host2.school34.local command 
ConnectStorageServerVDS failed: Message timeout which can be caused by 
communication issues

> vdsm.log
2020-03-31 09:34:07,264+0300 ERROR (jsonrpc/5) [storage.HSM] Could not connect 
to storageServer (hsm:2420)
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/vdsm/storage/hsm.py", line 2417, in 
connectStorageServer
conObj.connect()
  File "/usr/lib/python2.7/site-packages/vdsm/storage/storageServer.py", line 
488, in connect
iscsi.addIscsiNode(self._iface, self._target, self._cred)
  File "/usr/lib/python2.7/site-packages/vdsm/storage/iscsi.py", line 217, in 
addIscsiNode
iscsiadm.node_login(iface.name, target.address, target.iqn)
  File "/usr/lib/python2.7/site-packages/vdsm/storage/iscsiadm.py", line 337, 
in node_login
raise IscsiNodeError(rc, out, err)
IscsiNodeError: (8, ['Logging in to [iface: default, target: 
iqn.2002-09.com.lenovo:01.array.00c0ff3bfcb0, portal: 10.42.1.10,3260] 
(multiple)'], ['iscsiadm: Could not login to [iface: default, target: 
iqn.2002-09.com.lenovo:01.array.00c0ff3bfcb0, portal: 10.42.1.10,3260].', 
'iscsiadm: initiator reported error (8 - connection timed out)', 'iscsiadm: 
Could not log into all portals'])


2020-03-31 09:36:01,583+0300 WARN  (vdsm.Scheduler) [Executor] Worker blocked: 
 timeout=60, 
duration=60.00 at 0x7fe1ac1ffb10> task#=316 at 0x7fe1f0041ad0>, traceback:
File: "/usr/lib64/python2.7/threading.py", line 785, in __bootstrap
  self.__bootstrap_inner()
File: "/usr/lib64/python2.7/threading.py", line 812, in __bootstrap_inner
  self.run()
File: