[ovirt-users] Re: New failure Gluster deploy: Set granual-entry-heal on --> Bricks down

2021-01-27 Thread Sverker Abrahamsson via Users
We ran in to this issue as well when trying to install Ovirt Hyperconverged. The root issue is that kmod-kvdo in Centos 8 (and probably upstream) is built for a specific kernel and if you don't run that kernel it is not found. This is a major issue even if you match the kernel version then if

[ovirt-users] Re: Hosted engine install failure: ipv6.gateway: gateway cannot be set if there are no addresses configured

2020-09-03 Thread Sverker Abrahamsson via Users
: On Thu, Sep 3, 2020 at 12:21 PM Sverker Abrahamsson mailto:sver...@abrahamsson.com>> wrote: Hi Ales, right now I have a manually created ovirtmgmt bridge (virbr0 and vnet0 seems to be created during the failed attempt to deploy hosted engine): [root@h1-mgmt ~]# nmcli co

[ovirt-users] Re: Hosted engine install failure: ipv6.gateway: gateway cannot be set if there are no addresses configured

2020-09-03 Thread Sverker Abrahamsson via Users
  ipv4:     enabled: false   ipv6:     enabled: false   mac-address: A2:35:7A:6C:B7:EF   mtu: 1500 /Sverker Den 2020-09-03 kl. 11:54, skrev Ales Musil: On Thu, Sep 3, 2020 at 11:51 AM Sverker Abrahamsson via Users mailto:users@ovirt.org>> wrote: Hi Dominik That is my issue, I

[ovirt-users] Re: Hosted engine install failure: ipv6.gateway: gateway cannot be set if there are no addresses configured

2020-09-03 Thread Sverker Abrahamsson via Users
to change. /Sverker Den 2020-09-03 kl. 10:52, skrev Dominik Holler: On Wed, Sep 2, 2020 at 10:38 PM Sverker Abrahamsson via Users mailto:users@ovirt.org>> wrote: Well, unforturnatly I don't have a choise since it is out of my control. I only have one physical network port

[ovirt-users] Re: Hosted engine install failure: ipv6.gateway: gateway cannot be set if there are no addresses configured

2020-09-03 Thread Sverker Abrahamsson via Users
switch brand & model ? Maybe someone more experienced in networking can help. Best Regards, Strahil Nikolov В сряда, 2 септември 2020 г., 23:39:57 Гринуич+3, Sverker Abrahamsson via Users написа: Well, unforturnatly I don't have a choise since it is out of my control. I only have

[ovirt-users] Re: Hosted engine install failure: ipv6.gateway: gateway cannot be set if there are no addresses configured

2020-09-02 Thread Sverker Abrahamsson via Users
Гринуич+3, Sverker Abrahamsson via Users написа: Pretty formatting the "desired state" it seems that vdsm tries to remove the ip of my underlying interface, that is enp4s0: {     'interfaces': [{             'name': 'enp4s0',             'state': 'up',             '

[ovirt-users] Hosted engine + OVN

2020-09-02 Thread Sverker Abrahamsson via Users
Was it ever solved to install hosted engine with ovn? I tried a few years ago, got it almost to work but then gave up. ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to users-le...@ovirt.org Privacy Statement:

[ovirt-users] Re: Hosted engine install failure: ipv6.gateway: gateway cannot be set if there are no addresses configured

2020-09-02 Thread Sverker Abrahamsson via Users
to create the bridge manually and not through vdsm if that is possible. /Sverker Den 2020-09-02 kl. 19:14, skrev Sverker Abrahamsson via Users: Hi, I'm attempting to install hosted engine but getting this failure: [ ERROR ] fatal: [localhost]: FAILED! => {"changed": false, "m

[ovirt-users] Hosted engine install failure: ipv6.gateway: gateway cannot be set if there are no addresses configured

2020-09-02 Thread Sverker Abrahamsson via Users
Hi, I'm attempting to install hosted engine but getting this failure: [ ERROR ] fatal: [localhost]: FAILED! => {"changed": false, "msg": "The host has been set in non_operational status, deployment errors:   code 505: Host h1-mgmt.limetransit.com installation failed. Failed to configure

[ovirt-users] Re: Unable to start VM on host with OVS networking

2018-05-27 Thread Sverker Abrahamsson
In my setup the reason why I attempted to use OVS/OVN is that I (currently) have two hosts in a data center (Hetzner) which does not have a common subnet. Each of these hosts have one public IPv4 address. Because of that I want the ovirt networks to be on private ip ranges and they do not

[ovirt-users] Re: Unable to start VM on host with OVS networking

2018-05-20 Thread Sverker Abrahamsson
Hi Jonathan, it seems somewhat similar to what I've been struggeling with. I've worked around it with a hook script until someone can explain from where it should discover that the interface should be created on an ovs bridge. Look at the thread with topic "hosted engine with openvswitch".

[ovirt-users] Re: hosted engine with openvswitch

2018-05-20 Thread Sverker Abrahamsson
engine up, but resyncing host network from engine side makes it loose the connection. /Sverker Den 2018-05-14 kl. 10:12, skrev Sverker Abrahamsson: Apparently the logs were too big for the mailing list, but should have been received by Petr and Dominik. Let me know if not. What it boils down

[ovirt-users] Re: Fwd: Re: Re: hosted engine with openvswitch

2018-05-14 Thread Sverker Abrahamsson
rface element in xml sent to libvirt is similar so I think an understanding of where it comes from is necessary to troubleshoot that (if needed). /Sverker Den 2018-05-13 kl. 00:23, skrev Sverker Abrahamsson: Sure, they are attached. The attempt to start the hosted engine vm occurs at 14:29:42

[ovirt-users] Re: hosted engine with openvswitch

2018-05-10 Thread Sverker Abrahamsson
Hi Dominik Den 2018-05-10 kl. 22:08, skrev Dominik Holler: On Thu, 10 May 2018 19:15:07 +0200 Sverker Abrahamsson <sver...@abrahamsson.com> wrote: Hi I have a problem with running hosted engine with openvswitch. I have Which version of oVirt? Ovirt version is 4.2.3.5, vdsm version 4

[ovirt-users] hosted engine with openvswitch

2018-05-10 Thread Sverker Abrahamsson
Hi I have a problem with running hosted engine with openvswitch. I have one cluster where the ovirt engine runs on the host, there it works and when starting a vm the interface definition looks like this:         slot="0x03" type="pci" />               

Re: [ovirt-users] Network interface persistence

2018-03-26 Thread Sverker Abrahamsson
to set up a consistent naming from the virtual bios. If it matters the switch type used is OVS. /Sverker Den 2018-03-26 kl. 13:41, skrev Sverker Abrahamsson: I have a number of vm's running under Ovirt 4.2, most are CentOS 7 and one Debian. Issue is that when multiple network interfaces are assigned

[ovirt-users] Error during SSO authentication Cannot authenticate user 'admin@internal'

2017-11-13 Thread Sverker Abrahamsson
Since upgrading my test lab to ovirt 4.2 I can't get ovirt-provider-ovn to work. From ovirt-provider-ovn.log: 2017-11-14 00:40:15,795   Request: POST : /v2.0///tokens 2017-11-14 00:40:15,795   Request body: {   "auth" : {     "passwordCredentials" : {   "username" : "admin@internal",  

Re: [ovirt-users] engine upgrade 3.5 -> 4.1.1

2017-04-28 Thread Sverker Abrahamsson
vm_guid| run_on_vds --+ 4e4df6ea-ea01-465b-9424-4436aa24cec0 | (1 row) /Sverker Den 2017-04-28 kl. 10:32, skrev Simone Tiraboschi: On Thu, Apr 27, 2017 at 9:27 PM, Sverker Abrahamsson <sver...@abrah

[ovirt-users] engine upgrade 3.5 -> 4.1.1

2017-04-27 Thread Sverker Abrahamsson
Hi I upgraded an old ovirt installation from 3.5 to latest version, but end up with this error message when running engine-setup: [ INFO ] Stage: Setup validation [ ERROR ] It seems that you are running your engine inside of the hosted-engine VM and are not in "Global Maintenance" mode. In

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2017-01-16 Thread Sverker Abrahamsson
I've followed the instructions to best effort, so hopefully it's right.. Den 2017-01-13 kl. 10:31, skrev Marcin Mirecki: Please push the patch into: https://gerrit.ovirt.org/ovirt-provider-ovn (let me know if you need some directions) - Original Message - From: "Sverker Abraha

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2017-01-09 Thread Sverker Abrahamsson
Sverker Den 2017-01-09 kl. 10:41, skrev Sverker Abrahamsson: This is the content of vdsm.log on h1 at this time: 2017-01-06 20:54:12,636 INFO (jsonrpc/7) [jsonrpc.JsonRpcServer] RPC call VM.create succeeded in 0.01 seconds (__init__:515) 2017-01-06 20:54:12,636 INFO (vm/6dd5291e) [virt.vm] (v

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2017-01-09 Thread Sverker Abrahamsson
correct id. /Sverker Den 2017-01-09 kl. 10:06, skrev Marcin Mirecki: The port is set up on the host by the ovirt-provider-ovn-driver. The driver is invoked by the vdsm hook whenever any operation on the port is done. Please ensure that this is installed properly. You can check the vdsm log (/va

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2017-01-06 Thread Sverker Abrahamsson
dccb59a addresses: ["00:1a:4a:16:01:54"] port 92f6d3c8-68b3-4986-9c09-60bee04644b5 addresses: ["00:1a:4a:16:01:52"] port ovirtbridge-port2 addresses: ["unknown"] port ovirtbridge-port1 addresses: [&

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2017-01-06 Thread Sverker Abrahamsson
Port_Binding "ovirtbridge-port1" Chassis "4f10fb04-8fb2-48d7-8a3f-ea6444c02cf9" hostname: "h1.limetransit.com" Encap geneve ip: "144.76.84.73" options: {csum="true"} Port_Binding "ovirtbridge-port2" Port_

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2017-01-02 Thread Sverker Abrahamsson
rt2" Port_Binding "92f6d3c8-68b3-4986-9c09-60bee04644b5" I don't know from where the faulty id comes from, it's not in any logs. In the domain xml as printed in vdsm.log the id is correct:

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2017-01-02 Thread Sverker Abrahamsson
host works, although I need to resolve the traffic issue over the OVS tunnel. /Sverker Den 2017-01-02 kl. 01:13, skrev Sverker Abrahamsson: 1. That is not possible as ovirt (or vdsm) will rewrite the network configuration to a non-working state. That is why I've set that if as hidden to vdsm and

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2017-01-01 Thread Sverker Abrahamsson
g/repos/ovirt/experimental/master/ovirt-provider-ovn_fc24_46/rpm/fc24/noarch/ - Original Message - From: "Sverker Abrahamsson" <sver...@abrahamsson.com> To: "Marcin Mirecki" <mmire...@redhat.com> Cc: "Ovirt Users" <users@ovirt.org> Sent: Friday,

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-30 Thread Sverker Abrahamsson
- Original Message - From: "Sverker Abrahamsson" <sver...@abrahamsson.com> To: "Marcin Mirecki" <mmire...@redhat.com> Cc: "Ovirt Users" <users@ovirt.org> Sent: Friday, December 30, 2016 12:15:43 PM Subject: Re: [ovirt-users] Issue

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-30 Thread Sverker Abrahamsson
in your case would probably be to create br-int and connect this to your ovirtbridge, although I don't know the details of your env, so this is just my best guess. Marcin - Original Message - From: "Sverker Abrahamsson" <sver...@abrahamsson.com> To: "Marcin Mirecki&

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-29 Thread Sverker Abrahamsson
there + testcode of some variants /Sverker Den 2016-12-29 kl. 22:55, skrev Sverker Abrahamsson: When I change /usr/libexec/vdsm/hooks/before_device_create/ovirt_provider_ovn_hook to instead of hardcoded to br-int use BRIDGE_NAME = 'ovirtbridge' then I get the expected behaviour and I get

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-29 Thread Sverker Abrahamsson
:07, skrev Sverker Abrahamsson: By default the vNic profile of my OVN bridge ovirtbridge gets a Network filter named vdsm-no-mac-spoofing. If I instead set No filter then I don't get those ebtables / iptables messages. It seems that there is some issue between ovirt/vdsm and firewalld, which we

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-29 Thread Sverker Abrahamsson
. It is not clear for me why the port is added on br-int instead of the bridge I've assigned to the VM, which is ovirtbridge?? /Sverker Den 2016-12-29 kl. 14:20, skrev Sverker Abrahamsson: The specific command most likely fails because there is no chain named libvirt-J-vnet0, but when should

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-29 Thread Sverker Abrahamsson
emove the nameservers section as well. At first I could not get it to work, as vdsm-network would find the backup file /var/lib/vdsm/persistence/netconf/nets/ovirtmgmt~ but after removing that it worked fine. Not sure when nameservers and defaultroute was set in vdsm as it worked on reboot be

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-29 Thread Sverker Abrahamsson
-0500 (EST) Från: Marcin Mirecki <mmire...@redhat.com> Till: Sverker Abrahamsson <sver...@abrahamsson.com> Kopia: Ovirt Users <users@ovirt.org>, Lance Richardson <lrich...@redhat.com>, Numan Siddique <nusid...@redhat.com> Let me add the OVN team. Lanc

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-29 Thread Sverker Abrahamsson
setting configuring the OVN-controller? Marcin - Original Message - From: "Sverker Abrahamsson" <sver...@abrahamsson.com> To: "Marcin Mirecki" <mmire...@redhat.com> Cc: "Ovirt Users" <users@ovirt.org> Sent: Thursday, December 29, 2016 11:44

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-29 Thread Sverker Abrahamsson
vn-config" or using the OVN tools directly. Please check out: https://www.ovirt.org/blog/2016/11/ovirt-provider-ovn/ for details. Also please note that the OVN provider is completely different from the neutron-openvswitch plugin. Please don't mix the two. Marcin - Original Message

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Sverker Abrahamsson
From /usr/libexec/vdsm/hooks/before_device_create/ovirt_provider_ovn_hook (installed by ovirt-provider-ovn-driver rpm): BRIDGE_NAME = 'br-int' Den 2016-12-28 kl. 23:56, skrev Sverker Abrahamsson: Googling on the message about br-int suggested adding that bridge to ovs: ovs-vsctl add-br br

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Sverker Abrahamsson
in ?? [root@h2 share]# rpm -qf /usr/share/otopi/plugins/ovirt-host-deploy/openstack/neutron_openvswitch.py ovirt-host-deploy-1.6.0-0.0.master.20161215101008.gitb76ad50.el7.centos.noarch /Sverker Den 2016-12-28 kl. 23:24, skrev Sverker Abrahamsson: In addition I had to add an alias to modprobe:

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Sverker Abrahamsson
In addition I had to add an alias to modprobe: [root@h2 modprobe.d]# cat dummy.conf alias dummy0 dummy Den 2016-12-28 kl. 23:03, skrev Sverker Abrahamsson: Hi I first tried to set device name to dummy_0, but then ifup did not succeed in creating the device unless I first did 'ip link add

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Sverker Abrahamsson
to use it for the setup. Marcin - Original Message - From: "Marcin Mirecki" <mmire...@redhat.com> To: "Sverker Abrahamsson" <sver...@abrahamsson.com> Cc: "Ovirt Users" <users@ovirt.org> Sent: Wednesday, December 28, 2016 12:06:26 PM Subject: Re

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Sverker Abrahamsson
). Please give me some time to look for a solution. - Original Message - From: "Sverker Abrahamsson" <sver...@abrahamsson.com> To: "Marcin Mirecki" <mmire...@redhat.com> Cc: "Ovirt Users" <users@ovirt.org> Sent: Wednesday, December 28, 2016 11:48

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Sverker Abrahamsson
can only handle external networks, which can not be used for a management network. Marcin - Original Message - From: "Sverker Abrahamsson" <sver...@abrahamsson.com> To: users@ovirt.org Sent: Wednesday, December 28, 2016 12:39:59 AM Subject: [ovirt-users] Issue with OVN/O

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Sverker Abrahamsson
Building A, 4th floor Ra'anana, Israel 4350109 Tel : +972 (9) 7692306 8272306 Email: yd...@redhat.com <mailto:yd...@redhat.com> IRC : ydary On Wed, Dec 28, 2016 at 1:39 AM, Sverker Abrahamsson <sver...@abrahamsson.com <mailto:sver...@abrahamsson.com>> wrote: Hi For l

[ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-27 Thread Sverker Abrahamsson
Hi For long time I've been looking for proper support in ovirt for Open vSwitch so I'm happy that it is moving in the right direction. However, there seems to still be a dependency on a ovirtmgmt bridge and I'm unable to move that to the OVN provider. The hosting center where I rent hw

Re: [ovirt-users] Ovirt + OpenVSwitch

2016-05-23 Thread Sverker Abrahamsson
can I accomplish that? /Sverker On 2016-04-13 14:50, Dan Kenigsberg wrote: On Mon, Apr 11, 2016 at 01:24:51PM +0200, Sverker Abrahamsson wrote: Hi My usecase is that I am setting up a lab to emulate a customers production environment which has multiple vlans. As this is done in a hosting

Re: [ovirt-users] Ovirt + OpenVSwitch

2016-04-11 Thread Sverker Abrahamsson
Hi My usecase is that I am setting up a lab to emulate a customers production environment which has multiple vlans. As this is done in a hosting environment where I don't have any control over the switches, I've created virtual switches with OpenVSwitch which connects together a couple of

[ovirt-users] Ovirt + OpenVSwitch

2016-04-06 Thread Sverker Abrahamsson
Has anybody succeeded in installing Ovirt 3.6 with hosted engine on a server which uses OpenVSwitch for the network config? I believe my issue is that Ovirt wants to control the network to create a bridge for its management and I wants it to just use whatever network is available on the host