Re: [Users] Win8 on oVirt

2014-03-12 Thread Sven Kieske


Am 11.03.2014 17:33, schrieb Itamar Heim:
 engineconfig, change the EmaultedMachine for a 3.3 cluster version
I am sorry, but previously you said:

the guest is lanunched with -m rhel6.5.0 (which is the default for a
3.3 cluster)

and now you say you have to switch it by hand?

Which statement is true?
If it's the default, it should be set already and I would
consider this a bug, wouldn't you?


-- 
Mit freundlichen Grüßen / Regards

Sven Kieske

Systemadministrator
Mittwald CM Service GmbH  Co. KG
Königsberger Straße 6
32339 Espelkamp
T: +49-5772-293-100
F: +49-5772-293-333
https://www.mittwald.de
Geschäftsführer: Robert Meyer
St.Nr.: 331/5721/1033, USt-IdNr.: DE814773217, HRA 6640, AG Bad Oeynhausen
Komplementärin: Robert Meyer Verwaltungs GmbH, HRB 13260, AG Bad Oeynhausen
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-12 Thread Itamar Heim

On 03/12/2014 10:06 AM, Sven Kieske wrote:



Am 11.03.2014 17:33, schrieb Itamar Heim:

engineconfig, change the EmaultedMachine for a 3.3 cluster version

I am sorry, but previously you said:


the guest is lanunched with -m rhel6.5.0 (which is the default for a

3.3 cluster)

and now you say you have to switch it by hand?

Which statement is true?
If it's the default, it should be set already and I would
consider this a bug, wouldn't you?




sorry, i confused the RHEV default, which GA post rhel 6.5, with the 
ovirt one which GA pre-6.5.



___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-12 Thread Sven Kieske


Am 12.03.2014 09:13, schrieb Itamar Heim:
 
 sorry, i confused the RHEV default, which GA post rhel 6.5, with the
 ovirt one which GA pre-6.5.

Okay, thanks for the clarification!

-- 
Mit freundlichen Grüßen / Regards

Sven Kieske

Systemadministrator
Mittwald CM Service GmbH  Co. KG
Königsberger Straße 6
32339 Espelkamp
T: +49-5772-293-100
F: +49-5772-293-333
https://www.mittwald.de
Geschäftsführer: Robert Meyer
St.Nr.: 331/5721/1033, USt-IdNr.: DE814773217, HRA 6640, AG Bad Oeynhausen
Komplementärin: Robert Meyer Verwaltungs GmbH, HRB 13260, AG Bad Oeynhausen
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-12 Thread Michael Wagenknecht

I only get the parameter -m rhel6.4.0 in the qemu command line of the guest.
The Host and the linux guest runs with CentOS 6.5.
on the oVirt Engine I run:

engine-config -s ClusterEmulatedMachines=rhel6.5.0,pc-1.0 --cver=3.3


Am 12.03.2014 09:13, schrieb Itamar Heim:

On 03/12/2014 10:06 AM, Sven Kieske wrote:



Am 11.03.2014 17:33, schrieb Itamar Heim:

engineconfig, change the EmaultedMachine for a 3.3 cluster version

I am sorry, but previously you said:


the guest is lanunched with -m rhel6.5.0 (which is the default for a

3.3 cluster)

and now you say you have to switch it by hand?

Which statement is true?
If it's the default, it should be set already and I would
consider this a bug, wouldn't you?




sorry, i confused the RHEV default, which GA post rhel 6.5, with the 
ovirt one which GA pre-6.5.



___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


--
Mit freundlichen Grüßen

Michael Wagenknecht
FuH Entwicklungsgesellschaft mbH
Geschäftsführer Carola Fornoff
HRB Freiburg 701203, UID DE255007372
Elsässer Str. 18, D-79346 Endingen
Telefon +49 - 7642 - 92866 - 0

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-12 Thread Sven Kieske
Did you restart ovirt-engine after running engine-config?
This is required.

Am 12.03.2014 09:28, schrieb Michael Wagenknecht:
 I only get the parameter -m rhel6.4.0 in the qemu command line of the
 guest.
 The Host and the linux guest runs with CentOS 6.5.
 on the oVirt Engine I run:
 
 engine-config -s ClusterEmulatedMachines=rhel6.5.0,pc-1.0 --cver=3.3

-- 
Mit freundlichen Grüßen / Regards

Sven Kieske

Systemadministrator
Mittwald CM Service GmbH  Co. KG
Königsberger Straße 6
32339 Espelkamp
T: +49-5772-293-100
F: +49-5772-293-333
https://www.mittwald.de
Geschäftsführer: Robert Meyer
St.Nr.: 331/5721/1033, USt-IdNr.: DE814773217, HRA 6640, AG Bad Oeynhausen
Komplementärin: Robert Meyer Verwaltungs GmbH, HRB 13260, AG Bad Oeynhausen
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-12 Thread Michael Wagenknecht

Yes I do.

Am 12.03.2014 09:50, schrieb Sven Kieske:

Did you restart ovirt-engine after running engine-config?
This is required.

Am 12.03.2014 09:28, schrieb Michael Wagenknecht:

I only get the parameter -m rhel6.4.0 in the qemu command line of the
guest.
The Host and the linux guest runs with CentOS 6.5.
on the oVirt Engine I run:

engine-config -s ClusterEmulatedMachines=rhel6.5.0,pc-1.0 --cver=3.3


--
Mit freundlichen Grüßen

Michael Wagenknecht
FuH Entwicklungsgesellschaft mbH
Geschäftsführer Carola Fornoff
HRB Freiburg 701203, UID DE255007372
Elsässer Str. 18, D-79346 Endingen
Telefon +49 - 7642 - 92866 - 0

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-12 Thread Itamar Heim

On 03/12/2014 10:28 AM, Michael Wagenknecht wrote:

I only get the parameter -m rhel6.4.0 in the qemu command line of the
guest.
The Host and the linux guest runs with CentOS 6.5.
on the oVirt Engine I run:

engine-config -s ClusterEmulatedMachines=rhel6.5.0,pc-1.0 --cver=3.3


I assume cluster version is 3.3.
did your restart engine post the engine-config command?




Am 12.03.2014 09:13, schrieb Itamar Heim:

On 03/12/2014 10:06 AM, Sven Kieske wrote:



Am 11.03.2014 17:33, schrieb Itamar Heim:

engineconfig, change the EmaultedMachine for a 3.3 cluster version

I am sorry, but previously you said:


the guest is lanunched with -m rhel6.5.0 (which is the default for a

3.3 cluster)

and now you say you have to switch it by hand?

Which statement is true?
If it's the default, it should be set already and I would
consider this a bug, wouldn't you?




sorry, i confused the RHEV default, which GA post rhel 6.5, with the
ovirt one which GA pre-6.5.


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users




___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-12 Thread Michael Wagenknecht


Am 12.03.2014 10:04, schrieb Itamar Heim:

On 03/12/2014 10:28 AM, Michael Wagenknecht wrote:

I only get the parameter -m rhel6.4.0 in the qemu command line of the
guest.
The Host and the linux guest runs with CentOS 6.5.
on the oVirt Engine I run:

engine-config -s ClusterEmulatedMachines=rhel6.5.0,pc-1.0 --cver=3.3


I assume cluster version is 3.3.
did your restart engine post the engine-config command?

Cluster Version is 3.3 and I restart the engine after running the 
engine-config command.



Am 12.03.2014 09:13, schrieb Itamar Heim:

On 03/12/2014 10:06 AM, Sven Kieske wrote:



Am 11.03.2014 17:33, schrieb Itamar Heim:

engineconfig, change the EmaultedMachine for a 3.3 cluster version

I am sorry, but previously you said:


the guest is lanunched with -m rhel6.5.0 (which is the default for a

3.3 cluster)

and now you say you have to switch it by hand?

Which statement is true?
If it's the default, it should be set already and I would
consider this a bug, wouldn't you?




sorry, i confused the RHEV default, which GA post rhel 6.5, with the
ovirt one which GA pre-6.5.


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users






--
Mit freundlichen Grüßen

Michael Wagenknecht
FuH Entwicklungsgesellschaft mbH
Geschäftsführer Carola Fornoff
HRB Freiburg 701203, UID DE255007372
Elsässer Str. 18, D-79346 Endingen
Telefon +49 - 7642 - 92866 - 0

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-12 Thread Itamar Heim

On 03/12/2014 11:08 AM, Michael Wagenknecht wrote:


Am 12.03.2014 10:04, schrieb Itamar Heim:

On 03/12/2014 10:28 AM, Michael Wagenknecht wrote:

I only get the parameter -m rhel6.4.0 in the qemu command line of the
guest.
The Host and the linux guest runs with CentOS 6.5.
on the oVirt Engine I run:

engine-config -s ClusterEmulatedMachines=rhel6.5.0,pc-1.0 --cver=3.3


I assume cluster version is 3.3.
did your restart engine post the engine-config command?


Cluster Version is 3.3 and I restart the engine after running the
engine-config command.


right...
just remembered this is preserved at cluster level on first host joining 
the cluster to support both fedora and .el6 without manual intervention.

do you have at cluster level an emulation mode field?

omer/roy - is there an easy way to change cluster level emulation mode?




Am 12.03.2014 09:13, schrieb Itamar Heim:

On 03/12/2014 10:06 AM, Sven Kieske wrote:



Am 11.03.2014 17:33, schrieb Itamar Heim:

engineconfig, change the EmaultedMachine for a 3.3 cluster version

I am sorry, but previously you said:


the guest is lanunched with -m rhel6.5.0 (which is the default for a

3.3 cluster)

and now you say you have to switch it by hand?

Which statement is true?
If it's the default, it should be set already and I would
consider this a bug, wouldn't you?




sorry, i confused the RHEV default, which GA post rhel 6.5, with the
ovirt one which GA pre-6.5.


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users








___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-12 Thread Michael Wagenknecht


Am 12.03.2014 10:12, schrieb Itamar Heim:

On 03/12/2014 11:08 AM, Michael Wagenknecht wrote:


Am 12.03.2014 10:04, schrieb Itamar Heim:

On 03/12/2014 10:28 AM, Michael Wagenknecht wrote:

I only get the parameter -m rhel6.4.0 in the qemu command line of the
guest.
The Host and the linux guest runs with CentOS 6.5.
on the oVirt Engine I run:

engine-config -s ClusterEmulatedMachines=rhel6.5.0,pc-1.0 --cver=3.3


I assume cluster version is 3.3.
did your restart engine post the engine-config command?


Cluster Version is 3.3 and I restart the engine after running the
engine-config command.


right...
just remembered this is preserved at cluster level on first host 
joining the cluster to support both fedora and .el6 without manual 
intervention.

do you have at cluster level an emulation mode field?

omer/roy - is there an easy way to change cluster level emulation mode?


No I can't find an emulation mode field.



Am 12.03.2014 09:13, schrieb Itamar Heim:

On 03/12/2014 10:06 AM, Sven Kieske wrote:



Am 11.03.2014 17:33, schrieb Itamar Heim:

engineconfig, change the EmaultedMachine for a 3.3 cluster version

I am sorry, but previously you said:

the guest is lanunched with -m rhel6.5.0 (which is the default 
for a

3.3 cluster)

and now you say you have to switch it by hand?

Which statement is true?
If it's the default, it should be set already and I would
consider this a bug, wouldn't you?




sorry, i confused the RHEV default, which GA post rhel 6.5, with the
ovirt one which GA pre-6.5.


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users










--
Mit freundlichen Grüßen

Michael Wagenknecht
FuH Entwicklungsgesellschaft mbH
Geschäftsführer Carola Fornoff
HRB Freiburg 701203, UID DE255007372
Elsässer Str. 18, D-79346 Endingen
Telefon +49 - 7642 - 92866 - 0

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-12 Thread Michael Wagenknecht
If I change the machine type from rhel6.4.0 to rhel6.5.0 in the xml file 
of the guest with a hook script, then the SEP Flag is set.



Am 12.03.2014 10:32, schrieb Michael Wagenknecht:


Am 12.03.2014 10:12, schrieb Itamar Heim:

On 03/12/2014 11:08 AM, Michael Wagenknecht wrote:


Am 12.03.2014 10:04, schrieb Itamar Heim:

On 03/12/2014 10:28 AM, Michael Wagenknecht wrote:

I only get the parameter -m rhel6.4.0 in the qemu command line of the
guest.
The Host and the linux guest runs with CentOS 6.5.
on the oVirt Engine I run:

engine-config -s ClusterEmulatedMachines=rhel6.5.0,pc-1.0 --cver=3.3


I assume cluster version is 3.3.
did your restart engine post the engine-config command?


Cluster Version is 3.3 and I restart the engine after running the
engine-config command.


right...
just remembered this is preserved at cluster level on first host 
joining the cluster to support both fedora and .el6 without manual 
intervention.

do you have at cluster level an emulation mode field?

omer/roy - is there an easy way to change cluster level emulation mode?


No I can't find an emulation mode field.



Am 12.03.2014 09:13, schrieb Itamar Heim:

On 03/12/2014 10:06 AM, Sven Kieske wrote:



Am 11.03.2014 17:33, schrieb Itamar Heim:

engineconfig, change the EmaultedMachine for a 3.3 cluster version

I am sorry, but previously you said:

the guest is lanunched with -m rhel6.5.0 (which is the default 
for a

3.3 cluster)

and now you say you have to switch it by hand?

Which statement is true?
If it's the default, it should be set already and I would
consider this a bug, wouldn't you?




sorry, i confused the RHEV default, which GA post rhel 6.5, with the
ovirt one which GA pre-6.5.


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users











___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-12 Thread Omer Frenkel


- Original Message -
 From: Itamar Heim ih...@redhat.com
 To: Michael Wagenknecht wagenkne...@fuh-e.de, users@ovirt.org, Omer 
 Frenkel ofren...@redhat.com, Roy Golan
 rgo...@redhat.com
 Sent: Wednesday, March 12, 2014 11:12:07 AM
 Subject: Re: [Users] Win8 on oVirt
 
 On 03/12/2014 11:08 AM, Michael Wagenknecht wrote:
 
  Am 12.03.2014 10:04, schrieb Itamar Heim:
  On 03/12/2014 10:28 AM, Michael Wagenknecht wrote:
  I only get the parameter -m rhel6.4.0 in the qemu command line of the
  guest.
  The Host and the linux guest runs with CentOS 6.5.
  on the oVirt Engine I run:
 
  engine-config -s ClusterEmulatedMachines=rhel6.5.0,pc-1.0 --cver=3.3
 
  I assume cluster version is 3.3.
  did your restart engine post the engine-config command?
 
  Cluster Version is 3.3 and I restart the engine after running the
  engine-config command.
 
 right...
 just remembered this is preserved at cluster level on first host joining
 the cluster to support both fedora and .el6 without manual intervention.
 do you have at cluster level an emulation mode field?
 
 omer/roy - is there an easy way to change cluster level emulation mode?
 
it is set according to the host capabilities and engine config,
it is not exposed to the user, so can only be changed in the db.

by default, the config for 3.3 is rhel-6.4, so this is what we set for the 
cluster:
engine-config --get ClusterEmulatedMachines --cver 3.3
rhel6.4.0,pc-1.0,pseries

you can manually change in the db the emulation for a specific cluster:
update vds_groups set emulated_machine='rhel6.5.0' where name='cluster name';

 
 
  Am 12.03.2014 09:13, schrieb Itamar Heim:
  On 03/12/2014 10:06 AM, Sven Kieske wrote:
 
 
  Am 11.03.2014 17:33, schrieb Itamar Heim:
  engineconfig, change the EmaultedMachine for a 3.3 cluster version
  I am sorry, but previously you said:
 
  the guest is lanunched with -m rhel6.5.0 (which is the default for a
  3.3 cluster)
 
  and now you say you have to switch it by hand?
 
  Which statement is true?
  If it's the default, it should be set already and I would
  consider this a bug, wouldn't you?
 
 
 
  sorry, i confused the RHEV default, which GA post rhel 6.5, with the
  ovirt one which GA pre-6.5.
 
 
  ___
  Users mailing list
  Users@ovirt.org
  http://lists.ovirt.org/mailman/listinfo/users
 
 
 
 
 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-12 Thread Roy Golan

On 03/12/2014 11:12 AM, Itamar Heim wrote:

On 03/12/2014 11:08 AM, Michael Wagenknecht wrote:


Am 12.03.2014 10:04, schrieb Itamar Heim:

On 03/12/2014 10:28 AM, Michael Wagenknecht wrote:

I only get the parameter -m rhel6.4.0 in the qemu command line of the
guest.
The Host and the linux guest runs with CentOS 6.5.
on the oVirt Engine I run:

engine-config -s ClusterEmulatedMachines=rhel6.5.0,pc-1.0 --cver=3.3


I assume cluster version is 3.3.
did your restart engine post the engine-config command?


Cluster Version is 3.3 and I restart the engine after running the
engine-config command.


right...
just remembered this is preserved at cluster level on first host 
joining the cluster to support both fedora and .el6 without manual 
intervention.

do you have at cluster level an emulation mode field?

omer/roy - is there an easy way to change cluster level emulation mode?


not without db intervention. I opened a bug [1] to change it so we would 
be able to reset the cluster value


meanwhile:

psql engine engine -c update vds_groups set emulated_machine 
='${value}' where vds_group_id = '${vds_group_id}'


if ${value} is blank than your emulated machine value would be a match 
between the config value and the host value


[1] https://bugzilla.redhat.com/show_bug.cgi?id=1058751






Am 12.03.2014 09:13, schrieb Itamar Heim:

On 03/12/2014 10:06 AM, Sven Kieske wrote:



Am 11.03.2014 17:33, schrieb Itamar Heim:

engineconfig, change the EmaultedMachine for a 3.3 cluster version

I am sorry, but previously you said:

the guest is lanunched with -m rhel6.5.0 (which is the default 
for a

3.3 cluster)

and now you say you have to switch it by hand?

Which statement is true?
If it's the default, it should be set already and I would
consider this a bug, wouldn't you?




sorry, i confused the RHEV default, which GA post rhel 6.5, with the
ovirt one which GA pre-6.5.


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users










___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[Users] Win8 on oVirt

2014-03-11 Thread Michael Wagenknecht

Hi,
I try to install Windows 8 32 bit on our oVirt 3.3.2 environmet.
I googled that two CPU Flags (SEP and NX) have to be set.
But I cannot manipulate the CPU Flags in the GUI.
Is there an other way to set the SEP and NX Flags for the VM?

Best Regards,
Michael
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-11 Thread Sven Kieske
Well, maybe check with a linux distribution first:

cat /proc/cpuinfo

shows you that at least NX gets passed through
(on Intel Nehalem at least).

HTH

Am 11.03.2014 09:42, schrieb Michael Wagenknecht:
 Hi,
 I try to install Windows 8 32 bit on our oVirt 3.3.2 environmet.
 I googled that two CPU Flags (SEP and NX) have to be set.
 But I cannot manipulate the CPU Flags in the GUI.
 Is there an other way to set the SEP and NX Flags for the VM?
 
 Best Regards,
 Michael

-- 
Mit freundlichen Grüßen / Regards

Sven Kieske

Systemadministrator
Mittwald CM Service GmbH  Co. KG
Königsberger Straße 6
32339 Espelkamp
T: +49-5772-293-100
F: +49-5772-293-333
https://www.mittwald.de
Geschäftsführer: Robert Meyer
St.Nr.: 331/5721/1033, USt-IdNr.: DE814773217, HRA 6640, AG Bad Oeynhausen
Komplementärin: Robert Meyer Verwaltungs GmbH, HRB 13260, AG Bad Oeynhausen
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-11 Thread Michael Wagenknecht

Yes that's right. But I need the SEP Flag too.


Am 11.03.2014 10:23, schrieb Sven Kieske:

Well, maybe check with a linux distribution first:

cat /proc/cpuinfo

shows you that at least NX gets passed through
(on Intel Nehalem at least).

HTH

Am 11.03.2014 09:42, schrieb Michael Wagenknecht:

Hi,
I try to install Windows 8 32 bit on our oVirt 3.3.2 environmet.
I googled that two CPU Flags (SEP and NX) have to be set.
But I cannot manipulate the CPU Flags in the GUI.
Is there an other way to set the SEP and NX Flags for the VM?

Best Regards,
Michael


--
Mit freundlichen Grüßen

Michael Wagenknecht
FuH Entwicklungsgesellschaft mbH
Geschäftsführer Carola Fornoff
HRB Freiburg 701203, UID DE255007372
Elsässer Str. 18, D-79346 Endingen
Telefon +49 - 7642 - 92866 - 0

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-11 Thread Sven Kieske
Which OS/Distribution does your compute node
run?

I do not know if this might be related:

https://bugzilla.redhat.com/show_bug.cgi?id=821741

But I also don't see the SEP flag passed into
linux based vms on a CentOS 6.5 based compute node.

Maybe this is another feature just available to
qemu-kvm-rhev instead of qemu-kvm ?

-- 
Mit freundlichen Grüßen / Regards

Sven Kieske

Systemadministrator
Mittwald CM Service GmbH  Co. KG
Königsberger Straße 6
32339 Espelkamp
T: +49-5772-293-100
F: +49-5772-293-333
https://www.mittwald.de
Geschäftsführer: Robert Meyer
St.Nr.: 331/5721/1033, USt-IdNr.: DE814773217, HRA 6640, AG Bad Oeynhausen
Komplementärin: Robert Meyer Verwaltungs GmbH, HRB 13260, AG Bad Oeynhausen
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-11 Thread Michael Wagenknecht

The node runs with CentOS 6.5
I Understand, no Win8 guests on CentOS nodes.

Thank you very much Sven


Am 11.03.2014 11:21, schrieb Sven Kieske:

Which OS/Distribution does your compute node
run?

I do not know if this might be related:

https://bugzilla.redhat.com/show_bug.cgi?id=821741

But I also don't see the SEP flag passed into
linux based vms on a CentOS 6.5 based compute node.

Maybe this is another feature just available to
qemu-kvm-rhev instead of qemu-kvm ?



--
Mit freundlichen Grüßen

Michael Wagenknecht
FuH Entwicklungsgesellschaft mbH
Geschäftsführer Carola Fornoff
HRB Freiburg 701203, UID DE255007372
Elsässer Str. 18, D-79346 Endingen
Telefon +49 - 7642 - 92866 - 0

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-11 Thread Giorgio Bersano
2014-03-11 12:40 GMT+01:00 Michael Wagenknecht wagenkne...@fuh-e.de:
 The node runs with CentOS 6.5
 I Understand, no Win8 guests on CentOS nodes.

Hi,
not tried with Win8 but regarding flags I have this:

oVirt 3.4.0 RC

host: CentOS 6.5 with current updates

[root@host1 ~]# cat /proc/cpuinfo
processor   : 0
vendor_id   : GenuineIntel
cpu family  : 6
model   : 26
model name  : Intel(R) Xeon(R) CPU   E5504  @ 2.00GHz
stepping: 5
cpu MHz : 2000.165
cache size  : 4096 KB
physical id : 0
siblings: 4
core id : 0
cpu cores   : 4
apicid  : 0
initial apicid  : 0
fpu : yes
fpu_exception   : yes
cpuid level : 11
wp  : yes
flags   : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe
syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good
xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2
ssse3 cx16 xtpr pdcm dca sse4_1 sse4_2 popcnt lahf_lm dts tpr_shadow
vnmi flexpriority ept vpid
bogomips: 4000.33
clflush size: 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management:
[root@host1 ~]#


guest: CentOS 6.5 with current updates

[root@guest1 ~]# cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 26
model name : Intel Core i7 9xx (Nehalem Class Core i7)
stepping : 3
cpu MHz : 2000.066
cache size : 4096 KB
fpu : yes
fpu_exception : yes
cpuid level : 4
wp : yes
flags : fpu de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat
pse36 clflush mmx fxsr sse sse2 syscall nx lm constant_tsc
unfair_spinlock pni ssse3 cx16 sse4_1 sse4_2 x2apic popcnt hypervisor
lahf_lm
bogomips : 4000.13
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management:
[root@guest1 ~]#


SEP and NX are present in guest as in host.

Best regards,
Giorgio.
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-11 Thread Itamar Heim

On 03/11/2014 01:40 PM, Michael Wagenknecht wrote:

The node runs with CentOS 6.5
I Understand, no Win8 guests on CentOS nodes.


is your cluster version 3.3?



Thank you very much Sven


Am 11.03.2014 11:21, schrieb Sven Kieske:

Which OS/Distribution does your compute node
run?

I do not know if this might be related:

https://bugzilla.redhat.com/show_bug.cgi?id=821741

But I also don't see the SEP flag passed into
linux based vms on a CentOS 6.5 based compute node.

Maybe this is another feature just available to
qemu-kvm-rhev instead of qemu-kvm ?





___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-11 Thread Michael Wagenknecht


Am 11.03.2014 15:01, schrieb Itamar Heim:

On 03/11/2014 01:40 PM, Michael Wagenknecht wrote:

The node runs with CentOS 6.5
I Understand, no Win8 guests on CentOS nodes.


is your cluster version 3.3?


Yes it is.


Thank you very much Sven


Am 11.03.2014 11:21, schrieb Sven Kieske:

Which OS/Distribution does your compute node
run?

I do not know if this might be related:

https://bugzilla.redhat.com/show_bug.cgi?id=821741

But I also don't see the SEP flag passed into
linux based vms on a CentOS 6.5 based compute node.

Maybe this is another feature just available to
qemu-kvm-rhev instead of qemu-kvm ?







--
Mit freundlichen Grüßen

Michael Wagenknecht
FuH Entwicklungsgesellschaft mbH
Geschäftsführer Carola Fornoff
HRB Freiburg 701203, UID DE255007372
Elsässer Str. 18, D-79346 Endingen
Telefon +49 - 7642 - 92866 - 0

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-11 Thread Itamar Heim

On 03/11/2014 04:05 PM, Michael Wagenknecht wrote:


Am 11.03.2014 15:01, schrieb Itamar Heim:

On 03/11/2014 01:40 PM, Michael Wagenknecht wrote:

The node runs with CentOS 6.5
I Understand, no Win8 guests on CentOS nodes.


is your cluster version 3.3?


Yes it is.


then assuming qemu-kvm is up to date, it should expose sep to the guest 
if exists on the host.




Thank you very much Sven


Am 11.03.2014 11:21, schrieb Sven Kieske:

Which OS/Distribution does your compute node
run?

I do not know if this might be related:

https://bugzilla.redhat.com/show_bug.cgi?id=821741

But I also don't see the SEP flag passed into
linux based vms on a CentOS 6.5 based compute node.

Maybe this is another feature just available to
qemu-kvm-rhev instead of qemu-kvm ?









___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-11 Thread Sven Kieske
Well,

I got SEP flag on my compute node, the cluster level is 3.3
engine is 3.3.3-2.el6
however in my centos 6.5 vm I got no sep flag

this is my qemu-kvm version:

rpm -qa | grep qemu-kvm
qemu-kvm-0.12.1.2-2.415.el6_5.4.x86_64

yum update qemu-kvm shows me, there is a newer version:

0.12.1.2-2.415.el6_5.5

the changelog states:

2014-02-25 - Miroslav Rezanina mreza...@redhat.com -
0.12.1.2-2.415.el6_5.5 -
kvm-monitor-Cleanup-mon-outbuf-on-write-error.patch [bz#1069239] -
Resolves: bz#1069239 (QMP socket breaks on unexpected close)

Which leads to this BZ, which seems to have nothing to do at all
with this flag:

https://bugzilla.redhat.com/show_bug.cgi?id=1069239

Am 11.03.2014 15:06, schrieb Itamar Heim:
 then assuming qemu-kvm is up to date, it should expose sep to the guest
 if exists on the host.

-- 
Mit freundlichen Grüßen / Regards

Sven Kieske

Systemadministrator
Mittwald CM Service GmbH  Co. KG
Königsberger Straße 6
32339 Espelkamp
T: +49-5772-293-100
F: +49-5772-293-333
https://www.mittwald.de
Geschäftsführer: Robert Meyer
St.Nr.: 331/5721/1033, USt-IdNr.: DE814773217, HRA 6640, AG Bad Oeynhausen
Komplementärin: Robert Meyer Verwaltungs GmbH, HRB 13260, AG Bad Oeynhausen
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-11 Thread Itamar Heim

On 03/11/2014 04:51 PM, Sven Kieske wrote:

Well,

I got SEP flag on my compute node, the cluster level is 3.3
engine is 3.3.3-2.el6
however in my centos 6.5 vm I got no sep flag

this is my qemu-kvm version:

rpm -qa | grep qemu-kvm
qemu-kvm-0.12.1.2-2.415.el6_5.4.x86_64

yum update qemu-kvm shows me, there is a newer version:

0.12.1.2-2.415.el6_5.5

the changelog states:

2014-02-25 - Miroslav Rezanina mreza...@redhat.com -
0.12.1.2-2.415.el6_5.5 -
kvm-monitor-Cleanup-mon-outbuf-on-write-error.patch [bz#1069239] -
Resolves: bz#1069239 (QMP socket breaks on unexpected close)

Which leads to this BZ, which seems to have nothing to do at all
with this flag:

https://bugzilla.redhat.com/show_bug.cgi?id=1069239


and the guest is lanunched with -m rhel6.5.0 (which is the default for a 
3.3 cluster)?





Am 11.03.2014 15:06, schrieb Itamar Heim:

then assuming qemu-kvm is up to date, it should expose sep to the guest
if exists on the host.




___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-11 Thread Sven Kieske
I don't know to what you are pointing here directly, but I think you
mean the qemu commandline?

in fact it is:
/usr/libexec/qemu-kvm -name centosbootstrap -S -M rhel6.4.0

but when I check the webadmin GUI the correct OS is selected:

Red Hat Enterprise Linux 6.x x64

as you might guess it's not paid RHEL but CentOS.

But this shouldn't make any difference, should it?

Is this a bug?


Am 11.03.2014 16:03, schrieb Itamar Heim:
 and the guest is lanunched with -m rhel6.5.0 (which is the default for a
 3.3 cluster)?

-- 
Mit freundlichen Grüßen / Regards

Sven Kieske

Systemadministrator
Mittwald CM Service GmbH  Co. KG
Königsberger Straße 6
32339 Espelkamp
T: +49-5772-293-100
F: +49-5772-293-333
https://www.mittwald.de
Geschäftsführer: Robert Meyer
St.Nr.: 331/5721/1033, USt-IdNr.: DE814773217, HRA 6640, AG Bad Oeynhausen
Komplementärin: Robert Meyer Verwaltungs GmbH, HRB 13260, AG Bad Oeynhausen
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-11 Thread Sven Kieske


Am 11.03.2014 17:03, schrieb Itamar Heim:
 change it in config to rhel6.5.0.
how and where? in the db or manually in the qemu-cmd?
because I can't change this through webadmin.
there is just Red Hat Enterprise Linux 6.x x64 and
you can't select any specific subversion replacing x.
 its not technically a bug, since ovirt 3.3 GA'd before rhel 6.5 iirc.
 the SEP flag will only work on -m rhel6.5.0 to preserve backward
 compatibility (one host got upgraded to 6.5, another is still 6.4).


-- 
Mit freundlichen Grüßen / Regards

Sven Kieske

Systemadministrator
Mittwald CM Service GmbH  Co. KG
Königsberger Straße 6
32339 Espelkamp
T: +49-5772-293-100
F: +49-5772-293-333
https://www.mittwald.de
Geschäftsführer: Robert Meyer
St.Nr.: 331/5721/1033, USt-IdNr.: DE814773217, HRA 6640, AG Bad Oeynhausen
Komplementärin: Robert Meyer Verwaltungs GmbH, HRB 13260, AG Bad Oeynhausen
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [Users] Win8 on oVirt

2014-03-11 Thread Itamar Heim

On 03/11/2014 06:21 PM, Sven Kieske wrote:



Am 11.03.2014 17:03, schrieb Itamar Heim:

change it in config to rhel6.5.0.

how and where? in the db or manually in the qemu-cmd?
because I can't change this through webadmin.
there is just Red Hat Enterprise Linux 6.x x64 and
you can't select any specific subversion replacing x.

its not technically a bug, since ovirt 3.3 GA'd before rhel 6.5 iirc.
the SEP flag will only work on -m rhel6.5.0 to preserve backward
compatibility (one host got upgraded to 6.5, another is still 6.4).





engineconfig, change the EmaultedMachine for a 3.3 cluster version
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users