Re: [ovirt-users] Cannot sync networks

2016-05-25 Thread Alona Kaplan


- Original Message -
> From: "Alona Kaplan" <alkap...@redhat.com>
> To: "Roderick Mooi" <roder...@sanren.ac.za>
> Cc: "users" <users@ovirt.org>
> Sent: Wednesday, May 25, 2016 9:35:14 AM
> Subject: Re: [ovirt-users] Cannot sync networks
> 
> 
> 
> - Original Message -
> > From: "Roderick Mooi" <roder...@sanren.ac.za>
> > To: "Alona Kaplan" <alkap...@redhat.com>
> > Cc: "users" <users@ovirt.org>
> > Sent: Wednesday, May 25, 2016 9:24:28 AM
> > Subject: Re: [ovirt-users] Cannot sync networks
> > 
> > Hi Alona
> > 
> > Thanks but this is what I already tried between steps 5 and 6 - when I
> > click “ok” it tries to sync and eventually seems to give up and roll back.
> > Will it help if I uncheck “verify engine to host connectivity”? (I’m
> > surprised that the verification fails as technically the network I’m trying
> > to set is the one that is currently being used by the host and engine - all
> > I want to do is update the DC to match….)
> 
> Can you please try to perform my propose again and attach the engine + vdsm
> logs?

And also the supervdsm.log

> 
> > 
> > Regards,
> > 
> > Roderick
> > 
> > Roderick Mooi
> > 
> > Senior Engineer: South African National Research Network (SANReN)
> > Meraka Institute, CSIR
> > 
> > roder...@sanren.ac.za | +27 12 841 4111 | www.sanren.ac.za
> > 
> > On Sun, May 22, 2016 at 2:37 PM, Alona Kaplan <alkap...@redhat.com> wrote:
> > 
> > >
> > >
> > > - Original Message -
> > > > From: "Roderick Mooi" <roder...@sanren.ac.za>
> > > > To: users@ovirt.org
> > > > Sent: Tuesday, May 17, 2016 12:59:03 PM
> > > > Subject: [ovirt-users] Cannot sync networks
> > > >
> > > > Good day
> > > >
> > > > On oVirt 3.6.4 HE. I manually reconfigured host networks by doing the
> > > > following:
> > > > 1. Changed to global maintenance mode
> > > > 2. Shutdown the hosted engine
> > > > 3. on each host:
> > > > a. systemctl stop ovirt-ha-agent && systemctl stop ovirt-ha-broker &&
> > > > systemctl stop vdsmd
> > > > b. updated /var/lib/vdsm/persistence/netconf/nets to match the required
> > > > config
> > > > c. updated ifcfg files to match
> > > > d. rebooted each host
> > > > 4. When all is up and running again, verified network connectivity and
> > > > settings on each host - ok.
> > > > 5. Logged into engine web UI - all hosts detected but show network
> > > > out-of-sync (see attached example).
> > > > 6. Individual sync / sync all networks runs for a while till login time
> > > out.
> > > > Log back in and go to host - still shows out-of-sync (even next day or
> > > after
> > > > rebooting again).
> > > > 7. Eventually got one host to sync (not hosting any VMs and rebooted).
> > > > 8. Whatever I try cannot get the other hosts to sync (even when moving
> > > all
> > > > VMs off and rebooting).
> > > >
> > > > Any ideas? Do I have to manually edit the database and change the
> > > > network
> > > > settings for the DC - if so, how do I do this? (the host config is what
> > > > I
> > > > want - DC is old config.)
> > >
> > > Syncing a network means applying the DC config on the host (overriding
> > > the
> > > actual host config).
> > > Since as you mentioned, the DC config is old and not relevant,
> > > I guess it is not working since you're trying to apply wrong
> > > address/gateway/netmask on the management network, it causes the engine
> > > lose connectivity to the host, and eventually ends up with a rollback.
> > >
> > > What you need to do is to update the DC config to be same as the host
> > > config.
> > > Since the out-of-sync properties in the attached image are address,
> > > gateway and netmask of 'ovirtmgmt',
> > > you need to open the 'setup networks' dialog and edit the 'ovirtmgmt'
> > > network (clicking on the pencil icon).
> > > In order to be able to edit the network, you first have to mark the 'sync
> > > network' checkbox in the dialog. Then modify the address/gateway/netmask
> > > to
> > > the host value.
> > > Then click 'ok' and perform the setup networks ('ok' to the setup
> > > networks
> > > main dialog).
> > >
> > > >
> > > > Alternatively, if I have to start all over again, what is the correct
> > > way for
> > > > changing networks post HE install (I need this as the network for
> > > > installation and testing looks different to the final production
> > > network)?
> > > >
> > > > Thanks very much,
> > > >
> > > > Roderick
> > > >
> > > >
> > > >
> > > > ___
> > > > Users mailing list
> > > > Users@ovirt.org
> > > > http://lists.ovirt.org/mailman/listinfo/users
> > > >
> > >
> > 
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
> 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Cannot sync networks

2016-05-25 Thread Alona Kaplan


- Original Message -
> From: "Roderick Mooi" <roder...@sanren.ac.za>
> To: "Alona Kaplan" <alkap...@redhat.com>
> Cc: "users" <users@ovirt.org>
> Sent: Wednesday, May 25, 2016 9:24:28 AM
> Subject: Re: [ovirt-users] Cannot sync networks
> 
> Hi Alona
> 
> Thanks but this is what I already tried between steps 5 and 6 - when I
> click “ok” it tries to sync and eventually seems to give up and roll back.
> Will it help if I uncheck “verify engine to host connectivity”? (I’m
> surprised that the verification fails as technically the network I’m trying
> to set is the one that is currently being used by the host and engine - all
> I want to do is update the DC to match….)

Can you please try to perform my propose again and attach the engine + vdsm 
logs?

> 
> Regards,
> 
> Roderick
> 
> Roderick Mooi
> 
> Senior Engineer: South African National Research Network (SANReN)
> Meraka Institute, CSIR
> 
> roder...@sanren.ac.za | +27 12 841 4111 | www.sanren.ac.za
> 
> On Sun, May 22, 2016 at 2:37 PM, Alona Kaplan <alkap...@redhat.com> wrote:
> 
> >
> >
> > - Original Message -----
> > > From: "Roderick Mooi" <roder...@sanren.ac.za>
> > > To: users@ovirt.org
> > > Sent: Tuesday, May 17, 2016 12:59:03 PM
> > > Subject: [ovirt-users] Cannot sync networks
> > >
> > > Good day
> > >
> > > On oVirt 3.6.4 HE. I manually reconfigured host networks by doing the
> > > following:
> > > 1. Changed to global maintenance mode
> > > 2. Shutdown the hosted engine
> > > 3. on each host:
> > > a. systemctl stop ovirt-ha-agent && systemctl stop ovirt-ha-broker &&
> > > systemctl stop vdsmd
> > > b. updated /var/lib/vdsm/persistence/netconf/nets to match the required
> > > config
> > > c. updated ifcfg files to match
> > > d. rebooted each host
> > > 4. When all is up and running again, verified network connectivity and
> > > settings on each host - ok.
> > > 5. Logged into engine web UI - all hosts detected but show network
> > > out-of-sync (see attached example).
> > > 6. Individual sync / sync all networks runs for a while till login time
> > out.
> > > Log back in and go to host - still shows out-of-sync (even next day or
> > after
> > > rebooting again).
> > > 7. Eventually got one host to sync (not hosting any VMs and rebooted).
> > > 8. Whatever I try cannot get the other hosts to sync (even when moving
> > all
> > > VMs off and rebooting).
> > >
> > > Any ideas? Do I have to manually edit the database and change the network
> > > settings for the DC - if so, how do I do this? (the host config is what I
> > > want - DC is old config.)
> >
> > Syncing a network means applying the DC config on the host (overriding the
> > actual host config).
> > Since as you mentioned, the DC config is old and not relevant,
> > I guess it is not working since you're trying to apply wrong
> > address/gateway/netmask on the management network, it causes the engine
> > lose connectivity to the host, and eventually ends up with a rollback.
> >
> > What you need to do is to update the DC config to be same as the host
> > config.
> > Since the out-of-sync properties in the attached image are address,
> > gateway and netmask of 'ovirtmgmt',
> > you need to open the 'setup networks' dialog and edit the 'ovirtmgmt'
> > network (clicking on the pencil icon).
> > In order to be able to edit the network, you first have to mark the 'sync
> > network' checkbox in the dialog. Then modify the address/gateway/netmask to
> > the host value.
> > Then click 'ok' and perform the setup networks ('ok' to the setup networks
> > main dialog).
> >
> > >
> > > Alternatively, if I have to start all over again, what is the correct
> > way for
> > > changing networks post HE install (I need this as the network for
> > > installation and testing looks different to the final production
> > network)?
> > >
> > > Thanks very much,
> > >
> > > Roderick
> > >
> > >
> > >
> > > ___
> > > Users mailing list
> > > Users@ovirt.org
> > > http://lists.ovirt.org/mailman/listinfo/users
> > >
> >
> 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Cannot sync networks

2016-05-25 Thread Roderick Mooi
Hi Alona

Thanks but this is what I already tried between steps 5 and 6 - when I
click “ok” it tries to sync and eventually seems to give up and roll back.
Will it help if I uncheck “verify engine to host connectivity”? (I’m
surprised that the verification fails as technically the network I’m trying
to set is the one that is currently being used by the host and engine - all
I want to do is update the DC to match….)

Regards,

Roderick

Roderick Mooi

Senior Engineer: South African National Research Network (SANReN)
Meraka Institute, CSIR

roder...@sanren.ac.za | +27 12 841 4111 | www.sanren.ac.za

On Sun, May 22, 2016 at 2:37 PM, Alona Kaplan <alkap...@redhat.com> wrote:

>
>
> - Original Message -
> > From: "Roderick Mooi" <roder...@sanren.ac.za>
> > To: users@ovirt.org
> > Sent: Tuesday, May 17, 2016 12:59:03 PM
> > Subject: [ovirt-users] Cannot sync networks
> >
> > Good day
> >
> > On oVirt 3.6.4 HE. I manually reconfigured host networks by doing the
> > following:
> > 1. Changed to global maintenance mode
> > 2. Shutdown the hosted engine
> > 3. on each host:
> > a. systemctl stop ovirt-ha-agent && systemctl stop ovirt-ha-broker &&
> > systemctl stop vdsmd
> > b. updated /var/lib/vdsm/persistence/netconf/nets to match the required
> > config
> > c. updated ifcfg files to match
> > d. rebooted each host
> > 4. When all is up and running again, verified network connectivity and
> > settings on each host - ok.
> > 5. Logged into engine web UI - all hosts detected but show network
> > out-of-sync (see attached example).
> > 6. Individual sync / sync all networks runs for a while till login time
> out.
> > Log back in and go to host - still shows out-of-sync (even next day or
> after
> > rebooting again).
> > 7. Eventually got one host to sync (not hosting any VMs and rebooted).
> > 8. Whatever I try cannot get the other hosts to sync (even when moving
> all
> > VMs off and rebooting).
> >
> > Any ideas? Do I have to manually edit the database and change the network
> > settings for the DC - if so, how do I do this? (the host config is what I
> > want - DC is old config.)
>
> Syncing a network means applying the DC config on the host (overriding the
> actual host config).
> Since as you mentioned, the DC config is old and not relevant,
> I guess it is not working since you're trying to apply wrong
> address/gateway/netmask on the management network, it causes the engine
> lose connectivity to the host, and eventually ends up with a rollback.
>
> What you need to do is to update the DC config to be same as the host
> config.
> Since the out-of-sync properties in the attached image are address,
> gateway and netmask of 'ovirtmgmt',
> you need to open the 'setup networks' dialog and edit the 'ovirtmgmt'
> network (clicking on the pencil icon).
> In order to be able to edit the network, you first have to mark the 'sync
> network' checkbox in the dialog. Then modify the address/gateway/netmask to
> the host value.
> Then click 'ok' and perform the setup networks ('ok' to the setup networks
> main dialog).
>
> >
> > Alternatively, if I have to start all over again, what is the correct
> way for
> > changing networks post HE install (I need this as the network for
> > installation and testing looks different to the final production
> network)?
> >
> > Thanks very much,
> >
> > Roderick
> >
> >
> >
> > ___
> > Users mailing list
> > Users@ovirt.org
> > http://lists.ovirt.org/mailman/listinfo/users
> >
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Cannot sync networks

2016-05-22 Thread Alona Kaplan


- Original Message -
> From: "Roderick Mooi" <roder...@sanren.ac.za>
> To: users@ovirt.org
> Sent: Tuesday, May 17, 2016 12:59:03 PM
> Subject: [ovirt-users] Cannot sync networks
> 
> Good day
> 
> On oVirt 3.6.4 HE. I manually reconfigured host networks by doing the
> following:
> 1. Changed to global maintenance mode
> 2. Shutdown the hosted engine
> 3. on each host:
> a. systemctl stop ovirt-ha-agent && systemctl stop ovirt-ha-broker &&
> systemctl stop vdsmd
> b. updated /var/lib/vdsm/persistence/netconf/nets to match the required
> config
> c. updated ifcfg files to match
> d. rebooted each host
> 4. When all is up and running again, verified network connectivity and
> settings on each host - ok.
> 5. Logged into engine web UI - all hosts detected but show network
> out-of-sync (see attached example).
> 6. Individual sync / sync all networks runs for a while till login time out.
> Log back in and go to host - still shows out-of-sync (even next day or after
> rebooting again).
> 7. Eventually got one host to sync (not hosting any VMs and rebooted).
> 8. Whatever I try cannot get the other hosts to sync (even when moving all
> VMs off and rebooting).
> 
> Any ideas? Do I have to manually edit the database and change the network
> settings for the DC - if so, how do I do this? (the host config is what I
> want - DC is old config.)

Syncing a network means applying the DC config on the host (overriding the 
actual host config).
Since as you mentioned, the DC config is old and not relevant,
I guess it is not working since you're trying to apply wrong 
address/gateway/netmask on the management network, it causes the engine lose 
connectivity to the host, and eventually ends up with a rollback.

What you need to do is to update the DC config to be same as the host config.
Since the out-of-sync properties in the attached image are address, gateway and 
netmask of 'ovirtmgmt',
you need to open the 'setup networks' dialog and edit the 'ovirtmgmt' network 
(clicking on the pencil icon).
In order to be able to edit the network, you first have to mark the 'sync 
network' checkbox in the dialog. Then modify the address/gateway/netmask to the 
host value.
Then click 'ok' and perform the setup networks ('ok' to the setup networks main 
dialog). 

> 
> Alternatively, if I have to start all over again, what is the correct way for
> changing networks post HE install (I need this as the network for
> installation and testing looks different to the final production network)?
> 
> Thanks very much,
> 
> Roderick
> 
> 
> 
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
> 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] Cannot sync networks

2016-05-17 Thread Roderick Mooi
Good day

On oVirt 3.6.4 HE. I manually reconfigured host networks by doing the
following:
1. Changed to global maintenance mode
2. Shutdown the hosted engine
3. on each host:
a. systemctl stop ovirt-ha-agent && systemctl stop ovirt-ha-broker &&
systemctl stop vdsmd
b. updated /var/lib/vdsm/persistence/netconf/nets to match the required
config
c. updated ifcfg files to match
d. rebooted each host
4. When all is up and running again, verified network connectivity and
settings on each host - ok.
5. Logged into engine web UI - all hosts detected but show network
out-of-sync (see attached example).
6. Individual sync / sync all networks runs for a while till login time
out. Log back in and go to host - still shows out-of-sync (even next day or
after rebooting again).
7. Eventually got one host to sync (not hosting any VMs and rebooted).
8. Whatever I try cannot get the other hosts to sync (even when moving all
VMs off and rebooting).

Any ideas? Do I have to manually edit the database and change the network
settings for the DC - if so, how do I do this? (the host config is what I
want - DC is old config.)

Alternatively, if I have to start all over again, what is the correct way
for changing networks post HE install (I need this as the network for
installation and testing looks different to the final production network)?

Thanks very much,

Roderick
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users