Re: [ovirt-users] Debian linux and oVirt SSO

2016-07-18 Thread Tadas
ovirt agent stops on this line and code below it is not executed: https://github.com/oVirt/ovirt-guest-agent/blob/master/ovirt-guest-agen t/CredServer.py#L147 On Mon, 2016-07-18 at 14:12 +0300, Tadas wrote: > This is really interesting. > pam-ovirt-cred is randomly failing on one of two

Re: [ovirt-users] Debian linux and oVirt SSO

2016-07-18 Thread Tadas
This is really interesting. pam-ovirt-cred is randomly failing on one of two checks: https://github.com/oVirt/ovirt-guest-agent/blob/master/pam-ovirt-cred/c red_channel.c#L107 and https://github.com/oVirt/ovirt-guest-agent/blob/master/pam-ovirt-cred/c red_channel.c#L134 Theres  no pattern, on

Re: [ovirt-users] Debian linux and oVirt SSO

2016-07-18 Thread Tadas
After moving to gdm, I've managed to solve the timeout issue. Now i bumped into another one: oVirt agent seem to emit credentials without error: Dummy-1::DEBUG::2016-07-18 09:29:53,293::OVirtAgentLogic::304::root::User log-in (credentials = '\x00\x00\x00\x04test\x00')

Re: [ovirt-users] Debian linux and oVirt SSO

2016-07-15 Thread Vinzenz Feenstra
> On Jul 15, 2016, at 5:09 PM, Tadas wrote: > > Thank you for reply. > > > you =hould just add ovirtcred and not remove all the other options, > without =he other options you’re not able to login > > There are other options, i’ve just changed the folowing parameter: >

Re: [ovirt-users] Debian linux and oVirt SSO

2016-07-15 Thread Tadas
Thank you for reply. you =hould just add ovirtcred and not remove all the other options, without =he other options you’re not able to login There are other options, i’ve just changed the folowing parameter: PluginsLogin=ovirtcred should i use somekind of plugin list and add the classic

Re: [ovirt-users] Debian linux and oVirt SSO

2016-07-15 Thread Tadas
: Yaniv Kaul Sent: Friday, July 15, 2016 3:57 PM To: ta...@ring.lt Cc: users Subject: Re: [ovirt-users] Debian linux and oVirt SSO Part of the issue is that you are missing quite a bit of the orchestration that oVirt performs to make SSO work... There may some other issues, but I warmly suggest

Re: [ovirt-users] Debian linux and oVirt SSO

2016-07-15 Thread Yaniv Kaul
On Fri, Jul 15, 2016 at 12:50 PM, Tadas wrote: > Hello, > i'm struggling to get oVirt SSO working on Linux guest VM. > I can confirm, that SSO is fully functional on Windows guest (please > note it's not a full oVirt installation - I'm just testing oVirt guest > agent on virtual

[ovirt-users] Debian linux and oVirt SSO

2016-07-15 Thread Tadas
Hello, i'm struggling to get oVirt SSO working on Linux guest VM. I can confirm, that SSO is fully functional on Windows guest (please note it's not a full oVirt installation - I'm just testing oVirt guest agent on virtual machines running on plain KVM hypervisor). Steps I've made: got oVirt